Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libpam0-1.5.2-5.mga9 RPM for i586

From Mageia 9 for i586 / media / core / release

Name: libpam0 Distribution: Mageia
Version: 1.5.2 Vendor: Mageia.Org
Release: 5.mga9 Build date: Wed Jan 25 16:41:50 2023
Group: System/Libraries Build host: localhost
Size: 964502 Source RPM: pam-1.5.2-5.mga9.src.rpm
Packager: luigiwalser <luigiwalser>
Url: http://www.linux-pam.org/
Summary: Libraries for pam
PAM (Pluggable Authentication Modules) is a system security tool that
allows system administrators to set authentication policy without
having to recompile programs that handle authentication.

This package contains the libraries for pam.

Provides

Requires

License

BSD-3-Clause AND GPL-2.0-or-later

Changelog

* Wed Jan 25 2023 luigiwalser <luigiwalser> 1.5.2-5.mga9
  + Revision: 1936078
  - add patch4 from fedora to load pam_pwhistory config from file
  - add patch1000 from upstream to mitigate CVE-2022-28321
* Sun Jan 08 2023 wally <wally> 1.5.2-4.mga9
  + Revision: 1931615
  - fix system-auth update from mga8 without .rpmnew
* Sun Jan 08 2023 wally <wally> 1.5.2-3.mga9
  + Revision: 1931529
  - make sure pam_cracklib.so will be changed to pam_pwquality.so in /etc/pam.d/system-auth
  - drop old and unneeded rpm scriptlets
* Sun Mar 27 2022 umeabot <umeabot> 1.5.2-2.mga9
  + Revision: 1829192
  - Mageia 9 Mass Rebuild
* Sun Sep 26 2021 luigiwalser <luigiwalser> 1.5.2-1.mga9
  + Revision: 1746565
  - 1.5.2
  - pam_redhat 1.1.5
  - remove patches 4, 5, 521 (fixed upstream)
  - do not own /etc/motd.d
* Sun Sep 26 2021 wally <wally> 1.5.1-4.mga9
  + Revision: 1746469
  - drop ancient conflicts
  - require pam_pwquality for system-auth
* Sat Sep 25 2021 luigiwalser <luigiwalser> 1.5.1-3.mga9
  + Revision: 1746396
  - fix system-auth (we use sha512 by default still)
* Sat Sep 25 2021 wally <wally> 1.5.1-2.mga9
  + Revision: 1746387
  - sync system-auth with Fedora to fix auth issues due to a missing/removed pam_cracklib.so (mga#29475)
* Wed Aug 04 2021 luigiwalser <luigiwalser> 1.5.1-1.mga9
  + Revision: 1739003
  - add patch from fedora to not use crypt_checksalt for password expiration
  - add patch from fedora to fix issues detected by covscan tool
  - 1.5.1
  - pam-redhat 1.1.4
  - rediffed noflex, redhat-modules patches from fedora
  - add unix-nomsg patch (3) from fedora
  - rediff patches 512 and 521
  - add vendor-default pam.d directory
  - pam_cracklib is gone
  - pam_setquota and pam_usertype are new
  - drop tallylog

Files

/usr/lib/.build-id
/usr/lib/.build-id/00
/usr/lib/.build-id/00/aab06c08679b1471cb62bafc04d0d4fd334643
/usr/lib/.build-id/03
/usr/lib/.build-id/03/b73972a657111bf9335898f9551c4ce4c34e22
/usr/lib/.build-id/0e
/usr/lib/.build-id/0e/3673075161e565ef989a16e9dd2232b01eb57e
/usr/lib/.build-id/11
/usr/lib/.build-id/11/82723311417420a17af843d9140b0eec1a1969
/usr/lib/.build-id/15
/usr/lib/.build-id/15/ad663c35c14ff35f20c0706afd41b5a0a23b8f
/usr/lib/.build-id/17
/usr/lib/.build-id/17/393f80175e466c1938313f31225111d755b5a4
/usr/lib/.build-id/20
/usr/lib/.build-id/20/864eeae3e6a60def396658cd0634493aca9319
/usr/lib/.build-id/23
/usr/lib/.build-id/23/ee1c4a7c113264b27112fae3501a2c82227f93
/usr/lib/.build-id/26
/usr/lib/.build-id/26/8a66e4e54330bed07505ab86fdd929e134bd5a
/usr/lib/.build-id/30
/usr/lib/.build-id/30/2298b334019e510fcc3b2961c40cc359f9f45a
/usr/lib/.build-id/34
/usr/lib/.build-id/34/52ea6baf172d134721ced5be6bcfb74a349b28
/usr/lib/.build-id/34/9b4cf7ee86099a441b3b329259b2fa192ca0ca
/usr/lib/.build-id/37
/usr/lib/.build-id/37/d7da38a3c8b2a541e456585b2c38c6230eef39
/usr/lib/.build-id/3c
/usr/lib/.build-id/3c/ac096ce1ecbcf278419b9b96726b32a01de98a
/usr/lib/.build-id/41
/usr/lib/.build-id/41/7b894f03b687e0265655c0b58362828dd86e93
/usr/lib/.build-id/42
/usr/lib/.build-id/42/a7bc00955a1238e2727a6bdf9b10eda931c09f
/usr/lib/.build-id/43
/usr/lib/.build-id/43/fe3b6ee5f10642c970eca3257107467a0eddb8
/usr/lib/.build-id/45
/usr/lib/.build-id/45/d58150fc03863aa1aacf71c5facf2ae87527c5
/usr/lib/.build-id/48
/usr/lib/.build-id/48/d63f913f7023101df0a82e2e1a571466134101
/usr/lib/.build-id/49
/usr/lib/.build-id/49/4faec290305e556714d3d89c7821e0e4a14311
/usr/lib/.build-id/4d
/usr/lib/.build-id/4d/eb22b8e414080ecbf368d9d3dd162797baa09b
/usr/lib/.build-id/56
/usr/lib/.build-id/56/9182d6b17a4b88bf689677722524be70fe95ba
/usr/lib/.build-id/5a
/usr/lib/.build-id/5a/3ae94aa2caf58f32b7cffd24c91bc5204b55c2
/usr/lib/.build-id/5c
/usr/lib/.build-id/5c/229981353ec1b21a3fb64003abec57dd7d611d
/usr/lib/.build-id/63
/usr/lib/.build-id/63/881c969a6959cdeecd0b1b697d01ab61f8a817
/usr/lib/.build-id/6e
/usr/lib/.build-id/6e/21318496b7ecd694f48a7f5576b7ef55c894cc
/usr/lib/.build-id/6e/37d2c8c53f7b72398bfc2c7b0d5564b472975b
/usr/lib/.build-id/7d
/usr/lib/.build-id/7d/95b8d257d93fc5a8bfe29cc1e7d4f3bda3e349
/usr/lib/.build-id/86
/usr/lib/.build-id/86/c8817c3e23dc3140f5c96c5abcd894eaef3d05
/usr/lib/.build-id/87
/usr/lib/.build-id/87/640fe5e079b267ddde5fbceff77aa57891b474
/usr/lib/.build-id/8e
/usr/lib/.build-id/8e/0e85fba6a0591d62f44836bd6e5545ba65c659
/usr/lib/.build-id/96
/usr/lib/.build-id/96/51331895e1f01b42c632eb57005a02dde11ce0
/usr/lib/.build-id/ab
/usr/lib/.build-id/ab/c13779e7558113fe014121695411829ef54c68
/usr/lib/.build-id/b1
/usr/lib/.build-id/b1/83b5df8ebf99b2bdb60d3815965dcf9d178eb8
/usr/lib/.build-id/b7
/usr/lib/.build-id/b7/86bead22c14c01801fef3888f8cd2b2e4a9998
/usr/lib/.build-id/b8
/usr/lib/.build-id/b8/6fd085f167f64609261cc405e712e0875a98b9
/usr/lib/.build-id/c2
/usr/lib/.build-id/c2/304da6a7d753af7925369db2eb821972bb15f8
/usr/lib/.build-id/d9
/usr/lib/.build-id/d9/4a76c6e29b1ea4e37488dd17c7936ac1001fcc
/usr/lib/.build-id/da
/usr/lib/.build-id/da/77dadcbde74de3127afdab2143d4370b89045c
/usr/lib/.build-id/da/d5c8cd175ccc9229a8ad598ab179c70d489b4b
/usr/lib/.build-id/e1/ff6d000cebe3602565a7b52bbbfdc6c34ffc02
/usr/lib/.build-id/e2
/usr/lib/.build-id/e2/818771575bf4d48e8a2d67011b9b201415542b
/usr/lib/.build-id/e2/e89e2c84737e015f5c7d75d31e92a59355f737
/usr/lib/.build-id/e6
/usr/lib/.build-id/e6/78d44861aaa3752485a8f1e2ec83cab54cad28
/usr/lib/.build-id/e7
/usr/lib/.build-id/e7/370d8944cd58d93012fbfd51a8eff1ea109026
/usr/lib/.build-id/eb
/usr/lib/.build-id/eb/d7bc398b6495cbe4105597a8afc33897422c89
/usr/lib/.build-id/f2
/usr/lib/.build-id/f2/d960e8b977517de88931d1e0636ef96043fae1
/usr/lib/.build-id/f6
/usr/lib/.build-id/f6/e33b7eb050e15a4c4ef5b2e3fd6ab2f991d326
/usr/lib/.build-id/fe
/usr/lib/.build-id/fe/46c21291a511f3eb4927d269246925574fa134
/usr/lib/libpam.so.0
/usr/lib/libpam.so.0.85.1
/usr/lib/libpam_misc.so.0
/usr/lib/libpam_misc.so.0.82.1
/usr/lib/libpamc.so.0
/usr/lib/libpamc.so.0.82.1
/usr/lib/security
/usr/lib/security/pam_access.so
/usr/lib/security/pam_chroot.so
/usr/lib/security/pam_console.so
/usr/lib/security/pam_debug.so
/usr/lib/security/pam_deny.so
/usr/lib/security/pam_echo.so
/usr/lib/security/pam_env.so
/usr/lib/security/pam_exec.so
/usr/lib/security/pam_faildelay.so
/usr/lib/security/pam_faillock.so
/usr/lib/security/pam_filter
/usr/lib/security/pam_filter.so
/usr/lib/security/pam_filter/upperLOWER
/usr/lib/security/pam_ftp.so
/usr/lib/security/pam_group.so
/usr/lib/security/pam_issue.so
/usr/lib/security/pam_keyinit.so
/usr/lib/security/pam_lastlog.so
/usr/lib/security/pam_limits.so
/usr/lib/security/pam_listfile.so
/usr/lib/security/pam_localuser.so
/usr/lib/security/pam_loginuid.so
/usr/lib/security/pam_mail.so
/usr/lib/security/pam_mkhomedir.so
/usr/lib/security/pam_motd.so
/usr/lib/security/pam_namespace.so
/usr/lib/security/pam_nologin.so
/usr/lib/security/pam_permit.so
/usr/lib/security/pam_postgresok.so
/usr/lib/security/pam_pwhistory.so
/usr/lib/security/pam_rhosts.so
/usr/lib/security/pam_rootok.so
/usr/lib/security/pam_securetty.so
/usr/lib/security/pam_setquota.so
/usr/lib/security/pam_shells.so
/usr/lib/security/pam_stress.so
/usr/lib/security/pam_succeed_if.so
/usr/lib/security/pam_time.so
/usr/lib/security/pam_timestamp.so
/usr/lib/security/pam_tty_audit.so
/usr/lib/security/pam_umask.so
/usr/lib/security/pam_unix.so
/usr/lib/security/pam_unix_acct.so
/usr/lib/security/pam_unix_auth.so
/usr/lib/security/pam_unix_passwd.so
/usr/lib/security/pam_unix_session.so
/usr/lib/security/pam_userdb.so
/usr/lib/security/pam_usertype.so
/usr/lib/security/pam_warn.so
/usr/lib/security/pam_wheel.so
/usr/lib/security/pam_xauth.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Feb 21 02:53:13 2024