Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libdv4-1.0.0-179.8 RPM for armv7hl

From OpenSuSE Ports Tumbleweed for armv7hl

Name: libdv4 Distribution: openSUSE Tumbleweed
Version: 1.0.0 Vendor: openSUSE
Release: 179.8 Build date: Fri Feb 9 20:46:32 2024
Group: Development/Libraries/Other Build host: i03-armsrv1
Size: 98366 Source RPM: libdv-1.0.0-179.8.src.rpm
Packager: http://bugs.opensuse.org
Url: http://libdv.sourceforge.net/
Summary: The Quasar DV Codec
The Quasar DV codec (libdv) is a software codec for DV video, the
encoding format used by most digital camcorders, typically those that
support the IEEE 1394 (FireWire or i.Link) interface. Libdv was
developed according to the official standards for DV video: IEC 61834
and SMPTE 314M.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Tue May 17 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Replace SDL-devel BuildRequires with pkgconfig(sdl): allow to use
    sdl12_compat as an alternative.
* Mon Jun 07 2021 Jan Engelhardt <jengelh@inai.de>
  - Drop --with-pic (no effect with --disable-static)
  - Upgrade old rpm constructs (rediffs libdv-fix-no-add-needed.patch
    as p1)
* Mon Feb 03 2020 Stefan BrĂ¼ns <stefan.bruens@rwth-aachen.de>
  - Cleanup spec file, remove obsolete conditionals.
  - Build playdv as a separate package, removes X11, SDL1 and gtk2
    build dependencies from the library.
* Fri Mar 06 2015 mpluskal@suse.com
  - Cleanup spec file with spec-cleaner
  - User url for source
* Tue Jan 27 2015 crrodriguez@opensuse.org
  - libdv-endian.patch : Fix endiannnes tests to rely on the
    compiler instead on the precence of C library definitions
    This is more important for dv_types.h public header because
    BYTE_ORDER is only defined when USE_MISC is.
  - libdv-visibility.patch: Export only the public API (dv.h)
    private symbols are now hidden so the unprefixed ones
    do not name-clash with other components of the system.
* Mon Apr 22 2013 dimstar@opensuse.org
  - Add libXv-devel BuildRequires: this used to be pulled in by SDL,
    but those dependencies were cleaned up.
* Sun Nov 13 2011 coolo@suse.com
  - add libtool as explicit buildrequire to avoid implicit dependency from prjconf
* Sat Sep 03 2011 crrodriguez@opensuse.org
  - Fix build with no-add-needed
* Fri Jul 08 2011 idonmez@novell.com
  - Apply libdv-v4l-2.6.38.patch on openSUSE >= 12.1 to enable v4l
* Fri Jun 04 2010 cristian.rodriguez@opensuse.org
  - make it work with selinux enforcing "execmod" (patch by PaxTeam)

Files

/usr/lib/libdv.so.4
/usr/lib/libdv.so.4.0.3


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Apr 18 23:39:52 2024