Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python38-six-1.16.0-2.6 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: python38-six Distribution: openSUSE Tumbleweed
Version: 1.16.0 Vendor: openSUSE
Release: 2.6 Build date: Wed Jun 15 04:24:02 2022
Group: Development/Libraries/Python Build host: lamb27
Size: 103226 Source RPM: python-six-1.16.0-2.6.src.rpm
Packager: https://bugs.opensuse.org
Url: http://pypi.python.org/pypi/six/
Summary: Python 2 and 3 compatibility utilities
Six is a Python 2 and 3 compatibility library. It provides utility
functions for smoothing over the differences between the Python
versions with the goal of writing Python code that is compatible on
both Python versions. See the documentation for more information on
what is provided.

Provides

Requires

License

MIT

Changelog

* Thu Jun 17 2021 Benjamin Greiner <code@bnavigator.de>
  - provide python3*dist(six): work around boo#1186870
* Sun May 09 2021 Dirk Müller <dmueller@suse.com>
  - update to 1.16.0:
  - Port _SixMetaPathImporter to Python 3.10.
* Fri Oct 23 2020 Benjamin Greiner <code@bnavigator.de>
  - Use %pycache_only %python_sitelib instead of %python3_sitelib
    * fixes gh#openSUSE/python-rpm-macros#64#issuecomment-715373348
* Tue Jun 02 2020 Dirk Mueller <dmueller@suse.com>
  - update to 1.15.0:
    - Pull request #331: Optimize `six.ensure_str` and `six.ensure_binary`.
* Tue Mar 10 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Do not cause buildcycle with previous change but rather
    install the egg-info prepared metadata from the tarball
* Mon Mar 09 2020 Dirk Mueller <dmueller@suse.com>
  - use setuptools for building to support pip 10.x (bsc#1166139)
* Tue Jan 21 2020 Ondřej Súkup <mimi.vx@gmail.com>
  - update to 1.14.0
    * Add `six.assertNotRegex`
    * `six.moves._dummy_thread` now points to the `_thread` module on
      Python 3.9+. Python 3.7 and later requires threading and deprecated the
      `_dummy_thread` module
    * Remove support for Python 2.6 and Python 3.2
    * `six.wraps` now ignores missing attributes
* Thu Jan 02 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Pull in dbm/gdbm module from python for testing
* Fri Dec 20 2019 Dirk Mueller <dmueller@suse.com>
  - update to 0.13.0:
    - Issue #298, pull request #299: Add `six.moves.dbm_ndbm`.
    - Issue #155: Add `six.moves.collections_abc`, which aliases the `collections`
      module on Python 2-3.2 and the `collections.abc` on Python 3.3 and greater.
    - Pull request #304: Re-add distutils fallback in `setup.py`.
    - Pull request #305: On Python 3.7, `with_metaclass` supports classes using PEP
* Thu Jul 18 2019 Tomáš Chvátal <tchvatal@suse.com>
  - Simplify the pytest call
* Tue Jun 11 2019 Tomáš Chvátal <tchvatal@suse.com>
  - Fix pytest call
  - Fixdocumentation package generating
* Fri Jan 25 2019 Neal Gompa <ngompa13@gmail.com>
  - Change %pretrans back to %pre to fix bootstrap issue
    boo#1123064 bsc#1143893
* Thu Jan 17 2019 Tomáš Chvátal <tchvatal@suse.com>
  - Require just base python module, even full python is too much
    and it is not required here

Files

/usr/lib/python3.8/site-packages/__pycache__/six.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/__pycache__/six.cpython-38.pyc
/usr/lib/python3.8/site-packages/six-1.16.0-py3.8.egg-info
/usr/lib/python3.8/site-packages/six-1.16.0-py3.8.egg-info/PKG-INFO
/usr/lib/python3.8/site-packages/six-1.16.0-py3.8.egg-info/SOURCES.txt
/usr/lib/python3.8/site-packages/six-1.16.0-py3.8.egg-info/dependency_links.txt
/usr/lib/python3.8/site-packages/six-1.16.0-py3.8.egg-info/top_level.txt
/usr/lib/python3.8/site-packages/six.py
/usr/share/doc/packages/python38-six
/usr/share/doc/packages/python38-six/CHANGES
/usr/share/doc/packages/python38-six/README.rst
/usr/share/licenses/python38-six
/usr/share/licenses/python38-six/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Aug 30 23:24:07 2022