Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python38-jsonschema-4.4.0-1.3 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: python38-jsonschema Distribution: openSUSE Tumbleweed
Version: 4.4.0 Vendor: openSUSE
Release: 1.3 Build date: Fri May 13 05:56:51 2022
Group: Unspecified Build host: lamb21
Size: 270807 Source RPM: python-jsonschema-4.4.0-1.3.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/python-jsonschema/jsonschema
Summary: An implementation of JSON-Schema validation for Python
jsonschema is an implementation of JSON Schema (currently in Draft 3)
for Python (supporting 2.6+ including Python 3).

Provides

Requires

License

MIT

Changelog

* Tue Apr 26 2022 Ben Greiner <code@bnavigator.de>
  - Update to 4.4.0
    * Add mypy support (#892)
    * Add support for Python 3.11
  - Release 4.3.3
    * Properly report deprecation warnings at the right stack level
      (#899)
  - Release 4.3.2
    * Additional performance improvements for resolving refs (#896)
  - Release 4.3.1
    * Resolving refs has had performance improvements (#893)
  - Release 4.3.0
    * Fix undesired fallback to brute force container uniqueness
      check on certain input types (#893)
    * Implement a PEP544 Protocol for validator classes (#890)
  - Release 4.2.1
    * Pin importlib.resources from below (#877)
  - Release 4.2.0
    * Use importlib.resources to load schemas (#873)
    * Ensure all elements of arrays are verified for uniqueness by
      uniqueItems (#866)
  - Release 4.1.2
    * Fix dependentSchemas to properly consider non-object instances
      to be valid (#850)
  - Release 4.1.1
    * Fix prefixItems not indicating which item was invalid within
      the instance path (#862)
  - Release 4.1.0
    * Add Python 3.10 to the list of supported Python versions
  - Release 4.0.1
    * Fix the declaration of minimum supported Python version (#846)
  - Release 4.0.0
    * Partial support for Draft 2020-12 (as well as 2019-09). Thanks
      to Thomas Schmidt and Harald Nezbeda.
    * False and 0 are now properly considered non-equal even
      recursively within a container (#686). As part of this change,
      uniqueItems validation may be slower in some cases. Please feel
      free to report any significant performance regressions, though
      in some cases they may be difficult to address given the
      specification requirement.
    * The CLI has been improved, and in particular now supports a
    - -output option (with plain (default) or pretty arguments) to
      control the output format. Future work may add additional
      machine-parsable output formats.
    * Code surrounding DEFAULT_TYPES and the legacy mechanism for
      specifying types to validators have been removed, as per the
      deprecation policy. Validators should use the TypeChecker
      object to customize the set of Python types corresponding to
      JSON Schema types.
    * Validation errors now have a json_path attribute, describing
      their location in JSON path format
    * Support for the IP address and domain name formats has been
      improved
    * Support for Python 2 and 3.6 has been dropped, with
      python_requires properly set.
    * multipleOf could overflow when given sufficiently large
      numbers. Now, when an overflow occurs, jsonschema will fall
      back to using fraction division (#746).
    * jsonschema.__version__, jsonschema.validators.validators,
      jsonschema.validators.meta_schemas and
      jsonschema.RefResolver.in_scope have been deprecated, as has
      passing a second-argument schema to Validator.iter_errors and
      Validator.is_valid.
  - Drop webcolors.patch
* Sun Aug 22 2021 Stefan Schubert <schubi@suse.de>
  - Use libalternatives instead of update-alternatives.
* Tue May 25 2021 pgajdos@suse.com
  - %check: use %pytest rpm macro
* Fri Jan 15 2021 Benjamin Greiner <code@bnavigator.de>
  - Disable python2 build as indirect build dependencies to
    python2-cffi are not resolvable anymore
* Thu Mar 12 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Add patch to fix build with new webcolors:
    * webcolors.patch
* Fri Nov 22 2019 Arun Persaud <arun@gmx.de>
  - update to version 3.2.0:
    * Added a format_nongpl setuptools extra, which installs only format
      dependencies that are non-GPL (#619).
* Sat Nov 16 2019 Arun Persaud <arun@gmx.de>
  - specfile:
    * be more explicit in %files section
    * require python-importlib-metadata
  - update to version 3.1.1:
    * Temporarily revert the switch to js-regex until #611 and #612 are
      resolved.
  - changes from version 3.1.0:
    * Regular expressions throughout schemas now respect the ECMA 262
      dialect, as recommended by the specification (#609).
* Mon Oct 14 2019 Matej Cepl <mcepl@suse.com>
  - Replace %fdupes -s with plain %fdupes; hardlinks are better.
* Tue Sep 17 2019 John Vandenberg <jayvdb@gmail.com>
  - Activate more of the test suite
  - Remove tests and benchmarking from the runtime package
  - Update to v3.0.2
    * Fixed a bug where 0 and False were considered equal by
      const and enum
  - from v3.0.1
    * Fixed a bug where extending validators did not preserve their
      notion of which validator property contains $id information.
  - from v3.0.0
    * Support for Draft 6 and Draft 7
    * Draft 7 is now the default
    * New TypeChecker object for more complex type definitions
      (and overrides)
    * Falling back to isodate for the date-time format checker is
      no longer attempted, in accordance with the specification
* Tue Apr 16 2019 Matej Cepl <mcepl@suse.com>
  - Add non-updating note to the SPEC file
* Mon Apr 08 2019 Dirk Mueller <dmueller@suse.com>
  - downgrade to < 3.0.0 again to fix all openstack clients
* Thu Mar 28 2019 Tomáš Chvátal <tchvatal@suse.com>
  - Update to 3.0.1:
    * Support for Draft 6 and Draft 7
    * Draft 7 is now the default
    * New TypeChecker object for more complex type definitions (and overrides)
    * Falling back to isodate for the date-time format checker is no longer attempted, in accordance with the specification
* Mon Jan 14 2019 kukuk@suse.de
  - Use %license instead of %doc [bsc#1082318]

Files

/usr/bin/jsonschema
/usr/bin/jsonschema-3.8
/usr/lib/python3.8/site-packages/jsonschema
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/COPYING
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/INSTALLER
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/METADATA
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/RECORD
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/REQUESTED
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/WHEEL
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/direct_url.json
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/entry_points.txt
/usr/lib/python3.8/site-packages/jsonschema-4.4.0.dist-info/top_level.txt
/usr/lib/python3.8/site-packages/jsonschema/__init__.py
/usr/lib/python3.8/site-packages/jsonschema/__main__.py
/usr/lib/python3.8/site-packages/jsonschema/__pycache__
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/__init__.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/__init__.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/__main__.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/__main__.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_format.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_format.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_legacy_validators.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_legacy_validators.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_reflect.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_reflect.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_types.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_types.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_utils.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_utils.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_validators.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/_validators.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/cli.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/cli.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/exceptions.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/exceptions.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/protocols.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/protocols.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/validators.cpython-38.opt-1.pyc
/usr/lib/python3.8/site-packages/jsonschema/__pycache__/validators.cpython-38.pyc
/usr/lib/python3.8/site-packages/jsonschema/_format.py
/usr/lib/python3.8/site-packages/jsonschema/_legacy_validators.py
/usr/lib/python3.8/site-packages/jsonschema/_reflect.py
/usr/lib/python3.8/site-packages/jsonschema/_types.py
/usr/lib/python3.8/site-packages/jsonschema/_utils.py
/usr/lib/python3.8/site-packages/jsonschema/_validators.py
/usr/lib/python3.8/site-packages/jsonschema/cli.py
/usr/lib/python3.8/site-packages/jsonschema/exceptions.py
/usr/lib/python3.8/site-packages/jsonschema/protocols.py
/usr/lib/python3.8/site-packages/jsonschema/schemas
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft2019-09.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft2020-12.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft3.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft4.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft6.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/draft7.json
/usr/lib/python3.8/site-packages/jsonschema/schemas/vocabularies.json
/usr/lib/python3.8/site-packages/jsonschema/validators.py
/usr/share/doc/packages/python38-jsonschema
/usr/share/doc/packages/python38-jsonschema/README.rst
/usr/share/libalternatives
/usr/share/libalternatives/jsonschema
/usr/share/libalternatives/jsonschema/1038.conf
/usr/share/licenses/python38-jsonschema
/usr/share/licenses/python38-jsonschema/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Jun 6 23:29:32 2022