Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python313-jwcrypto-1.6.1-1.1 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: python313-jwcrypto Distribution: openSUSE Tumbleweed
Version: 1.6.1 Vendor: openSUSE
Release: 1.1 Build date: Wed Sep 30 15:18:21 2026
Group: Unspecified Build host: reproducible
Size: 890666 Source RPM: python-jwcrypto-1.6.1-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://github.com/latchset/jwcrypto
Summary: Python module package implementing JOSE Web standards
A Python implementation of the JOSE Working Group documents:
RFC 7515 - JSON Web Signature (JWS)
RFC 7516 - JSON Web Encryption (JWE)
RFC 7517 - JSON Web Key (JWK)
RFC 7518 - JSON Web Algorithms (JWA)
RFC 7519 - JSON Web Token (JWT)
RFC 7520 - Examples of Protecting Content Using JSON Object Signing and Encryption (JOSE)

Provides

Requires

License

LGPL-3.0-only

Changelog

* Wed Sep 30 2026 Nico Krapp <nico.krapp@suse.com>
  - Update to 1.6.1 (fixes CVE-2026-92091 (bsc#1280816))
    * Avoid quadratic duplicate check on JWK key_ops by @lissy93
      in #398
    * Loop optimizations by @rjeffman in #397
    * Simplify key_ops checks by @simo5 in #399
    * Version 1.6.1 by @simo5 in #400
* Tue Sep 01 2026 Nico Krapp <nico.krapp@suse.com>
  - Update to 1.6.0 (fixes CVE-2026-84185 (bsc#1278707)):
    * Fix an issue with parsing headers with 'kid' by @simo5 in #395
    * Version 1.6.0 by @simo5 in #396
  - Update to 1.5.9 (fixes CVE-2026-80179 (bsc#1277639):
    * Add ML-DSA post-quantum signature support (RFC 9964) by @rjeffman in #384
    * Support fully specified algorithms per RFC 9864 by @rjeffman in #389
    * Skip unknown kty in JWKSet import per RFC 7517 §5 by @rjeffman in #388
    * Reject non-empty encrypted key in bare ECDH-ES by @simo5 in #391
    * Limit dot splits during JWE and JWS parsing by @simo5 in #392
    * Version 1.5.9 by @simo5 in #393
* Sun Jun 28 2026 Dirk Müller <dmueller@suse.com>
  - update to 1.5.8:
    * Fix list iteration in claim format validation
    * fix: bump minimum cryptography dependency to >= 39.0.0
    * Wrap JWKSet parsing errors in InvalidJWKValue
    * jwt: add opt-in strict_serialization to enforce compact form
* Tue Apr 07 2026 Dirk Müller <dmueller@suse.com>
  - update to 1.5.7 (fixes CVE-2026-39373, bsc#1261802):
    * JWE: allow general (non flattened) serialization syntax
    * Update CI actions
    * Allow to pass through pem loading unsafe option
    * Add support for 'scope' claim with multiple scopes
    * Set default kid when importing keys from pyca.
    * Hardening: Enforce length of keys for HMAC operations
    * Add Ed25519 and Ed448 signature algorithms
    * Migrate jwcrypto packaging to Hatch
* Tue Mar 19 2024 Dirk Müller <dmueller@suse.com>
  - update to 1.5.6 (bsc#1221230, CVE-2024-28102):
    * Address potential DoS with high compression ratio
      (CVE-2024-28102)
  - update to 1.5.4:
    * One more release bump to address issues with
      typing_extensions minimum required version
  - update to 1.5.3:
    * Drop python 3.6 and 3.7 and add 3.11 support
    * replace deprecated package with typing_extensions
* Tue Jan 02 2024 Dirk Müller <dmueller@suse.com>
  - update to 1.5.1:
    * Fix X22519 import/export from PEM
    * Read the Docs now requires a config file
    * chore: refactor for removing pdb symbols
    * Fix potential DoS issue with p2c header
* Thu Dec 07 2023 Dirk Müller <dmueller@suse.com>
  - update to 1.5.0:
    * Minor bugfixes and the addition of Brainpool curves.
    * Raising the bar for minimum pyca/cryptography
    * Fix typos with codespell
    * Add codespell checks in CI
    * Add Brainpool EC-curves support
    * Fix error message
    * Fix  assorted CI issue
    * Better support for algorithms that have different input
      keysize requirement
* Fri Nov 18 2022 Michael Ströder <michael@stroeder.com>
  - update to 1.4.2 which also fixes CVE-2022-3102
    too many other changes to be listed here
* Wed Dec 08 2021 pgajdos@suse.com
  - do not require pytest-runner for build, not required
* Thu Aug 05 2021 Michael Ströder <michael@stroeder.com>
  - update to 1.0
    * Create SECURITY.md
    * Allow empty payloads in JWS tokens
    * Add tests to check empty payload support
    * Drop python2 compatibility
    * Fix python3 pylint issues
    * Add explicit support to check 'typ' in JWT
    * Drop support for importing old MutableMapping
    * Disable annoying pep8 naming checks

Files

/usr/lib/python3.13/site-packages/jwcrypto
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/INSTALLER
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/METADATA
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/RECORD
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/REQUESTED
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/WHEEL
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/licenses
/usr/lib/python3.13/site-packages/jwcrypto-1.6.1.dist-info/licenses/LICENSE
/usr/lib/python3.13/site-packages/jwcrypto/__init__.py
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/__init__.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/__init__.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/common.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/common.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwa.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwa.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwe.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwe.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwk.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwk.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jws.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jws.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwt.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/jwt.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests-cookbook.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests-cookbook.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests_mldsa.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/tests_mldsa.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/version.cpython-313.opt-1.pyc
/usr/lib/python3.13/site-packages/jwcrypto/__pycache__/version.cpython-313.pyc
/usr/lib/python3.13/site-packages/jwcrypto/common.py
/usr/lib/python3.13/site-packages/jwcrypto/jwa.py
/usr/lib/python3.13/site-packages/jwcrypto/jwe.py
/usr/lib/python3.13/site-packages/jwcrypto/jwk.py
/usr/lib/python3.13/site-packages/jwcrypto/jws.py
/usr/lib/python3.13/site-packages/jwcrypto/jwt.py
/usr/lib/python3.13/site-packages/jwcrypto/tests-cookbook.py
/usr/lib/python3.13/site-packages/jwcrypto/tests.py
/usr/lib/python3.13/site-packages/jwcrypto/tests_mldsa.py
/usr/lib/python3.13/site-packages/jwcrypto/version.py
/usr/share/doc/packages/python313-jwcrypto
/usr/share/doc/packages/python313-jwcrypto/README.md
/usr/share/licenses/python313-jwcrypto
/usr/share/licenses/python313-jwcrypto/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Oct 4 23:38:45 2026