Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgudev-1_0-0-237-2.5 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: libgudev-1_0-0 Distribution: openSUSE Tumbleweed
Version: 237 Vendor: openSUSE
Release: 2.5 Build date: Wed Aug 31 16:16:32 2022
Group: System/Libraries Build host: lamb57
Size: 77127 Source RPM: libgudev-237-2.5.src.rpm
Packager: https://bugs.opensuse.org
Url: https://wiki.gnome.org/Projects/libgudev
Summary: GObject library, to access udev device information
This package contains the GObject library libgudev, which provides
access to udev device information.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Fri Jan 28 2022 Dirk Müller <dmueller@suse.com>
  - add explicit glibc-locale buildrequires for passing the testsuite (bsc#1195390)
* Sun Aug 15 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 237:
    + Fix reading double precision floats from sysfs attributes in
      locales that use comma as a separator
    + Fix compilation warning
    + Fix headers to help with build reproducibility
    + Clarify licensing information
  - Changes from version 236:
    + Fix meson project name to match autotools.
  - Changes from version 235:
    + Port build system to meson and remove autotools
    + Fix conversion of sysfs attributes to boolean.
  - Add meson BuildRequires and macros following upstreams port.
  - Enable pkgconfig(umockdev-1.0) BuildRequires and test macro.
  - Update Licence tag to LGPL-2.1-or-later.
* Sun Jan 24 2021 Dirk Müller <dmueller@suse.com>
  - update to 234:
    * Clarify that _get_sysfs_attr() functions are cached
    * Add functions to get uncached sysfs attributes
* Sat Aug 03 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 233:
    + Require glib 2.38.
    + Small documentation updates.
    + Remove gnome-common build dependency.
  - Use modern macros.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Fri Sep 01 2017 zaitor@opensuse.org
  - Update to version 232:
    + Fix crash on plenty of architectures in the test suite.
    + Add g_autoptr automatic clean up for libgudev objects.
  - Tweak package description a bit.
* Mon Feb 13 2017 zaitor@opensuse.org
  - Update to version 231:
    + Fix a bug in the enumerator to ensure that client subsystems
      are implicitly matched.
    + Require a newer GLib to simplify some code.
  - Add disabled pkgconfig(umockdev-1.0) BuildRequires, new
    optional dependency, that is enabled by default upstream, but
    unfortunatly not yet available in openSUSE.
  - Following the above: pass --disable-umockdev to configure.
* Tue Mar 22 2016 fbui@suse.com
  - Import libgudev from Factory to SLE (fate#320658):
    new versions of systemd doesn't ship libgudev anymore and a
    dedicated package has been created and should be used instead.
* Fri Sep 25 2015 dimstar@suse.com
  - Enable build (dummy change for repo_checker, as libgudev was
    wrongly already checked in to openSUSE:Factory, but has since
    been disabled). With this, we can activate the Staging properly.
* Fri Jun 19 2015 jengelh@inai.de
  - Transplant baselibs.conf from systemd.spec. Update package
    metadata.

Files

/usr/lib/libgudev-1.0.so.0
/usr/lib/libgudev-1.0.so.0.3.0
/usr/share/licenses/libgudev-1_0-0
/usr/share/licenses/libgudev-1_0-0/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Jan 30 23:19:49 2023