Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libdbusmenu-gtk3-4-16.04.0-8.2 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: libdbusmenu-gtk3-4 Distribution: openSUSE Tumbleweed
Version: 16.04.0 Vendor: openSUSE
Release: 8.2 Build date: Wed May 11 04:26:48 2022
Group: System/Libraries Build host: lamb62
Size: 165569 Source RPM: libdbusmenu-gtk3-16.04.0-8.2.src.rpm
Packager: https://bugs.opensuse.org
Url: https://launchpad.net/dbusmenu
Summary: GTK+ 3 version of libdbusmenu
This package contains GTK 3 dbusmenu shared library.

Provides

Requires

License

GPL-3.0-only AND (LGPL-2.1-only OR LGPL-3.0-only)

Changelog

* Sun Apr 03 2022 Callum Farmer <gmbr3@opensuse.org>
  - Set GTKDOCIZE=true when gtk3 to fix issues with autoconf 2.70
* Mon Mar 23 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Require the tyeplib packages from the -devel packages: typelibs
    are shared libraries and consumers of the -devel package have a
    right to assume the libraries are present.
* Wed Dec 11 2019 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Disable testtools on %arm since Valgrind is broken on armv6/7 atm
* Tue Nov 19 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Work around OBS idiosyncrasies regarding packages name.
* Mon Nov 18 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Drop dependency on deprecated gnome-common, just run autoreconf
  - Do not include unused tree_index.sgml, fix build with gtk-doc >= 1.32,
    see https://gitlab.gnome.org/GNOME/gtk-doc/issues/103
    * add 0001-Fix-build-with-gtk-doc-1.32-due-to-non-existing-tree.patch
  - Fix missing accelerators, add
    0002-genericmenuitem-Make-accelerator-text-appear-again.patch
  - Split Gtk2 and Gtk3 build - glib, tools and doc subpackage are created
    from the Gtk2 flavor.
    * Fix building with disabled tests, add 0003-Fix-HAVE_VALGRIND-AM_CONDITIONAL.patch
* Wed Oct 16 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - Inject -Wno-error into CFLAGS. It's kinda ridiculous for code
    that is not maintained upstream to pass -Werror by default and
    then not catching up. So for now we accept warnings.
* Tue Aug 13 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Drop superfluous hard pkgconfig(gtk+-2.0) Requires from
    libdebusmenu-glib-devel sub-package.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Thu Sep 08 2016 dimstar@opensuse.org
  - Use proper libdbusmenu 16.04.0 tarball directly from launchpad:
    + The old tarball's configure.ac happened to still use an old
      version, causing the .pc file to advertise insufficient
      capabilities.
* Fri Mar 04 2016 sor.alexei@meowr.ru
  - Update to 12.10.3+bzr20160223 (changes since 12.10.3+bzr20150410):
    * Disable test-json-instruction, hangs on builds (lp#1429291).
    * gtk: Look for GtkImages on regular GtkMenuItems too (lp#1549021).

Files

/usr/lib/libdbusmenu-gtk3.so.4
/usr/lib/libdbusmenu-gtk3.so.4.0.12
/usr/share/doc/packages/libdbusmenu-gtk3-4
/usr/share/doc/packages/libdbusmenu-gtk3-4/NEWS
/usr/share/licenses/libdbusmenu-gtk3-4
/usr/share/licenses/libdbusmenu-gtk3-4/COPYING
/usr/share/licenses/libdbusmenu-gtk3-4/COPYING-GPL3
/usr/share/licenses/libdbusmenu-gtk3-4/COPYING.2.1


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 16 23:15:40 2022