Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

0ad-0.0.25b-5.6 RPM for i586

From OpenSuSE Tumbleweed for i586

Name: 0ad Distribution: openSUSE Tumbleweed
Version: 0.0.25b Vendor: openSUSE
Release: 5.6 Build date: Wed May 11 09:20:49 2022
Group: Amusements/Games/Strategy/Real Time Build host: build77
Size: 8963872 Source RPM: 0ad-0.0.25b-5.6.src.rpm
Packager: https://bugs.opensuse.org
Url: https://play0ad.com/
Summary: A real-time strategy game of ancient warfare
0 A.D. (pronounced "zero ey-dee") is a real-time strategy (RTS) game
of ancient warfare. It is a historically-based war/economy game that
allows players to relive or rewrite the history of Western
civilizations, focusing on the years between 500 B.C. and 500 A.D.
The project contains 3D graphics, detailed artwork, sound, and a
flexible game engine.

Provides

Requires

License

BSD-3-Clause AND CC-BY-SA-3.0 AND GPL-2.0-or-later AND LGPL-3.0-or-later AND MIT AND ISC AND MPL-2.0

Changelog

* Wed Mar 23 2022 Bernhard Wiedemann <bwiedemann@suse.com>
  - Drop fix-i586-build.patch after boo#1197065 was fixed
* Sun Mar 13 2022 Bernhard Wiedemann <bwiedemann@suse.com>
  - Add fix-i586-build.patch to fix build on i586
* Fri Mar 11 2022 Dominique Leuenberger <dimstar@opensuse.org>
  - Do not build on i586.
* Sun Feb 20 2022 Aaron Puchert <aaronpuchert@alice-dsl.net>
  - Add glibc-2.35.patch: Fix build with glibc 2.35.
  - Use system mozjs on Leap 15.4 as well.
* Tue Jan 11 2022 Simon Puchert <simonpuchert@alice.de>
  - Get rid of Python 2 dependency.
  - Disable tests. These require Python 2 to work, but also aren't
    executed or packaged anyway.
  - Remove duplicate listing of %{_libdir}/%{name}.
* Fri Jan 07 2022 Simon Puchert <simonpuchert@alice.de>
  - Make 0ad compatible with Tumbleweed's version of mozjs78:
    * no-version-check.patch: Disable the minor version check. This
      is required for a successful build using mozjs78 > 78.6.0.
    * PrepareZoneForGC.patch: This function got an additional
      parameter, change its usage accordingly. (boo#1187732)
* Sun Aug 29 2021 ecsos <ecsos@opensuse.org>
  - Update to version 0.0.25b:
    * Ranked matches did not longer grant points in the lobby.
    * Mod installation no longer require restart.
    * Mod installation no longer prints errors when installing mods by double-clicking
    * Mod installation now overwrites the existing mods to allow for easier updates.
    * Fishes are now easier to spot on lowest settings with the addition of seagulls.
    * See https://wildfiregames.com/forum/topic/53714-re-release-of-0-ad-alpha-25-yauna/
  - Increase disk size in _constraints to fix build error
    "No space left on device" in Leap.
* Mon Aug 16 2021 Simon Puchert <simonpuchert@alice.de>
  - Update to version 0.0.25:
    * See https://play0ad.com/new-release-0-a-d-alpha-25-yauna/
  - Dropped mozjs-rust_1_50.patch, merged upstream
* Tue Apr 27 2021 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - BuildRequires nvidia-texture-tools only when needed
* Mon Apr 26 2021 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Enable nvidia-texture-tools only on supported archs
* Fri Apr 09 2021 Ferdinand Thiessen <rpm@fthiessen.de>
  - Install bundled mozjs if needed (boo#1184063)
* Tue Mar 09 2021 Ferdinand Thiessen <rpm@fthiessen.de>
  - Update to version 0.0.24b:
    * See https://play0ad.com/new-release-0-a-d-alpha-24-xsayarsa/
    * Added upstream mozjs-rust_1_50.patch for Factory
  - Dropped upstream merged patches:
    * 0001-fix-fcollada-error.patch
    * 0001-Fix-ODR-violation-for-ShaderModelRendererInternals.patch
* Mon Aug 03 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Fix build on ix86 in combination with LTO, the bundled mbedtls
    from premake5 creates duplicate symbols from inline asm.
    Add avoid_duplicate_global_symbol_from_asm.patch
  - Add 0001-Fix-ODR-violation-for-ShaderModelRendererInternals.patch
  - Clean up dozens of unnecessary build dependencies.
* Sun Aug 02 2020 Simon Vogl <simon.vogl@gmx.net>
  - Disable --with-system-mozjs38 option on systems which lack the mozjs38 package
  - Include the libmozjs38-ps-release.so binary on systems which lack the mozjs38 package
  - Require more build dependencies on systems which lack the mozjs38 package
  - Add 0001-fix-fcollada-error.patch to fix a build failure with gcc10
* Fri Dec 20 2019 Dominique Leuenberger <dimstar@opensuse.org>
  - Disable LTO on i586.
* Mon May 20 2019 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Add _constraints to avoid build failures due to OOM
* Tue Apr 09 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Spec file cleanup:
    * Use https for Url and Source tags
    * Remove defattr
    * Remove __DATE__ mangling, handled by GCC + SOURCE_DATE_EPOCH
    * Remove support for Leap 42.x, unresolvable anyway

Files

/usr/bin/0ad
/usr/bin/ActorEditor
/usr/bin/pyrogenesis
/usr/lib/0ad
/usr/lib/0ad/libAtlasUI.so
/usr/lib/0ad/libCollada.so
/usr/share/0ad
/usr/share/appdata/0ad.appdata.xml
/usr/share/applications/0ad.desktop
/usr/share/doc/packages/0ad
/usr/share/doc/packages/0ad/README.txt
/usr/share/licenses/0ad
/usr/share/licenses/0ad/LICENSE.txt
/usr/share/licenses/0ad/license_gpl-2.0.txt
/usr/share/licenses/0ad/license_lgpl-2.1.txt
/usr/share/licenses/0ad/license_mit.txt
/usr/share/pixmaps/0ad.png


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Jun 16 23:15:40 2022