Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

yast2-update-FACTORY-4.2.20-lp152.2.4.1 RPM for ppc64le

From OpenSuSE Ports Leap 15.2 updates for ppc64le

Name: yast2-update-FACTORY Distribution: openSUSE Leap 15.2
Version: 4.2.20 Vendor: openSUSE
Release: lp152.2.4.1 Build date: Thu Jan 28 20:17:57 2021
Group: System/YaST Build host: obs-power8-05
Size: 27203 Source RPM: yast2-update-4.2.20-lp152.2.4.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/yast/yast-update
Summary: YaST2 - Update
Use this component if you wish to update your system.

Provides

Requires

License

GPL-2.0-only

Changelog

* Mon Dec 14 2020 Ladislav Slezák <lslezak@suse.cz>
  - Fixed selecting the base product (e.g. SLES) during upgrade
    (bsc#1176276)
  - 4.2.20
* Thu Sep 17 2020 schubi@suse.de
  - Adding additional compatible vendors which are defined in the
    control file (jsc#SLE-14807).
  - 4.2.19
* Thu Mar 12 2020 Ladislav Slezák <lslezak@suse.cz>
  - Do not remove the installation repositories in the "Previously
    Used Repositories" step (bsc#1163081)
  - 4.2.18
* Fri Feb 21 2020 Ladislav Slezák <lslezak@suse.cz>
  - Fixed repository loading to not remove the initial installation
    repository (bsc#1163081)
  - 4.2.17
* Wed Feb 19 2020 Ladislav Slezák <lslezak@suse.cz>
  - Switch from Autotools based build to Rake
* Wed Feb 19 2020 Stefan Hundhammer <shundhammer@suse.com>
  - Fixed user-visible messages (bsc#1084015)
  - 4.2.16
* Mon Feb 17 2020 mls@suse.de
  - Also accept Packages.db as valid rpm database (bsc#1162485)
  - 4.2.15
* Tue Jan 28 2020 Ladislav Slezák <lslezak@suse.cz>
  - Store the original repository setup early in the upgrade workflow
    so YaST can easily differ between the old and new repositories
    (bsc#1159433)
  - 4.2.14
* Fri Jan 03 2020 schubi@suse.de
  - Aborting upgrade: Restoring old settings e.g. RPM database
    (bsc#1158914).
  - mount /run and efivars into target to fix hanging LVM (bsc#1148500)
    by Steffen Winterfeldt <snwint@suse.com>
  - 4.2.13
* Wed Dec 04 2019 Josef Reidinger <jreidinger@suse.com>
  - fix upgrade for online medium (bsc#1158056 and bsc#1157636)
  - 4.2.12
* Tue Nov 19 2019 schubi@suse.de
  - Using Y2Packager::Resolvable.any? and Y2Packager::Resolvable.find
    in order to decrease the required memory (bsc#1132650,
    bsc#1140037).
  - 4.2.11
* Thu Nov 07 2019 Ladislav Slezák <lslezak@suse.cz>
  - Fixed too eager Rubocop cleanup resulting in "No fstab found"
    error after selecting a partition to upgrade (related to
    jsc#SLE-7101)
  - 4.2.10
* Thu Nov 07 2019 Ladislav Slezák <lslezak@suse.cz>
  - Implement upgrade for Full medium (jsc#SLE-7101)
  - 4.2.9
* Tue Nov 05 2019 Josef Reidinger <jreidinger@suse.com>
  - Add support for online auto_upgrade (jsc#SLE-7214)
  - 4.2.8
* Wed Oct 09 2019 Martin Vidner <mvidner@suse.com>
  - At upgrade time, mount also /run and efivars in the target,
    to fix hanging LVM tools (bsc#1148500)
  - 4.2.7
* Mon Sep 30 2019 José Iván López González <jlopez@suse.com>
  - Use new API to save encryption names from crypttab file (part of
    jsc#SLE-7376).
  - 4.2.6
* Thu Aug 22 2019 schubi@suse.de
  - Using rb_default_ruby_abi tag in the spec file in order to
    handle several ruby versions (bsc#1146403).
  - 4.2.5
* Thu Jun 06 2019 schubi@suse.de
  - Going back and forward in the update workflow: Initialize
    add-on products and system packages correctly (bsc#1136012).
  - 4.2.4
* Fri May 31 2019 Stasiek Michalski <hellcp@mailbox.org>
  - Add metainfo (fate#319035)
  - Revamp spec
  - Replace GenericName with Comment
  - 4.2.3
* Fri Apr 26 2019 Ladislav Slezák <lslezak@suse.cz>
  - Uninstall the "SUSE-Manager-Proxy" product when upgrading from
    SLES12 + SUMA Proxy + SUMA Branch Server (bsc#1133215)
  - 4.2.2
* Fri Apr 05 2019 José Iván López González <jlopez@suse.com>
  - Remove obsolete code.
  - 4.2.1
* Tue Mar 26 2019 José Iván López González <jlopez@suse.com>
  - Remove code related to device name translations.
  - 4.2.0
* Thu Jan 24 2019 lslezak@suse.cz
  - Added URL tag to the spec file (bsc#1097957)
  - 4.1.8
* Mon Nov 26 2018 Noah Davis <noahadvs@gmail.com>
  - Provide icon with module (boo#1109310)
  - 4.1.7
* Tue Nov 20 2018 schubi@suse.de
  - Function SelectProduct removed in order NOT to select All
    available products (bsc#1116332).
  - 4.1.6
* Mon Nov 05 2018 jlopez@suse.com
  - Avoid to crash when crypttab contains entries where the LUKS is
    given by UUID= format.
  - Avoid to crash when an encryption device is not probed with the
    name indicated in a fstab entry.
  - Related to bsc#1094963.
  - 4.1.5
* Tue Oct 16 2018 schubi@suse.de
  - Added license file to spec.
* Wed Sep 19 2018 schubi@suse.de
  - Fixed crash while writing backup (bsc#1108934)
  - 4.1.4
* Mon Sep 17 2018 dgonzalez@suse.com
  - Avoid to restore old backups when upgrade fails (bsc#1097297)
  - 4.1.3
* Tue Sep 11 2018 aschnell@suse.com
  - do not translate snapshot description (bsc#1092757)
  - 4.1.2
* Wed Aug 22 2018 schubi@suse.de
  - Switched license in spec file from SPDX2 to SPDX3 format.
* Tue Aug 21 2018 lslezak@suse.cz
  - Do not crash at upgrade when the original /etc/resolv.conf
    file is set to immutable (bsc#1096142)
  - 4.1.1
* Wed Jul 25 2018 schubi@suse.de
  - Wrong fstype "Windows Data Partition" will not be shown anymore
    for partition which are suggested for upgrade. (bsc#1079034)
  - 4.1.0
* Thu Jun 28 2018 schubi@suse.de
  - Added additional searchkeys to desktop file (fate#321043).
  - 4.0.17
* Thu Jun 07 2018 jlopez@suse.com
  - Update encryption device names according to the values in the
    crypttab file (bsc#1094963).
  - 4.0.16
* Wed Jun 06 2018 lslezak@suse.cz
  - Flush the disk cache after restoring the backup to mitigate
    risk of data loss after unexpected reboot/poweroff after aborting
    upgrade (bsc#1089643)
  - 4.0.15
* Wed May 09 2018 lslezak@suse.cz
  - Fixed unmounting /mnt/dev when going back to the partition
    selection dialog (fix up for the bsc#1089643)
  - 4.0.14
* Fri Apr 27 2018 lslezak@suse.cz
  - Copy the resolv.conf and bind mount /dev directory to the target
    root, sort the restore scripts to run them in the expected
    order (bsc#1089643)
  - The bind mount also fixes the libzypp plugin service refresh
    (bsc#1080693)
  - 4.0.13
* Mon Mar 19 2018 ancor@suse.com
  - Fixed a crash when upgrading systems with a separate /var
    (bsc#1071454).
  - Better support for upgrading systems with a /var subvolume.
  - 4.0.12
* Wed Mar 14 2018 lslezak@suse.cz
  - Properly restore the original installation repositories when
    going back to the partition selection dialog (related to
    bsc#1080979)
  - Remove the very old and unused stuff (dead code, unsupported
    file systems, ...)
  - 4.0.11
* Thu Mar 08 2018 lslezak@suse.cz
  - Automatically save a solver test case when the product summary
    contains a warning for easier debugging (related to bsc#1084248)
  - 4.0.10
* Fri Feb 09 2018 jlopez@suse.com
  - Adapt to new MountPoint API (part of fate#318196).
  - 4.0.9
* Mon Jan 15 2018 jreidinger@suse.com
  - remove obsolete rootpart_check_keyboard client that allows having
    different keyboard in update env and on target disk (related to
    bsc#1075828)
  - 4.0.6
* Tue Jan 09 2018 ancor@suse.com
  - When matching partitions, rely on the new
    Y2Storage::Devicegraph#find_by_any_name (bsc#1073254).
  - 4.0.5
* Fri Jan 05 2018 jsrain@suse.cz
  - upgrade the system always via equivalent of 'zypper dup'
    (bsc#1071708)
  - 4.0.4
* Tue Dec 19 2017 ancor@suse.com
  - When matching partitions, also use udev names that have been
    discarded by libstorage-ng (bsc#1073254).
  - 4.0.3
* Mon Dec 18 2017 ancor@suse.com
  - Use udev names, in addition to kernel device names, to match
    partitions (part of the fix for bsc#1073254).
  - 4.0.2
* Fri Nov 24 2017 jsrain@suse.cz
  - Display warning if system uses cryptconfig encrypted home
    directories (fate#323541)
  - 4.0.1
* Tue Oct 31 2017 mvidner@suse.com
  - Filter upgradable products in the partition selector already
    (FATE#323163).
  - 4.0.0
* Tue Aug 22 2017 knut.anderssen@suse.com
  - Show legacy root filesystems in the list of systems to upgrade
    from (fate#323394).
  - 3.3.4
* Mon Aug 21 2017 ancor@suse.com
  - Use translatable and human-friendly format to display the
    partition id during a system upgrade (part of fate#318196).
  - 3.3.3
* Thu Aug 17 2017 knut.anderssen@suse.com
  - Fixed a typo calling a Logger method (bsc#1054236).
  - 3.3.2
* Wed Aug 16 2017 knut.anderssen@suse.com
  - Do not allow to upgrade if the target system uses reiserfs
    (fate#323394).
  - 3.3.1
* Mon Aug 14 2017 ancor@suse.com
  - Merged storage-ng branch (fate#318196).
  - Note: all changes below with this date belong to the merge.
  - 3.3.0
* Mon Aug 14 2017 ancor@suse.com
  - storage-ng: adapted calls to temporary y2storage_* methods, since
    they were finally removed from Y2Storage::StorageManager.
* Mon Aug 14 2017 shundhammer@suse.de
  - Merged master to storage-ng branch
* Mon Aug 14 2017 jlopez@suse.com
  - storage-ng: add detection of previous systems using lvm.
* Mon Aug 14 2017 ancor@suse.com
  - storage-ng: detection of previous systems partially adapted.
* Wed Apr 19 2017 lslezak@suse.cz
  - Fixed parsing whitespace lines in the original /etc/fstab
    (bsc#1030425)
  - 3.2.2
* Mon Jan 30 2017 igonzalezsosa@suse.com
  - Allow YaST modules to add packages during upgrade (bsc#1009834)
  - 3.2.1
* Thu Jan 05 2017 jreidinger@suse.com
  - Add storage to build dependencies as tests depends on it
    (related to changes done for bsc#932331)
  - 3.2.0
* Thu Sep 29 2016 igonzalezsosa@suse.com
  - Translate description of Snapper pre-update snapshot
    (bsc#988700)
  - 3.1.43
* Fri Aug 26 2016 kanderssen@suse.com
  - The update installer has been moved earlier in the workflow. We
    don't need to store data to remember selected target/partitions
    anymore. (bsc#988287)
  - 3.1.42
* Fri Aug 05 2016 kanderssen@suse.com
  - Remember selected target/partitions after an installer update.
    (bsc#988287)
  - 3.1.41
* Mon Jun 06 2016 igonzalezsosa@suse.com
  - Stop generating autodocs (fate#320356)
  - 3.1.40
* Tue May 03 2016 lslezak@suse.cz
  - Updated yast2-packager dependency (FATE#320199)
  - 3.1.39
* Fri Apr 22 2016 lslezak@suse.cz
  - Select the default product patterns in the pattern based upgrade
    (FATE#320199)
  - 3.1.38
* Mon Mar 14 2016 igonzalezsosa@suse.com
  - Remove Yast::Transfer::FileFromUrl as it will be present
    in yast2-installation (FATE#319716).
  - 3.1.37
* Tue Feb 16 2016 mvidner@suse.com
  - Moved Yast::Transfer::FileFromUrl here from autoyast2.
    (FATE#316796)
  - 3.1.36
* Fri Jan 29 2016 lslezak@suse.cz
  - Fixed selecting additional products during system upgrade
    (do not select previously unselected products after adding
    repositories from the registration server) (bsc#959155)
  - 3.1.35
* Mon Oct 05 2015 locilka@suse.com
  - Added new test for Update.IsProductSupportedForUpgrade
    (bsc#947398)
  - 3.1.34
* Wed Jul 01 2015 shundhammer@suse.de
  - Cleanup for snapshots made during installation (bnc#935923)
  - 3.1.33
* Mon Jun 29 2015 lslezak@suse.cz
  - UX: add a link to the dependency error message to make the
    required user action obvious (bsc#936450)
  - 3.1.32
* Mon Jun 01 2015 jreidinger@suse.com
  - make junk_cleaner less aggresive to not remove important files
    (fate#317900)
  - 3.1.31
* Fri May 29 2015 jreidinger@suse.com
  - mount properly subvolumes of upgraded system (fate#317900)
  - 3.1.30
* Thu May 28 2015 jreidinger@suse.com
  - create pre update snapshot (fate#317900)
  - 3.1.29
* Mon May 18 2015 lslezak@suse.cz
  - sort patterns in the upgrade summary to have stable output for
    openQA tests (bsc#931295), escape the HTML tags
  - 3.1.28
* Mon Feb 09 2015 lslezak@suse.cz
  - install the packages needed for accesing the installation
    repository (bnc#916200)
  - 3.1.27
* Fri Feb 06 2015 ancor@suse.com
  - The unit tests are now compatible with RSpec 3 (bnc#916364)
  - 3.1.26
* Thu Dec 04 2014 jreidinger@suse.com
  - remove X-KDE-Library from desktop file (bnc#899104)
* Wed Nov 12 2014 lslezak@suse.cz
  - display product names in the incompatible products error
    message (bnc#904192)
  - 3.1.24

Files

/usr/share/YaST2/clients/run_update.rb
/usr/share/YaST2/clients/update.rb
/usr/share/YaST2/control
/usr/share/YaST2/control/update.xml
/usr/share/applications/YaST2
/usr/share/applications/YaST2/org.opensuse.yast.Update.desktop
/usr/share/icons
/usr/share/icons/hicolor
/usr/share/icons/hicolor/scalable
/usr/share/icons/hicolor/scalable/apps
/usr/share/icons/hicolor/scalable/apps/yast-update.svg
/usr/share/licenses/yast2-update-FACTORY
/usr/share/licenses/yast2-update-FACTORY/COPYING
/usr/share/metainfo
/usr/share/metainfo/org.opensuse.yast.Update.metainfo.xml


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Nov 29 23:53:12 2021