Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

SUSEConnect-0.3.31-lp152.2.9.1 RPM for ppc64le

From OpenSuSE Ports Leap 15.2 updates for ppc64le

Name: SUSEConnect Distribution: openSUSE Leap 15.2
Version: 0.3.31 Vendor: openSUSE
Release: lp152.2.9.1 Build date: Wed Sep 8 12:12:54 2021
Group: System/Management Build host: obs-power8-03
Size: 184778 Source RPM: SUSEConnect-0.3.31-lp152.2.9.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/SUSE/connect
Summary: Utility to register a system with the SUSE Customer Center
This package provides a command line tool and rubygem library for connecting a
client system to the SUSE Customer Center. It will connect the system to your
product subscriptions and enable the product repositories/services locally.

Provides

Requires

License

LGPL-2.1

Changelog

* Wed Jul 21 2021 Natnael Getahun <ngetahun@suse.com>
  - Update to 0.3.31
  - Disallow registering via SUSEConnect if the system is managed by SUSE Manager.
  - Add subscription name to output of 'SUSEConnect --status'
* Sun Jun 20 2021 Thomas Schmidt <tschmidt@suse.com>
  - Update to 0.3.30
  - send payload of GET requests as part of the url,
    not in the body (see bsc#1185611)
* Tue Nov 17 2020 Tamara Schmitz <tamara.schmitz@suse.com>
  - Update to 0.3.29
  - replace env ruby path with native ruby path during build phase
* Mon Sep 28 2020 Thomas Schmidt <tschmidt@suse.com>
  - Recognize more formats when parsing .curlrc for proxy credentials (bsc#1155027)
  - Add rpmlintrc to filter false-positive warning about patch not applied
* Mon Aug 31 2020 Thomas Muntaner <tmuntaner@suse.com>
  - Update to 0.3.27
  - SUSEConnect now ensures that it writes its configuration when it
    encounters errors. This helps in the situation where SUSEConnect
    announces itself, but fails during a later step. Without the saved
    configuration, a system could have credentials, but be unsure which
    registration proxy they're valid for.
* Wed Aug 26 2020 Imobach Gonzalez Sosa <igonzalezsosa@suse.com>
  - Update to 0.3.26
    - Extend the YaST API in order to access to the package search
      functionality (jsc#SLE-9109)
* Tue Jun 30 2020 Thomas Schmidt <tschmidt@suse.com>
  - Don't fail de-activation when '-release' package already got removed
* Thu Jan 02 2020 Ivan Kapelyukhin <ikapelyukhin@suse.com>
  - Update to 0.3.25
  - Fix cloud_provider detection on AWS large instances (bsc#1160007)
* Tue Nov 05 2019 Ivan Kapelyukhin <ikapelyukhin@suse.com>
  - Update to 0.3.24
  - Forbid de-registration for on-demand Public Cloud instances (bsc#1155911)
* Mon Oct 14 2019 Thomas Schmidt <tschmidt@suse.com>
  - 0.3.23
    fix .spec file to correctly apply switch_server_cert_location_to_etc.patch to SLE15SP2+ (bsc#1130864)
* Mon Sep 30 2019 Thomas Schmidt <tschmidt@suse.com>
  - Update to 0.3.22
    switch_server_cert_location_to_etc.patch: add patch to switch server cert path for SLE15.2+ to /etc (bsc#1130864)
* Thu Sep 26 2019 Thomas Schmidt <tschmidt@suse.com>
  - Update to 0.3.21
    Fix error on first activation of packagehub extension (bsc#1124318)
* Thu Aug 08 2019 Ivan Kapelyukhin <ikapelyukhin@suse.com>
  - Update to 0.3.20
  - Fix getting the list of installed products when zypper plugins are
    present (bsc#1143635)
* Wed Aug 07 2019 Giovanni Filippetti <giovanni.filippetti@suse.com>
  - Update to 0.3.19
    - Fix failing on registered system without arguments (bsc#1144020)
* Wed May 29 2019 Ivan Kapelyukhin <ikapelyukhin@suse.com>
  - Update to 0.3.18
  - Fix base product service removal during de-registration in public clouds (bsc#1136752)
* Tue Apr 02 2019 Ivan Kapelyukhin <ikapelyukhin@suse.com>
  - Update to 0.3.17
    - Don't try to remove a service during migration if a zypper service
      plugin already exists (bsc#1128969)
* Tue Feb 05 2019 Stephan Kulow <coolo@suse.com>
  - Replace --no-ri --no-rdoc with --no-document - these options
    are obsolete since at least ruby 2.1 - and finally removed in
    ruby 2.6
  - Only overwrite --bindir on fedora, it will overwrite --buildroot
    (which needs to be combined on newer fedoras)
* Fri Dec 07 2018 fschueller@suse.com
  - Update to 0.3.16
    - Show non-enabled extensions with a remark about availability
* Fri Nov 16 2018 fschueller@suse.com
  - Update to 0.3.15
    - Output information about registration and de-registration progress
* Fri Nov 09 2018 fschueller@suse.com
  - Output proper message when SUSEConnect is called without parameters (bsc#959561)
  - Default to https URI when no protocol prefix is provided for --url
  - Support transactional-update systems (fate#326482)
* Tue Oct 23 2018 hschmidt@suse.com
  - Changed "openssl" recommendation to "openssl(cli)"
    on SLE 12 SP3+ and SLE 15+ (bsc#1101470).
* Mon Oct 22 2018 hschmidt@suse.com
  - Update to 0.3.14
    - Fix s390 activation fails due to unavailable 'dmidecode' bsc#1112702
* Fri Sep 28 2018 skotov@suse.com
  - Update to 0.3.13
    - Fix migration targets sorting (bsc#1104183)
* Wed Sep 05 2018 tmuntaner@suse.com
  - Update to 0.3.12
    - Detect if system is in cloud provider (AWS/Google/Azure)
      (fate#320935)
    - Don't fail when trying to parse an empty body. Fixes bsc#1098220
    - Don't install release packages if they are already present
* Tue Jun 19 2018 tschmidt@suse.com
  - Fix .spec file for running SUSEConnect on Fedora28
* Tue Jun 05 2018 wstephenson@suse.com
  - Weaken dependencies of rmt-client-setup script to Recommends:
    (bsc#1094348)
  - Enhance error message generation
  - Add not supported operation exception to PackageSearch API
* Wed May 16 2018 hschmidt@suse.com
  - Update to 0.3.11
  - Add dependencies needed by the rmt-client-setup script. bsc#1093658
* Mon May 07 2018 hschmidt@suse.com
  - Prevent the automatic registration of recommended products that
    are not mirrored by the registration proxy.
* Thu Apr 19 2018 fschnizlein@suse.com
  - Update to 0.3.10
    - Fix rollback mechanism on SLE15 systems (bsc#1089320)
* Thu Apr 05 2018 wstephenson@suse.com
  - Update to 0.3.9
    - Enable access to package search via gem
    - Don't try to delete directory of nonexistent service files
      (bsc#1086420)
* Tue Mar 13 2018 fschnizlein@suse.com
  - Update to 0.3.8
    - Fix list-extensions to show the full SLE 15 tree (bsc#1064264)
    - Enable automatic activation of recommended extensions/modules
    - Automatically deregister all installed extensions/modules when
      deregistering a system
* Tue Jan 30 2018 fschueller@suse.com
  - Repackage gem
* Tue Jan 23 2018 fschueller@suse.com
  - Remove unnecessary .gz files
* Thu Jan 18 2018 fschueller@suse.com
  - Update to 0.3.7
    - virt-create-rootfs connects to SMT server without breaking (bsc#914297)
* Thu Dec 28 2017 hschmidt@suse.com
  - Update to 0.3.6
    - Make target_base_product parameter mandatory.
* Mon Dec 18 2017 hschmidt@suse.com
  - Update to 0.3.5
    - Add YaST.system_offline_migrations
* Thu Dec 14 2017 tschmidt@suse.com
  - Update to version 0.3.4:
    - Packaging improvements (bsc#964013)
* Thu Dec 07 2017 tschmidt@suse.com
  - Update to version 0.3.3:
    - Fix SLE15 build
* Mon Oct 16 2017 ikapelyukhin@suse.com
  - Properly refresh zypper services when deactivating a product on SMT (bsc#1047153)
* Mon Jun 26 2017 kpimenov@suse.com
  - Update to 0.3.2:
    - Fix --namespace parameter persistence (bsc#1044493)
* Thu Jun 08 2017 thutterer@suse.com
  - Update to 0.3.1:
    - Fix license auto-agree issue (bsc#1037783)
    - Add missing archs to SLE 12 SP3 build target
* Fri May 05 2017 andrei.shaidurov@suse.com
  - Update to 0.3.0:
    - Single product deactivation feature (fate#320572)
* Tue Mar 21 2017 ashaidurov@suse.com
  - Update to 0.2.43:
    - RPM spec fix for openSUSE:Factory rpmlint compliance (bsc#1028660)
* Fri Mar 03 2017 thutterer@suse.com
  - Update to 0.2.42:
    - Better error message for network request failure (bsc#982630)
    - Fix error message for --product with malformed identifier (bsc#1018190)
    - Fix some errors and formatting in manpages and help output
* Thu Oct 06 2016 thutterer@suse.com
  - Update to 0.2.41:
    - Better error message for --list-extensions on unregistered systems
* Tue Sep 13 2016 hschmidt@suse.com
  - Update to 0.2.40:
    - Update man page to include the --list-extensions option (bsc#998583)
* Thu Aug 11 2016 thutterer@suse.com
  - Update to 0.2.39:
    - Fix for bnc#990475: support for aarch64 hardware info
* Tue Aug 02 2016 thutterer@suse.com
  - Update to 0.2.38:
    - Fix for bnc#975484: better error message if SMT is too old
* Tue Jun 21 2016 hschmidt@suse.com
  - Update to 0.2.37:
    - Add method to YaST class to get Installer-Updates repositories (fate#319716).
* Wed May 11 2016 ashaidurov@suse.com
  - Update to 0.2.36:
    - Fix for bnc#973851: More flexible exit codes handling in internal zypper calls
* Tue Apr 05 2016 ashaidurov@suse.com
  - Update to 0.2.35:
    - Fix for bnc#973315: Direct update from <=0.2.27 does not remove /usr/bin symlink
* Thu Mar 10 2016 tschmidt@suse.com
  - Update to 0.2.34:
    - Fix for bnc#963996: Do not crash on --list-extensions when connected to SMT
    - Fix for bnc#968245: Do not let zypper attempt to read products from remote locations
* Mon Jan 25 2016 tschmidt@suse.com
  - Update to 0.2.33:
    - Re-add SUSEConnect binary to /usr/sbin (bnc#963080)
    - Use `--match-exact` when searching for a product (bnc#952804)
    - Fix fonts on xterm (bnc#957354)
* Wed Dec 16 2015 tschmidt@suse.com
  - Update to version 0.2.32: Remove unneeded link in %post which caused a warning (bnc#946183)
* Fri Nov 20 2015 kpimenov@novell.com
  - Update to version 0.2.31 (bnc#946183)
    - Drop url-implies-writeconfig.diff; it is included in upstream since commit 2ef5aa
    - Correct RPM group
    - Include SCCcredentials file as a ghost entry
    - Further packaging improvements
* Thu Nov 19 2015 kpimenov@suse.com
  - Update to version 0.2.30
    - New packaging spec. One `SUSEConnect` package to rule them all (bnc#951671)
    - Update manpages to match the latest CLI options
* Tue Nov 10 2015 kpimenov@suse.com
  - Update to version 0.2.29
    - bnc#954266 Silently ignore malformed lscpu lines instead of failing
* Fri Oct 30 2015 tschmidt@suse.com
  - Update to version 0.2.28
    - Properly handle empty repository lists from zypper (bnc#951566)
* Fri Oct 23 2015 tschmidt@suse.com
  - Update to version 0.2.27
    - Do not install recommended dependencies when installing the product release package (bnc#945462)
    - Addd --rollback option (fate#319114)
* Wed Oct 21 2015 vlewin@suse.com
  - Update to version 0.2.26
    - zypper migration extremly slow with lot of modules and extensions registered (bnc#945462)
* Thu Oct 15 2015 hschmidt@suse.com
  - Update to version 0.2.25
    - Solves Allow registration without system uid (dmidecode fails on qemu system) (bnc#934582)
* Mon Oct 12 2015 achernikov@suse.de
  - bnc#949424 ensure version of SUSEConnect is bumped in order to be
    able to distinct requests from affected YaST version in SCC API
* Wed Sep 23 2015 hschmidt@suse.com
  - Update to version 0.2.24
    - Bug 943451 - [Migration] failure when "zypper search" returns empty list
    - Bug 946488 - Synchronization API call returns "no implicit conversion of Symbol into Integer" error
    - Bug 941565 - zypper migration not using --releasever
    - Bug 945462 - zypper migration extremly slow with lot of modules and extensions registered
* Mon Sep 14 2015 vlewin@suse.com
  - Update to version 0.2.23
    - Improve hwinfo detection on physical s390 systems
    - Bug 939293 - [S390] Error: Registration failed. Undefined method 'strip' for nil:NilClass (bnc#939293)
* Mon Sep 14 2015 vlewin@suse.com
  - Update to version 0.2.22
    - Migration rollback (fate#319114)
    - [Migration rollback] zypper migrate: baseproduct mismatch (bnc#941303)
* Fri Aug 07 2015 vlewin@suse.com
  - Update to version 0.2.21
    - Escape parameters of remove and add_repository methods
* Tue Aug 04 2015 vlewin@suse.com
  - Update to version 0.2.20
    - Add find_products method to migration abstraction layer fate#319140
    - Fix add_service method which also creates the credentials files
* Fri Jul 31 2015 vlewin@suse.com
  - Update to version 0.2.19
    - Introduction of migration abstraction layer for migration script
    - Clean up and re-factoring of yast abstraction layer
* Mon Jun 15 2015 vlewin@suse.com
  - Update to version 0.2.18
    - Improve SUSEConnect error messages
    - New --cleanup option (remove old system credentials and all zypper services installed by SUSEConnect)
    - New --namespace option (forward SMT staging environment to proxy registration server)
* Wed May 20 2015 kpimenov@suse.de
  - Update to version 0.2.17
    - Added migrations endpoint support for Yast
    - Use C locale for all the syscalls (solves output parsing issues in some locales)
    - Stripping UUID from SCC API calls if it is not settable
    - Moved examples from gist to project
* Wed Dec 03 2014 achernikov@suse.de
  - Update to version 0.2.16
    - In case of wrong regcode provide meaningful message back to
      the user (Wrong regcode in that case).
* Mon Oct 20 2014 wstephenson@suse.com
  - Update to version 0.2.15
    - Always write config file when --url parameter used (bnc#900689)

Files

/etc/SUSEConnect
/etc/SUSEConnect.example
/etc/zypp
/etc/zypp/credentials.d
/etc/zypp/credentials.d/SCCcredentials
/usr/bin/SUSEConnect
/usr/lib64/ruby/gems/2.5.0/cache/suse-connect-0.3.31.gem
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/LGPL_2.1
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/LICENSE
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/README.md
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/bin
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/bin/SUSEConnect
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/api.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/cli.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/client.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/config.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/connection.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/core_ext
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/core_ext/hash_refinement.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/credentials.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/errors.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/hwinfo
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/hwinfo/arm64.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/hwinfo/base.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/hwinfo/s390.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/hwinfo/x86.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/logger.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/migration.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/package_search.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/product.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote/activation.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote/product.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote/server_driven_model.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote/service.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/remote/subscription.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/rexml_refinement.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/ssl_certificate.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/status.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/system.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/templates
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/templates/extension.text.erb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/templates/extension_item.text.erb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/templates/extensions_list.text.erb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/templates/product_statuses.text.erb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/version.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/yast.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/zypper
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/zypper.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/zypper/product.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/connect/zypper/product_status.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/cast.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/curlrc_dotfile.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/product_equality.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/renderer.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/system_calls.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/suse/toolkit/utilities.rb
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/tasks
/usr/lib64/ruby/gems/2.5.0/gems/suse-connect-0.3.31/lib/tasks/package.rake
/usr/lib64/ruby/gems/2.5.0/specifications/suse-connect-0.3.31.gemspec
/usr/sbin/SUSEConnect
/usr/share/man/man5/SUSEConnect.5.gz
/usr/share/man/man8/SUSEConnect.8.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 20 23:21:31 2021