Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

glib-networking-64bit-2.54.1-lp151.3.3.1 RPM for aarch64_ilp32

From OpenSuSE Ports Leap 15.1 updates for aarch64_ilp32

Name: glib-networking-64bit Distribution: Unknown
Version: 2.54.1 Vendor: openSUSE
Release: lp151.3.3.1 Build date: Tue May 21 12:20:30 2019
Group: Development/Libraries/C and C++ Build host: obs-arm-4
Size: 271768 Source RPM: glib-networking-2.54.1-lp151.3.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://www.gnome.org
Summary: Network-related GIO modules for glib
This package contains network-related GIO modules for glib.

Currently, there is only a proxy module based on libproxy.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Tue May 14 2019 Vítězslav Čížek <vcizek@suse.com>
  - Fix invalid TLS sessions when TLS 1.3 is used (bsc#1134795)
    * add 0001-gnutls-Add-support-for-timeouts-on-GnuTLS-pulls.patch
  - Polish spec with spec-cleaner
* Fri Oct 27 2017 luc14n0@linuxmail.org
  - Update to version 2.54.1:
    + gnutls: Fix using different client certs for different
      connections (bgo#781578).
    + Updated translations.
* Tue Sep 12 2017 luc14n0@linuxmail.org
  - Update to version 2.54.0:
    + Updated translations.
* Fri Sep 08 2017 jengelh@inai.de
  - Replace old macros and fixup RPM group.
* Tue Aug 15 2017 zaitor@opensuse.org
  - Update to version 2.53.90:
    + gnutls: Stop using %LATEST_RECORD_VERSION in priority string,
      since that gives better compatibility with current gnutls /
      current real world (bgo#782218).
    + gnutls: Provide a better error message when a TLS alert is
      received (bgo#782218).
    + Updated translations.
  - Conditionally apply translations-update-upstream BuildRequires
    and macro for non-openSUSE only.
* Mon Sep 19 2016 zaitor@opensuse.org
  - Update to version 2.50.0:
    + Updated translations.
* Tue Aug 16 2016 dimstar@opensuse.org
  - Update to version 2.49.90:
    + Ported to use upstream gettext rather than
      intltool/glib-gettext (bgo#768708).
    + Updated po files for future gettext versions.
    + Fixed translation lookup on Windows (bgo#765466).
    + Updated translations.
* Tue May 17 2016 mgorse@suse.com
  - Update to GNOME 3.20.2  Fate#318572
* Mon May 09 2016 zaitor@opensuse.org
  - Update to version 2.48.2:
    + gnutls: Fixed an infinite loop if a server sent two identical
      copies of its CA certificate (bgo#765317).
    + Updated translations.
* Tue Apr 26 2016 zaitor@opensuse.org
  - Update to version 2.48.1:
    + Fixed translations in non-UTF-8 domains (bgo#765466).
    + Fixed bash-ism in configure (bgo#765396).
    + Updated translations.
  - Stop passing V=1 to make, we do debugging locally.
  - Add default http://www.gnome.org as Url: Silence rpmlint.
* Tue Mar 22 2016 dimstar@opensuse.org
  - Update to version 2.48.0:
    + New stable release. (No changes since 2.47.90).
* Tue Feb 16 2016 dimstar@opensuse.org
  - Update to version 2.47.90:
    + gnutls: The non-PKCS#11 TLS plugin now uses gnutls's
      certificate validation code directly, rather than attempting to
      build a certificate chain itself first (bgo#753260 and others).
    + gnutls: Fixed a leak when closing a connection during an
      implicit handshake (bgo#736809).
    + gnutls: Fixed "make check" without PKCS#11 support
      (bgo#728977).
    + gnutls: Various changes in preparation for DTLS support (but
      not the actual DTLS support itself) (bgo#697908, bgo#735754).
    + Updated translations.
* Tue Nov 24 2015 zaitor@opensuse.org
  - Update to version 2.47.1:
    + Added a systemd service file for glib-pacrunner (bgo#755740).
* Mon Oct 12 2015 zaitor@opensuse.org
  - Update to version 2.46.1:
    + Fixed a certificate chain validation problem that affected
      Facebook in Epiphany (bgo#750457).
* Mon Sep 21 2015 dimstar@opensuse.org
  - Update to version 2.46.0:
    + Various minor cleanups and small memory leak fixes.
    + Added a new test case for client certificate chain handling
      (bgo#754129).
    + Updated translations.
* Fri May 01 2015 zaitor@opensuse.org
  - Update to version 2.45.1:
    + tls/gnutls: Implement
      g_tls_client_connection_copy_session_state(), to allow
      implementing FTP-over-TLS in gvfs (bgo#745255).
* Mon Mar 23 2015 dimstar@opensuse.org
  - Update to version 2.44.0:
    + Stable release, no changes since 2.43.92.
* Tue Mar 17 2015 dimstar@opensuse.org
  - Update to version 2.43.92:
    + Fix TLS session caching when using session tickets
      (bgo#745099).
    + Updated translations.
* Tue Mar 03 2015 dimstar@opensuse.org
  - Update to version 2.43.91:
    + tls/gnutls: Removed a workaround for connecting to servers with
      weak DH parameters, which was apparently only needed because
      gnutls was prioritizing DHE over RSA (rh#1177964#c8).
    + tls/gnutls: We now require gnutls 3.x again. (In fact, 2.42.1
      and 2.43.1 accidentally used a 3.x-only function, so we already
      required it, we were just failing to declare that fact).
    + tls/tests: Skip certain tests when running against old gnutls
      or GLib releases. (glib-networking 2.43.91 itself does not
      require GLib 2.43, but one of the test cases does).
    + Updated translations.
* Wed Dec 17 2014 zaitor@opensuse.org
  - Update to version 2.43.1:
    + The GTlsClientConnection "use-ssl3" property now falls back to
      TLS 1.0 if SSL 3.0 has been disabled, rather than just failing.
      Also, we now use the gnutls %LATEST_RECORD_VERSION option by
      default (to allow connecting to certain servers that were
      incorrectly patched for the POODLE attack), but also make sure
      to remove that option in the fallback ("use-ssl3") mode (to
      allow connecting to other servers that are differently broken)
      (bgo#738633, bgo#740087).
    + tls/gnutls: Miscellaneous warning, debugging, and leak fixes
      (bgo#736757, bgo#736809, bgo#737106).
    + Updated translations.
* Wed Dec 17 2014 zaitor@opensuse.org
  - Update to version 2.42.1:
    + The GTlsClientConnection "use-ssl3" property now falls back to
      TLS 1.0 if SSL 3.0 has been disabled, rather than just failing.
      Also, we now use the gnutls %LATEST_RECORD_VERSION option by
      default (to allow connecting to certain servers that were
      incorrectly patched for the POODLE attack), but also make sure
      to remove that option in the fallback ("use-ssl3") mode (to
      allow connecting to other servers that are differently broken).
      (bgo#738633, bgo#740087).
    + tls/gnutls: Miscellaneous warning, debugging, and leak fixes
      (bgo#736757, bgo#736809, bgo#737106).
    + Updated translations.

Files

/usr/lib64/gio
/usr/lib64/gio/modules
/usr/lib64/gio/modules/libgiognomeproxy.so
/usr/lib64/gio/modules/libgiognutls.so
/usr/lib64/gio/modules/libgiolibproxy.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 9 12:47:17 2021