Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python312-pycups-2.0.4-1.1 RPM for ppc64le

From OpenSuSE Ports Tumbleweed for ppc64le

Name: python312-pycups Distribution: openSUSE Tumbleweed
Version: 2.0.4 Vendor: openSUSE
Release: 1.1 Build date: Sat Apr 20 23:20:26 2024
Group: Development/Libraries/Python Build host: reproducible
Size: 325689 Source RPM: python-pycups-2.0.4-1.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://github.com/OpenPrinting/pycups
Summary: Python Bindings for CUPS
Python Bindings for CUPS, the Common Unix Printing System

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Sat Apr 20 2024 Dirk Müller <dmueller@suse.com>
  - update to 2.0.4:
    * remove the install_requires from setup.py
    * removed shebang from example/cupstree.py
    * ignore driverless utilities for postscriptdriver tags
      creation (Fedora bug #1873385)
    * remove epydoc from Makefile (#27)
    * fix invalid delete of pointer (#11)
    * Makefile uses wrong Python (#32)
    * define PY_SSIZE_T_CLEAN in cupsipp.h - fixes traceback during
      IPPRequest.writeIO with Python 3.10
    * fix the test.py when there is no printer installed (#46)
    * Use PyObject_Call() instead of deprecated PyEval
* Wed Jan 03 2024 Dirk Müller <dmueller@suse.com>
  - require setuptools
* Mon Aug 14 2023 Dirk Müller <dmueller@suse.com>
  - build as wheel
* Wed Feb 16 2022 Dirk Müller <dmueller@suse.com>
  - spec-cleaner
* Tue Feb 23 2021 Dirk Müller <dmueller@suse.com>
  - update to 2.0.1:
    * pypi required .tar.gz
    * cups.require couldn't handle version bigger than 1
    * dropped macros for older CUPS < 2.0.0
    * dropped Python 2 support and its related macros
    * update license headers
    * thread did not hold GIL when called Py_XDECREF() from destroy_TLS(), causing SIGSEGV(Fedora bug #1816107)
    * fixed several compiler warnings
    * fix silent error on Connection.printFiles() (patch by Wilbert Berendsen)
* Sat Nov 21 2020 Benjamin Greiner <code@bnavigator.de>
  - Let the python-rpm-macros take care of the correct python3
    provides for all python3 flavors gh#openSUSE/python-rpm-macros#66
* Mon Jul 06 2020 Ludwig Nussel <lnussel@suse.de>
  - ignore build requirement of cups-rpm-helper to avoid cycle with cups-devel
    (boo#1172407))
* Wed Aug 28 2019 Martin Wilck <mwilck@suse.com>
  - Package /usr/lib/rpm/postscriptdriver.prov again, in the
    new "cups-rpm-helper" subpackage (bsc#735865). The file hasn't
    been packaged any more after the switch from python-cups to
    python-pycups (sr#502741).
    * removed revert-postscriptdriver.prov-py3.patch
      (we use python3 now)
* Tue May 14 2019 svasudevan@suse.com
  - Update to version 1.9.74
    * no changelog provided
* Mon Jun 19 2017 toddrme2178@gmail.com
  - Provide python-cups/python3-cups

Files

/usr/lib64/python3.12/site-packages/cups.cpython-312-powerpc64le-linux-gnu.so
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/COPYING
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/INSTALLER
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/METADATA
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/RECORD
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/REQUESTED
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/WHEEL
/usr/lib64/python3.12/site-packages/pycups-2.0.4.dist-info/top_level.txt
/usr/share/doc/packages/python312-pycups
/usr/share/doc/packages/python312-pycups/NEWS
/usr/share/doc/packages/python312-pycups/README
/usr/share/doc/packages/python312-pycups/TODO
/usr/share/licenses/python312-pycups
/usr/share/licenses/python312-pycups/COPYING


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Jun 23 00:14:27 2024