Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

NetworkManager-libreswan-gnome-1.2.14-1.4 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: NetworkManager-libreswan-gnome Distribution: openSUSE Tumbleweed
Version: 1.2.14 Vendor: openSUSE
Release: 1.4 Build date: Sun May 30 13:34:42 2021
Group: Productivity/Networking/System Build host: obs-arm-6
Size: 96851 Source RPM: NetworkManager-libreswan-1.2.14-1.4.src.rpm
Packager: http://bugs.opensuse.org
Url: https://gitlab.gnome.org/GNOME/NetworkManager-libreswan
Summary: NetworkManager VPN plugin for libreswan - GNOME files
This package contains software for integrating VPN capabilities
with the libreswan server with NetworkManager (GNOME files).

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Tue Jan 12 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.2.14:
    + Support Libreswan 4, which changed the name of some
      configuration parameters. Now the plugin can detect the
      Libreswan version and use the appropriate parameter names.
    + The auth helper in external UI mode can now be run without a
      display server. Future nmcli version will utilize this for
      handling the secrets without a graphical desktop.
    + Update strings for new dialog design in gnome-shell.
    + Updated translations.
* Fri May 01 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - Set the path for the VPN service name file correctly to
    %_vpnservicedir (provided by macros.NetworkManager).
* Sat Jan 25 2020 Dominique Leuenberger <dimstar@opensuse.org>
  - No longer recommend -lang: supplements are in use
* Wed Jul 31 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.2.12:
    + libnm-glib compatibility (NetworkManager < 1.0) is disabled by
      default. It can be enabled by passing --with-libnm-glib to
      configure script. Nobody should need it by now. Users that
      still use this are encourage to let us know before the
      libnm-glib support is removed for good.
    + Fixed the advanced dialog not working in Gnome.
    + Updated translations.
  - Stop passing --without-libnm-glib to configure, no longer needed.
* Mon Oct 15 2018 bjorn.lie@gmail.com
  - Update to version 1.2.10:
    + Fixed import/export feature.
    + Added support to the 'pfs' Libreswan option.
    + Updated translations.
* Tue Sep 25 2018 bjorn.lie@gmail.com
  - Update to version 1.2.8:
    + GUI allows to set the remote id also for IKEv1 connections.
    + GUI "advanced" section as been moved to a separate dialog.
    + GUI allows to select IKEv2 certificate-based config.
    + Added support to many new Libreswan options: "'rightid',
      'narrowing', 'rekey', 'fragmentation', mobike' ... see man page
      for full list.
    + Added support for IKEv2.
    + Added nm-settings-libreswan man page to document supported
      options.
    + Added 'ikelifetime', 'salifetime' and 'rightsubnet' settings.
    + Updated translations.
* Tue Apr 10 2018 bjorn.lie@gmail.com
  - Initial packaging of NetworkManager-libreswan, version 1.2.6.

Files

/usr/lib/NetworkManager/libnm-vpn-plugin-libreswan-editor.so
/usr/libexec/nm-libreswan-auth-dialog
/usr/share/appdata
/usr/share/appdata/network-manager-libreswan.metainfo.xml
/usr/share/gnome-vpn-properties
/usr/share/gnome-vpn-properties/libreswan
/usr/share/gnome-vpn-properties/libreswan/nm-libreswan-dialog.ui


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 30 23:47:50 2021