Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libvtk1-openmpi3-9.0.1-3.2 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libvtk1-openmpi3 Distribution: openSUSE Tumbleweed
Version: 9.0.1 Vendor: openSUSE
Release: 3.2 Build date: Fri Jul 9 12:15:13 2021
Group: System/Libraries Build host: obs-arm-1
Size: 59120937 Source RPM: vtk-openmpi3-9.0.1-3.2.src.rpm
Packager: http://bugs.opensuse.org
Url: https://vtk.org/
Summary: The Visualization Toolkit - A high level 3D visualization library
VTK is a software system for image processing, 3D graphics, volume
rendering and visualization. VTK includes many advanced algorithms
(e.g. surface reconstruction, implicit modelling, decimation) and
rendering techniques (e.g. hardware-accelerated volume rendering,
LOD control).

This package provides the shared libraries for VTK.

Provides

Requires

License

BSD-3-Clause

Changelog

* Sat Jun 19 2021 Ben Greiner <code@bnavigator.de>
  - Add vtk-opensuse-python-metadata.patch:
    Installing without VTK_BUILD_WHEEL lacks the dist-info/egg-info
    metadata. When a user installs python packages which depend
    on vtk through pip (into the user home or into a virtualenv),
    pip does not recognize the files installed into site-packages
    without the metadata and pulls in a big manylinux wheel from
    PyPI. We introduce the necessary egg-info metadata in order to
    avoid this.
  - python3-vtk: Don't own the arch site-packages (%python3_sitearch)
    and the toplevel __pycache__ dir, only our own python files.
  - Move qt and python .so devel files to main devel package, adjust
    rpmlintrc: The devel files are not required by the
    python bindings (anymore?).
* Wed Jun 09 2021 Ben Greiner <code@bnavigator.de>
  - Add vtk-std_numeric_limits.patch in order to fix gcc 11.1 build
    https://gitlab.kitware.com/vtk/vtk/-/issues/18194
  - Require %{name}-qt in python3-%{name}: The Python bindings link
    to libvtkRenderingQt.so.1, but zypper fails to resolve the
    requirement to the correct (non-)mpi flavor -- boo#1187161
  - Change description: The vtk-qt subpackage provides some Qt
    libraries, not a designer plugin.
  - Support for QtWebkit was removed with vtk 9.0.0: Remove the build
    requirement.
* Tue Oct 20 2020 Ismail Dönmez <idonmez@suse.com>
  - Add vtk-freetype-2.10.3-replace-FT_CALLBACK_DEF.patch to fix
    compilation with FreeType 2.10.3+
* Thu Jul 16 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Update to version 9.0.1:
    * Drop obsolete patches:
      + bundled_exodusii_add_missing_libpthread.patch
      + vtk-parallelgeometry-dependency.patch
      + vtk-qt-5.15-include-QPainterPath.patch
  - Explicitly enable module RenderingContextOpenGL2 required for PCL
  - Conditionally add pugixml-devel Requires in devel package
  - Make devel package installable even when built without Java
  - Remove CAPITALIZATION from comments
  - Drop obsolete TK build dependency
  - Drop unused wget build dependency
  - Wrap devel-doc generation in bcond (keep defaulted to off), and
    drop the essentially empty package when disabled.
  - Fix build on ARM/Qt GLES (boo#1172723):
    * set VTK_OPENGL_USE_GLES
    * Add 0001-clean-up-some-old-opengl-es-stuff.patch
    * Add 0001-expose-1d-texture-options.patch
    * Add 0001-Remove-duplicate-check-for-QOpenGLFunctions_3_2_Core.patch
    * Rebase 0001-Allow-compilation-on-GLES-platforms.patch
    * Add 0001-Replace-last-glDrawBuffer-call-with-glDrawBuffers-1.patch
    * Add 0001-Use-2D-textures-for-1D-texture-emulation-on-GLES.patch
    * Add 0001-Add-missing-guard-required-for-GLES-to-disable-stere.patch
    * Add 0001-Correct-GL_BACK-GL_BACK_LEFT-mapping-on-GLES.patch
    * Add 0002-Use-GL_DRAW_BUFFER0-instead-of-GL_DRAW_BUFFER-for-GL.patch
    * Add 0001-GL_POINT_SPRITE-is-only-available-for-Compatibility-.patch
    * Add 0002-Guard-GL_LINE_SMOOTH-for-GLES.patch
    * Add 0001-Guard-glPointSize-with-GL_ES_VERSION_3_0.patch
  - Add 0001-Fix-PyVTKAddFile_-function-signature-mismatch.patch
  - Add 0001-Replace-invalid-GL_LINE-with-GL_LINES-for-glDrawArra.patch
* Mon Jun 15 2020 Andreas Schwab <schwab@suse.de>
  - Drop -ffat-lto-objects to avoid wasting disk space
* Wed Jun 10 2020 Guillaume GARDET <guillaume.gardet@opensuse.org>
  - Update _constraints to avoid OOM errors
* Sun May 31 2020 Atri Bhattacharya <badshah400@gmail.com>
  - Add vtk-qt-5.15-include-QPainterPath.patch: Include QPainterPath
    to fix build failures against Qt 5.15; patch taken from
    upstream, see
    <https://gitlab.kitware.com/vtk/vtk/-/merge_requests/6943>.
  - The %%cmake macro sets CMAKE_SKIP_RPATH=ON for Leap 15.x which
    causes build failures; set it to OFF and set
    CMAKE_SKIP_INSTALL_RPATH=ON for openSUSE <= 1500. See
    <https://discourse.vtk.org/t/building-fails-generating-wrap-hierarchy-for-vtk-commoncore-unable-to-open-libvtkwrappingtools-so-1>.
  - Build without pegtl for distributions where pegtl > 2.0 is
    unavailable (Leap 15.1).
  - Disable java bindings for Leap 15.1 only where cmake still
    searches for the javah binary (and setting it to %{_bindir}/true
    seems to no longer work).
  - Run ld post scripts for vtk-qt.
* Fri May 08 2020 Atri Bhattacharya <badshah400@gmail.com>
  - Update to version 9.0.0
    * See https://discourse.vtk.org/t/vtk-9-0-0/3205.
  - Rebase patches still required for building:
    * bundled_exodusii_add_missing_libpthread.patch: Update to
      upstream patch
      (https://gitlab.kitware.com/vtk/vtk/-/merge_requests/6865).
    * bundled_libharu_add_missing_libm.patch
  - Pass VTK_PYTHON_OPTIONAL_LINK:BOOL=OFF to cmake to link against
    the system python library explicitly.
  - Add vtk-parallelgeometry-dependency.patch to fix a missing
    dependency for vtkparallelgeometry (see
    https://discourse.vtk.org/t/building-vtk-9-0-fails-when-using-mpi-support/3227).
  - Comment out 0001-Allow-compilation-on-GLES-platforms.patch that
    no longer applies and needs extensive rebasing.
  - Drop patches incorporated or otherwise fixed upstream:
    * 0001-Make-code-calling-proj4-compatible-with-proj4-5.0-an.patch
    * 0001-Add-libogg-to-IOMovie-target-link-libraries.patch
    * python38.patch
    * reproducible.patch
  - Adapt to changes in upstream's cmake script:
    * Replace old options by their newer versions where applicable.
    * Pass VTK_USE_EXTERNAL=ON to use system libraries by default
      except for gl2ps, haru, and pugixml.
  - New BuildRequires: pegtl-devel and utfcpp-devel.
  - No longer needed to pass
    Java_JAVAH_EXECUTABLE:PATH=%{_bindir}/true to cmake; script does
    not look for javah any more.
  - Use autosetup to set up and patch sources: simplifies applying
    changing list of patches; use an if guard to avoid patch needing
    rebase while not running into conflict with factory bot.
  - Use system gl2ps for openSUSE > 1500.
* Mon Apr 27 2020 Atri Bhattacharya <badshah400@gmail.com>
  - Fix serial builds broken due to disabling the building of
    examples; instead of commenting out sections of the specfile
    related to examples, use %bcond_with to disable building
    examples by default and the corresponding conditionals where
    appropriate.
* Sun Apr 26 2020 Bernhard Wiedemann <bwiedemann@suse.com>
  - add reproducible.patch to override build date and to sort entries
    (boo#1047218, boo#1041090)
* Fri Apr 24 2020 Atri Bhattacharya <badshah400@gmail.com>
  - Disable building examples to prevent vtkLocalExample.java
    randomly missing from vtk.jar (boo#1138295, see also upstream
    recommendation in
    https://gitlab.kitware.com/vtk/vtk/issues/17619).
* Wed Mar 11 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Remove -DVTK_PYTHON_SITE_PACKAGES_SUFFIX silently added with the
    last change. As it specifies the path relative to the install
    prefix, setting it to the absolute python_sitearch is obviously
    wrong. As VTK figures out the correct path by itself, it is
    completely unnecessary.
* Tue Mar 10 2020 Tomáš Chvátal <tchvatal@suse.com>
  - Add patch to fix building with python 3.8:
    * python38.patch
* Tue Jan 28 2020 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Add openmpi3 flavor.
  - Disable openmpi1 for SLE/Leap 15.2, openmpi3 for SLE <= 15.1
  - Adjust disk _constraints.
  - Drop vtk-fix-file-contains-date-time.patch, GCC honors
    SOURCE_DATE_EPOCH.
  - Drop unused netcdf-c++-devel BuildRequires.
* Mon Nov 04 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Adapt to openmpi -> openmpi1 rename on Tumbleweed.
  - Spec file cleanup, remove conditionals for Leap 42.x.
  - Apply proj4 compatibility patch also on Leap.
* Tue Sep 10 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Use -ffat-lto-objects when building static libraries.
* Sun Apr 14 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Add more explicit dependencies to vtk-devel.
* Tue Apr 09 2019 Christophe Giboudeaux <christophe@krop.fr>
  - Add an explicit 'Requires: double-conversion-devel' for vtk-devel.
    The double-conversion library is mentioned in vtkdoubleconversion.cmake
    but isn't automatically installed.
* Fri Mar 15 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Update to version 8.2.0
    * Removed support for TCL and Qt4
    * Removed all VTK_OVERRIDE, VTK_FINAL, VTK_DELETE_FUNCTION macros as
      C++11 is now required.
    * vtkAbstractArray gained support for runtime user defined free functions,
      allowing for custom allocator memory to be used with VTK.
    * The vtkGeovis classes are now deprecated.
    See https://blog.kitware.com/vtk-8-2-0/ for a more exhaustive list.
  - Packaging changes:
    * Python bindings for MPI flavors are now installed below the MPI prefix
      and thus no longer conflict with each other. To use these, the
      PYTHONPATH currently has to be amended manually.
    * Removed several devel Requires: from the devel package. This reduces the
      dependency chain (e.g. java-devel) for all packages building against VTK,
      but may require to specify some dependencies explicitly, depending on
      the used VTK modules and bindings.
  - Patch updates/additions:
    * Rebase vtk-fix-file-contains-date-time.patch
    * Rebase 0001-Allow-compilation-on-GLES-platforms.patch
    * Drop obsolete fix_qt5_example_cmake.patch
    * Add bundled_libharu_add_missing_libm.patch
    * Add bundled_exodusii_add_missing_libpthread.patch
    * Add 0001-Add-libogg-to-IOMovie-target-link-libraries.patch
    * Add 0001-Make-code-calling-proj4-compatible-with-proj4-5.0-an.patch
* Sun Jan 06 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Correct names of built packages, the mpi flavors were lacking the
    flavor specific name infix, i.e. all flavors were named identically.
* Wed Jan 02 2019 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Add openmpi2 flavor
  - BuildRequire netcdf-{mpi_flavor}-devel for MPI flavors
  - Add Conflicts between flavors of python3 subpackage (all flavors
    install into python_sitearch).
* Fri Dec 14 2018 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Convert openmpi package to multibuild flavor
  - Use correct mpi version - openmpi currently means openmpi, and not openmpi2/3
    Otherwise, VTK depends on openmpi1 (HDF5, netcdf) and openmpi2/3 (direct)
  - Remove several mpi BuildRequires in serial flavor
* Wed Dec 12 2018 Stefan Brüns <stefan.bruens@rwth-aachen.de>
  - Add python3-vtk to vtk-devel Requires, same as for vtk-java/tcl
  - Remove empty testing subpackage
  - Fix path to VTK_DATA_ROOT default directory
* Thu Nov 22 2018 Todd R <toddrme2178@gmail.com>
  - Update to version 8.1.2
    * Issue error if vtkAlgorithm::GetInputConnection called on wrong port
    * Added explicit cast to pacify UBSan’s “implicit-integer-truncation”
    * Make some orientation marker widget methods virtual
    * vtkImageBlend bug fix for compound mode
    * vtkFlyingEdges2D: Properly color multiple isocontour values
    * Invoke DeletePointEvent before deleting vtkSeedWidget seed
    * Fix compilation issue due to Python3.7 API change
    * Fix bug where re-enabling seed widget wouldn't move existing seeds
  - Fix python dependencies
  - Test to make sure python package is importable
  - Split out MPI version since the MPI version cannot be used
    outside an MPI environment.
  - Build vtkData as part of the main package.  This makes sure the
    data is extracted into the correct format.
* Fri Jun 29 2018 badshah400@gmail.com
  - Drop post[un] scripts for devel and java subpackages; they are
    only needed for the versioned shlib.
* Mon Jun 11 2018 toddrme2178@gmail.com
  - Update to version 8.1.1:
    * Fixed thin border around vtkImageResliceMapper
      rendering
    * Fixed vtkImageResliceMapper showing a black
      polygon when slice is out of bounds.
    * Fixed conflict between Process.h and process.h
    * Fixed building VTK 8.1 against 10.13 SDK
      resulting in linker errors when trying to use
      resulting libraries on older SDK
    * Fixed vtkCellPicker::IntersectActorWithLine maybe
      using invalid cell id when picking composite data
  - Add fix_qt5_example_cmake.patch
    Fixes use of removed cmake macro in some examples
    See: https://gitlab.kitware.com/vtk/vtk/issues/17336
  - Use modern cmake spec file macros
  - Run spec cleaner
  - Other spec file cleanups
  - Support parallel HDF5.
  - Drop support for qt4.  Any version of openSUSE with a recent
    enough version of cmake to build the package supports Qt5.
  - Drop checks for old versions of openSUSE that have too old
    of a cmake to build.
* Sun Feb 04 2018 stefan.bruens@rwth-aachen.de
  - Use split libboost*-devel BuildRequires for TW and Leap/SLE 15
* Wed Jan 24 2018 fstrba@suse.com
  - Fix build with jdk10
    * give a bogus javah path "%{_bindir}/true", since the cmake
      checks the javah binary although the build does not use it.
* Fri Jan 12 2018 badshah400@gmail.com
  - Drop vtk-Rinterface-uintptr_t.patch as the related plugin has
    been retired.
* Wed Jan 10 2018 badshah400@gmail.com
  - Drop vtk-compat_gl: Building against OpenGL1 has now been
    deprecated with version 8.1.0, and the examples don't build
    against it already; so, drop all specfile and related
    modifications catering to OpenGL1 bindings.
* Thu Dec 28 2017 badshah400@gmail.com
  - Update to version 8.1.0:
    * Full release notes at https://blog.kitware.com/vtk-8-1-0/.
  - Turn OFF building against system libharu, since libharu
    upstream seems dead, while vtk's included libharu has new
    features essential for building vtk 8.1. Drop BuildRequires on
    libharu.
  - Does not build against java 10, so ensure at most java 9 is
    used by using appropriate versioning for java-devel
    BuildRequires.
  - Drop cmake options no longer used for build.
  - Drop VERBOSE=1 for make: it makes the compilation too verbose
    making brp checks for code warnings too slow to execute; this
    reduces build time by nearly half.
  - Enforce Qt4 for openSUSE <= 1320 explicitly because Qt5 is now
    the default option.
* Mon Dec 04 2017 bruno@ioda-net.ch
  - Move BuildRequires:  libQtWebKit-devel (Qt4) inside the else
    version < 13.2
* Thu Oct 26 2017 dimstar@opensuse.org
  - Add conflict between the -devel-doc variants.
* Tue Oct 24 2017 dimstar@opensuse.org
  - Setup MPI environment before building.
* Thu Oct 12 2017 jengelh@inai.de
  - Rectify RPM groups again.
* Sun Oct 01 2017 stefan.bruens@rwth-aachen.de
  - Move the vtk binary to the tcl subpackage, it is an interactive
    TCL shell, and depends on the TCL bindings. It can be used
    standalone from the devel package. Dito for its MPI variant, i.e.
    the pvtk binary.
  - Move all libvtk*Java.so to the java subpackage. These are part of
    the Java bindings, i.e. runtime dependencies. Otherwise, the java
    subpacakge depends on the devel subpackage.
  - Add the tcl and java subpackage to the devel requires again.
    Although not stricly necessary until building java or tcl packages,
    the cmake files have a hard dependency on several build artifacts
    provided by the tcl and java subpackages. Split devel packages
    for the bindings would be preferred, but this is not supported by
    the upstream build system.
  - Remove the openmpi-devel requires in the python subpackage, the
    mpi runtime libraries are provided by openmpi-libs, which is
    picked up automatically.
* Sun Oct 01 2017 stefan.bruens@rwth-aachen.de
  - Split the API documentation from the development subpackage. The
    documentation amounts to almost 1 GByte of data, not necessary
    when just building packages.
* Thu Sep 28 2017 badshah400@gmail.com
  - Drop vtk-compat_gl-rpmlintrc: openSUSE:Factory bots don't accept
    conditional sources and one rpmlintrc file is sufficient for
    both main and linked packages anyway.
* Tue Sep 19 2017 kkhere.geo@gmail.com
  - do not exclude libViewsGeovisJava.so from devel package
    This library is required for development.
  - package vtk binary in devel package.
  - VTKTargets-debug.cmake tests for the existance of the library (line 3394)
    and the binary (line 3404) and causes an error if the files do
    not exist
* Thu Sep 14 2017 stefan.bruens@rwth-aachen.de
  - Remove the various subpackage Requires from the devel package
    again. The qt subpackage contains a Qt Designer plugin and no
    dependency at all. Package the vtkWrap{Tcl,Java,Python} wrapper
    generators in the devel package, as these are useless without
    the vtk headers files.
  - Fix description/summary of vtk-qt subpackage
* Tue Sep 12 2017 kkhere.geo@gmail.com
  - devel subpackage should require -tcl, -java and -qt subpackages
    since the *.cmake files refer to files in those subpackages
* Mon Sep 11 2017 stefan.bruens@rwth-aachen.de
  - Add 0001-Allow-compilation-on-GLES-platforms.patch
    The QOpenGLFunctions_3_2_Core class providing the framebuffer
    blit functions is not available on GLES 2 builds of Qt5. Let Qt
    handle the framebuffer blit, and just use the GLES/GL subset
    provided by QOpenGLFunctions for the remainder.
    Fix for https://gitlab.kitware.com/vtk/vtk/issues/17113
* Fri Sep 01 2017 badshah400@gmail.com
  - Update to version 8.0.1:
    * Fix QVTKOpenGLWidget rendering issues on Windows machines with
      certain Intel graphics chips. This was a significant issue
      that broke all rendering and resulted in a black screen.
    * Fix data array range caching per finite component which would
      otherwise cause considerable slow-downs when using data
      arrays.
    * Fix button and slider widgets to work in multi-viewport render
      windows. Without this change the widgets would either be
      placed in the wrong viewport or be non-interactive completely.
    * Fix image XY sampling in the volume mapper when depth peeling
      is enabled.
    * Fix z-fighting issues with dual depth peeling between two
      layers of geometry that are too close.
    * Fix crash when reparenting the QVTKWidget to a different
      window. The application would crash due to lack of OpenGL
      resources for the reparented widget.
* Mon Aug 21 2017 badshah400@gmail.com
  - Suppress romlint error about shlib-policy-name-error for
    %{name}-java -- libvtkViewsGeovisJava.so packaged therein
    is not a versioned shared lib, and only used by vtk's java
    bindings, so there is no point in enforcing the shared lib
    packaging policy for this subpackage.
* Wed Aug 09 2017 badshah400@gmail.com
  - Move libvtkViewsGeovisJava.so to the %{name}-java subpackage,
    this is not really a devel file.
* Wed Aug 09 2017 jengelh@inai.de
  - Fix RPM groups. Use POSIX-compliant find call.
* Mon Aug 07 2017 badshah400@gmail.com
  - Implement shared library packaging policy for vtk:
    + Rename %{name} to %{shlib}.
    + Move all shared library objects to %{shlib} package.
    + Remove no longer needed Requires from %{name}-devel package;
      e.g.: %{name}-java contains the java binaries and jar object
      now, and no longer the lib*Java.so file which has been moved
      into %{shlib}.
    + Adapt conflicts for vtk-compat_gl accordingly.
    + Install libraries to /usr/lib(64) instead of
      /usr/lib(64)/vtk.
    + Do away with python3-%{name}-qt subpackage and
      Obsolete/Provide it from %{shlib} as it only contained a
      shared lib object.
  - Use system mpi4py; add BuildRequires on python3-mpi4py.
  - liblz4 >= 1.7.3 now required (since version 8.0); adapt
    BuildRequires accordingly.
* Tue Jul 25 2017 jengelh@inai.de
  - Trim descriptions and rectify RPM groups.
* Mon Jul 17 2017 adrian@suse.de
  - add liblz4-devel and libharu-devel also to Requires of devel package
    (fixes linking errors in other packages)
* Mon Jul 03 2017 badshah400@gmail.com
  - Update to version 8.0.0:
    * Read about changes here: https://blog.kitware.com/vtk-8-0-0/
    * API changes:
      http://www.vtk.org/Wiki/VTK/API_Changes_7_1_0_to_8_0_0
  - Add BuildRequires on liblz4-devel, libharu-devel, mandatory
    requirements for version 8.0.0.
  - Run make DoxygenDoc to generate documentation.
* Fri Apr 14 2017 kkhere.geo@gmail.com
  - add a separate package vtk-compat_gl compile using rendering backend
    OpenGL for systems without brand new graphic cards
  - default package vtk still uses new rendering backend default OpenGL2
* Wed Nov 23 2016 badshah400@gmail.com
  - Update to version 7.1.0: See news item at
    https://blog.kitware.com/kitware-plans-to-spotlight-new-vtk-and-paraview-releases-at-sc16/
  - Drop patch vtk-gcc6.patch, upstreamed.
  - Turn off usage of system DIY2, this library is not yet packaged
    for openSUSE.
  - Disable mkg3states binary also for openSUSE:Leap versions.
  - Update file list for upstream installation changes.
  - Use bundled gl2ps, as it no longer builds against the system
    one (requires svn trunk version of gl2ps).
  - CMake >= 3.4 is now required (earlier versions don't support
    NAMES_PER_DIR in find_program).
  - Enable use of SYSTEM_LIBRARIES for openSUSE:Leap versions too
    (only 13.2 requires this turned off as of now).
* Wed Aug 10 2016 badshah400@gmail.com
  - Refresh vtk-Rinterface-uintptr_t.patch to fix further issues
    with uintptr_t redefinition by defining the HAVE_UINTPTR_T
    macro using cmake functions; removing the #include of stdint.h
    is not needed any more since we will not be using the defs from
    Rinterface.h anyway (boo#985386). Although this really causes a
    build failure for the i586 arch, where the redefinition of
    unitptr_t in Rinterface.h conflicts with the stdint.h defintion,
    the patch is applied generally because the redefinition is not
    needed in any case. Patch sent upstream.
* Wed Apr 13 2016 badshah400@gmail.com
  - Add freetype2-devel as a Requires for vtk-devel.
* Wed Mar 30 2016 badshah400@gmail.com
  - Apply vtk-gcc6.patch also to python-vtk.
* Wed Mar 30 2016 stecue@gmail.com
  - Fixed RPATH error for Factory by passing the option
    CMAKE_NO_BUILTIN_CHRPATH:BOOL=ON to cmake.
* Tue Mar 29 2016 dmueller@suse.com
  - add vtk-gcc6.patch: Fix build with gcc 6
  - skip RPATH setting
* Fri Mar 18 2016 stecue@gmail.com
  - openmpi-libs will be installed with openmpi-devel if necessary.
    No such package on openSUSE 13.1.
* Tue Mar 15 2016 dvaleev@suse.com
  - Add disk constraints
* Wed Feb 17 2016 badshah400@gmail.com
  - Update to version 7.0.0:
    + See https://blog.kitware.com/vtk-7-0-0/ for a detailed
      article describing all the changes in this version.
  - Add vtk-Rinterface-uintptr_t.patch to fix building: uintptr_t
    is already defined in the R headers, uintptr_t definition in
    <stdint.h> conflicts with the R definition and causes builds to
    fail. This patch fixes the problem by commenting out the call
    to include stdint.h (it was only being used for this solitary
    symbol).
  - Use python 3 for building, rename python- subpackages
    accordingly to python3-.
  - Update file lists in accordance with added/dropped binaries
    upstream; affects vtk-examples, vtk-devel.
  - Drop conditionals referencing outdated openSUSE version 12.3.
  - Update rpmlintrc file to suppress rpmlint warnings for
    "no-manual-page-for-binary": upstream does not supply manuals
    for its binaries and does not plan to.
* Fri Sep 18 2015 badshah400@gmail.com
  - vtkdata should be a Recommends for vtk-examples, not Requires.
* Mon Aug 31 2015 badshah400@gmail.com
  - Update to version 6.3.0:
    - See list of changes at
      http://www.vtk.org/Bug/changelog_page.php?version_id=118
      or blog post at
      http://www.kitware.com/blog/home/post/963.
* Sat Aug 15 2015 badshah400@gmail.com
  - python-vtk also needs openmpi-devel at runtime.
* Fri Aug 14 2015 badshah400@gmail.com
  - python-vtk should have Requires on openmpi-libs to enable its
    parallelized modules to work.
* Thu Jun 25 2015 alinm.elena@gmail.com
  - use qt5 for factory
* Mon Jun 22 2015 olaf@aepfle.de
  - Add libxml2-devel/netcdf-devel/libnetcdf_c++-devel Requires to vtk-devel
* Wed Apr 08 2015 dimstar@opensuse.org
  - Add jsoncpp-devel Requires to vtk-devel (for openSUSE > 13.2):
    vtkjsoncpp.cmake has
    set(vtkjsoncpp_LIBRARIES "/usr/lib64/libjsoncpp.so").
* Fri Mar 13 2015 badshah400@gmail.com
  - Update to version 6.2.0:
    + See http://www.kitware.com/blog/home/post/858 for a list of
      changes.
  - Drop patches incorporated upstream:
    + vtk-install-missing-modules.patch
    + vtk-Mesa10.3-build-failures.patch
    + vtk-system.patch.
  - Update filelist to incorporate new files installed by upstream.
  - Use system hdf5 and netcdf on all openSUSE versions.
  - Build on openSUSE > 13.2 with system libraries ON (except
    for libproj4); all required depndencies for this purpose are
    now in Factory.
  - Add rpmlintrc file to suppress
    "devel-files-in-non-devel-package" warning; python-vtk needs
    these devel files for its own functioning.
* Thu Feb 26 2015 dkxls23@gmail.com
  - Add MPI support
* Thu Sep 11 2014 badshah400@gmail.com
  - Add vtk-Mesa10.3-build-failures.patch to workaround build
    failures when compiling against Mesa >= 10.3; patch taken from
    upstream git and rebased; applied only for openSUSE >= 13.2.
* Fri Jan 24 2014 badshah400@gmail.com
  - Update to version 6.1.0:
    + See http://www.kitware.com/news/home/browse/502 for a list of
      changes
  - Rebase patches:
    + vtk-system.patch
    + vtk-install-missing-modules.patch
  - Packaging changes:
    + Re-enable R bindings for 13.1 and above
    + Turn off building test modules for now as it leads to build
      issues (DBUILD_TESTING:BOOL=OFF)
    + Turn off usage of system libraries for now
      (DVTK_USE_SYSTEM_LIBRARIES:BOOL=OFF), as usage of system
      libraries now introduces dependency on json-cpp which is not
      available for openSUSE (yet)
    + Python modules are now installed by vtk's cmake script;
      hence, pass system python dirs to cmake by using cmake
      variable DVTK_INSTALL_PYTHON_MODULE_DIR instead of
      DVTK_PYTHON_SETUP_ARGS used previously
    + vtkpython is now installed by cmake script automatically;
      hence remove the manual copying to /usr/bin used earlier
    + Python libraries are now stripped automatically on install;
      chrpath no longer needed on these
    + Python object files are now installed in
      %python_sitearch
    + Skip examples no longer installed as a result of test modules
      being turned off
    + Install new binaries (mkg3states) and bundled data files
      (/usr/share/vtk-6.1)
    + Cleanup spec file:
    - Remove support for EOL openSUSE versions (12.1 and earlier)
      by dropping appropriate conditionals
    - Fix minor formatting issues.
* Fri Jul 19 2013 badshah400@gmail.com
  - Disable R bindings for Factory, since it causes weird build
    failures in openSUSE:Factory, (strangely no failures in devel
    project) until the reason behind the failure is found and fixed.
* Fri Jun 28 2013 badshah400@gmail.com
  - Update to version 6.0.0:
    + Lengthy list of changes, see
      http://www.kitware.com/blog/home/post/515 for a summary
  - Also build R language bindings, introduces dependency on R-base
  - Drop patches for already being incorporated upstream:
    + vtk-pythondestdir.patch
    + vtk-sqldatabaseschema.patch
    + vtk-soversion2.patch
  - Rebase patches for updated version:
    + vtk-fix-file-contains-date-time.patch
    + vtk-system.patch
  - Add vtk-install-missing-modules.patch to install cmake modules
    missed by the upstream packaging, will be required esp. when
    we will be able to use the system installed vtk to build
    paraview in the future; patch taken from Fedora
  - Remove unused cmake variables during configuration
  - Install all examples (several more added in current version)
  - Install vtk.conf file in /etc/ld.so.conf.d to enable vtk find
    its libraries
  - Testing binaries are no longer installed separately.
* Fri Oct 26 2012 badshah400@gmail.com
  - Update to version 5.10.1:
    + Fix netCDF symbol mangling, which allows applications to use
      an external netCDF library and VTK's internal copy
      simultaneously
    + Fixes for STL and SLC readers that prevent crashes and file
      handle resource exhaustion
    + Fix compilation on FreeBSD operating system
    + A handful of fixes in VTK's Qt interface kit
    + Fixes for interpreted language wrapping including a bug which
      prevented java wrapping of VTK on power PC macs, and
      compatibility with Tcl 8.6
  - Add vtk-fix-file-contains-date-time.patch to fix rpmlint
    warning about a packaged file containing DATE and TIME.
* Mon Jun 25 2012 scorot@free.fr
  - build python-qt and java binding for openSUSE version higher than
    11.2 which fixes build on SLE 11
* Fri May 18 2012 badshah400@gmail.com
  - Update to version 5.10.0: See
    http://www.kitware.com/news/home/browse/408
    for a detailed list of changes
  - Dropped patches:
    + vtk-boost149.patch: implemented upstream
  - Patch vtk-sqldatabaseschema.patch now only required for
    openSUSE 11.4
  - Minor rebasing of existing patches so they apply cleanly
  - No longer use verbose make.
* Thu May 10 2012 idonmez@suse.com
  - Remove openmotif dependency
* Sun Apr 22 2012 asterios.dramis@gmail.com
  - Use the gl2ps and hdf5 system libraries for building in openSUSE > 12.1.
  - Updated Mesa and XOrg dependencies for openSUSE > 12.1.
  - Removed the following dependencies which are not needed:
    MesaGLw-devel, freeglut-devel, gcc-java, libgcj-devel and sqlite3-devel.
  - Removed postgresql-devel dependency (wasn't enabled and fails to compile
    anyway - added a note about it).
  - Removed build time references so build-compare can do its work.
  - Compile the package out-of-source.
  - Use the generic "VTK_USE_SYSTEM_LIBRARIES" cmake variable for enabling the
    use of system libraries instead of doing it with a per package variable.
* Sun Apr 08 2012 idonmez@suse.com
  - Fix compilation with boost 1.49 and enable boost again
* Tue Mar 27 2012 toddrme2178@gmail.com
  - Cleaned up spec file formatting
  - Build and package python-qt (python-sip) bindings
  - Link libraries to library directory instead of moving them to
    avoid breaking the find vtk cmake macro
  - Force enable of various additional optional components
  - Removed redundant packages (readme and logo) from backends
  - Make the devel package depend on the backends, since it does not
    work properly without them
  - Disable boost building on factory due to an icompatibility with
    boosswt 1.4.9+.  See http://vtk.org/Bug/view.php?id=12988
* Thu Feb 02 2012 toddrme2178@gmail.com
  - Reverted the source file change since it didn't work
  - Changed the license text a little
* Wed Feb 01 2012 toddrme2178@gmail.com
  - Switched to approved license text (fix for RPMLINT warning)
  - Escaped some macros in comments (fix for RPMLINT warnings)
  - Made the source file a tiny bit easier to use
* Wed Oct 12 2011 prusnak@opensuse.org
  - updated to 5.8.0
  - removed patches:
    * vtk-Balloon-Representation.patch (applied in upstream)
    * vtk-gcc43.patch (applied in upstream)
    * vtk-gcc46.patch (applied in upstream)
    * vtk-libpng14.patch (applied in upstream)
    * vtk-python27-compat.patch (applied in upstream)
    * vtk-soversion.patch (applied in upstream)
    * vtk-string-length.patch (not needed anymore)
    * vtk-testcxxjavaremove.patch (applied in upstream)
* Sat May 28 2011 badshah400@gmail.com
  - Add explicit libQtWebKit-devel BuildRequires to fix build
    failures on openSUSE 11.3
  - Make description of sub-package vtk-qt more detailed
  - Spec file clean up
* Sat May 28 2011 alinm.elena@gmail.com
  - fix the missing soname for libVTKnetcdf_cxx
* Sun May 22 2011 stecue@gmail.com
  - Fix the broken vtk-qt package
* Thu Apr 14 2011 badshah400@gmail.com
  - Fix dependencies for openSUSE 11.2 and SLE 11
  - Fix build problems with openSUSE 11.4
* Thu Apr 14 2011 badshah400@gmail.com
  - Restored vtk-string-length.patch to solve buffer overflow errors
    during string copy operations
* Wed Mar 30 2011 badshah400@gmail.com
  - Added vtk-sqldatabaseschema.patch (from upstream) to fix
    compilation errors with python enabled
* Wed Mar 23 2011 badshah400@gmail.com
  - Update to version 5.6.1, rebase existing patches and remove
    unnecessary ones
* Wed Mar 23 2011 badshah400@gmail.com
  - Add vtk-python2.7-compat.patch to fix build problems with
    python 2.7
  - Add vtk-gcc4.3.patch to fix building issues with gcc 4.3
* Thu Mar 25 2010 boris@steki.net
  - Extended buffer size in VTK/Utilities/kwsys/SystemInformation.cxx

Files

/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkChartsCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkChartsCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonColor.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonColor.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonComputationalGeometry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonComputationalGeometry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonDataModel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonDataModel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonExecutionModel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonExecutionModel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonMath.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonMath.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonMisc.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonMisc.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonPython.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonSystem.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonSystem.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonTransforms.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkCommonTransforms.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDICOMParser.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDICOMParser.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDomainsChemistry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDomainsChemistry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDomainsParallelChemistry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkDomainsParallelChemistry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersAMR.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersAMR.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersExtraction.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersExtraction.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersFlowPaths.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersFlowPaths.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeneral.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeneral.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeneric.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeneric.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeometry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersGeometry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersHybrid.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersHybrid.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersHyperTree.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersHyperTree.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersImaging.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersImaging.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersModeling.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersModeling.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelGeometry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelGeometry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelImaging.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelImaging.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelMPI.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelMPI.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelVerdict.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersParallelVerdict.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersPoints.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersPoints.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersProgrammable.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersProgrammable.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersPython.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSMP.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSMP.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSelection.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSelection.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSources.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersSources.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersStatistics.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersStatistics.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersTexture.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersTexture.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersTopology.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersTopology.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersVerdict.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkFiltersVerdict.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkGeovisCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkGeovisCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOAMR.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOAMR.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOAsynchronous.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOAsynchronous.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOCityGML.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOCityGML.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOEnSight.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOEnSight.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExodus.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExodus.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExport.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExport.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExportPDF.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOExportPDF.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOGeometry.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOGeometry.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOImage.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOImage.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOImport.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOImport.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOInfovis.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOInfovis.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOLSDyna.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOLSDyna.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOLegacy.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOLegacy.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMINC.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMINC.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMPIImage.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMPIImage.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMPIParallel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMPIParallel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMotionFX.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMotionFX.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMovie.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOMovie.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIONetCDF.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIONetCDF.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOOggTheora.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOOggTheora.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOPLY.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOPLY.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallelNetCDF.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallelNetCDF.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallelXML.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOParallelXML.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOSQL.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOSQL.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOSegY.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOSegY.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOTecplotTable.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOTecplotTable.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOVeraOut.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOVeraOut.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOVideo.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOVideo.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOXML.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOXML.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOXMLParser.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkIOXMLParser.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingColor.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingColor.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingFourier.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingFourier.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingGeneral.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingGeneral.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingHybrid.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingHybrid.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingMath.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingMath.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingMorphological.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingMorphological.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingSources.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingSources.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingStatistics.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingStatistics.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingStencil.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkImagingStencil.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInfovisCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInfovisCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInfovisLayout.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInfovisLayout.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionImage.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionImage.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionStyle.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionStyle.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionWidgets.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkInteractionWidgets.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkJava.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelDIY.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelDIY.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelMPI.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelMPI.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelMPI4Py.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkParallelMPI4Py.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkPythonContext2D.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkPythonInterpreter.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingAnnotation.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingAnnotation.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingContext2D.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingContext2D.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingContextOpenGL2.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingContextOpenGL2.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingFreeType.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingFreeType.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingFreeTypeFontConfig.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingFreeTypeFontConfig.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingImage.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingImage.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingLOD.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingLOD.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingLabel.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingLabel.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingOpenGL2.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingOpenGL2.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingSceneGraph.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingSceneGraph.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingUI.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingUI.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVolume.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVolume.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVolumeOpenGL2.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVolumeOpenGL2.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVtkJS.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkRenderingVtkJS.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkTestingRendering.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkTestingRendering.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsContext2D.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsContext2D.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsCore.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsInfovis.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkViewsInfovis.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkWrappingPythonCore.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkWrappingTools.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkWrappingTools.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkexodusII.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkexodusII.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtklibharu.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtklibharu.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkloguru.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkloguru.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkmetaio.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkmetaio.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtksys.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtksys.so.9.0.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkverdict.so.1
/usr/lib64/mpi/gcc/openmpi3/lib64/libvtkverdict.so.9.0.1
/usr/share/licenses/libvtk1-openmpi3
/usr/share/licenses/libvtk1-openmpi3/Copyright.txt


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Oct 12 23:47:16 2021