Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libatk-bridge-2_0-0-2.46.0-2.1 RPM for aarch64

From OpenSuSE Ports Tumbleweed for aarch64

Name: libatk-bridge-2_0-0 Distribution: openSUSE Tumbleweed
Version: 2.46.0 Vendor: openSUSE
Release: 2.1 Build date: Tue Nov 1 13:47:48 2022
Group: System/Libraries Build host: obs-arm-8
Size: 267834 Source RPM: at-spi2-core-2.46.0-2.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://www.gnome.org/
Summary: ATK/D-Bus bridging library
AT-SPI is a general interface for applications to make use of the
accessibility toolkit. This version is based on dbus.

The package contains a ATK/D-Bus bridge library.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Fri Oct 28 2022 Frederic Crozat <fcrozat@suse.com>
  - Ensure xprop is required when xwayland is installed.
* Sat Sep 17 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.46.0:
    + Fix GetInterfaces documentation on org.a11y.atspi.Accessible
      interface.
* Fri Sep 16 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Add libatk-1_0-0 and libatk-bridge-2_0-0 to baselibs.conf, build
    32bit support.
* Sat Aug 27 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.45.91:
    + Send device event controller events using the same signature as
      other events.
    + Document the Accessible, Action, and Cache dbus interfaces.
    + Fix license of atspi-gmain.c.
  - Add fdupes BuildRequires and macro, remove duplicate files.
  - Provide and Obsolete atk from libatk sub-package.
* Wed Aug 10 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.45.90:
    + xml:
    - Add some documentation.
    - Fix event arguments.
    - Add some missing DeviceEventController methods.
    + Bind the AT-SPI bus to the graphical session.
    + Mark bus service as belonging to the session slice.
    + Add ATSPI_ROLE_PUSH_BUTTON_MENU.
    + Add an "announcement" event/signal to allow objects to send
      notifications.
    + Various code clean-ups and test improvements.
  - Add pkgconfig(libxml-2.0) BuildRequires: New dependency.
  - Add new sub-packages from the now included atk and at-spi2-atk
    packages: libatk-1_0-0, libatk-bridge-2_0-0 and
    typelib-1_0-Atk-1_0.
  - Provide/Obsolete at-spi2-atk-gtk2 by the main package.
* Thu Apr 21 2022 Michael Gorse <mgorse@suse.com>
  - Update to version 2.44.1:
    + Fix use after free when removing a hung process.
    + Fix the build with X11 disabled.
    + Fix crash when NULL is passed to some listener-related functions.
    + impl_deregister_keystroke_listener: fix memory leak on
      iteration error.
* Fri Mar 18 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.44.0:
    + Unlink the socket before binding when using dbus-broker. Fixes
      regression introduced in 2.43.92 where restarting the bus
      launcher would fail.
* Sat Mar 05 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.43.92:
    + The AT-SPI bus now uses the user's XDG_RUNTIME_DIR for its
      socket. Fixes accessibility for Snap-confined applications.
    + Caps lock is now unlocked for key synthesis. Fixes cutting and
      pasting from brltty when caps lock is on.
    + Several fixes to the dbus specification.
    + Fix the build when x11 is disabled.
    + Fix several compiler warnings.
  - Use ldconfig_scriptlets macro for post(un) handling.
  - Move autostart .desktop and xwayland-session config to
    distconfdir.
* Wed Dec 08 2021 Michael Gorse <mgorse@suse.com>
  - Configure to use dbus-broker when available.
  - Add libsystemd to BuildRequires: needed for dbus-broker support.
* Sun Sep 19 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.42.0:
    + Set X root property when Xwayland starts on demand.
    + Several dbus introspection fixes.
* Fri Jul 09 2021 Ferdinand Thiessen <rpm@fthiessen.de>
  - Update to version 2.40.3
    + Bugfix: Use abstract sockets if libdbus is older than 1.12.0
* Sun Jun 06 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.40.2:
    + README: Remove outdated links.
    + Key grab fixes for the new API.
    + registryd: Add a missing call to va_end.
* Sun May 02 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.1:
    + Fix double free when removing event listeners.
    + Fix numlock detection.
* Sat Mar 20 2021 Michael Gorse <mgorse@suse.com>
  - Update to version 2.40.0:
    + No changes.
* Thu Mar 18 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.39.91:
    + Fix a couple of memory leaks.
    + Remove const from AtspiDeviceListenerCB prototype.
* Tue Feb 23 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.39.90.1:
    + Fix a crash introduced in 2.39.90, along with a few warnings.
* Wed Feb 17 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.39.90:
    + Fix build with X11 disabled.
    + Various fixes for the new device API used for key monitoring
      and grabbing.
    + Fixed several memory leaks.
* Sun Jan 17 2021 Dominique Leuenberger <dimstar@opensuse.org>
  - Update to version 2.39.1:
    + Don't use gdbus-broker if not running under systemd.
    + Unref bus at the end of cleanup.
    + Fix XML interfaces.
    + Use unix sockets instead of abstract sockets.
    + Added a device API to replace the old API for capturing key
      grabs. This is needed for toolkits that do not report
      keystrokes to atk, such as gtk 4.
* Tue Sep 22 2020 dimstar@opensuse.org
  - Update to version 2.38.0:
    + Updated translations.
* Tue Sep 22 2020 dimstar@opensuse.org
  - Update to version 2.37.92:
    + Fix a possible memory leak if an event name cannot be parsed.
    + _atspi_dbus_set_interfaces: fix memory leak when called with an
      invalid DBus signature.
    + Fix a crash if an event listener is removed during an event
      callback.
* Tue Sep 22 2020 dimstar@opensuse.org
  - Update to version 2.37.90:
    + Add a mode-changed signal to allow a screen reader to indicate
      that its mode has changed.
    + Fix use after free when a device listener is destroyed.
    + Meson: de-duplicate deps of 'Requires' in pkgconfig file.
    + FIx use after free when an event listener is destroyed.
    + Make at-spi-dbus-bus.desktop validate.
    + atspi_accessible_set_cache_mask: relax assert that was
      generating a warning and causing the function to fail in some
      cases.
    + Fixes for synthesizing keys.
    + Fix Qt annotations in DBus xml files.
    + Memory test: replace gedit with a light-weight test
      application.
    + dbtest: print to stdout instead of stderr.
    + Tests: make test a bit verbose.
    + Constants: fix typos in two _COUNT constants.
* Sat Sep 12 2020 Matthias Eliasson <elimat@opensuse.org>
  - Update to version 2.36.1:
    + meson: De-duplicate deps of 'Requires' in pkgconfig file
    + Make at-spi-dbus-bus.desktop Validat
    + Fix ucs2keysym line for Euro sign
    + Fix Qt annotations in DBus xml files
    + constants: Fix typos in two _COUNT constants
    + Fix a couple of memory leaks.
    + Fix use after free when a device listener is destroyed.
    + Fix use after free when an event listener is destroyed.
  - Run spec-cleaner
    + Remove rpm groups
* Sun Mar 08 2020 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.36.0:
    + No changes, stable version update only.
* Sat Feb 29 2020 mgorse@suse.com
  - Update to version 2.35.92:
    + bus-launcher: make session management more robust
      (boo#1154582).
  - Drop at-spi2-core-async-session-register.patch: Fixed upstream.
* Thu Feb 27 2020 Michael Gorse <mgorse@suse.com>
  - Ad at-spi2-core-async-session-register.patch: make bus-launcher
    session registration more robust (boo#1154582).
* Wed Feb 12 2020 dimstar@opensuse.org
  - Update to version 2.35.1:
    + Fix source reproducibility.
    + Avoid depending on Meson 0.50.
    + Add ATSPI_ROLE_MARK and ATSPI_ROLE_SUGGESTION.
* Mon Sep 09 2019 mgorse@suse.com
  - Update to version 2.34.0:
    + Fix a use after free when freeing an event.
    + Clean up handling of the X11 property specifying the bus
      address.
    + Update doap.
* Mon Sep 02 2019 mgorse@suse.com
  - Update to version 2.33.92:
    + Now requires meson 0.50.0.
    + License is now LGPL-2.1+.
    + Meson: only link to libdl when it is necessary.
    + Update installation instructions.
    + Clarify atspi_editable_text_insert_text documentation.
    + Do not warn on no reply from pending get_items call.
    + Eliminate some superfluous runtime warnings.
  - Require meson >= 0.50.0.
  - Set license to LGPL-2.1-or-later.
* Fri Aug 30 2019 mgorse@suse.com
  - Update to version 2.33.90:
    + Refactor the API for the screen reader to notify listeners
      of its status.
    + Add a sender to the AtspiEvent struct.
    + Add missing atspi_application_get_type prototype.
    + Support mutter remote desktop interface for synthesizing
      keyboard/mouse events (likely still needs work).
* Tue Jun 25 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.33.2:
    + Check WAYLAND_DISPLAY, rather than XDG_SESSION_TYPE, to avoid X
      connections. Fixes breakage if X is started with startx and
      XDG_SESSION_TYPE is unset.
    + X11: also try mod4 and mod5 to generate keysyms.
    + Add ATSPI_ROLE_CONTENT_DELETION and
      ATSPI_ROLE_CONTENT_INSERTION.
    + Check for dbus-daemon in /usr/lib (for Solaris).
* Wed Apr 10 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.32.1:
    + Fix meson build for meson 0.50.0 and newer.
  - Drop at-spi2-core-meson-build-fix.patch: Fixed upstream.
* Tue Mar 12 2019 mgorse@suse.com
  - Add at-spi2-core-meson-build-fix.patch: fix build for meson
    0.50.0 (glgo#GNOME/at-spi2-core!9).
* Tue Mar 12 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.32.0:
    + Stable release version bump.
* Tue Mar 05 2019 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 2.31.92:
    + Fix atspi_table_cell_get_(row_column)_headers.
    + Update documentation to indicate that extents are only
      meaningful when an object has both STATE_VISIBLE and
      STATE_SHOWING.
    + Use a consistent style for the meson options.
    + Fix a compiler warning on BSD.
    + Add ScrollSubstringTo and ScrollSubstringToPoint text
      interfaces.
  - Enable gtk-docs BuildRequires and update options passed to meson.
  - Drop unneeded and unused intltool BuildRequires.
* Tue Mar 05 2019 bjorn.lie@gmail.com
  - Update to version 2.31.2:
    + Add ScrollSubstringTo and ScrollSubstringToPoint text
      interfaces.
* Tue Mar 05 2019 bjorn.lie@gmail.com
  - Update to version 2.31.1:
    + Bus launcher: fix an issue where the error wasn't cleared on
      failure.
    + Add support for locking/unlocking modifiers.
    + Update error log text for consistency.
    + Documentation clean-ups.
  - Drop upstream fixed patches:
    + at-spi2-core-bus-launch-use__linux__.patch.
    + at-spi2-core-generate-pc.patch.
* Mon Mar 04 2019 mgorse@suse.com
  - Update to version 2.30.1:
    + Fix atspi_table_cell_get_(row|column)_header_cells
      (bsc#1127792).

Files

/usr/lib64/libatk-bridge-2.0.so.0
/usr/lib64/libatk-bridge-2.0.so.0.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Feb 1 00:27:32 2023