Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

pia-3.103-lp152.4.1 RPM for armv7hl

From OpenSuSE Ports Leap 15.2 for armv7hl

Name: pia Distribution: openSUSE Leap 15.2
Version: 3.103 Vendor: openSUSE
Release: lp152.4.1 Build date: Mon Jun 8 14:54:32 2020
Group: Productivity/Multimedia/Video/Players Build host: obs-arm-5
Size: 165689 Source RPM: xawtv-3.103-lp152.4.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.kraxel.org/blog/linux/xawtv/
Summary: Simple Movie Player
pia is a simple movie player which can playback AVI and QuickTime
movies recorded by xawtv, motv, and streamer. Other movies might work
as well.

Provides

Requires

License

GPL-2.0+

Changelog

* Thu Jun 04 2020 matthias.gerstner@suse.com
  - v4l-conf: add v4l-conf-fix-CVE-2020-13696.patch: fix security issue in
    setuid-root program that allows for arbitrary file existence tests and
    open() with O_RDWR (bsc#1171655, CVE-2020-13696)
* Fri Dec 26 2014 bwiedemann@suse.com
  - fix Segfault at start + add xawtv-fixblitframesegfault.patch
* Thu Jul 25 2013 tchvatal@suse.com
  - Add missing dependencies so the package build on factory.
* Sun Jun 02 2013 asterios.dramis@gmail.com
  - Update to version 3.103:
    * Improve alsa stream handling
    * Add support for alsa audio loopback to the radio app
    * Add support for multiple-band (AM+FM) tuners to radio app
    * Tons of other bugfixes + improvements for the radio app
    * Fix xawtv window flashing to black when changing channel or taking a
      snapshot
    * Fix crackle crackle sound on mp34xx cards when changing channel
    * Various other bugfixes
  - Removed xawtv-3.95.patch, no-copy-dt-needed-entries.patch and
    xawtv-read-config.patch (not needed/fixed upstream).
  - Replaced Mesa-devel and xorg-x11-devel build requirements with the needed
    pkgconfig(...) ones.
  - Removed automake (autoreconf -fi is not needed) and openmotif (not needed)
    build requirements.
  - Use desktop-file-utils instead of update-desktop-files for openSUSE > 12.1.
* Sat Jun 16 2012 bwiedemann@suse.com
  - patch to read config as it can contain keyboard events for vdr
    (fixes bnc#735032)
* Fri Feb 24 2012 coolo@suse.com
  - buildrequire xorg-x11 for configure to find appdefaults location correctly
* Wed Nov 30 2011 coolo@suse.com
  - add automake as buildrequire to avoid implicit dependency
* Sat Sep 10 2011 asterios.dramis@gmail.com
  - Update to version 3.102:
    * Improve alsa latency handler and document the -alsa-latency parameter
    * Improve alsa handling, fixing a cut and past error that causes
      breakages with some cards
    * Improve audio parameters detection
    * fix build with ld --as-needed --no-copy-dt-needed
  - Spec file updates:
    * Changed License: to GPL-2.0+.
    * Recommend instead of Require "pia" for xawtv and motv.
    * Removed "export SUSE_ASNEEDED=0" (not needed anymore).
    * Minor other updates.
  - Added a patch "v4l-conf_non-position-independent-executable_fix.patch" to fix
    the non-position-independent-executable rpmlint warning for v4l-conf.
  - Added a patch "no-copy-dt-needed-entries.patch" to fix linking with
    - -no-copy-dt-needed-entries.
* Sun Jul 03 2011 asterios.dramis@gmail.com
  - Update to version 3.101:
    * Man fix to remove mention of v4l1, and describe libv4l instead
    * Fixes at fr/es manuals
    * Warning fixes
    * Addition of alsa streaming at xawtv: now, for devices with video
      associated with audio inputs.
    * Use X11 editres, instead of its on version, based on a port from
      a motif library released under a licence that is not GPL compatible
    * Add auto-detection logic for xawtv: by default, it will now seek for
      the first TV device. If not available, fall back to the first grabber
      device.
    * Add auto-detection logic for scanv: by default, it will now seek for
      the first TV device. If not afailable, fails.
    * Add optional support for libexplain at the v4l2/libv4l driver.
      Libexplain provides a  more complete explanation for the error codes,
      helping developers to better track what's happened.
    * Don't expose tuner commands, on devices that are grabber or  webcams
      at xawtv.
  - Removed the patch for the GPL incompatible OpenGroup license files issue
    bnc#696259 (fixed upstream).
* Sat May 28 2011 asterios.dramis@gmail.com
  - Added a patch (based on upstream) to fix the issue with GPL incompatible
    OpenGroup license files (bnc#696259).

Files

/usr/bin/pia
/usr/share/doc/packages/pia
/usr/share/doc/packages/pia/COPYING
/usr/share/doc/packages/pia/Changes
/usr/share/doc/packages/pia/README
/usr/share/man/man1/pia.1.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 14:49:53 2021