Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

alsa-plugins-pulse-1.1.5-lp150.1.1 RPM for armv7hl

From OpenSuSE Ports Leap 15.0 for armv7hl

Name: alsa-plugins-pulse Distribution: openSUSE Leap 15.0
Version: 1.1.5 Vendor: openSUSE
Release: lp150.1.1 Build date: Tue May 15 23:32:01 2018
Group: System/Libraries Build host: armbuild14
Size: 75430 Source RPM: alsa-plugins-1.1.5-lp150.1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.alsa-project.org/
Summary: Pulseaudio Plug-In for the ALSA Library
pulseaudio is a networked sound server for Linux and other Unix like
operating systems and Microsoft Windows. It is intended to be an
improved drop-in replacement for the Enlightened Sound Daemon (ESOUND).

This package contains the polypaudio I/O plug-in for the ALSA library.

Provides

Requires

License

GPL-2.0+ and LGPL-2.1+

Changelog

* Tue Nov 14 2017 tiwai@suse.de
  - Update to alsa-plugins 1.1.5:
    * pulse: prevent double-free when pulse_hw_constraint returns
      error
* Tue Aug 29 2017 tiwai@suse.de
  - Disable avcodec-related plugins for SLE packages
* Tue May 16 2017 tiwai@suse.de
  - Update to alsa-plugins 1.1.4:
    * extend configure script to disable more stuff
    * including previous fix for libavcodec
  - Obsoleted patch:
    0001-configure-Fix-detection-of-avcodec.h.patches
* Wed May 03 2017 tiwai@suse.de
  - Fix the detection of libavcodec header files:
    0001-configure-Fix-detection-of-avcodec.h.patches
  - Enable the build of a52 and lavcrate plugins for openSUSE
* Fri Dec 09 2016 zaitor@opensuse.org
  - Own alsa-lib dir, needed due to changes in alsa.
* Thu Mar 31 2016 tiwai@suse.de
  - Update to alsa-plugins 1.1.1:
    including all previous fixes, fixes of a52 plugin for the recent
    ffmpeg versions
  - Delete obsoleted patches:
    0001-speex-Add-missing-include-config.h.patch
    0002-a52-fix-reported-input-channel-order.patch
    0003-pph-include-config.h-from-rate_speexrate.c.patch
* Wed Feb 03 2016 tiwai@suse.de
  - Backport upstream fixes: build fixes with the recent ffmpeg
    0001-speex-Add-missing-include-config.h.patch
    0002-a52-fix-reported-input-channel-order.patch
    0003-pph-include-config.h-from-rate_speexrate.c.patch
  - Drop the obsoleted patch:
    alsa-plugins-include-config.h.patch
* Wed Nov 25 2015 tiwai@suse.de
  - Add supplements to 32bit packages to be fetched automatically
    (bsc#956402)
* Mon Nov 09 2015 tiwai@suse.de
  - Update to alsa-plugins 1.1.0:
    including all previous fixes, a small memory leak fix in jack
    plugin
  - Dropped patches:
    0001-rate-Allow-LGPL-for-libsamplerate-commercial-license.patch
    0002-mix-Fix-extplug-version-ifdef-checks.patch
    0003-a52-Fix-ioplug-version-ifdef-checks.patch
    0004-pulse-Add-24-bit-data-formats-to-Pulse-plugin.patch
    0005-arcam-av-Include-sys-select.h-for-fd_set-definition.patch
    0006-pph-include-speexdsp_types.h-not-speex_types.h.patch
    0007-pph-Fix-build-with-older-speex.patch
* Thu Jul 09 2015 tiwai@suse.de
  - Backport upstream fixes: just minor build fix issues that don't
    hit us, but kept here for consistency
    0005-arcam-av-Include-sys-select.h-for-fd_set-definition.patch
    0006-pph-include-speexdsp_types.h-not-speex_types.h.patch
    0007-pph-Fix-build-with-older-speex.patch
  - Fix build error with SLE11-SP3 due to lack of speexdsp pkgconfig.
* Fri May 22 2015 tiwai@suse.de
  - Backport upstream fixes: fixes for A52 plugin, mix plugin protocol
    version fix, and enhancement for JACK plugin to support 24bit
    formats:
    0001-rate-Allow-LGPL-for-libsamplerate-commercial-license.patch
    0002-mix-Fix-extplug-version-ifdef-checks.patch
    0003-a52-Fix-ioplug-version-ifdef-checks.patch
    0004-pulse-Add-24-bit-data-formats-to-Pulse-plugin.patch
* Thu Mar 12 2015 dimstar@opensuse.org
  - BuildRequire pkgconfig(speexdsp) instead of speex-devel: the
    packages have been rearranged/split.
  - Add alsa-plugins-include-config.h.patch: Fix build with new
    speexdsp versions. The speexdsp headers expect the caller to set
    HAVE_STDINT_H (or any of the other appropriate headers, based on
    platform) in order to define the specific types.
* Thu Feb 26 2015 tiwai@suse.de
  - Update to alsa-plugins 1.0.29:
    Just a version bump including previous fixes
  - Drop obsoleted patch:
    0001-jack-Restore-PID-to-jack-client-name-when-not-specif.patch
* Sun Nov 09 2014 Led <ledest@gmail.com>
  - fix bashisms in post/postun scripts:
    option '-p' of 'type' command may be unsupported is some shells,
    use 'command -v' instead
* Tue Aug 12 2014 tiwai@suse.de
  - Backport upstream fix for backward compatibility of jack PCM
    plugin:
    0001-jack-Restore-PID-to-jack-client-name-when-not-specif.patch
* Wed Jun 18 2014 tiwai@suse.de
  - Updated to alsa-plugins 1.0.28:
    All pervious fix patches are obsoleted:
    0001-Check-for-and-include-libavutil.h-to-avoid-unresolve.patch
    0002-Add-AM_MAINTAINER_MODE-enable-to-configure.in.patch
    0003-vdownmix-Add-chmap-support.patch
    0004-upmix-Add-chmap-support.patch
    0005-a52-Fix-build-error-with-the-recent-version.patch
    0006-a52-Add-chmap-support.patch
    0007-a52-Propagate-errors-from-hw.patch
    0008-a52-switch-to-AV_CODEC_ID-identifiers.patch
    0009-jack-Allow-to-specify-a-client-name-as-parameters.patch
* Tue Mar 11 2014 tiwai@suse.de
  - Backport upstream fixes: add chmap support to plugins, fix a52
    builds, add a new option to jack plugin:
    0003-vdownmix-Add-chmap-support.patch
    0004-upmix-Add-chmap-support.patch
    0005-a52-Fix-build-error-with-the-recent-version.patch
    0006-a52-Add-chmap-support.patch
    0007-a52-Propagate-errors-from-hw.patch
    0008-a52-switch-to-AV_CODEC_ID-identifiers.patch
    0009-jack-Allow-to-specify-a-client-name-as-parameters.patch
  - Run spec-cleaner
* Thu May 23 2013 tiwai@suse.de
  - Backport upstream fixes:
    0001-Check-for-and-include-libavutil.h-to-avoid-unresolve.patch
    0002-Add-AM_MAINTAINER_MODE-enable-to-configure.in.patch
* Fri Apr 12 2013 tiwai@suse.de
  - Updated to version 1.0.27:
    including all previous fixes; all 00*-* patches dropped
* Mon Mar 11 2013 tiwai@suse.de
  - Backport fix patches from upstream:
    0002-a52-Add-the-support-of-recent-libavcodec-libavutil.patch
    0003-a52-Fix-build-errors.patch
    0004-pulse-pulse_pcm_poll_revents-should-return-0-on-succ.patch
* Fri Feb 01 2013 tiwai@suse.de
  - Correct the package version number to 1.0.26; no content change
* Fri Nov 30 2012 tiwai@suse.de
  - Improve prebuf setup of pulse plugin:
    0001-pcm_pulse-set-prebuf-parameter-according-to-software.patch
* Fri Oct 26 2012 tiwai@suse.de
  - remove obsoleted alsa-plugins-include.patch
* Fri Sep 07 2012 tiwai@suse.de
  - Updated to version 1.0.26:
    including glibc-2.16 build fix, add support 24bit format to pulse
* Thu Sep 06 2012 tiwai@suse.de
  - Add post/postun hooks for pulse plugin to fix the leftover
    config path (bnc#779039)
* Sun Jul 29 2012 aj@suse.de
  - Move _GNU_SOURCE before any header inclusion to fix build with glibc 2.16
* Fri Mar 30 2012 reddwarf@opensuse.org
  - stop recommending -32bit packages
* Wed Jan 25 2012 tiwai@suse.de
  - updated to version 1.0.25; including all previous fixes
* Fri Sep 30 2011 coolo@suse.com
  - add libtool as buildrequire to make the spec file more reliable
* Tue Sep 27 2011 tiwai@suse.de
  - Set CLOEXEC flag to left-over fds in pulse plugin
* Tue Sep 20 2011 tiwai@suse.de
  - Install pulse plugin setup in the new config.d directory,
    use the upstream default
* Sat Sep 17 2011 jengelh@medozas.de
  - Remove redundant tags/sections from specfile
  - Use %_smp_mflags for parallel build
* Fri Aug 26 2011 tiwai@suse.de
  - Fix the build of pulse plugin with a very old PA
* Fri Aug 26 2011 tiwai@suse.de
  - Add a better overrun handling with the new PA API
* Mon Aug 08 2011 tiwai@suse.de
  - Fix hanging applications when using jack plugin
* Wed Jul 27 2011 tiwai@suse.de
  - Add PA_CONTEXT_NOAUTOSPAWN flag when fallback is set for pulse
    plugins
* Tue Jul 26 2011 tiwai@suse.de
  - Add fallback option to pulse plugin
  - Enable the fallback to the system-default in asound-pulse.conf
* Tue Apr 26 2011 tiwai@suse.de
  - Upstream fixes:
    * Fix build of a52 plugin (not used in this package, though)
    * Fix bogus snd_pcm_avail() zero return in pulse plugin
* Mon Jan 31 2011 tiwai@suse.de
  - Updated to version 1.0.24:
    * including previous fixes
    * Fix documents
* Thu Sep 02 2010 tiwai@suse.de
  - Backport upstream fix:
    pulse: Add handle_underrun option
* Thu Jun 24 2010 tiwai@suse.de
  - Backport upstream fix:
    pulse: Fix invalid buffer pointer return value
* Mon Apr 19 2010 tiwai@suse.de
  - updated to version 1.0.23:
    * including previous fixes
* Mon Mar 08 2010 tiwai@suse.de
  - Backport upstream fixes:
    * usb_stream: Check for NULL-ness before dereferencing
    * usb_stream: Allow user-set period-size and rate
* Wed Jan 27 2010 jengelh@medozas.de
  - package baselibs.conf
* Fri Dec 18 2009 tiwai@suse.de
  - set AUTOMAKE_JOBS for parallel automake
* Fri Dec 18 2009 tiwai@suse.de
  - updated to version 1.0.22:
    * upmix 7.1 channels support
    * fixes for a53 with recent libavcodec
* Wed Sep 09 2009 tiwai@suse.de
  - add recommends tags for 32bit packages (bnc#537555)
* Mon Aug 31 2009 tiwai@suse.de
  - updated to version 1.0.21:
    just a version bump including previous fixes
* Fri Aug 07 2009 tiwai@suse.de
  - yet another updates of pulse plugin:
    * replace manual mainloop by pa_mainloop_iterate()
    * move a couple of PCM related functions from pulse.c to pcm_pulse.c
    * get rid of redundant state variable
    * unify stream/context state checks
    * rework object destruction paths a bit
    * immediately trigger EIO when connection is dropped
* Mon Aug 03 2009 tiwai@suse.de
  - update pulse plugin:
    * get rid of a number of assert()s
    * unify destruction of snd_pulse_t
    * use PA_CONTEXT_IS_GOOD where applicable
    * call pa_threaded_mainloop_wait() to handle spurious wakeups
* Thu Jul 30 2009 sbrabec@suse.cz
  - alsa-plugin-pulse does not work without pulseaudio, add Requires.
* Fri Jul 17 2009 tiwai@suse.de
  - fix the missing initialization of OSS PCM plugin
* Fri Jun 19 2009 tiwai@suse.de
  - echo-cancelling support in speex dsp plugin
* Tue Jun 02 2009 tiwai@suse.de
  - extend rate plugins to follow the new protocol
* Wed May 06 2009 tiwai@suse.de
  - updated to version 1.0.20:
    * including previous patches
    * arcam-av plugin updates

Files

/etc/alsa-pulse.conf
/etc/asound-pulse.conf
/usr/lib/alsa-lib/libasound_module_conf_pulse.so
/usr/lib/alsa-lib/libasound_module_ctl_pulse.so
/usr/lib/alsa-lib/libasound_module_pcm_pulse.so
/usr/share/alsa/alsa.conf.d
/usr/share/alsa/alsa.conf.d/50-pulseaudio.conf
/usr/share/alsa/alsa.conf.d/99-pulseaudio-default.conf.example
/usr/share/doc/packages/alsa-plugins-pulse
/usr/share/doc/packages/alsa-plugins-pulse/COPYING
/usr/share/doc/packages/alsa-plugins-pulse/README-pulse


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Nov 10 09:52:08 2019