Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

openssl-1.1.1d-1.46 RPM for noarch

From OpenSuSE Leap 15.3 for noarch

Name: openssl Distribution: SUSE Linux Enterprise 15
Version: 1.1.1d Vendor: SUSE LLC <https://www.suse.com/>
Release: 1.46 Build date: Sat Jun 6 03:03:34 2020
Group: Productivity/Networking/Security Build host: sheep09
Size: 246 Source RPM: openssl-1.1.1d-1.46.src.rpm
Packager: https://www.suse.com/
Url: https://www.openssl.org/
Summary: Secure Sockets and Transport Layer Security
The OpenSSL Project is a collaborative effort to develop a robust,
commercial-grade, full-featured, and open source toolkit implementing
the Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS
v1) protocols with full-strength cryptography. The project is managed
by a worldwide community of volunteers that use the Internet to
communicate, plan, and develop the OpenSSL toolkit and its related
documentation.

Provides

Requires

License

OpenSSL

Changelog

* Thu Sep 12 2019 vcizek@suse.com
  - Update to 1.1.1d release
* Thu Aug 29 2019 vcizek@suse.com
  - Upgrade to 1.1.1c release to get TLS 1.3 support
    (jsc#SLE-9135, bsc#1148799)
* Thu Aug 16 2018 vcizek@suse.com
  - Update to 1.1.0i release
* Tue Mar 27 2018 vcizek@suse.com
  - Update to 1.1.0h release
* Fri Feb 16 2018 vcizek@suse.com
  - change the sonum to 1.1, as all the minor versions keep ABI
    compatibility (bsc#1081335)
  - update baselibs.conf
* Mon Nov 06 2017 vcizek@suse.com
  - Update to 1.1.0g release
* Thu Nov 02 2017 vcizek@suse.com
  - Revert version back to 1.0.2m to get security fixes quickly to
    Tumbleweed
    * OpenSSL Security Advisory [02 Nov 2017] (bsc#1066242,bsc#1056058)
* Mon Jul 31 2017 tchvatal@suse.com
  - Switch to 1.1.0f release as default again
* Tue Jul 11 2017 vcizek@suse.com
  - Obsolete openssl-debuginfo
    * the package doesn't exist any more, has been replaced by
      openssl-{so_version}-debuginfo (bsc#1040172)
* Fri Jun 23 2017 tchvatal@suse.com
  - Revert back to 1.0.2l for now so we get new fixes of 1.0 openssl
    to tumbleweed
* Mon May 29 2017 tchvatal@suse.com
  - Update to 1.1.0f release
* Wed May 24 2017 tchvatal@suse.com
  - Switch default to openssl-1.1.0
* Fri May 05 2017 tchvatal@suse.com
  - Provide pkgconfig(openssl)
* Tue May 02 2017 tchvatal@suse.com
  - Provide basic baselibs.conf for 32bit subpackages
  - Specify this package as noarch (as we just provide README files)
* Wed Apr 26 2017 tchvatal@suse.com
  - Fix typo in openssl requires
  - Add dependency on the branched devel package
  - Provide all pkgconfig symbols to hide them in versioned subpkgs
  - This allows us to propagate only the preffered version of openssl
    while allowing us to add extra openssl only as additional dependency
* Wed Apr 12 2017 tchvatal@suse.com
  - Remove the ssl provides as it is applicable for only those that
    really provide it
* Wed Apr 12 2017 tchvatal@suse.com
  - Prepare to split to various subpackages converting main one to
    dummy package
  - Reduce to only provide main pkg and devel and depend on proper
    soversioned package
  - Version in this package needs to be synced with the one provided
    by the split package
  - Remove all the patches, now in the proper versioned namespace:
    * merge_from_0.9.8k.patch
    * openssl-1.0.0-c_rehash-compat.diff
    * bug610223.patch
    * openssl-ocloexec.patch
    * openssl-1.0.2a-padlock64.patch
    * openssl-fix-pod-syntax.diff
    * openssl-truststore.patch
    * compression_methods_switch.patch
    * 0005-libssl-Hide-library-private-symbols.patch
    * openssl-1.0.2a-default-paths.patch
    * openssl-pkgconfig.patch
    * openssl-1.0.2a-ipv6-apps.patch
    * 0001-libcrypto-Hide-library-private-symbols.patch
    * openssl-1.0.2i-fips.patch
    * openssl-1.0.2a-fips-ec.patch
    * openssl-1.0.2a-fips-ctor.patch
    * openssl-1.0.2i-new-fips-reqs.patch
    * openssl-gcc-attributes.patch
    * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
    * openssl-no-egd.patch
    * openssl-fips-hidden.patch
    * openssl-1.0.1e-add-suse-default-cipher.patch
    * openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
    * openssl-missing_FIPS_ec_group_new_by_curve_name.patch
    * openssl-fips-dont_run_FIPS_module_installed.patch
    * openssl-fips_disallow_x931_rand_method.patch
    * openssl-fips_disallow_ENGINE_loading.patch
    * openssl-rsakeygen-minimum-distance.patch
    * openssl-urandom-reseeding.patch
    * openssl-fips-rsagen-d-bits.patch
    * openssl-fips-selftests_in_nonfips_mode.patch
    * openssl-fips-fix-odd-rsakeybits.patch
    * openssl-fips-clearerror.patch
    * openssl-fips-dont-fall-back-to-default-digest.patch
    * openssl-fipslocking.patch
    * openssl-print_notice-NULL_crash.patch
    * openssl-randfile_fread_interrupt.patch
* Tue Apr 04 2017 tchvatal@suse.com
  - Remove O3 from optflags, no need to not rely on distro wide settings
  - Remove conditions for sle10 and sle11, we care only about sle12+
  - USE SUSE instead of SuSE in readme
  - Pass over with spec-cleaner
* Thu Feb 02 2017 vcizek@suse.com
  - fix X509_CERT_FILE path (bsc#1022271) and rename
    updated openssl-1.0.1e-truststore.diff to openssl-truststore.patch
* Fri Jan 27 2017 meissner@suse.com
  - Updated to openssl 1.0.2k
    - bsc#1009528 / CVE-2016-7055: openssl: Montgomery multiplication may produce incorrect results
    - bsc#1019334 / CVE-2016-7056: openssl: ECSDA P-256 timing attack key recovery
    - bsc#1022085 / CVE-2017-3731: openssl: Truncated packet could crash via OOB read
    - bsc#1022086 / CVE-2017-3732: openssl: BN_mod_exp may produce incorrect results on x86_64
* Fri Sep 30 2016 vcizek@suse.com
  - resume reading from /dev/urandom when interrupted by a signal
    (bsc#995075)
    * add openssl-randfile_fread_interrupt.patch
* Fri Sep 30 2016 vcizek@suse.com
  - add FIPS changes from SP2:
  - fix problems with locking in FIPS mode (bsc#992120)
    * duplicates: bsc#991877, bsc#991193, bsc#990392, bsc#990428
      and bsc#990207
    * bring back openssl-fipslocking.patch
  - drop openssl-fips_RSA_compute_d_with_lcm.patch (upstream)
    (bsc#984323)
  - don't check for /etc/system-fips (bsc#982268)
    * add openssl-fips-dont_run_FIPS_module_installed.patch
  - refresh openssl-fips-rsagen-d-bits.patch
* Tue Sep 27 2016 michael@stroeder.com
  - update to openssl-1.0.2j
    * Missing CRL sanity check (CVE-2016-7052 bsc#1001148)
* Fri Sep 23 2016 vcizek@suse.com
  - OpenSSL Security Advisory [22 Sep 2016] (bsc#999665)
    Severity: High
    * OCSP Status Request extension unbounded memory growth
      (CVE-2016-6304) (bsc#999666)
    Severity: Low
    * Pointer arithmetic undefined behaviour (CVE-2016-2177) (bsc#982575)
    * Constant time flag not preserved in DSA signing (CVE-2016-2178) (bsc#983249)
    * DTLS buffered message DoS (CVE-2016-2179) (bsc#994844)
    * OOB read in TS_OBJ_print_bio() (CVE-2016-2180) (bsc#990419)
    * DTLS replay protection DoS (CVE-2016-2181) (bsc#994749)
    * OOB write in BN_bn2dec() (CVE-2016-2182) (bsc#993819)
    * Birthday attack against 64-bit block ciphers (SWEET32)
      (CVE-2016-2183) (bsc#995359)
    * Malformed SHA512 ticket DoS (CVE-2016-6302) (bsc#995324)
    * OOB write in MDC2_Update() (CVE-2016-6303) (bsc#995377)
    * Certificate message OOB reads (CVE-2016-6306) (bsc#999668)
  - update to openssl-1.0.2i
    * remove patches:
      openssl-1.0.2a-new-fips-reqs.patch
      openssl-1.0.2e-fips.patch
    * add patches:
      openssl-1.0.2i-fips.patch
      openssl-1.0.2i-new-fips-reqs.patch
* Wed Aug 03 2016 vcizek@suse.com
  - fix crash in print_notice (bsc#998190)
    * add openssl-print_notice-NULL_crash.patch
* Tue May 03 2016 vcizek@suse.com
  - OpenSSL Security Advisory [3rd May 2016]
  - update to 1.0.2h (boo#977584, boo#977663)
    * Prevent padding oracle in AES-NI CBC MAC check
      A MITM attacker can use a padding oracle attack to decrypt traffic
      when the connection uses an AES CBC cipher and the server support
      AES-NI.
      (CVE-2016-2107, boo#977616)
    * Fix EVP_EncodeUpdate overflow
      An overflow can occur in the EVP_EncodeUpdate() function which is used for
      Base64 encoding of binary data. If an attacker is able to supply very large
      amounts of input data then a length check can overflow resulting in a heap
      corruption.
      (CVE-2016-2105, boo#977614)
    * Fix EVP_EncryptUpdate overflow
      An overflow can occur in the EVP_EncryptUpdate() function. If an attacker
      is able to supply very large amounts of input data after a previous call to
      EVP_EncryptUpdate() with a partial block then a length check can overflow
      resulting in a heap corruption.
      (CVE-2016-2106, boo#977615)
    * Prevent ASN.1 BIO excessive memory allocation
      When ASN.1 data is read from a BIO using functions such as d2i_CMS_bio()
      a short invalid encoding can casuse allocation of large amounts of memory
      potentially consuming excessive resources or exhausting memory.
      (CVE-2016-2109, boo#976942)
    * EBCDIC overread
      ASN1 Strings that are over 1024 bytes can cause an overread in applications
      using the X509_NAME_oneline() function on EBCDIC systems. This could result
      in arbitrary stack data being returned in the buffer.
      (CVE-2016-2176, boo#978224)
    * Modify behavior of ALPN to invoke callback after SNI/servername
      callback, such that updates to the SSL_CTX affect ALPN.
    * Remove LOW from the DEFAULT cipher list.  This removes singles DES from the
      default.
    * Only remove the SSLv2 methods with the no-ssl2-method option. When the
      methods are enabled and ssl2 is disabled the methods return NULL.
* Fri Apr 15 2016 dvaleev@suse.com
  - Remove a hack for bsc#936563
  - Drop bsc936563_hack.patch
* Fri Apr 15 2016 vcizek@suse.com
  - import fips patches from SLE-12
    * openssl-fips-clearerror.patch
    * openssl-fips-dont-fall-back-to-default-digest.patch
    * openssl-fips-fix-odd-rsakeybits.patch
    * openssl-fips-rsagen-d-bits.patch
    * openssl-fips-selftests_in_nonfips_mode.patch
    * openssl-fips_RSA_compute_d_with_lcm.patch
    * openssl-fips_disallow_ENGINE_loading.patch
    * openssl-fips_disallow_x931_rand_method.patch
    * openssl-rsakeygen-minimum-distance.patch
    * openssl-urandom-reseeding.patch
* Tue Mar 08 2016 vcizek@suse.com
  - add support for "ciphers" providing no encryption (bsc#937085)
    * don't build with -DSSL_FORBID_ENULL
* Tue Mar 01 2016 vcizek@suse.com
  - update to 1.0.2g (bsc#968044)
    * Disable weak ciphers in SSLv3 and up in default builds of OpenSSL.
      Builds that are not configured with "enable-weak-ssl-ciphers" will not
      provide any "EXPORT" or "LOW" strength ciphers.
    * Disable SSLv2 default build, default negotiation and weak ciphers.  SSLv2
      is by default disabled at build-time.  Builds that are not configured with
      "enable-ssl2" will not support SSLv2.  Even if "enable-ssl2" is used,
      users who want to negotiate SSLv2 via the version-flexible SSLv23_method()
      will need to explicitly call either of:
      SSL_CTX_clear_options(ctx, SSL_OP_NO_SSLv2);
      or
      SSL_clear_options(ssl, SSL_OP_NO_SSLv2);
      (CVE-2016-0800)
    * Fix a double-free in DSA code
      (CVE-2016-0705)
    * Disable SRP fake user seed to address a server memory leak.
      Add a new method SRP_VBASE_get1_by_user that handles the seed properly.
      (CVE-2016-0798)
    * Fix BN_hex2bn/BN_dec2bn NULL pointer deref/heap corruption
      (CVE-2016-0797)
    * ) Side channel attack on modular exponentiation
      http://cachebleed.info.
      (CVE-2016-0702)
    * ) Change the req app to generate a 2048-bit RSA/DSA key by default,
      if no keysize is specified with default_bits. This fixes an
      omission in an earlier change that changed all RSA/DSA key generation
      apps to use 2048 bits by default.
* Thu Jan 28 2016 vcizek@suse.com
  - update to 1.0.2f (boo#963410)
    * ) DH small subgroups (boo#963413)
      Historically OpenSSL only ever generated DH parameters based on "safe"
      primes. More recently (in version 1.0.2) support was provided for
      generating X9.42 style parameter files such as those required for RFC 5114
      support. The primes used in such files may not be "safe". Where an
      application is using DH configured with parameters based on primes that are
      not "safe" then an attacker could use this fact to find a peer's private
      DH exponent. This attack requires that the attacker complete multiple
      handshakes in which the peer uses the same private DH exponent. For example
      this could be used to discover a TLS server's private DH exponent if it's
      reusing the private DH exponent or it's using a static DH ciphersuite.
      (CVE-2016-0701)
    * ) SSLv2 doesn't block disabled ciphers (boo#963415)
      A malicious client can negotiate SSLv2 ciphers that have been disabled on
      the server and complete SSLv2 handshakes even if all SSLv2 ciphers have
      been disabled, provided that the SSLv2 protocol was not also disabled via
      SSL_OP_NO_SSLv2.
      (CVE-2015-3197)
    * ) Reject DH handshakes with parameters shorter than 1024 bits.
* Fri Dec 04 2015 vcizek@suse.com
  - update to 1.0.2e
    * fixes five security vulnerabilities
    * Anon DH ServerKeyExchange with 0 p parameter
      (CVE-2015-1794) (bsc#957984)
    * BN_mod_exp may produce incorrect results on x86_64
      (CVE-2015-3193) (bsc#957814)
    * Certificate verify crash with missing PSS parameter
      (CVE-2015-3194) (bsc#957815)
    * X509_ATTRIBUTE memory leak
      (CVE-2015-3195) (bsc#957812)
    * Race condition handling PSK identify hint
      (CVE-2015-3196) (bsc#957813)
  - pulled a refreshed fips patch from Fedora
    * openssl-1.0.2a-fips.patch was replaced by
      openssl-1.0.2e-fips.patch
  - refresh openssl-ocloexec.patch
* Thu Jul 09 2015 vcizek@suse.com
  - update to 1.0.2d
    * fixes CVE-2015-1793 (bsc#936746)
    Alternate chains certificate forgery
      During certificate verfification, OpenSSL will attempt to find an
      alternative certificate chain if the first attempt to build such a chain
      fails. An error in the implementation of this logic can mean that an
      attacker could cause certain checks on untrusted certificates to be
      bypassed, such as the CA flag, enabling them to use a valid leaf
      certificate to act as a CA and "issue" an invalid certificate.
  - drop openssl-fix_invalid_manpage_name.patch (upstream)
* Thu Jul 02 2015 dvaleev@suse.com
  - Workaround debugit crash on ppc64le with gcc5
    bsc936563_hack.patch (bsc#936563)
* Wed Jul 01 2015 normand@linux.vnet.ibm.com
  - update merge_from_0.9.8k.patch replacing __LP64__ by __LP64
    this is a change versus previous request 309611
    required to avoid build error for ppc64
* Fri Jun 26 2015 crrodriguez@opensuse.org
  - Build with no-ssl3, for details on why this is needed read
    rfc7568. Contrary to the "no-ssl2" option, this does not
    require us to patch dependant packages as the relevant
    functions are still available (SSLv3_(client|server)_method)
    but will fail to negotiate. if removing SSL3 methods is desired
    at a later time, option "no-ssl3-method" needs to be used.
* Fri Jun 12 2015 vcizek@suse.com
  - update to 1.0.2c
    * Fix HMAC ABI incompatibility
  - refreshed openssl-1.0.2a-fips.patch
* Thu Jun 11 2015 vcizek@suse.com
  - update to 1.0.2b
    * Malformed ECParameters causes infinite loop (CVE-2015-1788)
    * Exploitable out-of-bounds read in X509_cmp_time (CVE-2015-1789)
    * PKCS7 crash with missing EnvelopedContent (CVE-2015-1790)
    * CMS verify infinite loop with unknown hash function (CVE-2015-1792)
    * Race condition handling NewSessionTicket (CVE-2015-1791)
  - refreshed patches:
    * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
    * 0001-libcrypto-Hide-library-private-symbols.patch
    * openssl-1.0.2a-default-paths.patch
    * openssl-1.0.2a-fips.patch
    * compression_methods_switch.patch
    * openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
* Sun May 24 2015 vcizek@suse.com
  - update to 1.0.2a
    * Major changes since 1.0.1:
    - Suite B support for TLS 1.2 and DTLS 1.2
    - Support for DTLS 1.2
    - TLS automatic EC curve selection.
    - API to set TLS supported signature algorithms and curves
    - SSL_CONF configuration API.
    - TLS Brainpool support.
    - ALPN support.
    - CMS support for RSA-PSS, RSA-OAEP, ECDH and X9.42 DH.
  - packaging changes:
    * merged patches modifying CIPHER_LIST into one, dropping:
    - openssl-1.0.1e-add-suse-default-cipher-header.patch
    - openssl-libssl-noweakciphers.patch
    * fix a manpage with invalid name
    - added openssl-fix_invalid_manpage_name.patch
    * remove a missing fips function
    - openssl-missing_FIPS_ec_group_new_by_curve_name.patch
    * reimported patches from Fedora
      dropped patches:
    - openssl-1.0.1c-default-paths.patch
    - openssl-1.0.1c-ipv6-apps.patch
    - openssl-1.0.1e-fips-ctor.patch
    - openssl-1.0.1e-fips-ec.patch
    - openssl-1.0.1e-fips.patch
    - openssl-1.0.1e-new-fips-reqs.patch
    - VIA_padlock_support_on_64systems.patch
      added patches:
    - openssl-1.0.2a-default-paths.patch
    - openssl-1.0.2a-fips-ctor.patch
    - openssl-1.0.2a-fips-ec.patch
    - openssl-1.0.2a-fips.patch
    - openssl-1.0.2a-ipv6-apps.patch
    - openssl-1.0.2a-new-fips-reqs.patch
    - openssl-1.0.2a-padlock64.patch
    * dropped security fixes (upstream)
    - openssl-CVE-2015-0209.patch
    - openssl-CVE-2015-0286.patch
    - openssl-CVE-2015-0287.patch
    - openssl-CVE-2015-0288.patch
    - openssl-CVE-2015-0289.patch
    - openssl-CVE-2015-0293.patch
    * upstream reformatted the sources, so all the patches have to
      be refreshed
* Thu Mar 19 2015 vcizek@suse.com
  - security update:
    * CVE-2015-0209 (bnc#919648)
    - Fix a failure to NULL a pointer freed on error
    * CVE-2015-0286 (bnc#922496)
    - Segmentation fault in ASN1_TYPE_cmp
    * CVE-2015-0287 (bnc#922499)
    - ASN.1 structure reuse memory corruption
    * CVE-2015-0288 x509: (bnc#920236)
    - added missing public key is not NULL check
    * CVE-2015-0289 (bnc#922500)
    - PKCS7 NULL pointer dereferences
    * CVE-2015-0293 (bnc#922488)
    - Fix reachable assert in SSLv2 servers
    * added patches:
    openssl-CVE-2015-0209.patch
    openssl-CVE-2015-0286.patch
    openssl-CVE-2015-0287.patch
    openssl-CVE-2015-0288.patch
    openssl-CVE-2015-0289.patch
    openssl-CVE-2015-0293.patch
* Wed Feb 04 2015 meissner@suse.com
  - The DATE stamp moved from crypto/Makefile to crypto/buildinf.h,
    replace it there (bsc#915947)
* Fri Jan 09 2015 meissner@suse.com
  - openssl 1.0.1k release
    bsc#912294 CVE-2014-3571: Fix DTLS segmentation fault in dtls1_get_record.
    bsc#912292 CVE-2015-0206: Fix DTLS memory leak in dtls1_buffer_record.
    bsc#911399 CVE-2014-3569: Fix issue where no-ssl3 configuration sets method to NULL.
    bsc#912015 CVE-2014-3572: Abort handshake if server key exchange
      message is omitted for ephemeral ECDH ciphersuites.
    bsc#912014 CVE-2015-0204: Remove non-export ephemeral RSA code on client and server.
    bsc#912293 CVE-2015-0205: Fixed issue where DH client certificates are accepted without verification.
    bsc#912018 CVE-2014-8275: Fix various certificate fingerprint issues.
    bsc#912296 CVE-2014-3570: Correct Bignum squaring.
    and other bugfixes.
  - openssl.keyring: use Matt Caswells current key.
    pub  2048R/0E604491 2013-04-30
    uid                            Matt Caswell <frodo@baggins.org>
    uid                            Matt Caswell <matt@openssl.org>
    sub  2048R/E3C21B70 2013-04-30
  - openssl-1.0.1e-fips.patch: rediffed
  - openssl-1.0.1i-noec2m-fix.patch: removed (upstream)
  - openssl-ocloexec.patch: rediffed
* Tue Nov 18 2014 brian@aljex.com
  - suse_version 10.1 & 10.2 x86_64 can not enable-ec_nistp_64_gcc_128
* Mon Nov 17 2014 meissner@suse.com
  - openssl-1.0.1i-noec2m-fix.patch: only report the Elliptic Curves
    we actually support (not the binary ones) (bnc#905037)
* Fri Nov 07 2014 brian@aljex.com
  - openSUSE < 11.2 doesn't have accept4()
* Tue Oct 21 2014 crrodriguez@opensuse.org
  - openSSL 1.0.1j
    * Fix SRTP Memory Leak (CVE-2014-3513)
    * Session Ticket Memory Leak (CVE-2014-3567)
    * Add SSL 3.0 Fallback protection (TLS_FALLBACK_SCSV)
    * Build option no-ssl3 is incomplete (CVE-2014-3568)

Files

/usr/share/doc/packages/openssl
/usr/share/doc/packages/openssl/README.SUSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Oct 9 18:33:21 2021