Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libqca-qt5-32bit-2.1.3-lp150.2.8 RPM for x86_64

From OpenSuSE Leap 15.0 for x86_64

Name: libqca-qt5-32bit Distribution: openSUSE Leap 15.0
Version: 2.1.3 Vendor: openSUSE
Release: lp150.2.8 Build date: Wed Dec 27 13:00:00 2017
Group: Development/Libraries/C and C++ Build host: cloud124
Size: 1941280 Source RPM: libqca-qt5-2.1.3-lp150.2.8.src.rpm
Packager: https://bugs.opensuse.org
Url: https://userbase.kde.org/QCA
Summary: Qt Cryptographic Architecture 2
This package provides a generic Qt cryptographic architecture,
including a library and a plug-in for using all supported capabilities
of openssl, like SSL/TLS, X509, RSA, SHA1, MD5, Blowfish, 3DES, and
AES.

It can be extended by further plug-ins, for example, with qca-sasl for
SASL support.

Provides

Requires

License

LGPL-2.1+

Changelog

* Wed Dec 27 2017 jengelh@inai.de
  - Diversify subpackage descriptions.
* Wed Dec 20 2017 fabian@ritter-vogt.de
  - Add patches to support OpenSSL 1.1.0:
    * 0001-Revert-tlsunittest-disable-some-ciphers.patch
    * 0002-Disable-missed-openssl-cipher-suites.patch
    * 0003-Add-support-for-OpenSSL-1.1.0.patch
  - Fix provides in main package
* Thu Oct 19 2017 meissner@suse.com
  - buildignore openssl-1_0_0 to avoid conflicts during the
    openssl 1.1 effort.
* Mon Oct 09 2017 vcizek@suse.com
  - Hardcode certstore path on Tumbleweed, in order to avoid
    BuildRequires: ca-certificates, which will create a conflict,
    because it requires openssl-1_1_0 (bsc#1055310)
* Sun Oct 01 2017 wbauer@tmo.at
  - Update to 2.1.3
    * No changelog provided
  - Drop libqca-qt5-2.1.1-explicit-signed-char.patch, merged upstream
  - Update Url
* Fri Sep 29 2017 wbauer@tmo.at
  - Remove libbotan-devel build requirement, we explicitly disable
    building the botan plugin anyway (boo#1055322)
* Fri Aug 25 2017 fvogt@suse.com
  - Force building against openSSL 1.0 (boo#1055310)
  - Disable PKCS11 on TW to avoid openssl conflicts
* Wed May 25 2016 antoine.belvire@laposte.net
  - Fix build on PowerPC with GCC 6:
    * Add libqca-qt5-2.1.1-explicit-signed-char.patch
* Sat Oct 03 2015 hrvoje.senjan@gmail.com
  - Update to 2.1.1
    * No changelog provided
  - Drop Use-Q_SLOTS-Q_SIGNALS.patch and 0001-Add-missing-QIODevice-include.patch
* Sat Sep 26 2015 hrvoje.senjan@gmail.com
  - Added Use-Q_SLOTS-Q_SIGNALS.patch from upstream: allow building
    without QT_NO_KEYWORDS define
* Sat Jan 10 2015 hrvoje.senjan@gmail.com
  - Update to 2.1.0.3
    * Allow co-installability with Qt4 build
  - Remove conflict with libqca2-devel
  - Bump required cmake version to 2.8.12
  - Added ansi.diff, rh#1182200
  - Added 0001-Add-missing-QIODevice-include.patch, fixes build with
    Qt 5.5
* Sat Nov 08 2014 hrvoje.senjan@gmail.com
  - Update to 2.1.0
    * Ported to Qt5 (Qt4 alsa supported)
    * New building system. CMake instead of qmake
    * Added CTR symetric cipher support to qca core
    * Added no padding encryption algorithm to qca core
    * qcatool2 renamed to qcatool
    * fixed crash in qcatool when only options provided on command
      line without any commands
    * Use plugins installation path as hard-coded runtime plugins
      search path
    * Added new functiion pluginPaths
    * Added functions to get runtime QCA version
    * Fixed 'no watch file' warnings in FileWatch
    * Added EME_PKCS1v15_SSL Encryption Algorithm
    * New implementation of SafeTimer to prevent crashes
    * Updated certificates for unittests
    * RSA Keys are permutable, can encrypt with private
      and decrypt with public
    * Add unloadProvider() function for symmetry
      with insertProvider()
    * Overloaded "makeKey" to derive a password depending
      on a time factor
    * Remove pointer to deinit() routine from QCoreApplication
      at deinitialization
    * Fix a couple of crashes where all plugins
      might not be available
    * Fix operating on keys with unrelated expired subkeys
    * Fixed timers in Synchronizer class
    * Dropped randomunittest
    * Fixed many unittests
    * qca-gnupg: internal refactoring
    * qca-gnupg: try both gpg and gpg2 to find gnupg executable
    * qca-gnupg: fixed some encodings problem
    * qca-ossl: no DSA_* dl groups in FIPS specification
    * qca-ossl: added missed signatures to CRLContext
    * qca-ossl: fixed certs time zone
    * qca-nss: fixed KeyLenght for Cipher
    * qca-botan: fixed getting result size for ciphers
* Thu Aug 14 2014 hrvoje.senjan@gmail.com
  - Activate libqca-qt5 package

Files

/usr/lib/libqca-qt5.so.2
/usr/lib/libqca-qt5.so.2.1.3
/usr/lib/qt5
/usr/lib/qt5/plugins
/usr/lib/qt5/plugins/crypto
/usr/lib/qt5/plugins/crypto/libqca-gcrypt.so
/usr/lib/qt5/plugins/crypto/libqca-gnupg.so
/usr/lib/qt5/plugins/crypto/libqca-logger.so
/usr/lib/qt5/plugins/crypto/libqca-ossl.so
/usr/lib/qt5/plugins/crypto/libqca-softstore.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Apr 9 10:08:57 2022