Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python2-ipaddr-2.1.11-lp150.1.3 RPM for noarch

From OpenSuSE Leap 15.0 for noarch

Name: python2-ipaddr Distribution: openSUSE Leap 15.0
Version: 2.1.11 Vendor: openSUSE
Release: lp150.1.3 Build date: Thu Aug 31 14:00:00 2017
Group: Development/Languages/Python Build host: lamb16
Size: 198350 Source RPM: python-ipaddr-2.1.11-lp150.1.3.src.rpm
Packager: https://bugs.opensuse.org
Url: http://code.google.com/p/ipaddr-py/
Summary: Google's IP address manipulation library
Google's IP address manipulation library. An IPv4/IPv6 manipulation library
in Python. This library is used to create/poke/manipulate IPv4 and IPv6
addresses and prefixes.

Provides

Requires

License

Apache-2.0

Changelog

* Thu Aug 31 2017 toddrme2178@gmail.com
  - Add use_2to3.patch
    * Allows setup.py to automatically convert code with 2to3 instead
      of having to do it manually.
* Thu Aug 24 2017 jmatejek@suse.com
  - singlespec auto-conversion
* Wed Mar 25 2015 klaussfreire@gmail.com
  Update to upstream ipaddr 2.1.11
  - hostmask parsing bug fixed by pmarks (a nearly complete rewrite of the mask parsing code)
  - i97, incorrectly parses some v6 addresses.
  - docstring typos.
  - i95, refer to the nets in the exception raised by collapse_address_list
  - add license to boilerplate to test-2to3.sh
* Thu Oct 24 2013 speilicke@suse.com
  - Require python-setuptools instead of distribute (upstreams merged)
* Sun Jan 22 2012 klaussfreire@gmail.com
  Update to upstream ipaddr 2.1.10
  - i84, fix iterhosts for /31's or /127's
  - private method arg cleanup.
  - i83, docstring issue.
  - i87, new ipv4/ipv6 parser. patch from pmarks
  - i90, fix copyright.
  - bytes fix. patch from pmarks.-
* Wed Nov 16 2011 klaussfreire@users.sourceforge.net
  - Fix license file to have proper attribution
    (upstream issue 90)
* Thu Sep 22 2011 saschpe@suse.de
  - Re-generated spec file with py2pack
  - Run testsuite (using python-nose)
  - Fix non-executable script rpmlint warning
* Fri Jul 08 2011 klaussfreire@users.sourceforge.net
  - Initial package, upstream ipaddr 2.1.9

Files

/usr/lib/python2.7/site-packages/ipaddr-2.1.11-py2.7.egg-info
/usr/lib/python2.7/site-packages/ipaddr-2.1.11-py2.7.egg-info/PKG-INFO
/usr/lib/python2.7/site-packages/ipaddr-2.1.11-py2.7.egg-info/SOURCES.txt
/usr/lib/python2.7/site-packages/ipaddr-2.1.11-py2.7.egg-info/dependency_links.txt
/usr/lib/python2.7/site-packages/ipaddr-2.1.11-py2.7.egg-info/top_level.txt
/usr/lib/python2.7/site-packages/ipaddr.py
/usr/lib/python2.7/site-packages/ipaddr.pyc
/usr/lib/python2.7/site-packages/ipaddr.pyo
/usr/share/doc/packages/python2-ipaddr
/usr/share/doc/packages/python2-ipaddr/COPYING
/usr/share/doc/packages/python2-ipaddr/README
/usr/share/doc/packages/python2-ipaddr/RELEASENOTES


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Jan 9 11:23:14 2022