Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python3-dbm-3.4.6-10.3.1 RPM for ppc64le

From OpenSuSE 42.2 updates for ppc64le

Name: python3-dbm Distribution: openSUSE Leap 42.2
Version: 3.4.6 Vendor: openSUSE
Release: 10.3.1 Build date: Thu May 18 16:25:06 2017
Group: Development/Languages/Python Build host: obs-power8-02
Size: 170352 Source RPM: python3-3.4.6-10.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.python.org/
Summary: Python Interface to the GDBM Library
An easy to use interface for Unix DBM databases, and more specifically,
the GNU implementation GDBM.

Provides

Requires

License

Python-2.0

Changelog

* Wed Mar 01 2017 jmatejek@suse.com
  - update to 3.4.6 (bsc#1027282):
    * fixed potential crash in PyUnicode_AsDecodedObject() in debug build
    * fixed possible DoS and arbitrary execution in gettext plurals
    * fix possible use of uninitialized memory in operator.methodcaller
    * fix possible Py_DECREF on unowned object in _sre
    * fix possible integer overflow in _csv module
    * prevent HTTPoxy attack (CVE-2016-1000110)
    * fix selectors incorrectly retaining invalid fds
  - drop upstreamed python-3.4-CVE-2016-1000110-fix.patch
  - move _elementtree to python3.rpm to match its pyexpat dependency
    (bsc#1029377)
* Mon Aug 08 2016 jmatejek@suse.com
  - rename rpmlintrc to python3-rpmlintrc (applied change from 13.2)
  - drop python-fix-short-dh.patch and dh2048.pem, this is now fixed
    upstream
  - drop disabled libffi-ppc64le.diff completely
  - reverse order of lowercase-proxies and HTTPoxy patches in order
    to fix documented behavior
  - drop upstreamed werror-declaration-after-statement.patch
* Sun Aug 07 2016 hpj@urpla.net
  - fix python3-urllib-prefer-lowercase-proxies.patch
* Sat Aug 06 2016 hpj@urpla.net
  - apply fix for CVE-2016-1000110 - CGIHandler: sets environmental
    variable based on user supplied Proxy request header:
    python-3.4-CVE-2016-1000110-fix.patch
    (fixes bsc#989523, CVE-2016-1000110)
  - refresh python3-urllib-prefer-lowercase-proxies.patch
* Sun Jul 03 2016 hpj@urpla.net
  - update to 3.4.5
    check: https://docs.python.org/3.4/whatsnew/changelog.html
    (fixes bsc#984751, CVE-2016-0772)
    (fixes bsc#985177, CVE-2016-5636)
    (fixes bsc#985348, CVE-2016-5699)
* Wed Jun 15 2016 hpj@urpla.net
  - apply upstream patch python3-urllib-prefer-lowercase-proxies.patch
    in order to make urllib proxy var handling behave as usual on POSIX
* Tue Jun 14 2016 hpj@urpla.net
  - Due to being fixed upstream (differently), removed outdated patch
    CVE-2014-4650-CGIHTTPServer-traversal.patch (bsc#983582)
* Sat May 07 2016 hpj@urpla.net
  - update to 3.4.4
    check: https://docs.python.org/3.4/whatsnew/changelog.html
  - all necessary patches refreshed
  - adjusted Python-3.3.0b2-multilib.patch
  - disabled libffi-ppc64le.diff: horribly deviated
  - fix a new multilib issue in configure.ac with $LIBPL
  - add new tests, that require ssl
* Thu Jul 31 2014 dimstar@opensuse.org
  - Rename rpmlintrc to %{name}-rpmlintrc.
    Follow the packaging guidelines.
* Fri May 23 2014 jmatejek@suse.com
  - update to 3.4.1
    * * bugfix-only release, over 300 bugs fixed
  - upgrade pip to Recommends (it seems to be a stronger hint)
  - move ensurepip here, because it requires ssl through pip
  - python-3.4.1-SUSE-ensurepip.patch: make ensurepip require
    python3-pip from separate package
  - Suggests every subpackage that is part of stdlib
* Mon Mar 17 2014 jmatejek@suse.com
  - update to 3.4.0 final
  - lower pip requirement to Suggests, to prevent build cycles
* Fri Mar 14 2014 andreas.stieger@gmx.de
  - Fix build with SQLite 3.8.4 [bnc#867887], fixing SQLite tests,
    adding python-2.7.6-sqlite-3.8.4-tests.patch
* Thu Feb 27 2014 jmatejek@suse.com
  - update to 3.4.0 rc2
    * for full changelog, see python3-base
  - hard Require for python3-pip, see what happens
* Tue Jan 21 2014 jmatejek@suse.com
  - initial commit of 3.4.0 beta 3
    * for full changelog, see python3-base
  - modify script shebangs in common %prep
* Tue Nov 19 2013 jmatejek@suse.com
  - update to 3.3.3
  - move example module xxlimited to python3-testsuite
  - drop CVE-2013-4238_py33.patch - it is upstreamed
* Tue Oct 15 2013 crrodriguez@opensuse.org
  - build with -DOPENSSL_LOAD_CONF for the same reasons
    described in the python2 package.
* Fri Aug 16 2013 jmatejek@suse.com
  - handle NULL bytes in certain fields of SSL certificates
    (CVE-2013-4238, bnc#834601)
* Thu Jun 13 2013 jmatejek@suse.com
  - update to 3.3.2
  - switch to xz compression
  - move _lzma module to python3-base
* Mon Apr 29 2013 schwab@suse.de
  - Readd missing bits from ctypes-libffi-aarch64.patch
* Sat Apr 13 2013 idonmez@suse.com
  - Update to version 3.3.1
    * Fix the –enable-profiling configure switch.
    * In IDLE, close the replace dialog after it is used.
  - Too many bugfixes to list here,
    see See http://hg.python.org/cpython/file/v3.3.0/Misc/NEWS
  - Refresh Python-3.3.0b2-multilib.patch
  - Refresh python-3.2b2-buildtime-generate.patch
  - Drop upstream patches: ctypes-libffi-aarch64.patch,
    python-3.2.3rc2-pypirc-secure.patch, python-3.3.0-getdents64.patch
* Mon Apr 08 2013 speilicke@suse.com
  - Exclude sqlite/test and tk/test directories from the respective
    sub-packages. These are owned by the testsuite sub-package already
* Fri Apr 05 2013 idonmez@suse.com
  - Add Source URL, see https://en.opensuse.org/SourceUrls
* Mon Oct 29 2012 dmueller@suse.com
  - disable more checks for qemu builds as they use syscalls not
    implemented yet
* Mon Oct 01 2012 idonmez@suse.com
  - Update to final 3.3.0 release
    * See http://hg.python.org/cpython/file/v3.3.0/Misc/NEWS
* Mon Aug 27 2012 jmatejek@suse.com
  - update to 3.3.0 RC1
  - added Provides for %{python_version}, we'll see whether that
    breaks everything
* Fri Aug 03 2012 jmatejek@suse.com
  - update to 3.3.0 beta 1
* Fri Jul 27 2012 dvaleev@suse.com
  - drop test_io ppc patch... we run only selective tests here
* Tue Jun 12 2012 adrian@suse.de
  - fix logic of checks exclusion
* Sun Dec 25 2011 idonmez@suse.com
  - Use system ffi, included one is broken see
    http://bugs.python.org/issue11729 and
    http://bugs.python.org/issue12081
* Fri Dec 09 2011 jmatejek@suse.com
  - license.opensuse.org-compatible license headers
* Fri Dec 02 2011 coolo@suse.com
  - add automake as buildrequire to avoid implicit dependency
* Fri Sep 02 2011 coolo@suse.com
  - fix baselibs.conf
* Mon Jul 18 2011 jmatejek@novell.com
  - update to 3.2.1
  - fix build on linux3
* Fri May 13 2011 jmatejek@novell.com
  - updated to build --with-wide-unicode (for compatibility with
    fedora and our own python 2.x series)
* Wed Mar 23 2011 termim@gmail.com
  - update to 3.2
* Tue Feb 08 2011 matejcik@suse.cz
  - update to 3.2 RC2
* Wed Jan 19 2011 jmatejek@novell.com
  - update to 3.2 beta 2 and other tales
* Fri Jan 14 2011 coolo@novell.com
  - update to 3.1.3
    * tons of bug fixes from 3.1 branch
* Mon Nov 15 2010 coolo@novell.com
  - update to 3.1.2
    * new stable release from 3.1 branch
  - add svn patch to fix zlib test case
* Sat Jan 23 2010 jengelh@medozas.de
  - package baselibs.conf
* Tue Nov 03 2009 coolo@novell.com
  - updated patches to apply with fuzz=0
* Tue Sep 08 2009 max@suse.de
  - removed blt from BuildRequires so that it can be dropped.
* Thu Aug 06 2009 matejcik@suse.cz
  - update to 3.1
    * new version, much improved over the shakedown 3.0 series
* Thu Jul 16 2009 coolo@novell.com
  - disable as-needed to fix build

Files

/usr/lib64/python3.4/dbm
/usr/lib64/python3.4/dbm/__init__.py
/usr/lib64/python3.4/dbm/__pycache__
/usr/lib64/python3.4/dbm/__pycache__/__init__.cpython-34.pyc
/usr/lib64/python3.4/dbm/__pycache__/__init__.cpython-34.pyo
/usr/lib64/python3.4/dbm/__pycache__/dumb.cpython-34.pyc
/usr/lib64/python3.4/dbm/__pycache__/dumb.cpython-34.pyo
/usr/lib64/python3.4/dbm/__pycache__/gnu.cpython-34.pyc
/usr/lib64/python3.4/dbm/__pycache__/gnu.cpython-34.pyo
/usr/lib64/python3.4/dbm/__pycache__/ndbm.cpython-34.pyc
/usr/lib64/python3.4/dbm/__pycache__/ndbm.cpython-34.pyo
/usr/lib64/python3.4/dbm/dumb.py
/usr/lib64/python3.4/dbm/gnu.py
/usr/lib64/python3.4/dbm/ndbm.py
/usr/lib64/python3.4/lib-dynload/_dbm.cpython-34m.so
/usr/lib64/python3.4/lib-dynload/_gdbm.cpython-34m.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Thu Dec 13 03:51:40 2018