Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

graphviz-gnome-2.38.0-4.5.2 RPM for aarch64

From OpenSuSE 42.2 updates for aarch64

Name: graphviz-gnome Distribution: openSUSE Leap 42.2
Version: 2.38.0 Vendor: openSUSE
Release: 4.5.2 Build date: Mon Nov 27 19:45:19 2017
Group: Productivity/Graphics/Visualization/Graph Build host: obs-arm-1
Size: 278568 Source RPM: graphviz-plugins-2.38.0-4.5.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.graphviz.org/
Summary: Graphviz plugins that use gtk/GNOME
Graphviz plugins that use gtk/GNOME.

Provides

Requires

License

EPL-1.0

Changelog

* Fri Nov 24 2017 pth@suse.de
  - Add graphviz-fix_format_string_vulnerability.patch to fix CVE-2014-9157
    (bsc#908426).
* Mon May 23 2016 olaf@aepfle.de
  - Disable ocaml plugins, not ready for upstream ocaml (fate#320836)
* Mon Jun 15 2015 schwab@suse.de
  - Enable ocaml and java plugins on aarch64
* Wed Jun 10 2015 mpluskal@suse.com
  - Update gnome dependencies
* Fri Apr 17 2015 stefan.bruens@rwth-aachen.de
  - Cleanup spec:
    * remove duplicate language binding files
    * fix fdupes invocation for doc files
    * remove statements without effect
    * silence warning messages on plugin deinstallation
    * fix %post/%pre Requires
* Thu Mar 19 2015 dvlaeev@suse.com
  - Disable Mono by default
* Mon Sep 08 2014 coolo@suse.com
  - remove conflict with lua 5.2, seems outdated
* Thu Jul 17 2014 pth@suse.de
  - Change License to EPL-1.0.
* Tue Jul 15 2014 toddrme2178@gmail.com
  - Require gd-devel instead of libgd-devel.  That is the current
    name for the package.
  - Remove upstream-included patch graphviz-ppc64le_lib64_support.patch
* Wed Jun 18 2014 pth@suse.de
  - Apply patch from darix to ask ruby for directories.
  - Fix install path for tcl plugins.
  - Fix file list for gnome plugins.
  - Remove graphviz-plugins-tcl_install_dir.patch as it's not needed
    anymore.
  - Remove graphviz-getaddrinfo.patch as the patch is upstream.
* Tue Jun 17 2014 mrueckert@suse.de
  - instead of guessing the ruby paths. let's just use the existing
    variables or at least ask ruby for it.
* Fri May 23 2014 pth@suse.de
  - Fix URL to point to the new location of the sources.
* Fri May 23 2014 pth@suse.de
  - Update to 2.38.0. Changes since 1.35.0:
    - Resolve bugs: 2409, 2413, 2417, 2420, 2422, 2423, 2425
    - Enable packing for dot
    - Allow scaling to work for all non-dot layouts
    - Add overline text characteristic.
    - Fix bugs in gvpr and gv.cpp so edges can be created in subgraphs.
    - Add edgepaint program for coloring edges to make them easier to
      tell apart.
    - Modify neato to avoid unnecessary translations of output. This
      allows positions given on input to remain the same on output.
    - Fix swig java package to work and support gv.renderresult.
    - Fix test for the absence of layout (old test relied on statically
      allocated Agraphinfo_t).
    - HTML-like tables and cells can now specify which borders should be drawn.
    - The fixedsize attribute now takes the value "shape" which allows
      labels much larger than the node shape.
  - Remove graphviz-fix-includes.patch as the fix has been done
    upstream.
  - Add graphviz-array_overflow.patch to fix an off-by-one error.
* Sat Feb 08 2014 pth@suse.de
  - Remove non-existing patch from spec.
* Tue Feb 04 2014 pth@suse.de
  - Change license to EPL-1.0. Remove contrib/gprof2dot.awk as it
    contains a non-working uri.
* Sat Feb 01 2014 coolo@suse.com
  - use the right ruby macro
* Sat Jan 18 2014 coolo@suse.com
  - fix mono bcond. It's without, not !with
* Sat Jan 18 2014 coolo@suse.com
  - use global java bcond instead of an own now that it buildrequires
    jdk and no longer gcc
* Tue Jan 14 2014 dvlaeev@suse.com
  - Don't build C# binding without mono. Otherwise we get unpackaged
    files.
* Sat Jan 11 2014 coolo@suse.com
  - remove unneeded ksh dependency
* Fri Dec 06 2013 matz@suse.de
  - Add powerpc64le to list of lib64 platforms
    (graphviz-ppc64le_lib64_support.patch).
* Mon Oct 14 2013 pth@suse.de
  - Use wildcards for specifying tcl directory.
* Thu Oct 10 2013 pth@suse.de
  - Change BuildRequires for Java so that the spec doesn't need
    to be modified for newer jdk versions.
* Tue Oct 08 2013 pth@suse.de
  - Don't apply graphviz-fix-pkgIndex.patch twice.
  - Remove Buildrequires for libqt4-devel.
* Thu Sep 12 2013 pth@suse.de
  - Add graphviz-python3_version.patch that put the call to print in
    Parentheses.
* Mon Sep 09 2013 pth@suse.de
  - Update to 2.34.0 (see changes for graphviz),
  - Remove patches accepted upstream:
    graphviz-missing_headers.patch, graphviz-aarch64_lib64_support.patch,
    graphviz-type_punning.patch, graphviz-buffer_overflow.patch,
    graphviz-proper_prototypes.patch, graphviz-python_version.patch,
    graphviz-guile.patch, graphviz-java_in_lib64.patch
  - Add graphviz-type_punning.patch which compiles the vmalloc sources
    with -fno-strict-aliasing.
* Thu Sep 05 2013 pth@suse.de
  - Update to 2.32.0. Changes since 2.28.0:
    2.32.0:
    - New version of xdot format, annotating gradient color schemes
    - Support for reading pdf images using poppler
    - Lefty/dotty/lneato now accept anonymous graphs
    - Add star node shape
    - Add two-tone (non-gradient) fill
    2.30.1:
    - various build fixes
    2.30.0:
    - Replaced libgraph with libcgraph; use of libgraph is now deprecated
    - New ranking algorithm that allows multiple subgraph constraints
    - Support edges using curved arcs.
    - Added new shapes used by the synthetic biology community.
    - For HTML-like labels, provide rounded cells, and dashed or dotted borders.
    - Add lcurve and rcurve arrowheads.
    - Add prototype pie chart and striped fills.
    - Support insets in treemaps to make containment clear
    - Add random rooted tree generation to gvgen
    - Allow GVPRPATH to specify that the default path be prepended or
      appended to it.
    - Support arbitrary lists of layers; allow the user to specify arbitrary
      layers for output.
    - A collection of gvpr scripts, which were part of the source package,
      are now installed in <prefix>/share/graphviz/gvpr, and the that path
      is used as part of th default built-in path for gvpr.
    - Update libexpr to reflect Glenn Fowler's changes including scopes for
      variables.
    - Add next graph variable to gvpr
    - Modify dot and fdp so that a cluster's margin attribute will affect
      the space between the bounding box and nodes
    - Modify the dijkstra tool to use only directed edges
    - Output numbers without quotes if quotes are not needed on input
    - Support gradient fill
    - Provide support for webp images
    - Fix tapered edges to use the dir attribute and arrowhead
    - Add imagepath attribute
    - Add help functionality to Graphviz.app
    - Add <B>,<I>,<U> to html strings via svg
    - Add tapered edges
    - Add support for external labels
    - Add initial implementation of graphml2gv
    - Add basic horizontal and vertical rules to html tables
  - Remove graphviz-gd_png_check_sig.patch as the file to patch doesn't
    exist anymore.
  - Add graphviz-buffer_overflow.patch to fix a buffer ovderflow in
    lib/common/shapes.c(round_corners) by increasing the number of
    elements in the array.
  - Add graphviz-proper_prototypes.patch that changes dthdr.h to
    include ast_common.h to get __STD_C defined, which in turn
    enables proper prototypes.
  - Run autoreconf to use -fno-strict-aliasing for libvmalloc sources
  - Remove graphviz-2.18-do_not_use_ocamlopt.patch as it's not needed
    anymore.
  - Adapt graphviz-guile.patch, graphviz-plugins-fix_install_dirs.patch
    and graphviz-python_version.patch to the new sources.
  - Add graphviz-java_in_lib64.patch to search in /usr/lib64/jvm for
    the java headers on platforms using lib64.
  - Add graphviz-proper_use_of_qw.patch to put the use of qw in
    config/config_perl.pl in brackets.
  - Add graphviz-useless_warnings.patch to make gcc not warn about
    harmless issues that arise from code generated by swig.
  - Add patch tags in the spec files
  - Upstreamed all patches that aren't SUSE specific.
* Fri May 31 2013 mhrusecky@suse.com
  - use %rb_ver to decide correct ruby version
* Thu Mar 28 2013 pth@suse.de
  - Rename aarch64-lib64-support.diff to graphviz-aarch64_lib64_support.patch.
  - Compile the code in lib/vmalloc with -fno-strict-aliasing
    as it does type punning.
* Sat Mar 16 2013 dmueller@suse.com
  - add build conditionals for java, ocaml and mono (needed for
    aarch64 port for now)
  - add aarch64-lib64-support.diff:
    add aarch64 to the list of lib64 architectures
* Mon Sep 03 2012 pth@suse.de
  - Reinstate the dependency on gtkglext-devel but guarded by an
    'if suse_version > 1220'.
* Mon Sep 03 2012 idonmez@suse.com
  - Remove dependency on gtkglext-devel, package no longer exists
    in openSUSE > 12.2
* Mon Jun 11 2012 coolo@suse.com
  - survive new ruby without autoreconf
* Wed Apr 04 2012 reddwarf@opensuse.org
  - Force lua 5.1 to fix Factory build
* Tue Feb 28 2012 jsmeix@suse.de
  - BuildRequire "ghostscript" instead of outdated "ghostscript-mini"
    (related to Ghostscript package clean-up, see bnc#735824).
* Wed Oct 19 2011 coolo@suse.com
  - /usr/bin/php5 does not exist
* Tue Oct 04 2011 pth@suse.de
  - Rename and prefix patch for uniformity within the package.
* Wed Sep 28 2011 idonmez@suse.com
  - Fix compilation with new guile
  - Update to version 2.28.0
    - incremented library api version:
      libcdt, libgraph, libcgraph, libgvpr, libgvc
    - Add gvmap, cluster and gvmap.sh
    - Deprecate dotty; prefer gvedit
    - Add patchwork supporting squarified tree maps
    - Add ordering as a node attribute
    - Fix problems with font resolution
    - Fix problems with text placement
    - Fix twopi to set root attribute
    - Make available layouts and formats available via the API
    - Fix error message system so that an application can capture the messages
    - New attributes and features for sfdp
    - gvgen now allows the user to specify graph name and node name template
    - Make overlap=false denote overlap=prism
    - More efficient xdot library
    - HTML-like labels provide ID
    - Fixed bugs: 1480 1980 2044 2087 2088 2089 2091 2093 2094
      2095 2101 2102 2103 2104 2112 2113 2118 2128 2129 2139 2149
      2157 2113 2159 2160 2161 2163
    - Add scale attribute to twopi
    - Add <B>,<I>,<U> to html strings
    - migrated to 2005 version of cdt
* Fri Mar 11 2011 coolo@novell.com
  - fix conflict with libltdl (http://bugs.gentoo.org/339298)
* Fri Jun 18 2010 pth@suse.de
  - Fix CPPFLAGS for real.
* Tue Jun 15 2010 pth@suse.de
  - Readd AM_CPPFLAGS for libgv_perl.
* Fri Jun 11 2010 pth@suse.de
  - Set rpath for libperl (bnc#612766).
* Wed Jun 02 2010 pth@suse.de
  - Dot requires fonts when using pango for output (bnc#610873).
* Fri May 28 2010 meissner@suse.de
  - remove a powerpc hack for Darwin that failed our PowerPC build.
* Fri Nov 13 2009 dmueller@suse.de
  - require the exact perl version it was build against, otherwise
    libperl.so can not be found
* Wed Aug 26 2009 mls@suse.de
  - make patch0 usage consistent

Files

/usr/lib64/graphviz/libgvplugin_gdk.so
/usr/lib64/graphviz/libgvplugin_gdk.so.6
/usr/lib64/graphviz/libgvplugin_gdk.so.6.0.0
/usr/lib64/graphviz/libgvplugin_gtk.so
/usr/lib64/graphviz/libgvplugin_gtk.so.6
/usr/lib64/graphviz/libgvplugin_gtk.so.6.0.0
/usr/lib64/graphviz/libgvplugin_pango.so
/usr/lib64/graphviz/libgvplugin_pango.so.6
/usr/lib64/graphviz/libgvplugin_pango.so.6.0.0
/usr/lib64/graphviz/libgvplugin_xlib.so
/usr/lib64/graphviz/libgvplugin_xlib.so.6
/usr/lib64/graphviz/libgvplugin_xlib.so.6.0.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Oct 10 02:41:35 2018