Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gimp-help-browser-2.8.0-3.9.1 RPM for x86_64

From OpenSuSE 12.2 updates for x86_64

Name: gimp-help-browser Distribution: openSUSE 12.2
Version: 2.8.0 Vendor: openSUSE
Release: 3.9.1 Build date: Wed Nov 28 09:50:35 2012
Group: Productivity/Graphics/Bitmap Editors Build host: build13
Size: 3184129 Source RPM: gimp-2.8.0-3.9.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.gimp.org/
Summary: The GNU Image Manipulation Program - Help Browser
This package contains the help browser for the GIMP.

Provides

Requires

License

GPL-3.0+

Changelog

* Tue Nov 27 2012 dimstar@opensuse.org
  - Add gimp-CVE-2012-5576.patch: fix memory corruption vulnerability
    when reading XWD files (bnc#791372, bgo#687392, CVE-2012-5576).
* Wed Aug 29 2012 rlmu@suse.com
  - fixed bnc#724628
    VUL-0: CVE-2012-3481: gimp: GIF plugin 'height' / 'len' integer overflow leading to heap-based buffer overflow
  - fixed bnc#763595
    VUL-0: CVE-2012-2763: gimp: buffer overflow in script-fu's server component
* Mon Jun 25 2012 vuntz@opensuse.org
  - Add gimp-CVE-2012-3236.patch: fix crash in file handling for fit
    files. Fix CVE-2012-3236, bnc#768376.
* Mon May 14 2012 vuntz@opensuse.org
  - Correctly version librsvg-devel BuildRequires: 2.36.0 is needed.
    We don't version the BuildRequires on 12.1 and earlier to avoid
    useless unresolvables; it will just result in file-svg plugin not
    being built when librsvg is not recent enough there.
* Thu May 03 2012 badshah400@gmail.com
  - Update to version 2.8.0:
    + Core: Add gimp's own GimpOperationBrightnessContrast because
      GEGL one is different
    + Plug-ins: Fix some GFig rendering issues
    + Source and build system: Depend on Babl 0.1.10, GEGL 0.2.0
      and some other new library versions.
* Sat Apr 07 2012 vuntz@opensuse.org
  - Update license from GPL-2.0+ to GPL-3.0+, following upstream
    change.
  - Completely drop HAL-related packaging since it is now gone
    upstream:
    + Remove build_hal macro
    + Remove optional hal-devel BuildRequires.
    + Remove optional gimp-module-hal subpackage.
    + Note that we already have a Obsoletes for gimp-module-hal.
  - Add pkgconfig(gudev-1.0) BuildRequires for the new gudev input
    module.
  - Add ghostscript-devel, ghostscript-library, libbz2-devel,
    libjasper-devel, pkgconfig(atk), pkgconfig(xcursor)
    BuildRequires: new dependencies upstream.
    + Note about ghostscript-library: ideally, we'd avoid listing it
      explicitly, but in OBS, ghostscript-mini is preferred by
      default, but it is not enough for gimp.
  - Add explicit pkgconfig(gdk-pixbuf-2.0) BuildRequires so it can be
    versioned.
  - Add explicit libjpeg-devel, xorg-x11-libXpm-devel, zlib-devel
    BuildRequires: they were missing before.
  - Add libxslt-tools BuildRequires (or libxslt-devel on versions of
    openSUSE <= 12.1) to have xsltproc installed.
  - Add fdupes BuildRequires and use %fdupes in %install to avoid
    duplicated files.
  - Change gimp-doc Obsoletes in devel subpackage from <= to < to
    avoid rpmlint warning about self-obsoletion.
* Fri Apr 06 2012 dimstar@opensuse.org
  - Update to 2.8.0-RC1:
    + User Interface:
    - Single-Window Mode
    - Multi-Column Dock Windows
    - More Screen Real Estate For Dockable Dialogs
    - Save And Export
    - Layer Groups
    - Tools Drawn With Cairo
    - On-Canvas Text Editing
    - Keyboard Shortcut Changes
    - Simple Math In Size Entries
    + Tools & Plug-ins:
    - Brush System Improvements
    - Tool Preset Improvements
    - Cage Transform Tool
    - File Plug-Ins
    - For Tablet Users
    - Resource Tagging
    + Miscellaneous:
    - Enhancements to scripting abilities
    - API changes
    + For detailed changes, see NEWS file and
      http://www.gimp.org/release-notes/gimp-2.7.html
* Wed Feb 01 2012 vuntz@opensuse.org
  - Update to version 2.6.12:
    + Bugs fixed: bgo#623045, bgo#627328, bgo#631728, bgo#631885,
      bgo#639203, bgo#640219, bgo#640612, bgo#641259, bgo#646947,
      bgo#652280, bgo#660305.
    + Updated translations.
  - Drop gimp-CVE-2010-4540-and-more.patch: fixed upstream.
  - Drop gimp-CVE-2010-4543.patch: fixed upstream.
  - Drop gimp-fix-linking.patch: fixed upstream.
  - Drop gimp-CVE-2011-2896.patch: fixed upstream.
  - Drop gimp-pyslice-cellspacing-fix.patch: fixed upstream.
  - Drop gimp-poppler-0.18.patch: fixed upstream.
  - Remove call to autoreconf and libtool BuildRequires: they were
    only needed for gimp-fix-linking.patch.
* Fri Oct 21 2011 vuntz@opensuse.org
  - Change gimp-2.0-scanner-plugin Recommends to a Suggests: this
    installs xsane by default, and really, xsane is so horribly
    broken UI-wise that we don't want that.
* Sat Oct 15 2011 coolo@suse.com
  - add libtool as buildrequire to make the spec file more reliable
* Wed Oct 12 2011 vuntz@opensuse.org
  - Add a warning comment about changing the content of the branding
    package, to make our life easier in branding-openSUSE.
* Thu Oct 06 2011 vuntz@opensuse.org
  - Add iso-codes Recommends since the iso-codes data is used at
    runtime, but its presence is not mandatory.
  - Remove explicit gtk2 Requires: the library will get
    automatically added to the list of Requires.
* Tue Sep 20 2011 vuntz@opensuse.org
  - Update gimp-fix-linking.patch: add another missing -lm.
  - Add gimp-poppler-0.18.patch: fix build with poppler 0.17/0.18.
* Fri Sep 09 2011 vuntz@opensuse.org
  - Add gimp-fix-linking.patch: fix linking issue.
  - Add gimp-CVE-2011-2896.patch: Fix heap corruption and buffer
    overflow in LZW code. Fix bnc#711491, CVE-2011-2896.
  - Add gimp-pyslice-cellspacing-fix.patch: fix a crash in the
    pyslice plugin.
  - Add call to autoreconf, needed by gimp-fix-linking.patch.
* Wed Jul 06 2011 vuntz@opensuse.org
  - Change branding-upstream subpackage:
    + Add Requires for gimp since the branding package is useless
      without it.
    + Update summary and description.
    + Make noarch.
  - Change branding Requires in main subpackage to be "= %{version}",
    instead of ">= 2.4", which is wrong.
* Wed Jun 15 2011 vuntz@opensuse.org
  - Fix build on Factory, by not excluding the
    libcontroller-linux-input.so module from the file list of the
    main package when we build without hal. It was only excluded to
    be part of a hal subpackage when there is the hal dependency.
* Sat Jun 11 2011 vuntz@opensuse.org
  - On 12.1 and later, stop building the gimp-module-hal subpackage:
    + we don't want hal anymore on 12.1 and later (see bnc#697016).
      We use a build_hal define to control that behavior.
    + remove hal-devel BuildRequires
    + do not build a gimp-module-hal subpackage anymore
    + add gimp-module-hal Obsoletes for smooth upgrades
* Tue Feb 15 2011 vuntz@opensuse.org
  - Add gimp-CVE-2010-4540-and-more.patch and
    gimp-CVE-2010-4543.patch to fix buffer overflows: CVE-2010-4540,
    CVE-2010-4541, CVE-2010-4542, CVE-2010-4543. Fix bnc#662043.
* Sat Feb 12 2011 vuntz@opensuse.org
  - Call relevant macros in %post/%postun:
    + %desktop_database_post/postun because the package ships at
      least one desktop file.
    + %icon_theme_cache_post/postun because the package ships themed
      icons.
  - Pass %{?no_lang_C} to %find_lang so that english documentation
    can be packaged with the program, and not in the lang subpackage.
* Fri Jan 07 2011 vuntz@opensuse.org
  - Move ownership from various directories from gimp to
    libgimp-2_0-0, to not force external gimp plug-ins/modules/etc.
    to have a gimp BuildRequires for directory ownership.
* Mon Dec 20 2010 vuntz@opensuse.org
  - Split gimp libraries in libgimp-2_0-0 and libgimpui-2_0-0
    subpackages, and add baselibs.conf for those. Fix bnc#660439.
  - Change accordingly the Requires of the devel package, and the
    scriptlets to run ldconfig.
  - Remove explicit glib2-devel and gtk2-devel Requires in devel
    package: they will automatically be added the pkgconfig() way.
  - Move the gimptool-2.0 man page to the devel subpackage, where the
    binary lives.
* Tue Nov 23 2010 aj@suse.de
  - Change lang package Requires to Recommends since it is not
    mandatory at runtime.
* Mon Oct 04 2010 vuntz@opensuse.org
  - Update to version 2.6.11:
    + bgo#631199: Printing and Print preview broken with cairo 1.10
    + Other bugs fixed: bgo#572865, bgo#628893, bgo#623850,
      bgo#624487, bgo#557380, bgo#627009, bgo#626020, bgo#624698,
      bgo#624275.
    + Updated translations.
* Mon Aug 09 2010 vuntz@opensuse.org
  - Add alsa-devel BuildRequires to build the MIDI Input module.
* Tue Aug 03 2010 dimstar@opensuse.org
  - Update to version 2.6.10:
    + bgo#613328: TGA files saved with incorrect header yOrigin data
    + bgo#623290: Save As... does not save Windows Bitmap as default
      in dialog
    + bgo#621363: CMYK decompose broken
    + bgo#595170: brush - color from gradient works wrong in
      greyscale
    + bgo#613838: Error in gimp-hue-saturation PDB call
    + bgo#622608: GIMP crashes when clicking any scroll bar from
      combo boxes
    + bgo#565459: newly opened images are put into the background
  - Changes from version 2.6.9:
    + bgo#612618: Font selection remains visible
    + bgo#620604: Description of "histogram" procedure is slightly
      inaccurate
    + bgo#541586: Tool options not saved/loaded correctly?
    + bgo#614153: Importing PDF files with long titles
    + bgo#599233: Dialog of "Save as BMP" ignores changes which are
      not made with a mouse
    + bgo#610478: Layer preview suddenly stops getting updated
    + bgo#609026: leaks shared memory
    + bgo#609056: Exporting to Alias PIX format fails
      are always in English
    + bgo#607242: GIMP 2.7.0 fails to build against libpng 1.4.0
    + bgo#606372: Saving to .ppm fails on indexed colorspace
    + bgo#604508: gimp-layer-new-from-visible should work from
      updated projection
    + Fix crashes: bgo#600112, bgo#565001, bgo#604820, bgo#603711
    + Other fixes: bgo#622234, bgo#622196, bgo#608188, bgo#605237
    + Updated translations.
  - Drop gimp-new-libpng.patch and gimp-fix-statusbar.patch, both
    came from upstream git and are now included.
* Mon Jun 14 2010 vuntz@opensuse.org
  - Ship the openSUSE palette so that it's available in GIMP.
* Sun May 23 2010 vuntz@opensuse.org
  - Add gimp-fix-statusbar.patch to fix missing widgets in status
    bar. Fix bnc#601712.
* Sun May 23 2010 vuntz@opensuse.org
  - Move the input device module to a specific package, to isolate
    the HAL dependency. Fix bnc#601947.
* Tue Apr 06 2010 vuntz@opensuse.org
  - Add gimp-new-libpng.patch to fix build with newer libpng.
* Fri Dec 11 2009 vuntz@opensuse.org
  - Update to version 2.6.8:
    + bgo#470698 - MapObject cannot modify highlight
    + bgo#593848 - FG color changed to black when FG-BG Editor tab
      created
    + bgo#594651 - layer.scale() raises RuntimeError
    + bgo#594998 - Keyboard shortcuts does not work for first image
      when dock is focused
    + bgo#599765 - F1 key on gimp-tool-align in menu have wrong link
      and it open gimp-tool-move
    + bgo#600484 - Gimp BMP Integer Overflow Vulnerability
    + bgo#600741 - "read_channel_data()" Integer Overflow
      Vulnerability
    + bgo#601891 - gimp_image_get_selection returns None
    + bgo#602761 - plug-in-grid: Parameters Horizontal/Vertical
      Spacing and Horizontal/Vertical Offset are
      reversed.
    + bgo#603995 - PCX plugin doesn't sanitize input to avoid
      allocation overflows.
    + bgo#603998 - PCX: Calculating amount of memory to allocate may
      overflow.
    + bgo#604000 - SGI: sanitize input
    + bgo#604001 - SGI: Calculating amount of memory to allocate may
      overflow.
    + bgo#604002 - SGI: RLE encoded input data may write beyond
      allocated buffers
    + bgo#604004 - SGI: allocate memory consistently
    + bgo#604008 - GBR, PAT: sanitize input data
    + bgo#604078 - Crash when pressing Backspace with Free Select
      Tool
    + Updated translations.
* Mon Oct 26 2009 sbrabec@suse.cz
  - Added support for translation-update-upstream (FATE#301344).
* Fri Sep 04 2009 vuntz@novell.com
  - Change Name in .desktop file to "GIMP", not "The GIMP". The
    project has stopped calling it the GIMP.
* Thu Aug 20 2009 crrodriguez@suse.de
  - add support for versioning external plugins, providing
    rpm macros gimp_abi_version and gimp_api_version
* Wed Aug 19 2009 beineri@opensuse.org
  - Everyone calls it "GIMP" so let us follow that in the application
    start menu, fixes problem with launcher finding it (bnc#508279).
* Fri Aug 14 2009 beineri@opensuse.org
  - Update to version 2.6.7:
    + bgo#591017 - Tablet pan is not working as fast as it should
    + bgo#577581 - Crashes when using any colors tool/function on
      Windows
    + bgo#589667 - GIMP crashes when clicking GEGL Operation on
      Windows
    + bgo#569833 - file-jpeg-save erroneous with small quality
      values
    + bgo#590638 - Changing palettes from list to grid view loses
      "locked to dock" status
    + bgo#589674 - "Send by Email" does not update "Filename"
    + bgo#589674 - "Send by Email" does not update "Filename"
    + bgo#586851 - Transparent BMP files fail to load
    + bgo#589205 - help-browser uses deprecated (and sometimes
      broken) webkit call
    + bgo#582821 - 'Sphere Designer' does not reset correctly...
    + bgo#570353 - first time open of .svg file ignores the
      requested units
    + bgo#555777 - Export to MNG animation fails
    + bgo#577301 - Dithering with transparency is broken for
      "positioned" method
    + bgo#493778 - metadata plug-in crashes on some images
    + bgo#567466 - PNG comment not found if more than 1 tEXt chunks
    + bgo#585665 - Exporting to PSD with a blank text layer creates
      a corrupt file
    + bgo#586316 - Levels tool does not adjust output levels
      correctly if input levels are changed
    + bgo#569661 - Import from PDF throws errors when entering
      resolution in pixels per millimetre
    + bgo#567262 - Black pixels appear in "Spread" filter preview
    + bgo#554658 - Path Dialog: Path preview pics not to see
      constantly
    + bgo#167604 - gimp_gradient_get_color_at() may return
      out-of-bounds values
    + bgo#567393 - Rectangle select tool size shrinks to 0 if size
      is larger than the image and the up or down arrow
      is pressed
    + bgo#587543 - crash when invoking certain actions by keyboard
      shortcut
    + bgo#563029 - Closing maximized image doesn't restore document
      window size
    + bgo#585488 - Perspective transformation on a layer with a mask
      causes crash
    + bgo#586008 - GIMP crashes when right-click canceling a drawing
      action initiated outside layer boundaries
    + bgo#584345 - when printing, the number of copies should be
      reset to 1
    + bgo#557061 - Alpha to Logo
    + bgo#472644 - Rotate with clipping crops the whole layer
    + bgo#577575 - transform tool fills underlying extracted area
      wrongly
    + bgo#555738 - Image display is wrong after undoing canvas size
    + bgo#577024 - help-browser plugin crashes when used with webkit
      1.1.3
    + bgo#555025 - Action GEGL box widgets weirdness
  - Drop gimp-gegl-babl-versions-check.patch: fixed upstream.
* Thu Jul 30 2009 vuntz@novell.com
  - Add a Supplements between gimp and gimp-help to get the
    help-browser package automatically installed.
  - Update descriptions of packages.
* Fri Jul 24 2009 beineri@opensuse.org
  - Split off gnome-help-browser sub-package to save 4MB libwebkit
    dependency on Live-CDs where gimp-help is not included.
  - Only include latest ChangeLog.
* Thu Jun 11 2009 vuntz@novell.com
  - Add gimp-gegl-babl-versions-check.patch to fix the code used to
    check the babl and gegl version. Taken from Fedora/upstream.
* Tue Mar 17 2009 mboman@suse.de
  - Update to version 2.6.6:
    + bgo#571117 - lcms plug-in crashes on broken profile
    + bgo#575154 - changing the help browser preference may not work
    + bgo#573542 - blur plugin: bug in the first line
    + bgo#572403 - gimp-2.6 crashed with SIGSEGV in
      IA__g_object_get()
    + bgo#573695 - 1-bit white background saved as PBM becomes all
      black
    + bgo#573488 - Small bug in Filter>Distorts>Ripple
    + bgo#572156 - top left pixel position/coordinate is not 0,0 but
      1,1
    + bgo#472644 - Rotate with clipping crops the whole layer
    + Translation updates
  - Remove glibc-devel from Requires in -devel package
  - Use py_requires.
  - Remove gimp-enable-gtk-deprecated.patch: unneeded now.

Files

/usr/lib64/gimp/2.0/plug-ins/help-browser
/usr/share/doc/packages/gimp-help-browser
/usr/share/doc/packages/gimp-help-browser/AUTHORS
/usr/share/doc/packages/gimp-help-browser/COPYING
/usr/share/doc/packages/gimp-help-browser/ChangeLog
/usr/share/doc/packages/gimp-help-browser/LICENSE
/usr/share/doc/packages/gimp-help-browser/NEWS
/usr/share/doc/packages/gimp-help-browser/NEWS.pre-2-0
/usr/share/doc/packages/gimp-help-browser/NEWS.pre-2-2
/usr/share/doc/packages/gimp-help-browser/NEWS.pre-2-4
/usr/share/doc/packages/gimp-help-browser/NEWS.pre-2-6
/usr/share/doc/packages/gimp-help-browser/README


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Dec 10 11:47:24 2014