Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

gstreamer-plugins-ugly-32bit-1.22.9-1.1 RPM for x86_64

From OpenSuSE Tumbleweed for x86_64

Name: gstreamer-plugins-ugly-32bit Distribution: openSUSE Tumbleweed
Version: 1.22.9 Vendor: openSUSE
Release: 1.1 Build date: Sat Feb 3 00:00:08 2024
Group: Productivity/Multimedia/Other Build host: i01-ch2c
Size: 593848 Source RPM: gstreamer-plugins-ugly-1.22.9-1.1.src.rpm
Packager: https://bugs.opensuse.org
Url: https://gstreamer.freedesktop.org
Summary: GStreamer Streaming-Media Framework Plug-Ins
GStreamer is a streaming media framework based on graphs of filters
that operate on media data. Applications using this library can do
anything media-related, from real-time sound processing to playing
videos. Its plug-in-based architecture means that new data types or
processing capabilities can be added simply by installing newplug-ins.

This package contains well-written plug-ins that can't be shipped in
gstreamer-plugins-good because:
- the license is not LGPL
- the license of the library is not LGPL
- there are possible licensing issues with the code.

Provides

Requires

License

LGPL-2.1-or-later

Changelog

* Thu Feb 01 2024 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.22.9:
    + No changes, stable bump only.
  - Rebase reduce-required-meson.patch.
* Thu Jan 04 2024 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.22.8:
    + No changes, stable bump only.
  - Rebase reduce-required-meson.patch.
* Mon Nov 20 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Move libgstasf plugin from BUILD_ORIG to main package, stop
    passing asfdemux=disabled to meson setup.
* Wed Nov 15 2023 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.22.7:
    + No changes, stable bump only.
  - Rebase reduce-required-meson.patch.
* Fri Sep 22 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.6:
    + No changes, stable bump only.
  - Rebase reduce-required-meson.patch.
* Tue Jul 25 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.5:
    + rmdemux: add some integer overflow checks (bsc#1213750,
      CVE-2023-38104, bsc#1213751, CVE-2023-38103).
  - Rebase reduce-required-meson.patch.
* Mon Jun 26 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.4:
    + No changes.
  - Rebase reduce-required-meson.patch.
* Wed May 24 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.3:
    + mpegpsdemux: Rework gap sending.
  - Rebase reduce-required-meson.patch
* Wed Apr 12 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.2:
    + No changes, version bump only.
  - Rebase patch with quilt.
* Fri Mar 17 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Enable build of amr-nb/wb plugins. Move pkgconfig(opencore-amrwb)
    BuildRequires to non-BUILD_ORIG part of spec, and stop passing
    amrnb=disabled and amrwbdec=disabled to meson.
* Thu Mar 09 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.1:
    + mpegpsdemux: Ignore DTS if PTS < DTS
  - Rebase patch with quilt.
* Fri Jan 27 2023 Antonio Larrosa <alarrosa@suse.com>
  - Add patch to reduce the required meson version to 0.61.0 since
    that's what we have in SLE 15:
    * reduce-required-meson.patch
* Wed Jan 25 2023 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.22.0:
    + Please see changes in gstreamer main package, major version
      bump.
* Fri Dec 23 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.20.5:
    + No changes, version bump only.
* Sat Oct 22 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.20.4:
    + tests: skip unit tests for dependency-less elements that have
      been disabled.
* Wed Jun 22 2022 Aaron Stern <ukbeast89@protonmail.com>
  - Update to version 1.20.3:
    + x264enc: fix plugin long-name and description
* Mon May 09 2022 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.20.2:
    + x264enc: Don't try to fixate ANY allowed caps
* Fri Mar 18 2022 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.20.1:
    + x264enc: fix plugin long-name and description
* Fri Feb 04 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.20.0:
    + Development in GitLab was switched to a single git repository
      containing all the modules
    + GstPlay: new high-level playback library, replaces GstPlayer
    + WebM Alpha decoding support
    + Encoding profiles can now be tweaked with additional
      application-specified element properties
    + Compositor: multi-threaded video conversion and mixing
    + RTP header extensions: unified support in RTP depayloader and
      payloader base classes
    + SMPTE 2022-1 2-D Forward Error Correction support
    + Smart encoding (pass through) support for VP8, VP9, H.265 in
      encodebin and transcodebin
    + Runtime compatibility support for libsoup2 and libsoup3
      (libsoup3 support experimental)
    + Video decoder subframe support
    + Video decoder automatic packet-loss, data corruption, and
      keyframe request handling for RTP / WebRTC / RTSP
    + mp4 and Matroska muxers now support profile/level/resolution
      changes for H.264/H.265 input streams (i.e. codec data changing
      on the fly)
    + mp4 muxing mode that initially creates a fragmented mp4 which
      is converted to a regular mp4 on EOS
    + Audio support for the WebKit Port for Embedded (WPE) web page
      source element
    + CUDA based video color space convert and rescale elements and
      upload/download elements
    + NVIDIA memory:NVMM support for OpenGL glupload and gldownload
      elements
    + Many WebRTC improvements
    + The new VA-API plugin implementation fleshed out with more
      decoders and new postproc elements
    + AppSink API to retrieve events in addition to buffers and
      buffer lists
    + AppSrc gained more configuration options for the internal queue
      (leakiness, limits in buffers and time, getters to read current
      levels)
    + Updated Rust bindings and many new Rust plugins
    + Improved support for custom minimal GStreamer builds
    + Support build against FFmpeg 5.0
    + Linux Stateless CODEC support gained MPEG-2 and VP9
    + Windows Direct3D11/DXVA decoder gained AV1 and MPEG-2 support
    + Lots of new plugins, features, performance improvements and bug
      fixes
  - Stop using service, use upstream url for tarball.
  - Drop obsolete and unused experimental define.
  - Pass gpl=enabled to meson, now needed to build a52 support.
* Fri Feb 04 2022 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.18.6:
    + No changes, version bump only.
  - Drop service, use source url, upstream changes in git.
* Fri Sep 17 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Stop building doc sub-package, we will in the future use
    upstreams own standalone doc package. Following this: Drop
    gtk-doc and hotdoc BuildRequires and pass doc=disabled to meson.
* Wed Sep 15 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.18.5:
    + asfdemux/realmedia: Drop duplicate seek events
    + Don't use volatile to mean atomic (fixes compiler warnings with
      gcc 11)
* Tue Mar 30 2021 Antonio Larrosa <alarrosa@suse.com>
  - Update to version 1.18.4:
    + rmdemux: Make sure we have enough data available when parsing
      audio/video packets
* Sat Jan 16 2021 Bjørn Lie <bjorn.lie@gmail.com>
  - Update to version 1.18.3:
    + No changes

Files

/usr/lib/gstreamer-1.0
/usr/lib/gstreamer-1.0/libgsta52dec.so
/usr/lib/gstreamer-1.0/libgstamrnb.so
/usr/lib/gstreamer-1.0/libgstamrwbdec.so
/usr/lib/gstreamer-1.0/libgstasf.so
/usr/lib/gstreamer-1.0/libgstcdio.so
/usr/lib/gstreamer-1.0/libgstdvdlpcmdec.so
/usr/lib/gstreamer-1.0/libgstdvdread.so
/usr/lib/gstreamer-1.0/libgstdvdsub.so
/usr/lib/gstreamer-1.0/libgstmpeg2dec.so
/usr/lib/gstreamer-1.0/libgstrealmedia.so


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Mar 6 23:57:23 2024