Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

perl-Sub-Uplevel-0.2800-1.4 RPM for noarch

From OpenSuSE Tumbleweed for noarch

Name: perl-Sub-Uplevel Distribution: openSUSE Tumbleweed
Version: 0.2800 Vendor: openSUSE
Release: 1.4 Build date: Wed Jun 12 18:38:47 2019
Group: Development/Libraries/Perl Build host: lamb61
Size: 55233 Source RPM: perl-Sub-Uplevel-0.2800-1.4.src.rpm
Packager: https://bugs.opensuse.org
Url: https://metacpan.org/release/Sub-Uplevel
Summary: Apparently run a function in a higher stack frame
Like Tcl's uplevel() function, but not quite so dangerous. The idea is
just to fool caller(). All the really naughty bits of Tcl's uplevel()
are avoided.

Provides

Requires

License

GPL-1.0-or-later OR Artistic-1.0

Changelog

* Fri Sep 14 2018 pmonrealgonzalez@suse.com
  - update to 0.2800
    - No changes from 0.2700-TRIAL
  - 0.2700    2017-03-30 10:09:46-04:00 America/New_York (TRIAL RELEASE)
    [Fixed]
    - Tests now work if '.' is not in @INC
  - 0.2600    2016-08-05 10:46:37-04:00 America/New_York
    - No changes from 0.2501-TRIAL
  - 0.2501    2016-07-29 16:18:45-04:00 America/New_York (TRIAL RELEASE)
    [Internal]
    - Optimized calls to caller()
  - 0.25      2015-01-26 20:32:52-05:00 America/New_York
    [Fixed]
    - fixed: 00-compile.t failures under Windows (bug #98230).
      The 00-compile.t file has been moved to a release test and is
      no longer shipped.  [Michael Gray]
    [Meta]
    - moved bug tracker to Github
    - updated repo files explaining how to contribute
    - enabled Travis CI
  - Cleaned with spec-cleaner
* Mon Apr 15 2013 idonmez@suse.com
  - Add Source URL, see https://en.opensuse.org/SourceUrls
* Wed Feb 22 2012 vcizek@suse.com
  - update to 0.24
    - fixed: additional test regex fixed
    - fixed: Perl 5.15 series Carp changes output format of messages (adds
      a period).  This fixes the test regular expressions. [Andreas Koenig]
    - added: the $Sub::Uplevel::CHECK_FRAMES global constant to enable the
      frame depth checking and compile it out if not needed.  [Adam
      Kennedy]
* Fri Nov 18 2011 coolo@suse.com
  - use original .tar.gz
* Tue Nov 30 2010 coolo@novell.com
  - switch to perl_requires macro
* Wed Aug 11 2010 chris@computersalat.de
  - update to 0.22
    - meta: added repository to metadata [Alexandr Ciornii]
  - 0.21_01 Sat Nov 29 15:24:49 EST 2008
    - added: the ":aggressive" tag may be used to force reloading of
      Exporter, which often binds caller() prior to Sub::Uplevel's global
      override
  - recreated by cpanspec 1.78
    o change to Build.PL
  - fix version mismatch
    o http://www.dagolden.com/index.php/369/version-numbers-should-be-boring/
      perl modules normaly use "decimal versioning", but for rpm
      we need "decimal dotted versioning", hence the decimal 0.22
      has to be normalized to decimal dotted 0.220.0
      perl -e "print version->new(0.22)->normal" | sed "s/v//"
    o without doing this (latest) 0.22 < 0.2002 (previous)
      normalized: 0.220.0 > 0.200.200
  - noarch pkg
* Sun Dec 20 2009 jengelh@medozas.de
  - enable parallel build
* Sat Jul 25 2009 chris@computersalat.de
  - spec mods
    * removed ^----------
    * removed ^#---------
* Wed Jul 01 2009 chris@computersalat.de
  - added perl-macros
    o autogen filelist with perl_gen_filelist
  - spec mods
    o added header
    o fixed deps
* Fri Sep 12 2008 anicka@suse.cz
  - update to 0.2002
    * changed: removed Exporter dependency
    * test fix: fixed strange t/07_uplevel_too_high.t fail on Win32

Files

/usr/lib/perl5/vendor_perl/5.28.1/Sub
/usr/lib/perl5/vendor_perl/5.28.1/Sub/Uplevel.pm
/usr/share/doc/packages/perl-Sub-Uplevel
/usr/share/doc/packages/perl-Sub-Uplevel/Changes
/usr/share/doc/packages/perl-Sub-Uplevel/README
/usr/share/doc/packages/perl-Sub-Uplevel/examples
/usr/share/doc/packages/perl-Sub-Uplevel/examples/uplevel-demo.pl
/usr/share/doc/packages/perl-Sub-Uplevel/xt
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/00-compile.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/critic.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/pod-coverage.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/pod-spell.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/pod-syntax.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/portability.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/author/test-version.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/release
/usr/share/doc/packages/perl-Sub-Uplevel/xt/release/distmeta.t
/usr/share/doc/packages/perl-Sub-Uplevel/xt/release/minimum-version.t
/usr/share/licenses/perl-Sub-Uplevel
/usr/share/licenses/perl-Sub-Uplevel/LICENSE
/usr/share/man/man3/Sub::Uplevel.3pm.gz


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Aug 19 23:15:26 2019