Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libid3tag0-0.15.1b-188.3.1 RPM for ppc64le

From OpenSuSE Ports Leap 42.3 updates for ppc64le

Name: libid3tag0 Distribution: openSUSE Leap 42.3
Version: 0.15.1b Vendor: openSUSE
Release: 188.3.1 Build date: Fri Mar 16 18:04:02 2018
Group: System/Libraries Build host: obs-power8-02
Size: 133640 Source RPM: libid3tag-0.15.1b-188.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.underbit.com/products/mad/
Summary: ID3 Tag Manipulation Library
libid3tag is a library for reading and writing ID3 tags, both ID3v1 and
the various versions of ID3v2.

Provides

Requires

License

GPL-2.0+

Changelog

* Wed Feb 21 2018 kbabioch@suse.com
  - Added libid3tag-utf16.patch: Fixed id3_utf16_deserialize() in utf16.c,
    which previously misparsed ID3v2 tags encoded in UTF-16 with an odd
    number of bytes, triggering an endless loop allocating memory until
    OOM leading to DoS. (CVE-2004-2779 bsc#1081959 CVE-2017-11551
    bsc#1081961)
  - Added libid3tag-unknown-encoding.patch: Fixed the handling of unknown
    encodings when parsing ID3 tags. (CVE-2017-11550 bsc#1081962
    CVE-2008-2109 bsc#387731)
  - Removed libid3tag-0.15.1b-fix_overflow.patch, since it is handled
    differently by libid3tag-utf16.patch already.
* Fri Nov 23 2012 jengelh@inai.de
  - Remove redundant tags/sections from specfile
  - Parallel build with %_smp_mflags
  - Employ shared library naming
  - Have makeinstall succeed on non-SUSE
* Thu Nov 22 2012 crrodriguez@opensuse.org
  - libid3tag-visibility.patch: Hide all symbols that are not
    part of the public API.
  - spec file: DO not inject bogus dependencies into the
    system via pkgconfig files.
* Sat Nov 19 2011 coolo@suse.com
  - add libtool as buildrequire to avoid implicit dependency
* Tue Apr 12 2011 toddrme2178@gmail.com
  - Added 32bit compatibility libraries
  - Added BuildRequires:  pkg-config (fixes RPMLINT warning)
* Thu May 08 2008 tiwai@suse.de
  - VUL-0: libid3tag overflow (CVE-2008-2109, bnc#387731)
  - don't install static and *.la files
  - clean up spec file
* Thu Mar 29 2007 meissner@suse.de
  - zlib-devel to buildrequires
* Tue Oct 31 2006 meissner@suse.de
  - fixed configure.ac to accept more than 1 -O/-f option, added
    requires
* Wed Jan 25 2006 mls@suse.de
  - converted neededforbuild to BuildRequires
* Wed Jan 11 2006 tiwai@suse.de
  - compile with -fstack-protector.

Files

/usr/lib64/libid3tag.so.0
/usr/lib64/libid3tag.so.0.3.0


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Jan 10 06:51:35 2020