Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libopenssl1_1-1.1.0h-lp150.3.3.1 RPM for ppc64le

From OpenSuSE Ports Leap 15.0 updates for ppc64le

Name: libopenssl1_1 Distribution: openSUSE Leap 15.0
Version: 1.1.0h Vendor: openSUSE
Release: lp150.3.3.1 Build date: Mon Jul 23 12:18:03 2018
Group: Productivity/Networking/Security Build host: obs-power8-02
Size: 3682320 Source RPM: openssl-1_1-1.1.0h-lp150.3.3.1.src.rpm
Packager: http://bugs.opensuse.org
Url: https://www.openssl.org/
Summary: Secure Sockets and Transport Layer Security
OpenSSL is a software library to be used in applications that need to
secure communications over computer networks against eavesdropping or
need to ascertain the identity of the party at the other end.
OpenSSL contains an implementation of the SSL and TLS protocols.

Provides

Requires

License

OpenSSL

Changelog

* Tue Jun 26 2018 sflees@suse.de
  - Reject excessively large primes in DH key generation (bsc#1097158,
    CVE-2018-0732)
    * openssl-CVE-2018-0732.patch
  - blinding enhancements for ECDSA and DSA (bsc#1097624, bsc#1098592)
    * openssl-add-blinding-to-ecdsa.patch
    * openssl-add-blinding-to-dsa.patch
* Thu May 10 2018 vcizek@suse.com
  - OpenSSL Security Advisory [16 Apr 2018]
    * Cache timing vulnerability in RSA Key Generation
      (CVE-2018-0737, bsc#1089039)
    * add openssl-CVE-2018-0737.patch
* Thu May 10 2018 vcizek@suse.com
  - Fix escaping in c_rehash (boo#1091961, bsc#1091963)
    * add 0001-Revert-util-dofile.pl-only-quote-stuff-that-actually.patch
* Wed Mar 28 2018 vcizek@suse.com
  - Tolerate a Certificate using a non-supported group on server side
    (boo#1084651)
    * https://github.com/openssl/openssl/pull/5607
    * add 0001-Tolerate-a-Certificate-using-a-non-supported-group-o.patch
* Tue Mar 27 2018 vcizek@suse.com
  - Update to 1.1.0h
    OpenSSL Security Advisory [27 Mar 2018]
    * Constructed ASN.1 types with a recursive definition could exceed
      the stack (CVE-2018-0739) (bsc#1087102)
    * rsaz_1024_mul_avx2 overflow bug on x86_64 (CVE-2017-3738)
      (bsc#1071906)
  - refresh patches:
    * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
    * openssl-1.1.0-fips.patch
    * openssl-pkgconfig.patch
    * openssl-rsakeygen-minimum-distance.patch
    * openssl-static-deps.patch
* Tue Feb 27 2018 dimstar@opensuse.org
  - Move the libopenssl1_1_0-32bit obsoletes in baselibs.conf to the
    new libopenssl1_1-32bit: it does not belong to the devel
    package.
* Fri Feb 16 2018 vcizek@suse.com
  - Renamed from openssl-1_1_0 (bsc#1081335)
    * All the minor versions of the 1.1.x openssl branch have the same
      sonum and keep ABI compatibility
    * obsolete the 1_1_0 packages
  - update baselibs.conf with the new version names
* Thu Feb 15 2018 tchvatal@suse.com
  - Remove bit obsolete syntax
  - Use %license macro
* Mon Jan 22 2018 schwab@suse.de
  - Don't disable afalgeng on aarch64
* Tue Jan 09 2018 vcizek@suse.com
  - Add support for s390x CPACF enhancements (fate#321518)
    patches taken from https://github.com/openssl/openssl/pull/2859:
    * 0002-crypto-modes-asm-ghash-s390x.pl-fix-gcm_gmult_4bit-K.patch
    * 0004-s390x-assembly-pack-add-OPENSSL_s390xcap-environment.patch
    * 0005-s390x-assembly-pack-add-OPENSSL_s390xcap-man-page.patch
    * 0006-s390x-assembly-pack-extended-s390x-capability-vector.patch
    * 0007-crypto-evp-e_aes.c-add-foundations-for-extended-s390.patch
    * 0008-s390x-assembly-pack-extended-s390x-capability-vector.patch
    * 0009-crypto-aes-asm-aes-s390x.pl-add-KMA-code-path.patch
    * 0010-doc-man3-OPENSSL_s390xcap.pod-update-KMA.patch
    * 0011-crypto-aes-asm-aes-s390x.pl-add-CFI-annotations-KMA-.patch
    * 0012-s390x-assembly-pack-add-KMA-code-path-for-aes-gcm.patch
    * 0013-crypto-aes-asm-aes-s390x.pl-add-CFI-annotations-KMA-.patch
* Tue Nov 28 2017 dimstar@opensuse.org
  - Do not filter pkgconfig() provides/requires.
* Tue Nov 28 2017 dimstar@opensuse.org
  - Obsolete openssl-1_0_0 by openssl-1_1_0: this is required for a
    clean upgrade path as an aid to zypp (boo#1070003).
* Thu Nov 02 2017 vcizek@suse.com
  - Update to 1.1.0g
    OpenSSL Security Advisory [02 Nov 2017]
    * bn_sqrx8x_internal carry bug on x86_64
      (CVE-2017-3736) (bsc#1066242)
    * Malformed X.509 IPAddressFamily could cause OOB read
      (CVE-2017-3735) (bsc#1056058)
  - drop 0001-Fix-a-TLSProxy-race-condition.patch (upstream)
  - refresh 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
* Fri Sep 01 2017 vcizek@suse.com
  - update DEFAULT_SUSE cipher list (bsc#1055825)
    * add CHACHA20-POLY1305
    * add ECDSA ciphers
    * remove 3DES
  - modified openssl-1.0.1e-add-suse-default-cipher.patch
* Tue Aug 15 2017 meissner@suse.com
  - do not require openssl1_1_0-targettype in devel-targettype, as it
    is not built (it has no libraries)
* Mon Aug 07 2017 jengelh@inai.de
  - The description is supposed to describe the package, not the
    development process or history. (Synchronize with the
    already-updates descriptions in openssl-1_0_0.)
  - Update historic copypasted boilerplate summaries
    ("include files mandatory for development")
* Thu Aug 03 2017 tchvatal@suse.com
  - Disable the verbosity of the tests as we expose yet another race
    condition in that
* Tue Jul 18 2017 vcizek@suse.com
  - Fix a race condition in tests to make the package build reliably
    * https://github.com/openssl/openssl/issues/3562
    * 0001-Fix-a-TLSProxy-race-condition.patch
* Tue Jul 18 2017 jimmy@boombatower.com
  - Add Provides and Conflicts for -devel package in baselibs.conf.
* Sun Jun 25 2017 tchvatal@suse.com
  - Add patch openssl-no-date.patch to disable date inclusion in most
    of the binaries
  - Use autopatch to make things smaller
  - Enable verbose output on the tests
  - Paralelize depmod
* Mon May 29 2017 vcizek@suse.com
  - update to 1.1.0f
    * bugfix only release
  - disable RSA keygen tests, because they use too small modulus, which
    is rejected by our CC/FIPS hardening patches
    * added openssl-disable_rsa_keygen_tests_with_small_modulus.patch
  - refreshed openssl-rsakeygen-minimum-distance.patch and
    0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
* Wed May 10 2017 tchvatal@suse.com
  - Add conflict for any libopenssl-devel that is not in our version
* Wed May 10 2017 tchvatal@suse.com
  - Avoid the requires conflict between 1.1 and 1.0 openssl
* Fri May 05 2017 tchvatal@suse.com
  - Add conflict on docu packages
* Wed May 03 2017 vcizek@suse.com
  - drop unnecessary README.SUSE
* Wed May 03 2017 vcizek@suse.com
  - add openssl-1.1-fix-ppc64.patch from Marcus Meissner to fix build
    on ppc64
* Wed May 03 2017 tchvatal@suse.com
  - Fix build on aarch64
* Wed May 03 2017 tchvatal@suse.com
  - Remove libpadlock conditional, no longer present
* Tue May 02 2017 tchvatal@suse.com
  - Update baselibs.conf to contain all the renamed packages
* Wed Apr 26 2017 vcizek@suse.com
  - re-enable tests on SLE-12 and below despite current failure, so
    they are automatically run once the issue is resolved
* Wed Apr 26 2017 tchvatal@suse.com
  - Filter out the pkgconfig provides to force usage of the main
    openssl package provides
* Fri Apr 21 2017 vcizek@suse.com
  - disable tests on SLE-12 and its derivates
    * they fail because of glibc bug bsc#1035445
  - remove README-FIPS.txt (outdated)
* Thu Apr 20 2017 vcizek@suse.com
  - drop openssl-fipslocking.patch
    The locking in 1.1.0 has been rewritten and converted to the new
    threading API. The fips deadlock (at least bsc#991193) can't be
    reproduced anymore.
  - don't ship useless INSTALL* files
* Thu Apr 20 2017 vcizek@suse.com
  - simplify openssl-fips-dont-fall-back-to-default-digest.patch
    The -non-fips-allow option was dropped in OpenSSL 1.1.0
  - drop openssl-no-egd.patch as OpenSSL 1.1.0 disables EGD at compile
    time by default
  - renumber the patches so the numbers are consequent
* Tue Apr 18 2017 tchvatal@suse.com
  - Update showciphers.c to work with new openssl
* Tue Apr 18 2017 tchvatal@suse.com
  - Add patch openssl-static-deps.patch to allow dependencies on
    statically build libraries
  - Refresh openssl-1-1.0-fips.patch to take in use the above approach
  - Silence the install manpage rename phase
* Thu Apr 13 2017 tchvatal@suse.com
  - Start update to 1.1.0e basing of the 1.0.0 split release
  - Drop patch merge_from_0.9.8k.patch the ppc64 should work out of the
    box
  - Drop patch openssl-engines-path.patch converted to configure option
  - Drop patch openssl-1.0.2a-padlock64.patch code behind was redone
    does not apply at all
  - Drop patch openssl-fix-pod-syntax.diff mostly merged upstream or
    not applicable
  - Drop patch compression_methods_switch.patch as we do not need
    to keep the compat on this release anymore
  - Drop patch openssl-1.0.2a-ipv6-apps.patch which was upstreamed
  - Drop upstreamed patch openssl-1.0.2a-default-paths.patch
  - Drop obsolete patch openssl-1.0.0-c_rehash-compat.diff
  - Drop obsolete patch openssl-missing_FIPS_ec_group_new_by_curve_name.patch
  - Drop obsolete patch openssl-print_notice-NULL_crash.patch
  - Drop obsolete patch openssl-randfile_fread_interrupt.patch
  - Refresh patch openssl-truststore.patch
  - Refresh baselibs.conf to correctly reflect soname
  - Add patch openssl-1.1.0-fips.patch obsoleting bunch of older:
    * openssl-1.0.2i-fips.patch
    * openssl-1.0.2a-fips-ec.patch
    * openssl-1.0.2a-fips-ctor.patch
    * openssl-1.0.2i-new-fips-reqs.patch
    * openssl-fips_disallow_x931_rand_method.patch
  - Add new patch for upstream:
    * 0001-Resume-reading-from-randfile-when-interrupted-by-a-s.patch
  - Refresh patch openssl-pkgconfig.patch
  - Drop patch openssl-gcc-attributes.patch as the code was redone
  - Rebase patch 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
  - Rebase patch openssl-no-egd.patch
  - Rebase patch openssl-1.0.1e-add-suse-default-cipher.patch and
    openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
  - Rebase patch openssl-fips_disallow_ENGINE_loading.patch
  - Rebase patch openssl-urandom-reseeding.patch
  - Rebase patch openssl-fips-rsagen-d-bits.patch
  - Rebase patch openssl-fips-selftests_in_nonfips_mode.patch
  - Remove switch for ssl2 - no longer present
  - Remve the buildinf.h parsing, should no longer be needed
  - Drop the rehash in build, no longer needed
  - Drop openssl-fips-hidden.patch as it is not really needed
  - Do not sed in secure_getenv upstream does it in code on their own
  - Do not install html converted manpages
    * openssl-1.1.0-no-html.patch
* Thu Apr 13 2017 tchvatal@suse.com
  - Drop the symbol hiding patches to ease maintenance updates:
    * 0005-libssl-Hide-library-private-symbols.patch
    * 0001-libcrypto-Hide-library-private-symbols.patch
* Thu Apr 13 2017 tchvatal@suse.com
  - Add new patch for engines folders to allow co-installation
    * openssl-engines-path.patch
* Thu Apr 13 2017 tchvatal@suse.com
  - Drop openssl-ocloexec.patch as it causes additional maintenance
    burden we would like to avoid
* Thu Apr 13 2017 tchvatal@suse.com
  - Drop bug610223.patch as we moved to libdir
* Thu Apr 13 2017 tchvatal@suse.com
  - Move check to %check phase
  - Split showciphers to separate file
* Wed Apr 12 2017 tchvatal@suse.com
  - Move openssl to /usr/lib64 from /lib64
* Wed Apr 12 2017 tchvatal@suse.com
  - Remove some of the DSO setting code that is not needed
  - Fix the showciphers binary
* Wed Apr 12 2017 tchvatal@suse.com
  - Rename to openssl-1_0_0 to allow instalation of multiple versions
* Tue Apr 04 2017 tchvatal@suse.com
  - Remove O3 from optflags, no need to not rely on distro wide settings
  - Remove conditions for sle10 and sle11, we care only about sle12+
  - USE SUSE instead of SuSE in readme
  - Pass over with spec-cleaner
* Thu Feb 02 2017 vcizek@suse.com
  - fix X509_CERT_FILE path (bsc#1022271) and rename
    updated openssl-1.0.1e-truststore.diff to openssl-truststore.patch
* Fri Jan 27 2017 meissner@suse.com
  - Updated to openssl 1.0.2k
    - bsc#1009528 / CVE-2016-7055: openssl: Montgomery multiplication may produce incorrect results
    - bsc#1019334 / CVE-2016-7056: openssl: ECSDA P-256 timing attack key recovery
    - bsc#1022085 / CVE-2017-3731: openssl: Truncated packet could crash via OOB read
    - bsc#1022086 / CVE-2017-3732: openssl: BN_mod_exp may produce incorrect results on x86_64
* Fri Sep 30 2016 vcizek@suse.com
  - resume reading from /dev/urandom when interrupted by a signal
    (bsc#995075)
    * add openssl-randfile_fread_interrupt.patch
* Fri Sep 30 2016 vcizek@suse.com
  - add FIPS changes from SP2:
  - fix problems with locking in FIPS mode (bsc#992120)
    * duplicates: bsc#991877, bsc#991193, bsc#990392, bsc#990428
      and bsc#990207
    * bring back openssl-fipslocking.patch
  - drop openssl-fips_RSA_compute_d_with_lcm.patch (upstream)
    (bsc#984323)
  - don't check for /etc/system-fips (bsc#982268)
    * add openssl-fips-dont_run_FIPS_module_installed.patch
  - refresh openssl-fips-rsagen-d-bits.patch
* Tue Sep 27 2016 michael@stroeder.com
  - update to openssl-1.0.2j
    * Missing CRL sanity check (CVE-2016-7052 bsc#1001148)
* Fri Sep 23 2016 vcizek@suse.com
  - OpenSSL Security Advisory [22 Sep 2016] (bsc#999665)
    Severity: High
    * OCSP Status Request extension unbounded memory growth
      (CVE-2016-6304) (bsc#999666)
    Severity: Low
    * Pointer arithmetic undefined behaviour (CVE-2016-2177) (bsc#982575)
    * Constant time flag not preserved in DSA signing (CVE-2016-2178) (bsc#983249)
    * DTLS buffered message DoS (CVE-2016-2179) (bsc#994844)
    * OOB read in TS_OBJ_print_bio() (CVE-2016-2180) (bsc#990419)
    * DTLS replay protection DoS (CVE-2016-2181) (bsc#994749)
    * OOB write in BN_bn2dec() (CVE-2016-2182) (bsc#993819)
    * Birthday attack against 64-bit block ciphers (SWEET32)
      (CVE-2016-2183) (bsc#995359)
    * Malformed SHA512 ticket DoS (CVE-2016-6302) (bsc#995324)
    * OOB write in MDC2_Update() (CVE-2016-6303) (bsc#995377)
    * Certificate message OOB reads (CVE-2016-6306) (bsc#999668)
  - update to openssl-1.0.2i
    * remove patches:
      openssl-1.0.2a-new-fips-reqs.patch
      openssl-1.0.2e-fips.patch
    * add patches:
      openssl-1.0.2i-fips.patch
      openssl-1.0.2i-new-fips-reqs.patch
* Wed Aug 03 2016 vcizek@suse.com
  - fix crash in print_notice (bsc#998190)
    * add openssl-print_notice-NULL_crash.patch
* Tue May 03 2016 vcizek@suse.com
  - OpenSSL Security Advisory [3rd May 2016]
  - update to 1.0.2h (boo#977584, boo#977663)
    * Prevent padding oracle in AES-NI CBC MAC check
      A MITM attacker can use a padding oracle attack to decrypt traffic
      when the connection uses an AES CBC cipher and the server support
      AES-NI.
      (CVE-2016-2107, boo#977616)
    * Fix EVP_EncodeUpdate overflow
      An overflow can occur in the EVP_EncodeUpdate() function which is used for
      Base64 encoding of binary data. If an attacker is able to supply very large
      amounts of input data then a length check can overflow resulting in a heap
      corruption.
      (CVE-2016-2105, boo#977614)
    * Fix EVP_EncryptUpdate overflow
      An overflow can occur in the EVP_EncryptUpdate() function. If an attacker
      is able to supply very large amounts of input data after a previous call to
      EVP_EncryptUpdate() with a partial block then a length check can overflow
      resulting in a heap corruption.
      (CVE-2016-2106, boo#977615)
    * Prevent ASN.1 BIO excessive memory allocation
      When ASN.1 data is read from a BIO using functions such as d2i_CMS_bio()
      a short invalid encoding can casuse allocation of large amounts of memory
      potentially consuming excessive resources or exhausting memory.
      (CVE-2016-2109, boo#976942)
    * EBCDIC overread
      ASN1 Strings that are over 1024 bytes can cause an overread in applications
      using the X509_NAME_oneline() function on EBCDIC systems. This could result
      in arbitrary stack data being returned in the buffer.
      (CVE-2016-2176, boo#978224)
    * Modify behavior of ALPN to invoke callback after SNI/servername
      callback, such that updates to the SSL_CTX affect ALPN.
    * Remove LOW from the DEFAULT cipher list.  This removes singles DES from the
      default.
    * Only remove the SSLv2 methods with the no-ssl2-method option. When the
      methods are enabled and ssl2 is disabled the methods return NULL.
* Fri Apr 15 2016 dvaleev@suse.com
  - Remove a hack for bsc#936563
  - Drop bsc936563_hack.patch
* Fri Apr 15 2016 vcizek@suse.com
  - import fips patches from SLE-12
    * openssl-fips-clearerror.patch
    * openssl-fips-dont-fall-back-to-default-digest.patch
    * openssl-fips-fix-odd-rsakeybits.patch
    * openssl-fips-rsagen-d-bits.patch
    * openssl-fips-selftests_in_nonfips_mode.patch
    * openssl-fips_RSA_compute_d_with_lcm.patch
    * openssl-fips_disallow_ENGINE_loading.patch
    * openssl-fips_disallow_x931_rand_method.patch
    * openssl-rsakeygen-minimum-distance.patch
    * openssl-urandom-reseeding.patch
* Tue Mar 08 2016 vcizek@suse.com
  - add support for "ciphers" providing no encryption (bsc#937085)
    * don't build with -DSSL_FORBID_ENULL
* Tue Mar 01 2016 vcizek@suse.com
  - update to 1.0.2g (bsc#968044)
    * Disable weak ciphers in SSLv3 and up in default builds of OpenSSL.
      Builds that are not configured with "enable-weak-ssl-ciphers" will not
      provide any "EXPORT" or "LOW" strength ciphers.
    * Disable SSLv2 default build, default negotiation and weak ciphers.  SSLv2
      is by default disabled at build-time.  Builds that are not configured with
      "enable-ssl2" will not support SSLv2.  Even if "enable-ssl2" is used,
      users who want to negotiate SSLv2 via the version-flexible SSLv23_method()
      will need to explicitly call either of:
      SSL_CTX_clear_options(ctx, SSL_OP_NO_SSLv2);
      or
      SSL_clear_options(ssl, SSL_OP_NO_SSLv2);
      (CVE-2016-0800)
    * Fix a double-free in DSA code
      (CVE-2016-0705)
    * Disable SRP fake user seed to address a server memory leak.
      Add a new method SRP_VBASE_get1_by_user that handles the seed properly.
      (CVE-2016-0798)
    * Fix BN_hex2bn/BN_dec2bn NULL pointer deref/heap corruption
      (CVE-2016-0797)
    * ) Side channel attack on modular exponentiation
      http://cachebleed.info.
      (CVE-2016-0702)
    * ) Change the req app to generate a 2048-bit RSA/DSA key by default,
      if no keysize is specified with default_bits. This fixes an
      omission in an earlier change that changed all RSA/DSA key generation
      apps to use 2048 bits by default.
* Thu Jan 28 2016 vcizek@suse.com
  - update to 1.0.2f (boo#963410)
    * ) DH small subgroups (boo#963413)
      Historically OpenSSL only ever generated DH parameters based on "safe"
      primes. More recently (in version 1.0.2) support was provided for
      generating X9.42 style parameter files such as those required for RFC 5114
      support. The primes used in such files may not be "safe". Where an
      application is using DH configured with parameters based on primes that are
      not "safe" then an attacker could use this fact to find a peer's private
      DH exponent. This attack requires that the attacker complete multiple
      handshakes in which the peer uses the same private DH exponent. For example
      this could be used to discover a TLS server's private DH exponent if it's
      reusing the private DH exponent or it's using a static DH ciphersuite.
      (CVE-2016-0701)
    * ) SSLv2 doesn't block disabled ciphers (boo#963415)
      A malicious client can negotiate SSLv2 ciphers that have been disabled on
      the server and complete SSLv2 handshakes even if all SSLv2 ciphers have
      been disabled, provided that the SSLv2 protocol was not also disabled via
      SSL_OP_NO_SSLv2.
      (CVE-2015-3197)
    * ) Reject DH handshakes with parameters shorter than 1024 bits.
* Fri Dec 04 2015 vcizek@suse.com
  - update to 1.0.2e
    * fixes five security vulnerabilities
    * Anon DH ServerKeyExchange with 0 p parameter
      (CVE-2015-1794) (bsc#957984)
    * BN_mod_exp may produce incorrect results on x86_64
      (CVE-2015-3193) (bsc#957814)
    * Certificate verify crash with missing PSS parameter
      (CVE-2015-3194) (bsc#957815)
    * X509_ATTRIBUTE memory leak
      (CVE-2015-3195) (bsc#957812)
    * Race condition handling PSK identify hint
      (CVE-2015-3196) (bsc#957813)
  - pulled a refreshed fips patch from Fedora
    * openssl-1.0.2a-fips.patch was replaced by
      openssl-1.0.2e-fips.patch
  - refresh openssl-ocloexec.patch
* Thu Jul 09 2015 vcizek@suse.com
  - update to 1.0.2d
    * fixes CVE-2015-1793 (bsc#936746)
    Alternate chains certificate forgery
      During certificate verfification, OpenSSL will attempt to find an
      alternative certificate chain if the first attempt to build such a chain
      fails. An error in the implementation of this logic can mean that an
      attacker could cause certain checks on untrusted certificates to be
      bypassed, such as the CA flag, enabling them to use a valid leaf
      certificate to act as a CA and "issue" an invalid certificate.
  - drop openssl-fix_invalid_manpage_name.patch (upstream)
* Thu Jul 02 2015 dvaleev@suse.com
  - Workaround debugit crash on ppc64le with gcc5
    bsc936563_hack.patch (bsc#936563)
* Wed Jul 01 2015 normand@linux.vnet.ibm.com
  - update merge_from_0.9.8k.patch replacing __LP64__ by __LP64
    this is a change versus previous request 309611
    required to avoid build error for ppc64
* Fri Jun 26 2015 crrodriguez@opensuse.org
  - Build with no-ssl3, for details on why this is needed read
    rfc7568. Contrary to the "no-ssl2" option, this does not
    require us to patch dependant packages as the relevant
    functions are still available (SSLv3_(client|server)_method)
    but will fail to negotiate. if removing SSL3 methods is desired
    at a later time, option "no-ssl3-method" needs to be used.
* Fri Jun 12 2015 vcizek@suse.com
  - update to 1.0.2c
    * Fix HMAC ABI incompatibility
  - refreshed openssl-1.0.2a-fips.patch
* Thu Jun 11 2015 vcizek@suse.com
  - update to 1.0.2b
    * Malformed ECParameters causes infinite loop (CVE-2015-1788)
    * Exploitable out-of-bounds read in X509_cmp_time (CVE-2015-1789)
    * PKCS7 crash with missing EnvelopedContent (CVE-2015-1790)
    * CMS verify infinite loop with unknown hash function (CVE-2015-1792)
    * Race condition handling NewSessionTicket (CVE-2015-1791)
  - refreshed patches:
    * 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
    * 0001-libcrypto-Hide-library-private-symbols.patch
    * openssl-1.0.2a-default-paths.patch
    * openssl-1.0.2a-fips.patch
    * compression_methods_switch.patch
    * openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
* Sun May 24 2015 vcizek@suse.com
  - update to 1.0.2a
    * Major changes since 1.0.1:
    - Suite B support for TLS 1.2 and DTLS 1.2
    - Support for DTLS 1.2
    - TLS automatic EC curve selection.
    - API to set TLS supported signature algorithms and curves
    - SSL_CONF configuration API.
    - TLS Brainpool support.
    - ALPN support.
    - CMS support for RSA-PSS, RSA-OAEP, ECDH and X9.42 DH.
  - packaging changes:
    * merged patches modifying CIPHER_LIST into one, dropping:
    - openssl-1.0.1e-add-suse-default-cipher-header.patch
    - openssl-libssl-noweakciphers.patch
    * fix a manpage with invalid name
    - added openssl-fix_invalid_manpage_name.patch
    * remove a missing fips function
    - openssl-missing_FIPS_ec_group_new_by_curve_name.patch
    * reimported patches from Fedora
      dropped patches:
    - openssl-1.0.1c-default-paths.patch
    - openssl-1.0.1c-ipv6-apps.patch
    - openssl-1.0.1e-fips-ctor.patch
    - openssl-1.0.1e-fips-ec.patch
    - openssl-1.0.1e-fips.patch
    - openssl-1.0.1e-new-fips-reqs.patch
    - VIA_padlock_support_on_64systems.patch
      added patches:
    - openssl-1.0.2a-default-paths.patch
    - openssl-1.0.2a-fips-ctor.patch
    - openssl-1.0.2a-fips-ec.patch
    - openssl-1.0.2a-fips.patch
    - openssl-1.0.2a-ipv6-apps.patch
    - openssl-1.0.2a-new-fips-reqs.patch
    - openssl-1.0.2a-padlock64.patch
    * dropped security fixes (upstream)
    - openssl-CVE-2015-0209.patch
    - openssl-CVE-2015-0286.patch
    - openssl-CVE-2015-0287.patch
    - openssl-CVE-2015-0288.patch
    - openssl-CVE-2015-0289.patch
    - openssl-CVE-2015-0293.patch
    * upstream reformatted the sources, so all the patches have to
      be refreshed
* Thu Mar 19 2015 vcizek@suse.com
  - security update:
    * CVE-2015-0209 (bnc#919648)
    - Fix a failure to NULL a pointer freed on error
    * CVE-2015-0286 (bnc#922496)
    - Segmentation fault in ASN1_TYPE_cmp
    * CVE-2015-0287 (bnc#922499)
    - ASN.1 structure reuse memory corruption
    * CVE-2015-0288 x509: (bnc#920236)
    - added missing public key is not NULL check
    * CVE-2015-0289 (bnc#922500)
    - PKCS7 NULL pointer dereferences
    * CVE-2015-0293 (bnc#922488)
    - Fix reachable assert in SSLv2 servers
    * added patches:
    openssl-CVE-2015-0209.patch
    openssl-CVE-2015-0286.patch
    openssl-CVE-2015-0287.patch
    openssl-CVE-2015-0288.patch
    openssl-CVE-2015-0289.patch
    openssl-CVE-2015-0293.patch
* Wed Feb 04 2015 meissner@suse.com
  - The DATE stamp moved from crypto/Makefile to crypto/buildinf.h,
    replace it there (bsc#915947)
* Fri Jan 09 2015 meissner@suse.com
  - openssl 1.0.1k release
    bsc#912294 CVE-2014-3571: Fix DTLS segmentation fault in dtls1_get_record.
    bsc#912292 CVE-2015-0206: Fix DTLS memory leak in dtls1_buffer_record.
    bsc#911399 CVE-2014-3569: Fix issue where no-ssl3 configuration sets method to NULL.
    bsc#912015 CVE-2014-3572: Abort handshake if server key exchange
      message is omitted for ephemeral ECDH ciphersuites.
    bsc#912014 CVE-2015-0204: Remove non-export ephemeral RSA code on client and server.
    bsc#912293 CVE-2015-0205: Fixed issue where DH client certificates are accepted without verification.
    bsc#912018 CVE-2014-8275: Fix various certificate fingerprint issues.
    bsc#912296 CVE-2014-3570: Correct Bignum squaring.
    and other bugfixes.
  - openssl.keyring: use Matt Caswells current key.
    pub  2048R/0E604491 2013-04-30
    uid                            Matt Caswell <frodo@baggins.org>
    uid                            Matt Caswell <matt@openssl.org>
    sub  2048R/E3C21B70 2013-04-30
  - openssl-1.0.1e-fips.patch: rediffed
  - openssl-1.0.1i-noec2m-fix.patch: removed (upstream)
  - openssl-ocloexec.patch: rediffed
* Tue Nov 18 2014 brian@aljex.com
  - suse_version 10.1 & 10.2 x86_64 can not enable-ec_nistp_64_gcc_128
* Mon Nov 17 2014 meissner@suse.com
  - openssl-1.0.1i-noec2m-fix.patch: only report the Elliptic Curves
    we actually support (not the binary ones) (bnc#905037)
* Fri Nov 07 2014 brian@aljex.com
  - openSUSE < 11.2 doesn't have accept4()
* Tue Oct 21 2014 crrodriguez@opensuse.org
  - openSSL 1.0.1j
    * Fix SRTP Memory Leak (CVE-2014-3513)
    * Session Ticket Memory Leak (CVE-2014-3567)
    * Add SSL 3.0 Fallback protection (TLS_FALLBACK_SCSV)
    * Build option no-ssl3 is incomplete (CVE-2014-3568)
* Thu Aug 21 2014 meissner@suse.com
  - openssl.keyring: the 1.0.1i release was done by
    Matt Caswell <matt@openssl.org> UK 0E604491
* Thu Aug 14 2014 vcizek@suse.com
  - rename README.SuSE (old spelling) to README.SUSE (bnc#889013)
* Wed Aug 13 2014 vcizek@suse.com
  - update to 1.0.1i
    * Fix SRP buffer overrun vulnerability. Invalid parameters passed to the
      SRP code can be overrun an internal buffer. Add sanity check that
      g, A, B < N to SRP code.
      (CVE-2014-3512)
    * A flaw in the OpenSSL SSL/TLS server code causes the server to negotiate
      TLS 1.0 instead of higher protocol versions when the ClientHello message
      is badly fragmented. This allows a man-in-the-middle attacker to force a
      downgrade to TLS 1.0 even if both the server and the client support a
      higher protocol version, by modifying the client's TLS records.
      (CVE-2014-3511)
    * OpenSSL DTLS clients enabling anonymous (EC)DH ciphersuites are subject
      to a denial of service attack. A malicious server can crash the client
      with a null pointer dereference (read) by specifying an anonymous (EC)DH
      ciphersuite and sending carefully crafted handshake messages.
      (CVE-2014-3510)
    * By sending carefully crafted DTLS packets an attacker could cause openssl
      to leak memory. This can be exploited through a Denial of Service attack.
      (CVE-2014-3507)
    * An attacker can force openssl to consume large amounts of memory whilst
      processing DTLS handshake messages. This can be exploited through a
      Denial of Service attack.
      (CVE-2014-3506)
    * An attacker can force an error condition which causes openssl to crash
      whilst processing DTLS packets due to memory being freed twice. This
      can be exploited through a Denial of Service attack.
      (CVE-2014-3505)
    * If a multithreaded client connects to a malicious server using a resumed
      session and the server sends an ec point format extension it could write
      up to 255 bytes to freed memory.
      (CVE-2014-3509)
    * A malicious server can crash an OpenSSL client with a null pointer
      dereference (read) by specifying an SRP ciphersuite even though it was not
      properly negotiated with the client. This can be exploited through a
      Denial of Service attack.
      (CVE-2014-5139)
    * A flaw in OBJ_obj2txt may cause pretty printing functions such as
      X509_name_oneline, X509_name_print_ex et al. to leak some information
      from the stack. Applications may be affected if they echo pretty printing
      output to the attacker.
      (CVE-2014-3508)
    * Fix ec_GFp_simple_points_make_affine (thus, EC_POINTs_mul etc.)
      for corner cases. (Certain input points at infinity could lead to
      bogus results, with non-infinity inputs mapped to infinity too.)
  - refreshed patches:
    * openssl-1.0.1e-new-fips-reqs.patch
    * 0005-libssl-Hide-library-private-symbols.patch
      (thanks to Marcus Meissner)
* Mon Jul 21 2014 jengelh@inai.de
  - Move manpages around: *.1ssl should be in openssl
    (e.g. ciphers(1ssl) is also referenced by openssl(1)),
    and *.3ssl should be in openssl-doc.
* Tue Jun 24 2014 meissner@suse.com
  - recommend: ca-certificates-mozilla instead of openssl-certs
* Thu Jun 05 2014 meissner@suse.com
  - updated openssl to 1.0.1h (bnc#880891):
    - CVE-2014-0224: Fix for SSL/TLS MITM flaw. An attacker using a carefully crafted
      handshake can force the use of weak keying material in OpenSSL
      SSL/TLS clients and servers.
    - CVE-2014-0221: Fix DTLS recursion flaw. By sending an invalid DTLS handshake to an
      OpenSSL DTLS client the code can be made to recurse eventually crashing
      in a DoS attack.
    - CVE-2014-0195: Fix DTLS invalid fragment vulnerability. A buffer
      overrun attack can be triggered by sending invalid DTLS fragments to
      an OpenSSL DTLS client or server. This is potentially exploitable to
      run arbitrary code on a vulnerable client or server.
    - CVE-2014-3470: Fix bug in TLS code where clients enable anonymous
      ECDH ciphersuites are subject to a denial of service attack.
  - openssl-buffreelistbug-aka-CVE-2010-5298.patch: removed, upstream
  - CVE-2014-0198.patch: removed, upstream
  - 0009-Fix-double-frees.patch: removed, upstream
  - 0012-Fix-eckey_priv_encode.patch: removed, upstream
  - 0017-Double-free-in-i2o_ECPublicKey.patch: removed, upstream
  - 0018-fix-coverity-issues-966593-966596.patch: removed, upstream
  - 0020-Initialize-num-properly.patch: removed, upstream
  - 0022-bignum-allow-concurrent-BN_MONT_CTX_set_locked.patch: removed, upstream
  - 0023-evp-prevent-underflow-in-base64-decoding.patch: removed, upstream
  - 0024-Fixed-NULL-pointer-dereference-in-PKCS7_dataDecode-r.patch: removed, upstream
  - 0025-fix-coverity-issue-966597-error-line-is-not-always-i.patch: removed, upstream
  - 0001-libcrypto-Hide-library-private-symbols.patch: disabled heartbeat testcase
  - openssl-1.0.1c-ipv6-apps.patch: refreshed
  - openssl-fix-pod-syntax.diff: some stuff merged upstream, refreshed
* Wed May 21 2014 vpereira@novell.com
  - Added new SUSE default cipher suite
    openssl-1.0.1e-add-suse-default-cipher.patch
    openssl-1.0.1e-add-suse-default-cipher-header.patch
    openssl-1.0.1e-add-test-suse-default-cipher-suite.patch
* Fri May 09 2014 crrodriguez@opensuse.org
  - Add upstream patches fixing coverity scan issues:
    * 0018-fix-coverity-issues-966593-966596.patch
    * 0020-Initialize-num-properly.patch
    * 0022-bignum-allow-concurrent-BN_MONT_CTX_set_locked.patch
    * 0023-evp-prevent-underflow-in-base64-decoding.patch
    * 0024-Fixed-NULL-pointer-dereference-in-PKCS7_dataDecode-r.patch
    * 0025-fix-coverity-issue-966597-error-line-is-not-always-i.patch
  - Update 0001-libcrypto-Hide-library-private-symbols.patch
    to cover more private symbols, now 98% complete and probably
    not much more can be done to fix the rest of the ill-defined API.
  - openssl-fips-hidden.patch new, hides private symbols added by the
    FIPS patches.
  - openssl-no-egd.patch disable the EGD (entropy gathering daemon)
    interface, we have no EGD in the distro and obtaining entropy from
    a place other than /dev/*random, the hardware rng or the openSSL
    internal PRNG is an extremely bad & dangerous idea.
  - use secure_getenv instead of getenv everywhere.
* Mon May 05 2014 crrodriguez@opensuse.org
  -  0005-libssl-Hide-library-private-symbols.patch
    Update to hide more symbols that are not part of
    the public API
  - openssl-gcc-attributes.patch BUF_memdup also
    needs attribute alloc_size as it returns memory
    of size of the second parameter.
  - openssl-ocloexec.patch Update, accept()
    also needs O_CLOEXEC.
  - 0009-Fix-double-frees.patch, 0017-Double-free-in-i2o_ECPublicKey.patch
    fix various double frees (from upstream)
  - 012-Fix-eckey_priv_encode.patch eckey_priv_encode should
    return an error inmediately on failure of i2d_ECPrivateKey (from upstream)
  - 0001-Axe-builtin-printf-implementation-use-glibc-instead.patch
    From libressl, modified to work on linux systems that do not have
    funopen() but fopencookie() instead.
    Once upon a time, OS didn't have snprintf, which caused openssl to
    bundle a *printf implementation. We know better nowadays, the glibc
    implementation has buffer overflow checking, has sane failure modes
    deal properly with threads, signals..etc..
  - build with -fno-common as well.
* Mon May 05 2014 citypw@gmail.com
  - Fixed bug[ bnc#876282], CVE-2014-0198 openssl: OpenSSL NULL pointer dereference in do_ssl3_write
    Add file: CVE-2014-0198.patch
* Sun Apr 20 2014 crrodriguez@opensuse.org
  - Build everything with full RELRO (-Wl,-z,relro,-z,now)
  - Remove -fstack-protector from the hardcoded build options
    it is already in RPM_OPT_FLAGS and is replaced by
    - fstack-protector-strong with gcc 4.9
* Sun Apr 20 2014 crrodriguez@opensuse.org
  - Remove the "gmp" and "capi" shared engines, nobody noticed
    but they are just dummies that do nothing.
* Sat Apr 19 2014 crrodriguez@opensuse.org
  - Use enable-rfc3779 to allow projects such as rpki.net
    to work in openSUSE and match the functionality
    available in Debian/Fedora/etc
* Sat Apr 19 2014 crrodriguez@opensuse.org
  - openssl-buffreelistbug-aka-CVE-2010-5298.patch fix
    CVE-2010-5298 and disable the internal BUF_FREELISTS
    functionality. it hides bugs like heartbleed and is
    there only for systems on which malloc() free() are slow.
  - ensure we export MALLOC_CHECK and PERTURB during the test
    suite, now that the freelist functionality is disabled it
    will help to catch bugs before they hit users.
* Sat Apr 19 2014 crrodriguez@opensuse.org
  - openssl-libssl-noweakciphers.patch do not offer "export"
    or "low" quality ciphers by default. using such ciphers
    is not forbidden but requires an explicit request
* Fri Apr 18 2014 crrodriguez@opensuse.org
  - openssl-gcc-attributes.patch: fix thinko, CRYPTO_realloc_clean does
    not return memory of "num * old_num" but only "num" size
    fortunately this function is currently unused.
* Fri Apr 11 2014 crrodriguez@opensuse.org
  - openssl-gcc-attributes.patch
    * annotate memory allocation wrappers with attribute(alloc_size)
      so the compiler can tell us if it knows they are being misused
    * OPENSSL_showfatal is annotated with attribute printf to detect
      format string problems.
  - It is time to try to disable SSLv2 again, it was tried a while
    ago but broke too many things, nowadays Debian, Ubuntu, the BSDs
    all have disabled it, most components are already fixed.
    I will fix the remaining fallout if any. (email me)
* Tue Apr 08 2014 dmueller@suse.com
  - update to 1.0.1g:
    * fix for critical TLS heartbeat read overrun (CVE-2014-0160) (bnc#872299)
    * Fix for Recovering OpenSSL ECDSA Nonces (CVE-2014-0076) (bnc#869945)
    * Workaround for the "TLS hang bug" (see FAQ and PR#2771)
  - remove CVE-2014-0076.patch
  - openssl.keyring: upstream changed to:
    pub  4096R/FA40E9E2 2005-03-19 Dr Stephen N Henson <steve@openssl.org>
    uid                            Dr Stephen Henson <shenson@drh-consultancy.co.uk>
    uid                            Dr Stephen Henson <shenson@opensslfoundation.com>
* Tue Mar 25 2014 shchang@suse.com
  - Fix bug[ bnc#869945] CVE-2014-0076: openssl: Recovering OpenSSL ECDSA Nonces Using the FLUSH+RELOAD Cache Side-channel Attack
    Add file: CVE-2014-0076.patch
* Mon Mar 03 2014 shchang@suse.com
  - additional changes required for FIPS validation( from Fedora repo)
    Add patch file: openssl-1.0.1e-new-fips-reqs.patch
* Sat Jan 11 2014 shchang@suse.com
  - Remove GCC option "-O3" for compiliation issue of ARM version
    Modify: openssl.spec
* Fri Jan 10 2014 shchang@suse.com
  - Adjust the installation path( libopenssl/hmac into /lib or /lib64)
    Modify files: README-FIPS.txt openssl.spec
* Thu Jan 09 2014 andreas.stieger@gmx.de
  - 1.0.1f:
    * Fix for TLS record tampering bug CVE-2013-4353
  - already included:
    * Fix for TLS version checking bug CVE-2013-6449
    * Fix for DTLS retransmission bug CVE-2013-6450
  - removed patches:
    * CVE-2013-6449.patch, committed upstream
    * CVE-2013-6450.patch, committed upstream
    * SSL_get_certificate-broken.patch, committed upstream
    * openssl-1.0.1e-bnc822642.patch, committed upstream
  - modified patches:
    * openssl-1.0.1e-fips.patch, adjust for upstream changes
    * openssl-fix-pod-syntax.diff, adjust for upstream changes
* Wed Jan 08 2014 andreas.stieger@gmx.de
  - add a gpg keyring for source tarball
* Wed Jan 08 2014 shchang@suse.com
  - Fixed bnc#857850, openssl doesn't load engine
    Modify file: openssl.spec
* Thu Jan 02 2014 shchang@suse.com
  - Fixed bnc#857203, openssl: crash in DTLS renegotiation after packet loss
    Add file: CVE-2013-6450.patch
* Sun Dec 22 2013 shchang@suse.com
  - Fixed bnc#856687, openssl: crash when using TLS 1.2
    Add file: CVE-2013-6449.patch
* Tue Dec 17 2013 meissner@suse.com
  - compression_methods_switch.patch: setenv might not be successful
    if a surrounding library or application filters it, like e.g. sudo.
    As setenv() does not seem to be useful anyway, remove it.
    bnc#849377
* Mon Dec 16 2013 shchang@suse.com
  - Adjust the installation path.
    Modify files: README-FIPS.txt openssl.spec
* Fri Dec 06 2013 lnussel@suse.de
  - don't own /etc/ssl/certs, it's owned by ca-certificates
* Tue Dec 03 2013 meissner@suse.com
  - Actually enable it (in a building way) for openSUSE and SLES,
    as we intended.
  - Add README-FIPS.txt from SLE 11.
* Mon Dec 02 2013 crrodriguez@opensuse.org
  - Restrict the (broken beyond build) FIPS certification code
    to SLE releases only, it has no value in openSUSE at all.
* Sat Nov 23 2013 shchang@suse.com
  - Patches for OpenSSL FIPS-140-2/3 certification
    Add patch files: openssl-1.0.1e-fips.patch, openssl-1.0.1e-fips-ec.patch,
    openssl-1.0.1e-fips-ctor.patch
* Wed Oct 23 2013 crrodriguez@opensuse.org
  - 0001-libcrypto-Hide-library-private-symbols.patch
    This patch implements the libcrpto part complimentary to
    0005-libssl-Hide-library-private-symbols.patch.
    This patch is however not 100% complete, as some private library
    symbols are declared in public headers that shall not be touched
    or are defined/declared in "perlasm". (tested in 13.1, 12.3, factory)
  - openSSL defaults to -O3 optimization level but we override
    it with RPM_OPT_FLAGS, ensure we use -O3 like upstream.
* Fri Oct 11 2013 meissner@suse.com
  - openssl-1.0.1c-ipv6-apps.patch:
    Support ipv6 in the openssl s_client / s_server commandline app.
* Fri Sep 27 2013 dmacvicar@suse.de
  - VPN openconnect problem (DTLS handshake failed)
    (git 9fe4603b8, bnc#822642, openssl ticket#2984)
* Wed Sep 04 2013 guillaume@opensuse.org
  - Fix armv6l arch (armv7 was previously used to build armv6 which
    lead to illegal instruction when used)
* Mon Aug 12 2013 shchang@suse.com
  - Fix bug[ bnc#832833] openssl ssl_set_cert_masks() is broken
    modify patch file: SSL_get_certificate-broken.patch
* Fri Aug 09 2013 crrodriguez@opensuse.org
  - Via padlock is only found in x86 and x86_64 CPUs, remove
    the shared module for other archs.
* Wed Aug 07 2013 crrodriguez@opensuse.org
  - Cleanup engines that are of no use in a modern linux distro
  - The following engines stay:
    * libcapi.so --> usable in case you have third party /dev/crypto
    * libgmp.so --> may help to doing some maths using GMP
    * libgost.so --> implements the GOST block cipher
    * libpadlock.so --> VIA padlock support
  - Al other are removed because they require third party propietary
    shared libraries nowhere to be found or that we can test.
* Wed Aug 07 2013 crrodriguez@opensuse.org
  - openssl-pkgconfig.patch: Here we go.. For applications
    to benefit fully of features provided by openSSL engines
    (rdrand, aes-ni..etc) either builtin or in DSO form applications
    have to call ENGINE_load_builtin_engines() or OPENSSL_config()
    unfortunately from a total of 68 apps/libraries linked to libcrypto
    in a desktop system, only 4 do so, and there is a sea of buggy
    code that I dont feel like fixing.
    Instead we can pass -DOPENSSL_LOAD_CONF in the pkgconfig files
    so the needed operation becomes implicit the next time such apps
    are recompiled, see OPENSSL_config(3)
    Unfortunately this does not fix everything, because there are apps
    not using pkgconfig or using it incorrectly, but it is a good start.
* Wed Aug 07 2013 dmueller@suse.com
  - add openssl-1.0.1c-default-paths.patch:
    Fix from Fedora for openssl s_client not setting
    CApath by default
* Sat Aug 03 2013 crrodriguez@opensuse.org
  - 0005-libssl-Hide-library-private-symbols.patch: hide
    private symbols, this *only* applies to libssl where
    it is straightforward to do so as applications should
    not be using any of the symbols declared/defined in headers
    that the library does not install.
    A separate patch MAY be provided in the future for libcrypto
    where things are much more complicated and threfore requires
    careful testing.
* Mon Jul 29 2013 meissner@suse.com
  - compression_methods_switch.patch: Disable compression by default to
    avoid the CRIME attack (CVE-2012-4929 bnc#793420)
    Can be override by setting environment variable
      OPENSSL_NO_DEFAULT_ZLIB=no
* Tue Jul 02 2013 lnussel@suse.de
  - Don't use the legacy /etc/ssl/certs directory anymore but rather
    the p11-kit generated /var/lib/ca-certificates/openssl one
    (fate#314991, openssl-1.0.1e-truststore.diff)
* Sat Jun 29 2013 crrodriguez@opensuse.org
  - Build enable-ec_nistp_64_gcc_128, ecdh is many times faster
    but only works in x86_64.
    According to the openSSL team
    "it is superior to the default in multiple regards (speed, and also
    security as the new implementations are secure against timing
    attacks)"
    It is not enabled by default due to the build system being unable
    to detect if the compiler supports __uint128_t.
* Thu Jun 20 2013 coolo@suse.com
  - pick openssl-fix-pod-syntax.diff out of the upstream RT to fix
    build with perl 5.18
* Sat May 25 2013 i@marguerite.su
  - add %if tag for BuildArch. sles may also need latest openssl.
* Fri Feb 22 2013 dmueller@suse.com
  - disable fstack-protector on aarch64
* Tue Feb 12 2013 hrvoje.senjan@gmail.com
  - Update to 1.0.1e
    o Bugfix release (bnc#803004)
  - Drop openssl-1.0.1d-s3-packet.patch, included upstream
* Sun Feb 10 2013 hrvoje.senjan@gmail.com
  - Added openssl-1.0.1d-s3-packet.patch from upstream, fixes
    bnc#803004, openssl ticket#2975
* Tue Feb 05 2013 meissner@suse.com
  - update to version 1.0.1d, fixing security issues
    o Fix renegotiation in TLS 1.1, 1.2 by using the correct TLS version.
    o Include the fips configuration module.
    o Fix OCSP bad key DoS attack CVE-2013-0166
    o Fix for SSL/TLS/DTLS CBC plaintext recovery attack CVE-2013-0169
      bnc#802184
    o Fix for TLS AESNI record handling flaw CVE-2012-2686
* Mon Nov 12 2012 gjhe@suse.com
  - fix bug[bnc#784994] - VIA padlock support on 64 systems
    e_padlock: add support for x86_64 gcc
* Sun Aug 19 2012 crrodriguez@opensuse.org
  - Open Internal file descriptors with O_CLOEXEC, leaving
    those open across fork()..execve() makes a perfect
    vector for a side-channel attack...
* Tue Aug 07 2012 dmueller@suse.com
  - fix build on armv5 (bnc#774710)
* Thu May 10 2012 crrodriguez@opensuse.org
  - Update to version 1.0.1c for the complete list of changes see
    NEWS, this only list packaging changes.
  - Drop aes-ni patch, no longer needed as it is builtin in openssl
    now.
  - Define GNU_SOURCE and use -std=gnu99 to build the package.
  - Use LFS_CFLAGS in platforms where it matters.
* Fri May 04 2012 lnussel@suse.de
  - don't install any demo or expired certs at all
* Mon Apr 23 2012 gjhe@suse.com
  - update to latest stable verison 1.0.0i
    including the following patches:
    CVE-2012-2110.path
    Bug748738_Tolerate_bad_MIME_headers.patch
    bug749213-Free-headers-after-use.patch
    bug749210-Symmetric-crypto-errors-in-PKCS7_decrypt.patch
    CVE-2012-1165.patch
    CVE-2012-0884.patch
    bug749735.patch
* Tue Mar 27 2012 gjhe@suse.com
  - fix bug[bnc#749735] - Memory leak when creating public keys.
    fix bug[bnc#751977] - CMS and S/MIME Bleichenbacher attack
    CVE-2012-0884
* Thu Mar 22 2012 gjhe@suse.com
  - fix bug[bnc#751946] - S/MIME verification may erroneously fail
    CVE-2012-1165
* Wed Mar 21 2012 gjhe@suse.com
  - fix bug[bnc#749213]-Free headers after use in error message
    and bug[bnc#749210]-Symmetric crypto errors in PKCS7_decrypt
* Tue Mar 20 2012 cfarrell@suse.com
  - license update: OpenSSL
* Fri Feb 24 2012 gjhe@suse.com
  - fix bug[bnc#748738] - Tolerate bad MIME headers in openssl's
    asn1 parser.
    CVE-2006-7250
* Thu Feb 02 2012 gjhe@suse.com
  - Update to version 1.0.0g fix the following:
    DTLS DoS attack (CVE-2012-0050)
* Wed Jan 11 2012 gjhe@suse.com
  - Update to version 1.0.0f fix the following:
    DTLS Plaintext Recovery Attack (CVE-2011-4108)
    Uninitialized SSL 3.0 Padding (CVE-2011-4576)
    Malformed RFC 3779 Data Can Cause Assertion Failures (CVE-2011-4577)
    SGC Restart DoS Attack (CVE-2011-4619)
    Invalid GOST parameters DoS Attack (CVE-2012-0027)
* Tue Oct 18 2011 crrodriguez@opensuse.org
  - AES-NI: Check the return value of Engine_add()
    if the ENGINE_add() call fails: it ends up adding a reference
    to a freed up ENGINE which is likely to subsequently contain garbage
    This will happen if an ENGINE with the same name is added multiple
    times,for example different libraries. [bnc#720601]
* Sat Oct 08 2011 crrodriguez@opensuse.org
  - Build with -DSSL_FORBID_ENULL so servers are not
    able to use the NULL encryption ciphers (Those offering no
    encryption whatsoever).
* Wed Sep 07 2011 crrodriguez@opensuse.org
  - Update to openssl 1.0.0e fixes CVE-2011-3207 and CVE-2011-3210
    see http://openssl.org/news/secadv_20110906.txt for details.
* Sat Aug 06 2011 crrodriguez@opensuse.org
  - Add upstream patch that calls ENGINE_register_all_complete()
    in ENGINE_load_builtin_engines() saving us from adding dozens
    of calls to such function to calling applications.
* Fri Aug 05 2011 crrodriguez@opensuse.org
  - remove -fno-strict-aliasing from CFLAGS no longer needed
    and is likely to slow down stuff.
* Mon Jul 25 2011 jengelh@medozas.de
  - Edit baselibs.conf to provide libopenssl-devel-32bit too
* Fri Jun 24 2011 gjhe@novell.com
  - update to latest stable version 1.0.0d.
    patch removed(already in the new package):
    CVE-2011-0014
    patch added:
    ECDSA_signatures_timing_attack.patch
* Tue May 31 2011 gjhe@novell.com
  - fix bug[bnc#693027].
    Add protection against ECDSA timing attacks as mentioned in the paper
    by Billy Bob Brumley and Nicola Tuveri, see:
    http://eprint.iacr.org/2011/232.pdf
    [Billy Bob Brumley and Nicola Tuveri]
* Mon May 16 2011 andrea@opensuse.org
  - added openssl as dependency in the devel package
* Thu Feb 10 2011 gjhe@novell.com
  - fix bug [bnc#670526]
    CVE-2011-0014,OCSP stapling vulnerability
* Sat Jan 15 2011 cristian.rodriguez@opensuse.org
  - Add patch from upstream in order to support AES-NI instruction
    set present on current Intel and AMD processors
* Mon Jan 10 2011 meissner@suse.de
  - enable -DPURIFY to avoid valgrind errors.
* Thu Dec 09 2010 gjhe@novell.com
  - update to stable version 1.0.0c.
    patch included:
    CVE-2010-1633_and_CVE-2010-0742.patch
    patchset-19727.diff
    CVE-2010-2939.patch
    CVE-2010-3864.patch
* Thu Nov 18 2010 gjhe@novell.com
  - fix bug [bnc#651003]
    CVE-2010-3864
* Sat Sep 25 2010 gjhe@novell.com
  - fix bug [bnc#629905]
    CVE-2010-2939
* Wed Jul 28 2010 cristian.rodriguez@opensuse.org
  - Exclude static libraries, see what breaks and fix that
    instead
* Wed Jun 30 2010 jengelh@medozas.de
  - fix two compile errors on SPARC
* Tue Jun 15 2010 bg@novell.com
  - -fstack-protector is not supported on hppa
* Fri Jun 04 2010 gjhe@novell.com
  - fix bnc #610642
    CVE-2010-0742
    CVE-2010-1633
* Mon May 31 2010 gjhe@novell.com
  - fix bnc #610223,change Configure to tell openssl to load engines
    from /%{_lib} instead of %{_libdir}
* Mon May 10 2010 aj@suse.de
  - Do not compile in build time but use mtime of changes file instead.
    This allows build-compare to identify that no changes have happened.
* Tue May 04 2010 gjhe@novell.com
  - build libopenssl to /%{_lib} dir,and keep only one
    libopenssl-devel for new developping programs.
* Tue Apr 27 2010 gjhe@novell.com
  - build libopenssl and libopenssl-devel to a version directory
* Sat Apr 24 2010 coolo@novell.com
  - buildrequire pkg-config to fix provides
* Wed Apr 21 2010 lnussel@suse.de
  - also create old certificate hash in /etc/ssl/certs for
    compatibility with applications that still link against 0.9.8
* Mon Apr 12 2010 meissner@suse.de
  - Disable our own build targets, instead use the openSSL provided ones
    as they are now good (or should be good at least).
  - add -Wa,--noexecstack to the Configure call, this is the upstream
    approved way to avoid exec-stack marking
* Mon Apr 12 2010 gjhe@novell.com
  - update to 1.0.0
    Merge the following patches from 0.9.8k:
    openssl-0.9.6g-alpha.diff
    openssl-0.9.7f-ppc64.diff
    openssl-0.9.8-flags-priority.dif
    openssl-0.9.8-sparc.dif
    openssl-allow-arch.diff
    openssl-hppa-config.diff
* Fri Apr 09 2010 meissner@suse.de
  - fixed "exectuable stack" for libcrypto.so issue on i586 by
    adjusting the assembler output during MMX builds.
* Wed Apr 07 2010 meissner@suse.de
  - Openssl is now partially converted to libdir usage upstream,
    merge that in to fix lib64 builds.
* Thu Mar 25 2010 gjhe@novell.com
  - fix security bug [bnc#590833]
    CVE-2010-0740
* Mon Mar 22 2010 gjhe@novell.com
  - update to version 0.9.8m
    Merge the following patches from 0.9.8k:
    bswap.diff
    non-exec-stack.diff
    openssl-0.9.6g-alpha.diff
    openssl-0.9.7f-ppc64.diff
    openssl-0.9.8-flags-priority.dif
    openssl-0.9.8-sparc.dif
    openssl-allow-arch.diff
    openssl-hppa-config.diff
* Fri Feb 05 2010 jengelh@medozas.de
  - build openssl for sparc64
* Mon Dec 14 2009 jengelh@medozas.de
  - add baselibs.conf as a source
  - package documentation as noarch
* Tue Nov 03 2009 coolo@novell.com
  - updated patches to apply with fuzz=0
* Tue Sep 01 2009 gjhe@novell.com
  - fix Bug [bnc#526319]
* Wed Aug 26 2009 coolo@novell.com
  - use %patch0 for Patch0
* Fri Jul 03 2009 gjhe@novell.com
  - update to version 0.9.8k
  - patches merged upstream:
    openssl-CVE-2008-5077.patch
    openssl-CVE-2009-0590.patch
    openssl-CVE-2009-0591.patch
    openssl-CVE-2009-0789.patch
    openssl-CVE-2009-1377.patch
    openssl-CVE-2009-1378.patch
    openssl-CVE-2009-1379.patch
    openssl-CVE-2009-1386.patch
    openssl-CVE-2009-1387.patch
* Tue Jun 30 2009 gjhe@novell.com
  - fix security bug [bnc#509031]
    CVE-2009-1386
    CVE-2009-1387
* Tue Jun 30 2009 gjhe@novell.com
  - fix security bug [bnc#504687]
    CVE-2009-1377
    CVE-2009-1378
    CVE-2009-1379
* Wed Apr 15 2009 gjhe@suse.de
  - fix security bug [bnc#489641]
    CVE-2009-0590
    CVE-2009-0591
    CVE-2009-0789

Files

/usr/lib64/engines-1.1
/usr/lib64/engines-1.1/afalg.so
/usr/lib64/engines-1.1/capi.so
/usr/lib64/engines-1.1/padlock.so
/usr/lib64/libcrypto.so.1.1
/usr/lib64/libssl.so.1.1
/usr/share/licenses/libopenssl1_1
/usr/share/licenses/libopenssl1_1/LICENSE


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 12 00:08:56 2019