Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

NetworkManager-strongswan-gnome-1.4.4-2.3 RPM for armv6hl

From OpenSuSE Ports Tumbleweed for armv6hl

Name: NetworkManager-strongswan-gnome Distribution: openSUSE Tumbleweed
Version: 1.4.4 Vendor: openSUSE
Release: 2.3 Build date: Sun Apr 21 01:31:41 2019
Group: Productivity/Networking/System Build host: armbuild15
Size: 45408 Source RPM: NetworkManager-strongswan-1.4.4-2.3.src.rpm
Packager: http://bugs.opensuse.org
Url: http://www.strongswan.org/
Summary: NetworkManager VPN support for strongSwan
NetworkManager-strongswan provides VPN support to NetworkManager for
strongSwan.

Provides

Requires

License

GPL-2.0-or-later

Changelog

* Mon Jun 11 2018 bjorn.lie@gmail.com
  - Fix packaging error in previous sub, README was moved from
    source1 tag to source3, move to tag source99 to avoid similar
    error in the future.
* Wed May 23 2018 kbabioch@suse.com
  - Use OpenPGP signature provided upstream
  - Added NetworkManager-strongswan.keyring, which contains the key
    from the author
* Wed May 09 2018 bjorn.lie@gmail.com
  - Update to version 1.4.4:
    + Fixed paths when building without libnm-glib.
    + Fixed proposal tooltips.
    + Updated translations.
* Tue Apr 17 2018 bjorn.lie@gmail.com
  - Pass --without-libnm-glib, no longer build deprecated libnm-glib
    support, following this, drop pkgconfig(NetworkManager),
    pkgconfig(libnm-glib), pkgconfig(libnm-glib-vpn),
    pkgconfig(libnm-gtk) and pkgconfig(libnm-util) BuildRequires.
  - Add pkgconfig(libnm) BuildRequires.
  - Add explicit --with-charon=%%{_libexecdir}/ipsec/charon-nm to
    configure.
  - Drop unneeded NetworkManager-gnome Requires from gnome
    sub-package, it is no longer of use for us.
* Wed Mar 07 2018 bjorn.lie@gmail.com
  - Update to version 1.4.3:
    + Add option to disable libnm-glib compatibility.
* Wed Feb 28 2018 dimstar@opensuse.org
  - Modernize spec-file by calling spec-cleaner
* Thu Sep 07 2017 zaitor@opensuse.org
  - Update to version 1.4.2:
    + Add support to configure IKE/ESP proposals.
    + Explicitly prevent PIN from getting stored.
* Fri Oct 28 2016 zaitor@opensuse.org
  - Update to version 1.4.1:
    + Fixed several build issues.
* Fri Sep 09 2016 zaitor@opensuse.org
  - Update to version 1.4.0:
    + Updated to NetworkManager 1.2.
  - Changes from version 1.3.2:
    + GUI fix.
    + Update to libsecret.
    + D-Bus policy moved to charon-nm.
  - Modify BuildRequires following upstreams changes:
    + Drop: pkgconfig(gnome-keyring-1), pkgconfig(gtk+-2.0),
      pkgconfig(dbus-glib-1) and pkgconfig(libgnomeui-2.0).
    + Add pkgconfig, pkgconfig(libnm-gtk), pkgconfig(libnma),
      pkgconfig(gtk+-3.0) and pkgconfig(libsecret-1).
  - Drop nm-strongswan-service-conf.patch,
    nm-strongswan-fix-config.patch and nm-strongswan-UI-fixup.patch.
  - Drop libtool BuildRequires and autoreconf call, we no longer
    carry any patches.
* Tue Sep 08 2015 dimstar@opensuse.org
  - Add nm-strongswan-fix-config.patch: Fix path to NM plugins in
    config files (boo#944769).
  - Add nm-strongswan-UI-fixup.patch: Fix broken UI (boo#944769).
  - Add libtool BuildRequires and call to autoreconf, as above patch
    touches the build system.
* Wed Jun 10 2015 dimstar@opensuse.org
  - Drop the sed hack to fix bnc#824079: since verson 1.3.1, the
    charon binary to be found is already called charon-nm by
    upstream (boo#934129).
  - Clean out conditions for legacy openSUSE versions: we will always
    require strongswan > 5 as a consequence (which is correct, as
    that's when charon-nm was introduced).

Files

/usr/lib/NetworkManager/nm-strongswan-auth-dialog
/usr/share/appdata/NetworkManager-strongswan.appdata.xml
/usr/share/gnome-vpn-properties
/usr/share/gnome-vpn-properties/strongswan
/usr/share/gnome-vpn-properties/strongswan/nm-strongswan-dialog.ui


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Jul 10 12:35:37 2019