Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libgpg-error0-1.29-lp152.3.1 RPM for aarch64

From OpenSuSE Ports Leap 15.2 for aarch64

Name: libgpg-error0 Distribution: openSUSE:Leap:15.2:ARM / ports
Version: 1.29 Vendor: openSUSE
Release: lp152.3.1 Build date: Tue Jul 23 13:00:58 2019
Group: Development/Libraries/C and C++ Build host: obs-arm-8
Size: 569983 Source RPM: libgpg-error-1.29-lp152.3.1.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.gnupg.org/
Summary: Library That Defines Common Error Values for All GnuPG Components
This is a library that defines common error values for all GnuPG
components.  Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
pinentry, SmartCard Daemon, and possibly more in the future.

Provides

Requires

License

GPL-2.0-or-later AND LGPL-2.1-or-later

Changelog

* Thu Apr 19 2018 astieger@suse.com
  - update signature files as more signatures got added
  - refresh package signing keyring from upstream
* Wed Apr 11 2018 kbabioch@suse.com
  - Cleaned up spec file with spec-cleaner
* Wed Apr 11 2018 kbabioch@suse.com
  - Update to 1.29:
    * The yat2m tool is during cross-compile now also installed on the
    host platform.
    * New option parser and associated functions similar to the one used
    by GnuPG.
    * New Base-64 encoder.
    * Fixes regression in 1.28 for arm64 and w64 builds.
  - Dropped fix_aarch64.patch (included upstream now)
* Thu Mar 22 2018 guillaume.gardet@opensuse.org
  - Backport upstream patch to fix AArch64 build:
    * fix_aarch64.patch
* Tue Mar 13 2018 kbabioch@suse.com
  - update to 1.28:
    * The formerly internal yat2m tool is now installed for a native build.
    * The new files gpgrt.m4 and gpgrt-config are now installed. They can
      be used instead of gpg-error.m4 and gpg-error-config.
    * New logging functions similar to those used by GnuPG.
    * New helper functions for platform abstraction.
    * Interface changes
* Tue Mar 07 2017 astieger@suse.com
  - update to 1.27:
    * Added a Base64 decoder.
    * Added support for the sh3 architecture.
    * Added header gpgrt.h as an alias for gpg-error.h.
    * Fixed macro GPGRT_GCC_VERSION.
    * Interface changes relative to the 1.26 release:
    gpgrt_b64state_t                 NEW type.
    gpgrt_b64dec_start               NEW.
    gpgrt_b64dec_proc                NEW.
    gpgrt_b64dec_finish              NEW.
    GPG_ERR_WRONG_NAME               NEW.
    gpgrt.h                          NEW header.
* Thu Dec 22 2016 astieger@suse.com
  - update to 1.26:
    * New option --desc for gpg-error.
    * Interface changes relative to the 1.25 release:
    GPG_ERR_UNKNOWN_FLAG         NEW.
    GPG_ERR_INV_ORDER            NEW.
    GPG_ERR_ALREADY_FETCHED      NEW.
    GPG_ERR_TRY_LATER            NEW.
    GPG_ERR_SYSTEM_BUG           NEW.
    GPG_ERR_DNS_UNKNOWN          NEW.
    GPG_ERR_DNS_SECTION          NEW.
    GPG_ERR_DNS_ADDRESS          NEW.
    GPG_ERR_DNS_NO_QUERY         NEW.
    GPG_ERR_DNS_NO_ANSWER        NEW.
    GPG_ERR_DNS_CLOSED           NEW.
    GPG_ERR_DNS_VERIFY           NEW.
    GPG_ERR_DNS_TIMEOUT          NEW.
* Tue Nov 15 2016 astieger@suse.com
  - update to 1.25:
    * New interface gpgrt_get_syscall_clamp to allow libaries to make
      use of Libgpg-error's system call wrapper functions.
    * Fixed bug in the locking code when used with the nPth threading
      library.
    * Added new error codes.
    * Interface changes relative to the 1.23 release:
      gpgrt_get_syscall_clamp          NEW.
      GPG_ERR_ENGINE_TOO_OLD	     NEW.
      GPG_ERR_WINDOW_TOO_SMALL         NEW.
      GPG_ERR_WINDOW_TOO_LARGE         NEW.
      GPG_ERR_MISSING_ENVVAR	     NEW.
      GPG_ERR_USER_ID_EXISTS           NEW.
      GPG_ERR_NAME_EXISTS              NEW.
      GPG_ERR_DUP_NAME                 NEW.
      GPG_ERR_TOO_OLD                  NEW.
      GPG_ERR_TOO_YOUNG                NEW.
* Mon Jul 18 2016 astieger@suse.com
  - update to 1.24:
    * Fixes a bug in es_fclose_snatch when used used after es_fseek.
    * Fixes building without thread support.
    * New configure option --disable-tests.
* Wed Jun 15 2016 astieger@suse.com
  - update to 1.23:
    * Fixes an assertion failure due to es_flush on read/write streams.
    * Fixes a bug with a too short memory limit is es_fopenmen.
    * Interface changes relative to the 1.22 release:
      GPG_ERR_SUBKEYS_EXP_OR_REV       NEW.
* Fri Apr 29 2016 astieger@suse.com
  - update to 1.22:
    * Support for LeakSanitizer with the gpgrt_annotate_leaked_object
      inline function.
    * Interface changes relative to the 1.21 release:
      GPG_ERR_DB_CORRUPTED             NEW.
      gpgrt_annotate_leaked_object     NEW inline func.
      GPGRT_ENABLE_W32_ICONV_MACROS    NEW.
      gpgrt_w32_iconv_open             NEW.
      gpgrt_w32_iconv_close            NEW.
      gpgrt_w32_iconv                  NEW.
* Mon Dec 14 2015 astieger@suse.com
  - update to 1.21:
    * New functions gpgrt_poll and gpgrt_set_nonblock.  For now only
      pipes and sockets on Unix are supported.
    * Interface changes relative to the 1.20 release:
      gpgrt_set_nonblock               NEW.
      gpgrt_get_nonblock               NEW.
      gpgrt_poll                       NEW.
      gpgrt_poll_t                     NEW type.
      es_poll_t                        NEW type.
      es_set_nonblock                  NEW macro.
      es_get_nonblock                  NEW macro.
      es_poll                          NEW macro.
      GPG_ERR_TRUE                     NEW.
      GPG_ERR_FALSE                    NEW.
      GPG_ERR_NO_NAME                  NEW.
      GPG_ERR_NO_KEY                   NEW.
      GPG_ERR_SERVER_FAILED            NEW.
* Wed Aug 26 2015 astieger@suse.com
  - update to 1.20:
    * New macros for GCC attributes.
    * Allow building without thread support.
    * Build without a build timestamp by default.
    * Interface changes relative to the 1.19 release:
    GPGRT_VERSION                    NEW macro.
    GPGRT_VERSION_NUMBER             NEW macro.
    GPGRT_INLINE                     NEW macro.
    GPGRT_GCC_VERSION                NEW macro.
    GPGRT_ATTR_NORETURN              NEW macro.
    GPGRT_ATTR_PRINTF                NEW macro.
    GPGRT_ATTR_NR_PRINTF             NEW macro.
    GPGRT_ATTR_FORMAT_ARG            NEW macro.
    GPGRT_ATTR_SENTINEL              NEW macro.
    GPGRT_ATTR_USED                  NEW macro.
    GPGRT_ATTR_UNUSED                NEW macro.
    GPGRT_ATTR_DEPRECATED            NEW macro.
    GPGRT_ATTR_PURE                  NEW macro.
    GPGRT_ATTR_MALLOC                NEW macro.
    GPGRT_HAVE_MACRO_FUNCTION        NEW macro.
    GPGRT_HAVE_PRAGMA_GCC_PUSH       NEW macro.
* Fri Apr 10 2015 astieger@suse.com
  - update to 1.19:
    * New set of error codes for use with LDAP.
    * New options --help and --defines for gpg-error.
    * Allow building with gcc 5.
    (replacing patch libgpg-error-1.18-gcc5.patch now removed)
    * Interface changes relative to the 1.18 release:
    GPG_ERR_LDAP_*                   NEW.
* Thu Mar 19 2015 astieger@suse.com
  - remove libtool requirement
* Thu Feb 19 2015 rguenther@suse.com
  - Add libgpg-error-1.18-gcc5.patch to pass -P to the preprocessor
    when generating files to deal with C preprocessor changes in GCC 4.9 and up.
* Mon Jan 26 2015 andreas.stieger@gmx.de
  - update to 1.18:
    * New translations for Hungarian, Portuguese, Russian, and
    traditional Chinese.  Updated other translations.
    * New error codes.
    * Interface changes relative to the 1.17 release:
    GPG_ERR_FORBIDDEN                NEW.
    GPG_ERR_OBJ_TERM_STATE           NEW.
    GPG_ERR_REQUEST_TOO_SHORT        NEW.
    GPG_ERR_REQUEST_TOO_LONG         NEW.
    GPG_ERR_LEGACY_KEY               NEW.
* Wed Oct 15 2014 andreas.stieger@gmx.de
  - update to 1.17:
    * New error codes for TLS protocol libraries.
    * New configure option --enable-build-timestamp.
    * New man page for gpg-error-config.
    * Interface changes relative to the 1.16 release:
    GPG_ERR_SOURCE_TLS               NEW.
    GPG_ERR_NO_CERT_CHAIN            NEW.
    GPG_ERR_CERT_TOO_LARGE	          NEW.
    GPG_ERR_INV_RECORD               NEW.
    GPG_ERR_BAD_MAC	          NEW.
    GPG_ERR_UNEXPECTED_MSG           NEW.
    GPG_ERR_COMPR_FAILED             NEW.
    GPG_ERR_WOULD_WRAP               NEW.
    GPG_ERR_FATAL_ALERT              NEW.
    GPG_ERR_NO_CIPHER                NEW.
    GPG_ERR_MISSING_CLIENT_CERT      NEW.
    GPG_ERR_CLOSE_NOTIFY             NEW.
    GPG_ERR_TICKET_EXPIRED           NEW.
    GPG_ERR_BAD_TICKET               NEW.
    GPG_ERR_UNKNOWN_IDENTITY         NEW.
    GPG_ERR_BAD_HS_CERT              NEW.
    GPG_ERR_BAD_HS_CERT_REQ          NEW.
    GPG_ERR_BAD_HS_CERT_VER          NEW.
    GPG_ERR_BAD_HS_CHANGE_CIPHER     NEW.
    GPG_ERR_BAD_HS_CLIENT_HELLO      NEW.
    GPG_ERR_BAD_HS_SERVER_HELLO      NEW.
    GPG_ERR_BAD_HS_SERVER_HELLO_DONE NEW.
    GPG_ERR_BAD_HS_FINISHED          NEW.
    GPG_ERR_BAD_HS_SERVER_KEX        NEW.
    GPG_ERR_BAD_HS_CLIENT_KEX        NEW.
    GPG_ERR_BOGUS_STRING             NEW.
    gpgrt_pending                    NEW.
    gpgrt_pending_unlocked           NEW.
  - Build with --enable-build-timestamp=no to prevent unneccessary
    rebuilds of dependent packages
  - add required spec for introducted info page

Files

/usr/lib64/libgpg-error.so.0
/usr/lib64/libgpg-error.so.0.24.0
/usr/share/locale/cs/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/da/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/de/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/eo/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/fr/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/hu/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/it/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/ja/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/nl/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/pl/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/pt/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/ro/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/ru/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/sr/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/sv/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/uk/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/vi/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/zh_CN/LC_MESSAGES/libgpg-error.mo
/usr/share/locale/zh_TW/LC_MESSAGES/libgpg-error.mo


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Nov 10 14:55:12 2019