Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

libbrlapi0_6-5.5-lp151.4.3 RPM for armv7hl

From OpenSuSE Ports Leap 15.1 for armv7hl

Name: libbrlapi0_6 Distribution: openSUSE Leap 15.1
Version: 5.5 Vendor: openSUSE
Release: lp151.4.3 Build date: Fri Apr 26 11:54:50 2019
Group: System/Daemons Build host: obs-arm-5
Size: 110117 Source RPM: brltty-5.5-lp151.4.3.src.rpm
Packager: https://bugs.opensuse.org
Url: http://mielke.cc/brltty/
Summary: Library to use BRLTTY from applications
BrlAPI is a service provided by the brltty daemon.

Its purpose is to allow programmers to write applications that take
advantage of a braille terminal in order to deliver a blind user
suitable information for his/her specific needs.

While an application communicates with the braille terminal, everything
brltty sends to the braille terminal in the application's console is
ignored, whereas each piece of data coming from the braille terminal is
sent to the application, rather than to brltty.

Provides

Requires

License

GPL-2.0+

Changelog

* Wed Jan 03 2018 mgorse@suse.com
  - Fix %pre, %post, and %postun: brltty.service is now
    brltty@.service (boo#1074096).
* Tue Dec 05 2017 cbosdonnat@suse.com
  - Drop python2 dependency (fate#323526)
* Fri Sep 01 2017 mgorse@suse.com
  - Update to version 5.5
    +  HandyTech's Actilino is supported.
    +  HumanWare's Braille Note Touch is supported.
    +  The Orbit 20 is supported.
    + Various other changes; please read ChangeLog :
  - Drop brltty-udev-rule.patch, brltty-polkit-fixes.patch,
    brltty-5.0-speechd.diff,
    brltty-5.4-latex-tables-executable.patch,
    brltty-braillenote-usb.patch, brltty.format-error.patch,
    brltty.makedev.patch, and brltty.ocaml.patch: fixed upstream.
  - Add brltty-5.5-systemd-install.patch: fix systemd service
    directory on lib64
  - polkit policy is now named org.a11y.brlapi.policy
  - API version is now 0.6.6
  - Don't create rcbrltty (why were we symlinking a systemd unit
    file here? Seems wrong)
* Thu Aug 10 2017 olaf@aepfle.de
  - Update filename in /var/adm/update-messages to match documentation,
    and build-compare pattern
* Tue Jul 18 2017 olaf@aepfle.de
  - Provide caml__frame with brltty.ocaml.patch
* Fri Jun 09 2017 tchvatal@suse.com
  - Require java-devel >= 1.6 to not fail during bootstrapping
* Tue Mar 21 2017 mgorse@suse.com
  - Replace brltty.format-error.patch with the upstream fix; our
    current patch doesn't appear to be sufficient (boo#1030240).
* Tue Mar 21 2017 olaf@aepfle.de
  - Add -Wformat to work around build failure (boo#1030240)
    Add brltty.format-error.patch
    Add brltty.makedev.patch
* Tue Feb 14 2017 mgorse@suse.com
  - Disable udev rule for generic FTDI devices to avoid taking
    USB-to-serial converters (boo#1007652). Add an update
    message if one of these devices is detected.
  - Add a README.SUSE.
  - Add brltty-polkit-fixes.patch:  don't delay brltty if waiting
    for polkit initialization, and fix polkit+key authentication
    (bsc#930242).
  - Add brltty-braillenote-usb.patch: autodetect BrailleNote via
    USB.
  - Always enable polkit (intention of the conditional was to
    disable on 13.2 and 42.1, but it was being disabled under 42.2
    as well).
* Mon Nov 07 2016 olaf@aepfle.de
  - Fix syntax error in rule files
    brltty-udev-rule.patch
* Fri Sep 16 2016 mgorse@suse.com
  - Update to version 5.4
    + Too many changes; please read ChangeLog :
  - Drop b40-1.patch, brltty-polkit.patch, and
    brltty-5.3.1-udev-systemd.patch: fixed upstream.
  - Add brltty-5.4-latex-tables-executable.patch: LaTeX tables
    should be executable.
  - API version is now 0.6.5
  - Install rules file into %{_udevdir}/rules.d
  - Install systemd files via the Makefile
  - Make polkit a conditional.
* Thu Sep 15 2016 mgorse@suse.com
  - Install polkit file (bsc#930242).
  - Add brltty-5.3.1-udev-systemd.patch: fix udev rules to work with
    systemd. From upstream.
* Sun Jun 19 2016 jengelh@inai.de
  - Add missing service_add_pre call. Add missing argument to fdupes.
  - Fix misplacement of /69-brltty.rules in the root directory
    because pkgconfig(udev) was not requested, which led to _udevdir
    being the empty string.
* Tue Jun 07 2016 mgorse@suse.com
  - Update to version 5.3.1 (fate#320893).
    + Too many changes; please read ChangeLog :
      usr/share/doc/packages/brltty/ChangeLog
  - API version is now 0.6.4
  - Require systemd to build
  - Install brltty-atb, brltty-ktb, and brltty-tune (new binaries)
  - Add b40-1.patch - fix for invalid packets from a Brailliant
  - Add brltty-polkit.patch: support polkit-based authentication for brlapi.
    Install policy file
    Set polkit as default brlapi authentication mechanism
  - Install udev rules
* Tue Feb 10 2015 mgorse@suse.com
  - Modify systemd service file to correct brltty path (boo#917176).
* Tue Dec 23 2014 p.drouand@gmail.com
  - Add a dependency to python3 for building; brltty fails in his staging
    project because of mssing python3-xml module
* Fri Dec 19 2014 p.drouand@gmail.com
  - Update to version 5.2
    + Too many changes; please read ChangeLog :
      usr/share/doc/packages/brltty/ChangeLog
  - API version is now 0.6.3
  - Remove obsolete patches;
    + brltty-python-prefix.patch
    + brltty-5.1-fix-bashisms.patch
* Sun Nov 16 2014 Led <ledest@gmail.com>
  - fix bashisms in brltty-install script
  - add patches:
    * brltty-5.1-fix-bashisms.patch
* Sun Oct 19 2014 crrodriguez@opensuse.org
  - Replace xorg-x11-devel by specific individual pkgconfig()
    buildrequires.

Files

/etc/brlapi.key
/usr/lib/libbrlapi.so.0.6
/usr/lib/libbrlapi.so.0.6.6
/usr/share/doc/packages/libbrlapi0_6
/usr/share/doc/packages/libbrlapi0_6/Manual-BrlAPI
/usr/share/doc/packages/libbrlapi0_6/Manual-BrlAPI/English
/usr/share/doc/packages/libbrlapi0_6/Manual-BrlAPI/English/BrlAPI.html
/usr/share/doc/packages/libbrlapi0_6/Manual-BrlAPI/English/BrlAPI.txt


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon Feb 10 08:50:40 2020