Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ladspa-1.13-lp150.2.4 RPM for ppc64le

From OpenSuSE Ports Leap 15.0 for ppc64le

Name: ladspa Distribution: openSUSE Leap 15.0
Version: 1.13 Vendor: openSUSE
Release: lp150.2.4 Build date: Wed May 9 01:06:12 2018
Group: Productivity/Multimedia/Sound/Utilities Build host: obs-power8-03
Size: 541903 Source RPM: ladspa-1.13-lp150.2.4.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.ladspa.org/
Summary: The Linux Audio Developer's Simple Plug-In API
The Linux Audio Developer's Simple Plug-in API (LADSPA) provides the
ability to write simple plug-in audio processors in C/C++ and link them
dynamically.  This package contains the plugins built from LADSPA SDK.

Provides

Requires

License

LGPL-2.1+

Changelog

* Sat Nov 04 2017 davejplater@gmail.com
  - Add ladspa-find-plugin-path.patch to enable listplugins to find
    plugins without LADSPA_PATH variable set.
  - Add ladspa-pie.patch to enable position independent executables.
* Mon Mar 03 2014 tiwai@suse.de
  - package the original tarball instead of re-packed tar.bz2
* Sat Mar 01 2014 andreas.stieger@gmx.de
  - some spec file cleanup
  - add source URLs, see https://en.opensuse.org/SourceUrls
* Mon Dec 16 2013 tiwai@suse.de
  - Split to each plugin sub-package; also fix the self-dependency
    on ladspa-devel
  - Fix build with SLE11 targets
* Wed Dec 04 2013 tiwai@suse.de
  - Merge ladspa-devel.spec into ladspa.spec; back to root, as OBS
    doesn't like split packages (the submitreq always declined),
    and the development activity of this package is pretty low, so
    no worth to resist
* Thu Sep 26 2013 tiwai@suse.de
  - caps-fix-double-free.diff:
    Fix double free in destructor of caps plugin (bnc#842420)
* Tue Feb 14 2012 coolo@suse.com
  - remove old %suse_update_config
* Thu Feb 09 2012 reddwarf@opensuse.org
  - Remove swh-configure-2.65.patch for >12.1
* Sun Nov 13 2011 coolo@suse.com
  - add libtool as explicit buildrequire to avoid implicit dependency from prjconf
* Sun May 01 2011 toddrme2178@gmail.com
  - Added 32bit compatibility libraries
  - Removed tests for obsolete openSUSE versions
  - Fixed self-obsoletes (fix for RPMLINT warning)
* Thu Apr 22 2010 davejplater@gmail.com
  - Added obsoletes and provides for all conflicting packman plugins.
  - Changed group to more suitable one.
* Wed Apr 14 2010 davejplater@gmail.com
  - Enabled "autoreconf --install --force" in blop build to fix a
    segfault in blop plugins
  - Removed old BuildRequires:fftw-devel because fftw3-devel is sufficient
  - Enabled multiple jobs in all plugin builds.
* Mon Mar 22 2010 davejplater@gmail.com
  - Add swh-configure-2.65.patch for autoconf-2.65 build
* Tue Jan 26 2010 davejplater@gmail.com
  - Fixed swt lib build with swh-liblo.dif & swh-configure.patch
* Fri Jan 22 2010 davejplater@gmail.com
  - Update plugins to AMB-plugins-0.6.1, FIL-plugins-0.3.0,
    MCP-plugins-0.4.0, caps_0.4.4, pvoc_0.1.12, tap-plugins-0.7.1 and
    vocoder-ladspa-0.3.
  - Fix tap-type-punning-fix.dif
* Thu Jan 21 2010 davejplater@gmail.com
  - Update to ladspa-1.13
  - Removed ladspa_sdk-compile-fix.diff and adapted ladspa.dif
  - Moved examples directory to {_docdir}/{name}/examples
  - Updated "License: LGPL2.1+"
  - Version 1.13 - 6 Nov 2007
    • Fix compile error in sine.cpp (GCC4).
    • Fix typo in text output by analyseplugin.
    • Extra usage text in analyseplugin and applyplugin.
    • Replace strdup() with localStrdup() in sine.cpp to avoid malloc/new
      mismatch.
    • Remove "local" part from install directories.
* Wed Nov 25 2009 mseben@novell.com
  - added blop-ladspa_dir.diff to correct ladspa dir for 64 bit arch
  - corrected blop-wdautil-fix.diff (bnc#553647)
* Tue Nov 17 2009 tiwai@suse.de
  - refresh patches with fuzz=0
  - add -fno-strict-aliasing for swh plugins
* Tue Nov 10 2009 tiwai@suse.de
  - make static varibles in some blop plugins (possible fix for
    bnc#553647)
* Mon Nov 02 2009 tiwai@suse.de
  - fix invalid so files due to static linking in swh plugins
    (bnc#549865)
* Fri Jun 19 2009 coolo@novell.com
  - disable as-needed for this package as it fails to build with it

Files

/usr/bin/analyseplugin
/usr/bin/applyplugin
/usr/bin/listplugins
/usr/lib64/ladspa
/usr/lib64/ladspa/amp.so
/usr/lib64/ladspa/delay.so
/usr/lib64/ladspa/filter.so
/usr/lib64/ladspa/noise.so
/usr/lib64/ladspa/sine.so
/usr/share/doc/packages/ladspa
/usr/share/doc/packages/ladspa/README


Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Sep 10 15:14:38 2019