Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

rubygem-passenger-6.0.1-bp154.1.115 RPM for ppc64le

From OpenSuSE Leap 15.4 for ppc64le

Name: rubygem-passenger Distribution: SUSE Linux Enterprise 15 SP4
Version: 6.0.1 Vendor: openSUSE
Release: bp154.1.115 Build date: Thu May 12 04:02:23 2022
Group: Development/Languages/Ruby Build host: obs-power9-07
Size: 9139997 Source RPM: rubygem-passenger-6.0.1-bp154.1.115.src.rpm
Packager: https://bugs.opensuse.org
Url: https://www.phusionpassenger.com/
Summary: A fast and robust web server and application server for Ruby, Python
A modern web server and application server for Ruby, Python and Node.js,
optimized for performance, low memory usage and ease of use.

Provides

Requires

License

MIT AND GPL-2.0-only

Changelog

* Mon Jan 14 2019 mschnitzer@suse.com
  - updated to version 6.0.1 (boo#1121748)
    * Adds Ubuntu 18.10 "Cosmic" packages.
    * Skips trying to set oom score in LXC container environments.
      Closes GH-2143.
    * Fixes an issue during the GLS startup handshake where ephemeral
      ports could be exhausted. Closes GH-2144.
    * Updated Ruby versions used in precompiled binaries (used for
      e.g. gem installs) to include 2.5.3, and 2.4.5 (removed: 2.4.4).
    * Bumps the preferred Nginx version to 1.15.8.
    * Updated various library versions used in precompiled binaries
      (used for e.g. gem installs):
    - Curl: 7.62.0 -> 7.63.0
    - Git: 2.19.2 -> 2.20.1
    - Gnupg: 2.2.11 -> 2.2.12
    - libassuan: 2.5.1 -> 2.5.2
    - libgpg_error: 1.32 -> 1.33
    - Ruby: 2.4.4 -> 2.4.5, + 2.5.3
    - RubyGems: 2.7.6 -> 3.0.1
* Fri Nov 30 2018 mschnitzer@suse.com
  - updated to version 6.0.0 (boo#1117900)
    * Introduces support for *all* programming languages. Yes that's
    right... Java, Elixir, Go — Passenger now supports them all!
    This effort is called "generic language support".
    * Bumps the preferred Nginx version to 1.15.7.
    * Introduces anonymous usage telemetry, which helps us improve
    Passenger. Please read the docs on what data is collected and
    how to disable this.
    * [Nginx] Introduces a new option "passenger_request_buffering on|off",
    to allow disabling request body buffering. This is only supported
    in Nginx >= 1.15.3. Closes GH-2121.
    * Updated various library versions used in precompiled binaries
    (used for e.g. gem installs):
    - OpenSSL: 1.0.2q (was: 1.0.2p)
    - libcurl: 7.62.0 (was: 7.61.1)
    - Ruby: 2.3.8 (was: 2.3.7)
* Sun Nov 11 2018 mschnitzer@suse.com
  - updated to version 5.3.7 (boo#1115545)
    * Fixes package installation issues on Ubuntu 18.04. These issues
    were caused by an update released by Ubuntu on the nginx-common
    package. Closes GH-2122, GH-2140.
    * Fixes compilation problems and warnings with GCC 8.2. Tested on
    Alpine Linux edge 2018-11-05. Closes GH-2139.
    * Fixes compatibility with libcurl 7.62.0. Contributed by
    Po-Chuan Hsieh (@sunpoet).
    * Changes minimum supported macOS version to 10.11 El Capitan.
    * Removes packages for Ubuntu 17.10 Artful.
* Mon Nov 05 2018 mschnitzer@suse.com
  - updated to version 5.3.6 (boo#1114735)
    * Fixes smart spawning. A regression in 5.3.5 (due to a refactoring) made it so that Passenger only used the direct spawning method. This issue was mostly noticeable in the form of increased process spawning times between 5.3.4 and 5.3.5.
    * Fixes Passenger Core and application processes staying on the Watchdog's OOM score (unkillable). Closes GH-2105.
    * Fixes "mach_vm_map failed" warnings on macOS >= High Sierra. These warnings were harmless, but annoying. Closes GH-2101.
    * Fixes `passenger-config compile-agent` compilation with optimizations. The optimization flags were not properly passed to the compiler.
    * Fixes a crash that could occur when HTTP clients send a chunked transfer-encoding body containing a chunk larger than 429496729 bytes.
    * Improves detection of the system Apache's include headers on macOS High Sierra and later.
    * Fixes RVM gemset detection on RVM 1.29.
    * No longer supplies precompiled Ruby extensions for Ruby 1.9.3 and 2.0.0. When running Ruby 1.9.3 and 2.0.0, Passenger will attempt to compile from source instead.
  - changed suse.patch to apply again
  - changed fix_shebangs.patch to apply again
* Tue Sep 25 2018 mschnitzer@suse.com
  - updated to version 5.3.5
    * Fixes Ubuntu 18.04 package installation problems due to Nginx
      version mismatch. Closes GH-2122.
    * Improves usability of crash reports. Crash reports are no
      longer dumped in one big chunk to stderr. Instead, they are
      now dumped into multiple files, making it easy to inspect
      relevant reports.
    * Fixes some crashes that only occur with log level 7.
    * Downloads binaries from the newly-introduced Github mirror.
      This improves the reliability of binary downloads.
    * Updated various library versions used in precompiled binaries
      (used for e.g. gem installs):
    - OpenSSL: 1.0.2p (was: 1.0.2o)
    - libcurl: 7.61.1 (was: 7.60.0)
* Thu Aug 02 2018 mschnitzer@suse.com
  - updated to version 5.3.4
    * Fixes a crash during startup on FreeBSD 11.2 and recent OpenBSD versions due to C++11 compatibility issues in the code. Closes GH-2097.
    * Updates Boost to version 1.67.0.
    * [Apache] Fixes the handling of HTTP requests with chunked bodies in combination with `PassengerBufferUploads off`. Closes GH-2102
* Thu Jun 28 2018 mschnitzer@suse.com
  - updated to version 5.3.3
    * [Apache, Nginx] Fixes the passenger-install-*-module scripts. (Regression in 5.3.2) Closes GH-2093.
    * [Nginx] Fixed nginx module building on CentOS 6. Closes GH-2081. Thanks to defanator for contributing this.
* Wed Jun 13 2018 mschnitzer@suse.com
  - updated to version 5.3.2
    Release 5.3.2
    - ------------
    This release contains many security updates. Users are advised to upgrade as soon as possible. See our blog for more information on the vulnerabilities.
    * [Nginx] Fixes CVE-2018-12029, a local privilege escalation vulnerability in the Nginx module that occurs when `passenger_instance_registry_dir` is configured to a directory with insufficiently strict permissions.
    * Fixes CVE-2018-12026, 12027, and 12028. These are local denial of service, local information disclosure and local privilege escalation vulnerabilities that could be exploited by malicious applications or malicious users on the system.
    * Updated various library versions used in precompiled binaries (used for e.g. gem installs):
    - OpenSSL (Linux only): 1.0.2o (was: 1.0.2k; on macOS it was already 1.0.2o)
    - GeoIP: 1.6.12 (was: 1.6.11)
    - libcurl: 7.60.0 (was: 7.56.1)
    * Fixes Meteor support in non-bundled mode (regression from 5.3.0). Closes GH-2082.
    * Fixes the fact that the error page (which is shown when an app fails to spawn) sometimes contains unsufficient analysis details about the app.
    * [Apache] Fixes PassengerMaxInstancesPerApp not being respected (regression from config refactor in 5.2.0). Closes GH-2059.
    * [Enterprise, Apache] Fixes PassengerMaxInstances not being respected (regression from config refactor in 5.2.0).
    * [Enterprise] Fixes passenger-irb being unable to connect to an app process (regression from 5.3.0). Closes GH-2087.
  - Change suse.patch to apply again
* Tue May 15 2018 mschnitzer@suse.com
  - updated to version 5.3.1
    Release 5.3.1
    - ------------
    * Fixes a regression from 5.3.0: a crash that occurs if the user that an application should run under, does not have a shell configured. Closes GH-2078.
    * Fixes a regression from 5.3.0: setting supplementary group IDs during user switching. Closes GH-2077.
* Fri May 11 2018 mschnitzer@suse.com
  - updated to version 5.3.0
    Release 5.3.0
    - ------------
    * Adds Ubuntu 18.04 "Bionic" packages.
    * Removes packages for Debian 7 "Wheezy" (EOL May 2018).
    * Vastly improves spawning error page: quick overview of where the problem is, and the option to drill down in extensive troubleshooting information.
    * Fuse Panel support: fixes a crash that occurs when you shut down Passenger right after it fails to connect to Fuse Panel.
    * [Nginx] Updates the preferred Nginx version to 1.14.0 (from 1.12.2).
    * [Apache] Updates the recommended package for apache dev headers on debian >= 9.4. Closes GH-2048.
    * [Enterprise] Fix licensing proxy warning to refer to licensing_proxy_url instead of licensing_proxy.
    * [Enterprise] Add new `PassengerAppLogFile` (Apache) / `passenger_app_log_file` (Nginx) config option to specify a file for app-specific logs. Closes GH-1279.
    - Change suse.patch to apply again
* Tue Apr 10 2018 mschnitzer@suse.com
  - mention `series` in spec file
  - mention `rubygem-passenger-rpmlintrc` in spec file
* Wed Apr 04 2018 mschnitzer@suse.com
  - updated to version 5.2.3
    Release 5.2.3
    - ------------
    * Fuse Panel support: fixes a few bugs with handling small log files and with apps that don't output any messages.
    * Python app support: fixes a Python 3 compatibility issue w.r.t. writing data over the socket.
    * macOS support: fixes a crash in the `passenger-config compile-nginx-engine` command which only occurs on macOS >= 10.13. This crash was caused by a missing `require` call in our code, and affects users who compile Passenger from source, e.g. users of the Passenger Enterprise Homebrew formula.
    * Fixes a small memory corruption issue (dangling pointer) in the ApplicationPool subsystem.
    * Improves support for the $TMPDIR environment variable by removing leftover hardcoded references to /tmp. Closes GH-2052.
    * Updated PCRE version to 8.42 (was: 8.41) across the board.
    Release 5.2.2
    - ------------
    * Adds an option for dumping the web server config manifest to a given file: `PassengerDumpConfigManifest` (Apache) / `passenger_dump_config_manifest` (Nginx). This option is mostly useful for Passenger developers.
    * [Nginx] Fixes support for configurations that have two `passenger_base_uri` options in a single virtual host, without corresponding `passenger_app_group_name` and `passenger_app_root` directives. Closes GH-2043.
    * [Enterprise] Improved support for RAM-based pricing on Heroku (now using officially recommended memory limit reporting via CGROUP).
    Release 5.2.1
    - ------------
    * Fixes a regression from 5.1.11 that prevented Passenger from compiling on FreeBSD in some cases. Closes GH-2031.
    * Fixes a bounds issue in printing an error message that could occur in some cases when spawning a child process fails. Issue was present from 5.1.11.
    * Fixes a regression from 5.2.0 which prevented setting the max pool idle time to 0. Closes GH-2020.
    * Warns if using an incompatible compiler on macOS < 10.13. Closes GH-2017.
    * No longer uses Security Framework on macOS 10.13+. This will prevent further keychain warnings from appropriately compiled Passengers.
    * Fixes warning on macOS about /proc/self access (excluded some code that was intended only for Linux).
    * `passenger-install-nginx-module` now downloads the preferred Nginx version via https. Thanks to smiba for pointing this out.
    * [Apache] Fixes a regression from 5.2.0 that caused a crash on startup when no top-level ServerName is set. Closes GH-2029.
    * [Enterprise] Adds support for using RAM-based pricing on Heroku.
    Release 5.2.0
    - ------------
    * [Apache] Breaking change: to avoid configuration ambiguity, options that act on a per-process level (rather than per-request level) can no longer be used in .htaccess. See the Passenger Library -> configuration -> intro for more info (https://www.phusionpassenger.com/library/config/apache/intro.html#global-per-application-and-per-request-options).
    * [Apache] Breaking change: the option PassengerResolveSymlinksInDocumentRoot has been removed (old Passenger 2 compatibility option, see PassengerAppRoot for new method).
    * [Apache] Option handling has been refactored to avoid silent conflicts and errors: warnings are now generated for global config options in <VirtualHost> (they conflict between VHosts) and per-application options in <Files>, <FilesMatch> and <If> (silently failed before).
    * [Apache] Fixes compilation issues on some systems with macOS 10.13 High Sierra (in addition to the fixes from 5.1.11).
    * [Enterprise] Fixes two unnecessary warnings about failure to contact the licensing server, one occurring since version 5.1.8 ("3 days out of contact"), the other since 5.1.11 + Apache ("failure to contact").
    * [Nginx] Fixes the default for the `passenger_app_group_name` to start with the `passenger_app_root` rather than the document root (the end remains the same: `passenger_app_env`).
    * [Standalone] Adds command line support for `start_timeout` in Passenger Standalone (also removes unnecessary warning when using it in `Passengerfile.json`).
    * [Standalone, Nginx] Waits for Nginx to exit before cleaning up temp dir (started happening more since the switch to Nginx graceful shutdown in 5.1.6). Closes GH-1970.
    * Deprecated options for Union Station.
    * Ruby 2.5 compatibility: handle case where an exception's backtrace may be nil. Closes GH-2011.
    * Adds JSON mime type for static file serving. Closes GH-2018.
    * Removes packages for Ubuntu 17.04 "Zesty" (EOL 13-jan-2018).
  - Add fix_shebangs.patch:
    * Required to fix the package building because we don't allow /usr/bin/env shebangs.
  - Change suse.patch to apply again
* Thu Nov 23 2017 mschnitzer@suse.com
  - updated to version 5.1.12
    * Changes the Debian/Ubuntu install script to completely restart Apache upon upgrade. This prevents issues due to a "half upgraded" state (old Passenger Apache module + new Passenger core). Closes GH-2000.
    * Adds Ubuntu 17.10 "Artful" packages.
    * Fixes a case in which -- when Passenger is configured with user switching turned off -- it is unable to open the web server log file and aborts during startup. This regression was introduced in 5.1.8. Closes GH-1990.
    * [Nginx] The preferred Nginx version is now 1.12.2
    * [Nginx] The preferred PCRE version is now 8.41 (previously 8.39).
    * [Standalone] Adds support for using `start_timeout` in Passengerfile.json.
    * [Enterprise] Uses libuv to detect total system RAM, allows for compilation on pre-10.11 macOS.
    * [Enterprise] Added a max request queue time option, to limit time requests spend in the request queue. Closes GH-1688.
    * Updated libcurl version used in precompiled binaries (used for e.g. gem installs) to 7.56.1 (was: 7.54.1).
    * Updated OpenSSL version used in precompiled binaries (used for e.g. gem installs) to 1.0.2m (was: 1.0.2l).
    * Updated PCRE version used in precompiled binaries (used for e.g. gem installs) to 8.41 (was: 8.40).
    * Updated Ruby versions used in precompiled binaries (used for e.g. gem installs) to include 2.1.10, 2.2.8, 2.3.5, and 2.4.2 (removed: 2.1.9, 2.2.7, 2.3.4, and 2.4.1).
* Thu Nov 23 2017 adrian@suse.de
  - drop upstream merged patch fix-undeclared-isnan.patch to fix build
  - add openssl build dependency
* Thu Oct 26 2017 coolo@suse.com
  - updated to version 5.1.11
    see installed CHANGELOG
    Release 5.1.11
    - -------------
    * [Apache] Fixes a race condition (segfault) on startup, which primarily affected macOS hosts (regression in 5.1.8 due to the logging improvements). Closes GH-1973.
    * [Apache] Fixes compilation on macOS 10.13 High Sierra.
    * [Nginx] It is now allowed to specify `passenger_enabled` in the `http` context as well.
    * [Nginx] Namespaced Jsoncpp under the Passenger namespace to avoid collisions with Google Pagespeed's copy when linked into Nginx.
    * [Standalone] Enables HTTP/2 support in the Nginx template. Support is only active if SSL is used, to avoid potential issues with HTTP/2 on HTTP ports. Closes GH-1945.
    * [Enterprise, Standalone] Adds a new feature that is especially useful on Heroku: deferred port binding. When `--defer-port-binding` is set, Passenger does not listen on the given port until the application has finished spawning. If the application starts slowly then this mechanism can prevent the Heroku request timeout from killing the dyno (the boot timeout still applies).
    * [Enterprise, Standalone] Fixes duplicate warnings when Passengerfile.json contains errors.
    * [Standalone] `passenger start` now accepts the `--start-timeout` configuration option.
    * Adds support for Bundler 2.0's new `gems.rb` and `gems.locked`. Learn more about these in [Gemfile's new clothes](https://depfu.com/blog/2017/09/06/gemfiles-new-clothes). Closes GH-1982.
    * Removes Debian packages for Ubuntu 12.04 Precise.
    * Fixes compilation warnings on macOS + Clang 9.0.
    * Introduces a new check that logs a vulnerability warning if Passenger is run with root permissions while the directory permissions of (parts of) its root dir allow modifications by non-root users.
    * Fixes an arbitrary file read vulnerability (if Passenger is running as root and the attacker has access to a user account that hosts an application).
    Release 5.1.10
    - -------------
    * This was an Enterprise-only hotfix release (no changes in Passenger Open Source).
    Release 5.1.9
    - ------------
    * This was an Enterprise-only hotfix release (no changes in Passenger Open Source).
    Release 5.1.8
    - ------------
    * Introduces a shorter and more informative log format. The new format significantly shortens the thread ID, and includes the message's log level (critical, error, warning, notice, etc) so that users can more easily filter out uninteresting messages.
    * [Nginx] The Phusion Nginx APT package is upgraded to Nginx version 1.12.1 (previously pinned at 1.10.3 while waiting for a compatible lua module release).
    * [Standalone] Automatically uses Nginx to serves static asset URLs that conform to the [webpacker](https://github.com/rails/webpacker) gem's format. Closes GH-1966.
    * [Standalone] If configured to listen on a Unix domain socket, properly cleans up this socket on Nginx shutdown. Fixes a regression from 5.1.6. Closes GH-1969.
    * [Standalone] Fixes the `--max-requests` option when using the builtin engine. Fixes a regression from 5.1.4.
    * [Enterprise] Fixes a potential use-after-free bug when reporting usage data to the Phusion licensing server. This bug only occurs when Passenger Enterprise is running inside a container.
    Release 5.1.7
    - ------------
    * Fixes compilation problems on some systems.
    * Upgrades the JSON parser (json-cpp) to version 1.8.1. This makes parsing slightly faster, adds various security checks and fixes some JSON generation issues.
    * [Enterprise] Fixes an SSL certificate issue in the license usage data reporter, which only occurs when Passenger Enterprise installed from gem or tarball. The license usage data reporter now searches for the correct system CA path.
    * [Enterprise] Fixes a potential use-after-free bug when reporting usage data to the Phusion licensing server, and improves reliability of usage data recording.
    Release 5.1.6
    - ------------
    * Fixes a typo that causes a looping crash when long security update information is sent by the server. In practice we will keep the messages shorter to avoid triggering this until there has been ample time to upgrade.
    * Fixes unnecessary process respawn if it was detached and min_instances is set to 0. Closes GH-1735.
    * Introduces APT packages for Debian 9 "Stretch", with Passenger built as dynamic module. Closes GH-1960.
    * Changes APT packages for Ubuntu 17.04 "Zesty" from static to dynamic module.
    * [Standalone] Now uses graceful shutdown for the Nginx engine under the hood (requested as part of GH-1598). Thanks to PikachuEXE for contributing this.
    * [Standalone] Fixes a memory corruption issue in the builtin engine. The issue was introduced in 5.1.5 (settings handling refactoring).
    * [Standalone] Cleanup the temp dir before aborting when startup cannot continue, e.g. when Passenger is already running. Closes GH-1953.
    * Fixes WSGI crash with Python 3 and non-ASCII characters in headers or the URL. Closes GH-1935. Thanks to n4nn31355 for the assistance.
    * [Nginx] The preferred Nginx version is now 1.12.1 (previously 1.10.3), except for the Phusion Nginx APT package, which is pinned at 1.10.3 until an 1.12.x compatible lua module becomes available.
    * [Nginx] Fixes CVE-2017-7529, an integer overflow vulnerability in the Nginx range filter module. This is accomplished by upgrading to Nginx 1.12.1, or applying the patch (Phusion Nginx APT package).
    * Updated libcurl version used in precompiled binaries (used for e.g. gem installs) to 7.54.1 (was: 7.54.0).
    * Updated OpenSSL version used in precompiled binaries (used for e.g. gem installs) to 1.0.2l (was: 1.0.2k).
    * Updated GeoIP version used in precompiled binaries (used for e.g. gem installs) to 1.6.11 (was: 1.6.9).
    * Updated PCRE version used in precompiled binaries (used for e.g. gem installs) to 8.40 (was: 8.39).
    * Adds support for building with MacPorts' OpenSSL. Closes GH-1959.
    Release 5.1.5
    - ------------
    * Updated Boost to version 1.64.0, which fixed a compilation issue on certain Gentoo based setups. Closes GH-1942.
    * Improved the error message shown when an app fails to start in time.
    * [Apache] Remove option to configure PassengerAppGroupName from .htaccess because, assuming AllowOverride Options is set, malicious users (having an account on the same server) can sometimes collide app group names of other users and capture their traffic.
    * Major internal refactoring of settings handling, to prepare for supporting settings changes without restart.
* Tue May 23 2017 coolo@suse.com
  - updated to version 5.1.4
    see installed CHANGELOG
    Release 5.1.4
    - ------------------------------
    * Updated zlib version used in building precompiled binaries (used for e.g. gem installs) to 1.2.11 (was: 1.2.8).
    * Updated openssl version used in building precompiled binaries (used for e.g. gem installs) to 1.0.2k (was: 1.0.2j).
    * Updated curl version used in building precompiled binaries (used for e.g. gem installs) to 7.54.0 (was: 7.51.0).
    * Added support for rbenv when building precompiled binaries (passenger_binary_build_automation submodule).
    * Fixes issue when building precompiled binaries (used for e.g. gem installs) found in release 5.1.3.
    * Added Ruby 2.4.1 precompiled native extension.
    Release 5.1.3
    - ------------------------------
    * [Standalone] Fixes `install-standalone-runtime` command after regression in 5.1.2.
    * Removes unnecessary logging of "No Error" from macOS Security Update Checker.
    * Adds support for compiling against the built-in Apache installation supplied with macOS 10.12 Sierra. Previous versions of Passenger failed because macOS Sierra's Apache installation is incomplete and does not supply the apr-config tool. We now work around this by using hardcoded default values for macOS.
    * Don't output colorized text during dependency check when output isn't a TTY, unless forced. Closes GH-1902.
    * [Nginx] The preferred Nginx version is now 1.10.3 (previously 1.10.2).
    * Adds Ubuntu 17.04 "Zesty" packages.
    * [Enterprise] Fixes `send-cloud-usage` command when Passenger is installed from gem.
    * [Enterprise] Improves robustness of machine properties reporting for pay-as-you-go cloud-license holders.
    * [Enterprise] Adds support for reporting available RAM, and CONTAINER_HOST_IDENTIFIER envvar, to support RAM-based pricing model.
    * Added additional debug level logging for troubleshooting issues with bash scripts. Closes GH-1928.
    * Revert private keychain use in the Security Update Checker when run as root on macOS, in order to avoid changing the default System Keychain. Closes GH-1922. Remove Cert and Key from keychain separately, to avoid errors when clearing the client certificate.
    * Fix missing openssl check in `passenger-install-apache2-module` dependency checker. Closes GH-1934.
* Tue Feb 14 2017 coolo@suse.com
  - updated to version 5.1.2
    see installed CHANGELOG
    Release 5.1.2
    - ------------
    * Improve curl check for passenger-install- scripts to catch (very old) curl versions that won't compile against 5.1+.
    * Fixes remaining false positives (logging) from the new Meteor cluster warning system. Closes GH-1905.
    * Create a private keychain on macOS when the system keychain is defaulted to, this avoids a permissions issue with the system keychain when performing the Security Update Check. This is necessary because the system keychain is the default keychain of daemon users and root on macOS.
    * Improve `passenger-memory-stats` to include JRuby processes that fail to rename as expected. Closes GH-1878.
    * [Standalone] Don't download or compile Nginx when using the builtin engine. Closes GH-1910.
    * [Standalone] Fixes `--nginx-tarball` option of `passenger start` and `passenger-config install-standalone-runtime` (wasn't working). Also verifies that `--nginx-version` is explicitly specified as it should be.
    Release 5.1.1
    - ------------
    * The precompiled version of the PassengerAgent binary (used for e.g. gem installs) now configures (statically linked) libcurl with system keystore, so that the new security update check can successfully validate certs.
    * Fixes some false positives (logging) from the new Node and Meteor cluster warning system. Logging is less repetitive and has extra debug info. Closes GH-1905.
    * Updates the upload-progress module in the Nginx Debian package. The module version that we linked against in 5.1.0 was 0.9.2, but due to a bug in that version the module didn't work.
    * The security update check now reports whether libcurl + SSL backend are statically linked to Passenger, in which case the check also needs to warn about relevant OpenSSL vulnerabilities in the linked library.
    * Increases the allowed line lengths emmited by apps at startup.
    * Adds support for the unary 'not' operator in the Union Station filter language.
    * [Enterprise] Add missing flying-passenger integration mode to security update check.
    * Fixes support for Rails 5.0.1 Action Cable. Specifically, we now support the `options` argument in the `write_nonblock` method in hijacked Rack IO sockets.
    * [Apache] Introduces a small delay to prevent running the Security Update Checker twice at startup.
    Release 5.1.0
    - -------------
    * Upgrades union_station_hooks_core to version 2.1.2.
    * [Enterprise] When running a Rails app in multithreaded mode, Passenger Enterprise automatically tags Rails logs with the current thread number. This makes it possible to distinguish logs generated by different threads.
    * Fixes permissions issue on Linux when setting OOM score after lowering privileges. Closes GH-1858.
    * [Standalone] Allows raw json envvars in Passengerfile.json. Closes GH-1837.
    * [Standalone] Make the `max_requests` option available on the command line as well.
    * Fixes unaligned memory access in base64 decoder on platforms that have strict aliasing requirements (non x86/x86_64). Closes GH-1646.
    * Introduces daily Passenger security update check to warn (error log) if there are newer Passenger versions with important security fixes (describing what was discovered, what is affected, which version has the fix).
    * Fixes compilation on Linux when a non-glibc C library is in use. Closes GH-1870.
    * `passenger-install-nginx-module` and the standalone compiler now add the http v2, realip and addition module flags for Nginx (just like the APT/RPM/autobuilder already had). Closes GH-1788.
    * [Apache] Fixes PassengerShowVersionInHeader option. Thanks to Sebastian Welther for contributing this.
    * Passenger now reports when you try to use Node.js or Meteor clustering, and tries to continue with just a nonfunctional shim in place, so that if your code uses the clustering APIs your app may still work.
    * Updates libev config.sub and config.guess to support newer platforms such as the IBM power 8.
    * Fixes an issue where passenger-config couldn't restart an app if the TMPDIR variable was set to /tmp
    * `passenger-install-apache-module` now suggests the correct apache package on Ubuntu Xenial. Closes GH-1884.
    * [Standalone] The TempDirToucher will now spend most of its time with reduced privileges, except when it's actively touching files. This allows it to be killed when Passenger is quit in most circumstances. Closes GH-1678.
    * Fixes a file overwrite vulnerability caused by a predictable temporary file being written by `passenger-install-nginx-module`. Thanks to Jeremy Evans for reporting this.
    * [Standalone] Fixes starting Passenger as a non-extant user. Closes GH-1849.
    * Improved look of the error pages for failing to spawn an application (development & production mode), and Error ID is now also shown in production mode.
    * [Standalone] Enable ipv6 support by default in builtin nginx. Closes GH-1873.
    * [Nginx] Updates to APT package builder (Debian & Ubuntu) with fix for www-data to root privilege escalation via log file handling (CVE-2016-1247/USN-3114-1).
    * [Nginx] Updates to RPM package builder (CentOS & RHEL) with fix for 1.10.x system nginx package overriding the nginx from the Passenger repo. Closes GH-1895.
    * [Nginx] The preferred Nginx version is now 1.10.2 (previously 1.10.1).
    * RPM pkg builder fix for breaking SELinux change in RHEL 7.3.
    * RPM pkg builder fix for RHEL6/CentOS6 incompatibility and replacement in Passenger.
    * Adds Ubuntu 16.10 "Yakkety" packages.
* Tue Jul 26 2016 coolo@suse.com
  - updated to version 5.0.30
    see installed CHANGELOG
    Release 5.0.30
    - -------------
    * Changes mbuf block size from 512 to 4096 bytes to better fit modern requests and significantly speed up disk buffering.
    * [Nginx] Fixes PCRE checksum after the preferred version update in 5.0.29 (contributed by: clemensg).
    * [Apache] Fixes buffer limit crash on large file upload (when core disk buffer can't keep up with client for some time), and limits per-client buffer memory usage to 130 KB. Closes GH-1620.
    * Fixes potential hang when an UnseekableSocket gets serialized to json. Closes GH-1838.
* Thu Jun 23 2016 coolo@suse.com
  - updated to version 5.0.29
    see installed CHANGELOG
    Release 5.0.29
    - -------------
    * Fixes the FreeBSD build breaking due to the `-ldl` flag introduced by the LVE integration patch (5.0.28). Closes GH-1805.
    * Fixes per-application interpreter override (ruby, node, python) being ignored in mass deployment mode. Closes GH-1818.
    * Fixes incomplete refactor from 5.0.27 that could, under specific conditions, lead to a Passenger crash. Closes GH-1794.
    * [Apache] Remove unused code that caused a crash in configurations with thousands of VirtualHost entries. Closes GH-1676.
    * [Nginx] Fixes use of invalid logfile name (memory already released) in backup log redirection code. Possibly related to GH-1774.
    * [Nginx] The preferred Nginx version is now 1.10.1 (previously 1.10.0).
    * [Nginx] The preferred PCRE version is now 8.39 (previously 8.34).
    * [Standalone] Passenger Standalone now supports /dev/stdout and /dev/stderr as log file path (via `--log-file` or Passengerfile.json). This is especially useful in Docker containers. In previous versions logging to those paths did not work, resulting in nothing getting logged at all.
* Thu May 12 2016 ct@kki.org
  - add fix-undeclared-isnan.patch (from https://github.com/boostorg/math/commit/fbd1393858719c7bda7d251f742950c1bc691ea8)
* Tue May 10 2016 ct@kki.org
  - update to version 5.0.28
    * Finalizes the fix (5.0.26) for the `rails server` command integration to prevent "missing on_event" errors. Closes GH-1768.
    * Fixes missing -fPIC in Nginx dynamic module compilation (5.0.26) on Linux (rewrite of a patch by Andrei Belov). Closes GH-1793.
    * Fixes memory leak that could occur whenever more than 1024 concurrent requests are handled (more likely since the higher concurrency support options from 5.0.24). Closes GH-1797.
    * Integrates with CloudLinux LVE and CageFS (security checks and a new option PassengerLveMinUid). Thanks to Oleksiy Shchukin from CloudLinux Inc. for contributing this.
    * Fixes the Nginx build when the PCRE library is not available (such as when compiling with `--without-http_rewrite_module`). Closes GH-1796.
    * Extends `passenger-memory-stats` filter to show the instance dir toucher too (as well as the core in valgrind debug runs).
    * Changes the default for friendly error pages to "off" unless the environment is set to "development", rather than "on" unless "staging" or "production". Closes GH-1782.
    * [Nginx] The preferred Nginx version is now 1.10.0 (previously 1.8.1).
  - changes in release 5.0.27
    * Fixes encoding issue for Ruby apps that resulted in a 0-byte response body. This occurred when the Ruby native support lib was not used and the app outputted an encoding that doesn't mix with UTF-8 (like UTF-16). Closes GH-1763.
    * Fixes Passenger Core and application processes staying on the Watchdogs OOM score (unkillable) when user switching is set to off. Closes GH-1631.
    * Supports Debian GNU/kFreeBSD build. Based on contribution by stevenc99.
    * Switches a number of places in the Passenger Core over to using the monotonic clock instead of the wallclock for robustness against clock time-stepping.
    * Slightly improves out-of-memory detection in some subroutines.
    * Fixes incomplete libuv upgrade: some build files were not autoregenerated during the upgrade from 1.5.0 to 1.8.0 in the previous release.
    * Warnings about 502 responses that are caused by applications aborting their output while the client is no longer connected (e.g. due to half-close event, reported since 5.0.26) are now reduced to debug level.
    * Fixes automatic compilation of Ruby's native_support library in case Passenger was installed through Debian or RPM packages. Closes GH-1778.
    * Fixes memory leak when buffering large request/response bodies to disk (which happens as soon as the 100 KB memory buffer is full).
    * Fixes crash if an application spawn fails and a non-UTF8 character appears in the spawn output. Closes GH-1601.
    * Updates the `rails server` command integration (from 5.0.25) to prevent "missing on_event" errors. Closes GH-1768. Update: not all required code made it to the release, the final fix is delivered in 5.0.28.
    * [Union Station] Fixes a crash that occurs if all of the following conditions are met: 1) Union Station support is enabled, 2) the client sent at least one header containing the empty string, 3) the application responds with a 4xx or 5xx status. Closes GH-1776.
* Wed Mar 23 2016 olaf@aepfle.de
  - Force fixed timestamps for patched gems (bsc#916047)
* Thu Mar 03 2016 mrueckert@suse.de
  - refresh suse patch to apply cleanly again
* Wed Mar 02 2016 coolo@suse.com
  - updated to version 5.0.26
    see installed CHANGELOG
    Release 5.0.26
    - -------------
    * `passenger-status --show=server` now reports the speed at which new requests are accepted.
    * `passenger-status --show=server` now reports `last_data_send_time` and `last_data_receive_time` which can be used to troubleshoot long-running requests (for example, to see if a websocket heartbeat is stuck).
    * Passenger now reports TCP half-closing events to Node.js and Meteor applications, which allows them to detect request body and WebSocket closes without having to send data to the client.
    * Fixes outputting Content-Length and Transfer-Encoding headers on HEAD requests for Ruby apps. These headers were omitted in previous versions on HEAD requests.
    * Bumps the default socket backlog size from 1024 to 2048.
    * Upgrades libuv to version 1.8.0.
    * When using our RPM packages, system SELinux policy upgrades no longer break the Passenger SELinux policy. Closes GH-1663.
    * [Apache] Fixes compilation against Apache installations which include `-pie` in CFLAGS. Closes GH-1756.
    * [Nginx, Standalone] Bumps default Nginx worker_connections from 1024 to 4096 (effectively 2048 because of internal reverse proxy)
    * [Nginx, Standalone] Introduces the option `core_file_descriptor_ulimit` and `app_file_descriptor_ulimit`, for setting the file descriptor ulimits of the Passenger core and the application, respectively.
    * [Nginx] Passenger can now be [compiled as an Nginx dynamic module](https://www.phusionpassenger.com/library/install/nginx/install_as_nginx_module.html#dynamic-module). Thanks to Ruslan Ermilov from NGINX Inc for contributing this.
    * [Standalone] Prints a warning when an unsupported configuration option in Passengerfile.json is set.
    * [Standalone] Fixes "address already in use" errors when using the builtin engine.
    * [Enterprise] The rolling restart feature now waits until the old process is completely gone (drained its request queue, process exited) before proceeding with rolling restarting the next process. This results in friendlier resource usage during rolling restart.
    * [Union Station] Fixes custom logging time arguments getting overwritten by current time for Ruby apps (so some sub-blocks like "framework request processing" appeared shorter than they were). This could happen since the switch to monotonic clock in 5.0.22.
* Fri Feb 19 2016 coolo@suse.com
  - updated to version 5.0.25
    see installed CHANGELOG
    Release 5.0.25
    - -------------
    * Integrates into the `rails server` command. Please learn more at [the Passenger + Rails integration documentation](https://www.phusionpassenger.com/library/dev/ruby/rails_integration.html).
    * Adds explicit support for Action Cable. Please learn more at the [Passenger Library](https://www.phusionpassenger.com/library/dev/ruby/rails_integration.html#action_cable).
    * Removes packages for Ubuntu 15.04 Vivid and Debian 6. Ubuntu 15.04 and Debian 6 are still supported, we just don't supply packages for them anymore. If you are an Ubuntu 15.04 or Debian 6 user and you want to use Passenger >= 5.0.25, then please upgrade your distribution, or install Passenger from RubyGems/tarball.
    * Fixes a potential crash due to memory corruption in code for `passenger-config reopen-logs`.
    * Fixes a potential crash in the large (inbound/outbound) file buffering code.
    * Fixes a crash that occurs when using Nginx + HTTPS + Sub-requests. Closes GH-1724.
    * Fixes a crash that occurs when using Nginx + syslog and a logfile for Passenger. Also fixes edge cases where the Nginx logpath would override the Passenger logpath. Closes GH-1514 (again).
    * [Union Station] Fixes a potential crash due to a wrong limit on snprintf (introduced in 5.0.24 by GH-1633). Closes GH-1744.
    * [Union Station] Fixes Union Station Node.js request introspection to allow for application.use method chaining. Closes GH-1745.
    * [Union Station] Fixes information about sinks sometimes missing from `passenger-status --show=union_station`.
    * [Union Station] When one or more Union Station gateways are suffering from technical difficulties, the Union Station support code now tries more quickly to reestablish the connection.
    * [Standalone] Don't reject the value 0 (meaning no limit) for `--max-request-queue-size`. Closes GH-1743.
    * [Standalone] Makes the `--address` option work more reliably if the passed hostname may resolve to multiple addresses. For example, if you pass `--address localhost` then previous versions could fail because Passenger thinks it's an IPv6 address (::1) while Nginx thinks it's an IPv4 address (127.0.0.1). Hostname resolution is now done in a consistent manner.
    * [Standalone] Adds the `--unlimited-concurrency-path` configuration option.
    * [Standalone] Adds IPv6 support to the builtin engine.
* Tue Feb 02 2016 coolo@suse.com
  - updated to version 5.0.24
    see installed CHANGELOG
    Release 5.0.24
    - -------------
    * Fixes a crash when the new `force_max_concurrent_requests_per_process` option (5.0.22) was used for non-Node.js apps (e.g. Ruby). Closes GH-1720.
    * Fixes Solaris compilation. This was a regression due to the patch for GH-1643 in 5.0.22. Closes GH-1694, GH-1701.
    * Logs for [Union Station](https://www.unionstationapp.com) provide more information about request queueing. Closes GH-1633.
    * Also log HTTP headers to Union Station for HTTP 4xx responses (extends the header logging for HTTP 5xx that was added in 5.0.22)
    * Fixes cases where compilation failure of (optional) native utils was not reported.
    * On Ruby, no longer traps SIGEXIT. This fixes erroneously setting `$ERROR_INFO` in `at_exit` callbacks. Closes GH-1730.
    * Fixes a wrong loop exit condition that could cause a deadlock with 100% CPU usage by Passenger core. Closes GH-1709, GH-1732.
    * Adds `socket_backlog` option to configure the Passenger Core socket backlog. For use with e.g. "Resource temporarily unavailable while connecting to upstream" errors. Closes GH-1726.
    * [Nginx] The preferred Nginx version is now 1.8.1 (previously 1.8.0).
    * [Standalone] Fixes the default value of the `load_shell_envvars` option. It's supposed to be disabled by default, but due to a typo it was enabled by default.
* Tue Dec 22 2015 coolo@suse.com
  - updated to version 5.0.23
    see installed CHANGELOG
    Release 5.0.23
    - -------------
    * Fixes the request acceptor error handling timeout. When an error occurs while Passenger is accepting a request (for example, when Passenger has run out of file descriptors), Passenger is supposed to wait for 3 seconds before trying again. Because of a typo, Passenger actually waited 3 milliseconds.
    * [Enterprise] Fixed a regression in the Passenger Standalone Nginx config template that breaks the Mass Deployment feature.
    * The mime type for serving static XHTML files is updated. We no longer use the mobile profile, so it is recognized by desktop browsers. Closes GH-1695.
    * Improves error messages about Ruby native support to indicate the optional nature. Passenger is able to operate even without the native support extension, but that wasn't clear enough to some users, causing them to think of the old messages as errors.
    * [Standalone, Nginx] When using the new `abort_websockets_on_process_shutdown` configuration option, Passenger waited for the app to close without signaling it that shutdown was in progress. Node.js apps now get a SIGINT. Closes GH-1702.
    * With friendly error pages off Passenger would still show a trace (referencing only Passenger code) for unusual spawn errors. This has been changed to a generic error message. Closes GH-1704.
* Wed Dec 09 2015 mrueckert@suse.de
  - update to version 5.0.22 (boo#956281)
    - Fixes a header collision vulnerability (CVE-2015-7519, medium
      severity). Please see our blog for detailed vulnerability
      description and advisory. Thanks to the SUSE security team for
      reporting this issue.
    - [Apache] Fixes compatibility with Apache 2.4.17's
      mod_autoindex. Fix contributed by Eric Covener. Closes GH-1642.
    - [Standalone] Passenger Standalone now [accepts configuration
      options from environment
      variables](https://www.phusionpassenger.com/library/config/standalone/intro.html).
      This makes using Passenger Standalone significantly easier on
      Heroku or on systems that follow the 12-factor principle.
      Closes GH-1661.
    - [Standalone] The Nginx configuration template has been cleaned
      up. It is now significantly easier to edit the Nginx
      configuration template without breaking compatibility with
      future versions.
    - [Standalone] The `passenger start` command now performs a
      sanity check on the internally generated Nginx configuration
      file and advises you accordingly when there is a problem.
    - [Standalone] The `passenger status` and `passenger stop`
      commands now respect Passengerfile.json. Closes GH-1593.
    - [Standalone] Passenger Standalone on Solaris now properly tails
      the application log file.
    - [Standalone] Fixes a problem with Passenger Standalone's
      builtin engine exiting at startup when run on Solaris.
    - [Standalone] `passenger start` now accepts the `--envvar`
      command line option for passing environment variables to the
      application.
    - [Standalone] `passenger start` now accepts the `--memory-limit`
      configuration option.
    - [Standalone] `passenger start` now accepts the
      `--max-request-queue-size` configuration option.
    - [Standalone] `passenger start` now accepts the
      `--debug-nginx-config` configuration option. This option allows
      you to view the Nginx configuration file that Passenger
      Standalone generates internally.
    - [Standalone, Nginx] Introduces a new configuration option:
      `abort_websockets_on_process_shutdown`. By default, when
      Passenger shuts down or restarts an application process, it
      will abort associated Websocket connections. This option allows
      you to disable that behavior. Closes GH-1686.
    - Introduces a new configuration option:
      `force_max_concurrent_requests_per_process`. This option is
      mostly useful for making dynamic process scaling work in
      Node.js and Meteor apps.
    - Various administration tools, such as `passenger-status`, no
      longer raise an flock EBADF error on Solaris. Closes GH-1643.
    - The `passenger-config reopen-logs` command, when used in
      combination with Passenger Standalone and the Nginx engine, now
      also instructs Nginx to reopen its log files. Closes GH-1674.
    - Fixes Passenger erroneously adding a `Content-Length` or
      `Transfer-Encoding` header to Ruby HTTP 204 No Content
      responses. Closes GH-1595.
    - Fixes Union Station logging of Rack response body actions.
    - The `passenger-config restart-app` command, when given
      `--ignore-app-not-running`, now properly exits with a zero
      status when one or more applications are running, but none of
      them belonging to the invoking user. Closes GH-1655.
    - The `passenger-config validate-install` command no longer
      prints false warnings about duplicate Passenger installs on
      systems that use RBenv. Closes GH-1627.
    - Fixes race conditions in the automatic building of the Ruby
      native support extension. Closes GH-1570.
    - [Enterprise] Fixes compatibility with byebug 7.0. Closes
      GH-1662.
    - Support Union Station logging for Node.js applications, with
      Express/MongoDB automatically supported.
    - The Ruby Union Station hooks no longer abort with a fatal error
      when the application does not call the Union Station
      initializer method during startup. The error is now only
      logged.
    - In case of an error response (HTTP 5xx), Union Station logging
      will also contain request headers.
    - The Union Station hooks are now more resilient against
      environment variable problems.
  - rebase suse.patch to apply cleanly again
* Mon Oct 26 2015 mrueckert@suse.de
  - update to version 5.0.21
    - Properly handles Ruby applications that output the
      `Content-Length` and `Transfer-Encoding` headers in
      non-standard casing, e.g. `Content-length`. Closes GH-1517.
    - Fixes Ruby application loading incompatibilities caused by the
      use of absolute paths. Closes GH-1596.
    - Fixes OpenSSL detection problems on OS X 10.11 El Capitan. OS X
      10.11 no longer includes OpenSSL headers, so Passenger will
      suggest and use OpenSSL from Homebrew. Closes GH-1630.
    - Introduces the [secure HTTP
      headers](https://www.phusionpassenger.com/library/indepth/meteor/secure_http_headers.html)
      feature for Node.js and Meteor apps. This mechanism allows
      Passenger to send per-request information to the application,
      while guaranteeing that this information is not spoofed by the
      client.
    - Per-request Apache environment variables are now passed to
      Node.js and Meteor apps through the
      [`!~Passenger-Envvars`](https://www.phusionpassenger.com/library/indepth/nodejs/apache_per_request_envvars.html)
      secure header.
    - Fixes some unintentional caching of request-specific
      environment variables. Closes GH-1479.
    - For Node.js applications, Passenger now calls
      `process.emit('message', 'shutdown')` whenever Passenger shuts
      down an application process. This is the same hook as used by
      PM2, allowing applications which use the PM2 graceful shutdown
      mechanism to be run on Passenger without changes.
    - [Enterprise] Fixes a bug in passenger-irb where printing
      strings larger than 64 KB would cause it to crash.
    - [Enterprise] Fixes the `passenger-config restart-app` command
      so that it performs a non-rolling-restart unless
      `--rolling-restart` is given as command line option, as per the
      documentation. Previously, `passenger-config restart-app`
      without `--rolling-restart` would perform a rolling restart if
      rolling restarts are configured in the configuration file, but
      this contradicted documented behavior. Closes GH-1634.
  - rebase suse.patch to apply cleanly again
* Thu Oct 08 2015 coolo@suse.com
  - fix requires and supplements of apache2 subpackage
* Wed Oct 07 2015 mrueckert@suse.de
  - fix path for native support library
* Tue Oct 06 2015 mrueckert@suse.de
  - squashed all patches into suse.patch and added
    /etc/passenger/locations.ini
  - dropped patches
    - 0001-fix-shebang.patch
    - 0002-load-system-passenger-libs.patch
    - 0003-use-shared-path-for-shared-resources.patch
    - 0004-fix-default-temp-dir.patch
* Wed Sep 30 2015 mrueckert@suse.de
  - update to version 5.0.20
    - Fixes memory management bugs in Union Station support.
    - Improves the error handling in Union Station support.
    - `passenger-config validate-install` now properly handles CR
      characters in Apache configuration files.
  - changes from  5.0.19
    - Fixes an encoding crash in `passenger-memory-stats` on OS X in
      case one or more processes are running on the system with names
      containing UTF-8 characters. Closes GH-1603.
    - [Ruby] Fixes handling of HTTP 205 responses, which would cause
      client connections to freeze.
    - Improves Union Station data collection: more Rack I/O events
      are now logged. The time taken to write out and to close the
      Rack response body are now logged.
    - Improves Union Station data sending: errors are now logged more
      clearly, and DNS errors are now handled more robustly.
    - Improves Union Station troubleshooting: errors can now be
      diagnosed by running `passenger-status --show=union_station`.
    - Refactors the Union Station Ruby hook code. They have been
      extracted to external gems. However, they are still bundled
      with Passenger for ease of use.
  - drop all patches and replaced with a git-format-patch series:
    - added patches
    - 0001-fix-shebang.patch
    - 0002-load-system-passenger-libs.patch
    - 0003-use-shared-path-for-shared-resources.patch
    - 0004-fix-default-temp-dir.patch
    - removed patches:
    - passenger-4.0.14_missing_includes.patch
    - passenger-4.0.50_fix_shebang.patch
    - passenger-4.0.50_load_system_passenger_libs.patch
    - passenger-4.0.50_paths.patch
    - passenger-4.0.53_fix-default-temp-dir.patch
* Thu Sep 10 2015 coolo@suse.com
  - updated to version 5.0.18
    see installed CHANGELOG
    Release 5.0.18
    - -------------
    * Fixes more memory corruption issues in the palloc subsystem.
    * Fixes memory corruption issues in the Passenger core that may occur if the application sets many response headers. The issue was caused by an off-by-one bug.
* Tue Sep 08 2015 coolo@suse.com
  - updated to version 5.0.17
    see installed CHANGELOG
    Release 5.0.17
    - -------------
    * Adds packages for Ubuntu 15.10 "Wily", even though Ubuntu 15.10 hasn't been released yet.
    * Fixes some memory corruption issues in the palloc subsystem. Closes GH-1587.
    * Fixes the Node.js `PhusionPassenger.on('exit')` event. This event worked if you restart the app or detach an application process, but not if you stop Passenger.
    * Fixes support for `passenger_pre_start` URLs that contain very long authentication strings. This was caused by the fact that our Base64 encoder generated unexpected newlines.
    * [Standalone] Improves application prestarting. Application prestarting is now available in combination with the 'builtin' engine, and now works when SSL is used.
* Tue Aug 25 2015 coolo@suse.com
  - updated to version 5.0.16
    see installed CHANGELOG
    Release 5.0.16
    - -------------
    * Allows independent configuration of Union Station gateway address, port and certificate. Closes GH-1543.
    * Supports seek() such that body.rewind works when using Rack middleware that uses Zlib::GzipReader (e.g. for compressed requests). Closes GH-1553.
    * [Apache] Improves detection of Apache configuration file problems. Closes GH-1577.
    * [Enterprise] Fixes installation of the Passenger Enterprise Apache module on Debian Testing.
    * Fixes logging of HTTP response code for Union Station. This regression was introduced by Passenger 5. Closes GH-1581.
    * Adds a new subcommand `passenger-config about support-binaries-dir`.
    * Fixes a regression in the Node.js loader with regard to custom startup files. This bug was introduced in 5.0.14. Closes GH-1557 (again).
    * Fixes a crash when a Ruby application is accessed through a sub-URI and a root virtual host at the same time.
* Wed Aug 12 2015 mrueckert@suse.de
  - make sure we set up /{var/,}run/passenger on install
* Wed Aug 12 2015 mrueckert@suse.de
  - update to version 5.0.15
    - Support SHA256 digests for the Rails asset pipeline, as used by
      Sprockets 3.x.
    - Support for JRuby 9.0.0.0. Closes GH-1562.
    - Fixes some bugs in Union Station support, which causes some
      data (such as controller information and exceptions) to not be
      logged.
    - The old Users Guides have been deprecated in favor of the
      [Passenger Library](https://www.phusionpassenger.com/library/).
      The Users Guides now redirect to appropriate sections in the
      Passenger Library.
  - additional changes in 5.0.14
    - [Standalone] Relative path handling has been improved. In
      previous versions, relative paths were not handled in a
      consistent manner. Relative paths are now handled consistently
      according to the following rules:
    - If a relative path is given via a command line option, then
      it is relative to the current working directory.
    - If a relative path is given via Passengerfile.json, then it
      is relative to Passengerfile.json.  Closes GH-1557.
    - [Standalone] The `--disable-turbocaching` now works with the
      Nginx engine.
  - additional changes in 5.0.13
    - The `passenger-config restart-app` command now supports the
      option `--ignore-passenger-not-running`. If this option is
      given, the command will exit normally instead of exiting with
      an error, if Passenger is not running. This option is useful in
      deployments involving Passenger Standalone. In an initial
      deployment, Passenger Standalone may not yet be running.
      Passing this option allows you to ignore that issue.
    - SELinux policy issues in the RPMs have been fixed.
    - [Apache] `passenger-config reopen-logs` didn't work on Apache
      unless you explicitly set `PassengerLogFile`. This has now been
      fixed.
    - [Standalone] Due to some internal refactorings, the Passenger
      Standalone Nginx configuration template has changed. If you
      used a custom Nginx configuration template, please merge our
      latest changes into it.
  - additional changes in 5.0.12
    - [Enterprise] Fixed passenger-irb. It was broken in 5.0.10
      because of the change that made using admin commands without
      sudo possible.
  - additional changes in 5.0.11
    - In 5.0.10, admin tools such as `passenger-status` and
      `passenger-config restart-app` display an authorization error
      if they are run without sudo, while at the same time Passenger
      isn't serving any applications. Since this is confusing, they
      have now been modified to display a more appropriate error
      message.
    - Fixes a bug in the RPMs that prevent admin tools such as
      `passenger-status` and `passenger-config restart-app` from
      working when they are invoked without root privileges.
    - Fixes a bug on OS X that prevent admin tools such as
      `passenger-status` and `passenger-config restart-app` from
      detecting Passenger instance directories when they are invoked
      without root privileges. Closes GH-1535.
    - Fixes a bug that causes Passenger not to work if the HOME
      environment variable is not set.
    - Fixes compatibility with non-Rails Ruby apps that require the
      actionview gem. Closes GH-1547.
    - Fixes some non-fatal "permission denied" error that may
      occasionally occur if user switching is turned off. Closes
      GH-1541.
    - Relative values for the `pid_file` and `log_file` options in
      Passengerfile.json are now supported.
    - If Passengerfile.json contains a syntax error, Passenger
      Standalone now correctly prints an error message instead of
      crashing.
    - Sending a SIGABRT signal to a Ruby process now properly makes
      it terminate.
    - The `passenger-config restart-app` command now accepts `.` as
      parameter, which it will interpreter as "restart the app in the
      current working directory". Closes GH-1386.
    - [Apache] Setting `PassengerLogLevel` no longer redirects
      Apache's own stderr to that log file. Closes GH-1373.
    - [Standalone] Passenger Standalone's Nginx engine now includes
      the RealIP module. Closes GH-1389.
    - [Standalone] The `--max-preloader-idle-time` option has been
      added.
  - additional changes in 5.0.10
    - It is now possible to run `passenger-status`, `passenger-config
      restart-app` and other admin commands without using sudo. When
      run without sudo, these admin commands will allow you to
      operate on apps and processes that are owned by the user that
      invoked the admin command. Closes GH-1392.
    - Fixes a crash introduces in 5.0.9 due to not properly
      initializing a variable. Closes GH-1530.
    - The `passenger-config reopen-logs` command now works by
      instructing the Watchdog process to reopen the log file, while
      instructing the other Passenger processes to re-inerhit the log
      file from the Watchdog instead of trying to reopen the log file
      on their own. This makes log file reopening more robust. Closes
      GH-1452.
    - `passenger-config restart-app` no longer leaves the terminal in
      a state with black background. Closes GH-1526.
    - `passenger-config admin-command` has been renamed to
      `passenger-config api-call` in order to avoid confusion with
      any potential admin interfaces that we will introduce in the
      future.
    - If Union Station support is enabled, process and system metrics
      weren't being sent correctly to Union Station. This has been
      fixed.
    - [Enterprise] Fixes the fact that the Passenger Enterprise RPM
      didn't correctly set SELinux permissions on its own files.
    - [Apache] passenger-install-apache2-module no longer aborts with
      an error if the Apache configuration file contains errors.
      Closes GH-1525.
    - [Apache] Fixes a typo that would cause
      passenger-install-apache2-module to crash on Red Hat and CentOS
      systems on which the SELinux command line tools are not
      installed. Closes GH-1527.
  - additional changes in 5.0.9
    - The casing of original headers as generated by the application
      are now preserved, instead of being downcased. This fixes
      compatibility issues with broken HTTP clients. Closes GH-1436.
    - Internal refactoring: we've replaced libeio with libuv. This
      makes some of our code simpler. Closes GH-1428.
    - When the passenger-status tool tries to cleanup a stale
      instance directory, it will no longer abort with an error when
      it fails to do that. It will now merely print a warning. Fixes
      [StackOverflow question
      30354732](http://stackoverflow.com/questions/30354732/cap-aborted-capistrano-aborts-rails-deploy-while-attempting-to-chown-tmp-p/30357100#30357100).
    - Fixes compilation problems on Solaris.
    - The Ruby handler has been made more robust. Previously, it was
      possible for applications to corrupt connections by returning
      incorrect Rack responses. This may cause connections to get
      stuck. The Rack handler has been hardened to ensure that
      connections will never get corrupted or stuck. Closes GH-1512.
    - The Ruby handler now closes the Rack response body even when
      the socket connection is hijacked by the application. The Rack
      specification is unclear about what to do in this case, and
      different Ruby app servers do different things. We have found
      that by closing the body object anyway, we maximize
      compatibility with existing Rack middlewares and apps, such as
      Rack::Lock. Background information about this issue can be
      found at
      https://github.com/ngauthier/tubesock/issues/10#issuecomment-72539461.
    - Fixes a crash that could occur if some HTTP request headers are
      present, but have the empty value. Closes GH-1524.
    - Fixes a permission problem that prevents the web server from
      communicating with Passenger when user switching is off. Closes
      GH-1520.
    - Fixes a few small one-time memory leaks in the Passenger agent.
      This wraps up the workitems discovered in valgrind runs on
      earlier versions.
    - Fixes use of uninitialized metrics. This could happen for a
      brief moment after spawning.
    - [Apache] If you pass the `--apxs2-path` parameter to
      `passenger-install-apache2-module`, and the apxs2 path that you
      specified is not in PATH, then the installer would think that
      Apache installation is broken. This has been fixed.
    - [Apache] A `Connection: close` header that was used for
      internal communication between Passenger processes was being
      leaked to the client, which breaks HTTP keep-alive connections.
      This has been fixed. Closes GH-1516.
    - [Nginx] The preferred Nginx version is now 1.8.0. It was
      previously 1.6.3.
    - [Nginx] Passenger now passes to the application the raw URI as
      sent by the client, as long as Nginx didn't modify the URI
      (e.g. as part of rewrite rules). This means that escaped
      slashes (%2F) in the URI now work correctly and out-of-the-box
      as long as there are no applicable rewrite rules.
    - [Nginx] Fixes that crash that would occur if Nginx is
      configured to log to syslog. And to prevent log messages from
      disappearing into a black hole, Passenger will now ask you to
      set `passenger_log_file` if Nginx is configured to log to
      syslog. Closes GH-1514.
    - [Standalone] Prevents an existing instance from being shut down
      if starting a new instance fails.
  - additional changes in 5.0.8
    - We now supply Debian 8 and Ubuntu 15.04 packages. Closes
      GH-1494 and GH-1400.
    - We now supply Red Hat 6, Red Hat 7, CentOS 6 and CentOS 7
      packages.
    - We no longer supply Ubuntu 10.04 packages because Ubuntu 10.04
      is no longer supported by Canonical.
    - Fixes a Passenger crash (SIGSEGV) that occurs occasionally when
      out-of-band garbage collection is enabled. Closes GH-1469.
    - Fixes a Passenger crash (SIGSEGV) that occurs occasionally with
      redirects to relative URLs. Closes GH-1513.
    - Fixes cases when Passenger shuts down more processes than is
      allowed by the `min_instances` limit. Closes GH-1500.
    - Fixes "Bad Gateway" errors that would occur when an application
      sets the X-Sendfile or X-Accel-Redirect header, together with a
      non-empty response body. Closes GH-1498.
    - Fixes the fact that Passenger agent processes don't lower their
      privilege when user switching is turned off.
    - Fixes autodetection of Apache on Gentoo. Closes GH-1510.
    - Fixes compilation problems on Solaris. Closes GH-1508.
    - [Standalone] Adds the `--pool-idle-time` command line
      parameter.
    - [Standalone] Adds the `--auto` command line parameter for
      running non-interactively. This supresses prompts. Closes
      GH-1511.
* Mon May 18 2015 mrueckert@suse.de
  - update to version 5.0.7
    - Supports changed way of specifying settings for (non-bundled)
      Meteor apps. Closes GH-1403.
    - Fixes an integer-to-string conversion bug in the code
      responsible for buffering chunked request bodies. This bug
      could cause the PassengerAgent to crash due to an exception.
      Thanks to Marcus Rückert of SUSE for reporting this.
    - Request-specific environment variables are no longer cached.
      This fixes a number of issues, such as Shibboleth not working
      properly and conflicts between HTTPS and non-HTTPS virtual
      hosts. Closes GH-1472.
    - Fixes a memory corruption bug that would be triggered when
      using `passenger_base_uri`. The memory corruption bug resided
      in the code for resolving symlinks. Closes GH-1388.
    - Re-introduced signal catchers during shutdown, to allow clean
      shutdown in Foreman. Closes GH-1454.
    - `passenger-status --show=xml` no longer outputs the non-XML
      header by default. This fixes a regression as reported in a
      comment in GH-1136.
    - Passenger now prefers to load Rack and Bundler from RubyGems
      instead of from `vendor_ruby`. This solves some issues with
      Rack and Bundler on Debian systems. Closes GH-1480 and GH-1478.
    - The turbocache no longer caches responses that contain the
      `X-Sendfile` or the `X-Accel-Redirect` header.
    - The preferred Nginx version has been upgraded to 1.6.3.
    - The logging agent no longer aborts with an error if one of the
      Passenger root directory's parent directories is not
      world-executable. Closes GH-1487.
    - [Standalone] It is now possible to configure the Ruby, Node.js
      and Python executable to use in Passenger Standalone through
      the command line options --ruby, --nodejs and --python. Closes
      GH-1442.
    - [Standalone] Running `passenger start --engine=builtin
    - -daemonize` would fail with a timeout error. This has been
      fixed.
    - [Standalone] Running `passenger start --nginx-version=XXX`
      would crash. This has been fixed. Closes GH-1490.
    - [Apache] Fixed some issues with X-Sendfile. Closes GH-1376.
    - [Apache] If the installer fails to autodetect Apache while the
      installer is running as a normal user, it will now ask you to
      give it root privileges. Closes GH-1289.
    - [Apache] The installer now validates your Apache configuration
      file to check for common problems. The validator can also be
      accessed separately by running `passenger-config
      validate-install --validate-apache2`.
    - [Nginx] Introduces the `passenger_read_timeout` option for rare
      cases when server needs more than the default 10 minute
      timeout. Contributed by pkmiec. Closes
      [GH-PR-34](https://github.com/phusion/passenger/pull/34).
    - [Nginx] The Nginx module now looks for index.html if the path
      ends in / so that it works intuitively, without needing to use
      try_files.
    - Fixes wrong memory address display in crash dumps. Thanks to
      thoughtpolice for pointing it out.
    - Fixes an ugly backtrace that would be shown if an invalid
      request is made to an application process using the private
      HTTP interface. Contributed by jbergler. Closes GH-1311.
    - Various documentation improvements. Closes
      [GH-PR-1332](https://github.com/phusion/passenger/pull/1332),
      [GH-PR-1354](https://github.com/phusion/passenger/pull/1354),
      [GH-PR-1216](https://github.com/phusion/passenger/pull/1216),
      [GH-PR-1385](https://github.com/phusion/passenger/pull/1385),
      [GH-PR-1302](https://github.com/phusion/passenger/pull/1302).
  - drop 3cd918c27e7015d5e60106f4574ea439fc4a16da.patch: included in
    update
* Thu Apr 16 2015 mrueckert@suse.de
  - update to passenger-4.0.50_load_system_passenger_libs.patch:
    we still had 2 places that tried to load the libraries from the
    relative path instead of the installed library.
  - pull 3cd918c27e7015d5e60106f4574ea439fc4a16da.patch until 5.0.7
    is released
* Thu Apr 02 2015 mrueckert@suse.de
  - use intree libebio as well. our system copy seems to be broken.
* Thu Apr 02 2015 asn@cryptomilk.org
  - Fix temp directory path in mod_passenger.conf
* Tue Mar 31 2015 mrueckert@suse.de
  - use intree libev again. according to passenger upstream it is
    patched with things they need which are not in upstream libev.
* Tue Mar 31 2015 mrueckert@suse.de
  - update to version 5.0.6
    - The turbocache no longer caches responses for which the
      Cache-Control header contains "no-cache". Please note that
      "no-cache" does not mean "do not cache this response". Instead,
      it means "any caching servers may only serve the cached
      response after validating it". Since the turbocache does not
      support validation, we've chosen to skip caching instead.
      Coincidentally, this change "fixes" problems with applications
      that erroneously use "no-cache" as a flag for "do not cache
      this response". What these applications should actually use is
      "no-store". We recommend the developers of such applications to
      change their caching headers in this manner, because even if
      Passenger doesn't unintentionally cache the response, any
      intermediate proxies that visitors are behind may still cache
      the response.
    - Fixes a number of memory leaks. Memory was leaked upon
      processing a request with multiple headers, upon processing a
      response with multiple headers, and upon processing a response
      with Set-Cookie headers. Every time such a request or response
      was processed, 512 bytes of memory was leaked due to improperly
      dereferencing relevant memory buffers. Closes GH-1455.
    - Fixes various bugs related to Union Station data collection.
      Union Station is our upcoming application analytics and
      performance monitoring SaaS platform. It is opt-in: no data is
      collected unless you turn the feature on.
    - Fixes a Union Station-related file descriptor leak. Closes
      GH-1439.
    - Fixes some bugs w.r.t. use of uninitialized memory.
    - More informative error message if a support binary is not
      found, including a resolution hint. Closes GH-1395.
    - [Apache] `SetEnv` variables are now passed as Rack/CGI/request
      variables. This was also the case in Passenger 4, but not in
      Passenger 5.0.0-5.0.5. We've restored the old behavior because
      the behavior in 5.0.0-5.0.5 breaks certain Apache modules such
      as Shibboleth. Closes GH-1446.
    - [Standalone] PID and log files now correctly created if user
      specifies relative path.
* Wed Mar 25 2015 mrueckert@suse.de
  - updated to version 5.0.5
    - Fixes various crashes due to use of uninitialized memory. One
      such crash is documented in GH-1431.
    - Fixes a connection stall in the Apache module. Closes GH-1425.
    - Fixes a potential read-past-buffer bug in string-to-integer
      conversion routines. Thanks to dcb314 for spotting this. Closes
      GH-1441.
    - Fixes a compilation problem on Solaris. This problem was caused
      by the fact that `tm_gmtoff` is not supported on that platform.
      Closes GH-1435.
    - There is now an API endpoint for force disconnecting a client:
      `passenger-config admin-command DELETE /server/<client
      name>.json`. Closes GH-1246.
    - Fixes some file descriptor leaks. These leaks were caused by
      the fact that keep-alive connections with application processes
      were not being closed properly. Closes GH-1439.
    - In order to more easily debug future file descriptor leaks,
      we've introduced the `PassengerFileDescriptorLogFile` (Apache)
      and `passenger_file_descriptor_log_file` (Nginx) config
      options. This allows Passenger to log all file descriptor
      open/close activity to a specific log file.
    - The `PassengerDebugLogFile` (Apache) and
      `passenger_debug_log_file` (Nginx) configuration options have
      been renamed to `PassengerLogFile` and `passenger_log_file`,
      respectively. The old name is support supported for backward
      compatibility reasons.
    - [Enterprise] Fixes a bug in Flying Passenger's
      `--instance-registry-dir` command line parameter. This command
      line parameter didn't do anything.
    - [Enterprise] The Flying Passenger daemon no longer supports the
      `--max-preloader-idle-time` config option. This is because the
      config option never worked. The correct way to set the max
      preloader idle time is through the Nginx config option, but
      this was wrongly documented, so the documentation has been
      fixed.
  - adapted several patches
* Tue Mar 17 2015 mrueckert@suse.de
  - use new ruby-find-versioned script and make it build on 1.8
* Tue Mar 17 2015 coolo@suse.com
  - updated to version 5.0.4
    * Fixes a compilation problem introduced in 5.0.3.
* Tue Feb 10 2015 coolo@suse.com
  - updated to version 4.0.59
* Wed Nov 26 2014 adrian@suse.de
  - fix default tmp dir in code, matching our default configs
* Tue Nov 25 2014 mrueckert@suse.de
  - make it easier to run apps not under wwwrun:www by setting
    /run/passenger to root:root and 1777.
* Tue Nov 25 2014 mrueckert@suse.de
  - update to 4.0.53
    - Upgraded the preferred Nginx version to 1.6.2.
    - Improved RVM gemset autodetection.
    - Fixed some Ruby 2.2 compatibility issues.
  - changes in 4.0.52
    - Fixed a null termination bug when autodetecting application
      types.
    - Node.js apps can now also trigger the inverse port binding
      mechanism by passing `'/passenger'` as argument. This was
      introduced in order to be able to support the Hapi.js
      framework. Please read
      http://stackoverflow.com/questions/20645231/phusion-passenger-error-http-server-listen-was-called-more-than-once/20645549
      for more information regarding Hapi.js support.
    - It is now possible to abort Node.js WebSocket connections upon
      application restart. Please refer to
      https://github.com/phusion/passenger/wiki/Phusion-Passenger:-Node.js-tutorial#restarting_apps_that_serve_long_running_connections
      for more information. Closes GH-1200.
    - Passenger Standalone no longer automatically resolves symlinks
      in its paths.
    - `passenger-config system-metrics` no longer crashes when the
      system clock is set to a time in the past. Closes GH-1276.
    - `passenger-status`, `passenger-memory-stats`,
      `passenger-install-apache2-module` and
      `passenger-install-nginx-module` no longer output ANSI color
      codes by default when STDOUT is not a TTY. Closes GH-487.
    - `passenger-install-nginx-module --auto` is now all that's
      necessary to make it fully non-interactive. It is no longer
      necessary to provide all the answers through command line
      parameters. Closes GH-852.
    - Minor contribution by Alessandro Lenzen.
* Thu Nov 20 2014 mrueckert@suse.de
  - remove .o files
* Thu Nov 20 2014 mrueckert@suse.de
  - it seems we need the buildout part for the agents
* Thu Nov 20 2014 mrueckert@suse.de
  - fixed paths to some scripts:
    - added passenger-4.0.50_paths.patch:
    - patch paths to match our configs
    - no longer copy the bin dir to the
      %{_libdir}/passenger/%{version}
    - copy the agents directory directly without the buildout part in
      the target directory

Files

/etc/passenger
/etc/passenger/locations.ini
/usr/lib/tmpfiles.d/passenger.conf
/usr/lib64/passenger
/usr/lib64/passenger/6.0.1
/usr/lib64/passenger/6.0.1/bin
/usr/lib64/passenger/6.0.1/bin/passenger
/usr/lib64/passenger/6.0.1/bin/passenger-config
/usr/lib64/passenger/6.0.1/bin/passenger-install-apache2-module
/usr/lib64/passenger/6.0.1/bin/passenger-install-nginx-module
/usr/lib64/passenger/6.0.1/bin/passenger-memory-stats
/usr/lib64/passenger/6.0.1/bin/passenger-status
/usr/lib64/passenger/6.0.1/buildout
/usr/lib64/passenger/6.0.1/helper-scripts
/usr/lib64/passenger/6.0.1/helper-scripts/README.md
/usr/lib64/passenger/6.0.1/helper-scripts/backtrace-sanitizer.rb
/usr/lib64/passenger/6.0.1/helper-scripts/crash-watch.rb
/usr/lib64/passenger/6.0.1/helper-scripts/download_binaries
/usr/lib64/passenger/6.0.1/helper-scripts/download_binaries/extconf.rb
/usr/lib64/passenger/6.0.1/helper-scripts/meteor-loader.rb
/usr/lib64/passenger/6.0.1/helper-scripts/node-loader.js
/usr/lib64/passenger/6.0.1/helper-scripts/prespawn
/usr/lib64/passenger/6.0.1/helper-scripts/rack-loader.rb
/usr/lib64/passenger/6.0.1/helper-scripts/rack-preloader.rb
/usr/lib64/passenger/6.0.1/helper-scripts/wsgi-loader.py
/usr/lib64/passenger/6.0.1/nodejs_supportlib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/phusion_passenger
/usr/lib64/passenger/6.0.1/nodejs_supportlib/phusion_passenger/line_reader.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/codify
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/codify/codify.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/codify/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/context.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/glue.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/index.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/shimmer
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/shimmer/index.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/node_modules/shimmer/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/async-listener/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/listener.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/shimmer
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/shimmer/index.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/node_modules/shimmer/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/node_modules/emitter-listener/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/continuation-local-storage/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order/lib/index.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/network-byte-order/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/LICENSE
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/common.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/cli-config.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/npm-config.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/config/syslog-config.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/container.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/exception.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/logger.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/console.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/daily-rotate-file.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/file.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/http.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/memory.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/transport.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/lib/winston/transports/webhook.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/LICENSE
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/lib/async.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/support
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/async/support/sync-package-managers.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/MIT-LICENSE.txt
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/colors.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/custom
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/custom/trap.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/custom/zalgo.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/extendStringPrototype.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/index.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/america.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/rainbow.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/random.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/maps/zebra.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/styles.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/system
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/lib/system/supports-colors.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/safe.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/themes
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/colors/themes/generic-logging.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/cycle
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/cycle/cycle.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/cycle/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/LICENSE
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/lib/eyes.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/eyes/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/LICENSE.md
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/isstream.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/isstream/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/LICENSE
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/lib/pkginfo.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/pkginfo/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/License
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/lib
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/lib/stack-trace.js
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/node_modules/stack-trace/package.json
/usr/lib64/passenger/6.0.1/nodejs_supportlib/vendor-copy/winston/package.json
/usr/lib64/passenger/6.0.1/resources
/usr/lib64/passenger/6.0.1/resources/mime.types
/usr/lib64/passenger/6.0.1/resources/release.txt
/usr/lib64/passenger/6.0.1/resources/standalone_default_root
/usr/lib64/passenger/6.0.1/resources/standalone_default_root/index.html
/usr/lib64/passenger/6.0.1/resources/templates
/usr/lib64/passenger/6.0.1/resources/templates/apache2
/usr/lib64/passenger/6.0.1/resources/templates/apache2/apache_install_broken.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/apache_must_be_compiled_with_compatible_mpm.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/config_snippets.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/deployment_example.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/installing_against_a_different_apache.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/mpm_unknown.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/multiple_apache_installations_detected.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/notify_apache_module_installed.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/possible_solutions_for_compilation_and_installation_problems.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/present_choice_for_no_update_config.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/rpm_installation_recommended.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/run_installer_as_root_for_apache_analysis.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/apache2/welcome.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config
/usr/lib64/passenger/6.0.1/resources/templates/config/agent_compiler
/usr/lib64/passenger/6.0.1/resources/templates/config/agent_compiler/confirm_enable_optimizations.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/cannot_create_user_support_binaries_dir.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/download_tool_missing.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/passenger_not_installed_as_root.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/support_binaries_dir_not_writable_despite_running_as_root.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/unexpected_filesystem_problem.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/installation_utils/user_support_binaries_dir_not_writable.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/config/nginx_engine_compiler
/usr/lib64/passenger/6.0.1/resources/templates/config/nginx_engine_compiler/possible_solutions_for_download_and_extraction_problems.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/README.md
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/dist
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/dist/bundle.js
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/dist/styles.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/DetailsView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/GetHelpView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/JourneyView.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/JourneyView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/PageMain.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/PageMain.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/ProblemDescriptionView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/ProcessDetailsView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SolutionDescriptionView.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SolutionDescriptionView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SummaryView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentView.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentsView.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/SystemComponentsView.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/Tab.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/Tabs.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/bootstrap.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/bootstrap.js
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/bootstrap/config.json
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/index.html.template
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/src/index.jsx
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/with_details/webpack.config.js
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/dist
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/dist/bundle.js
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/dist/styles.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/src
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/src/index.html.template
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/src/index.js
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/src/main.css
/usr/lib64/passenger/6.0.1/resources/templates/error_renderer/without_details/webpack.config.js
/usr/lib64/passenger/6.0.1/resources/templates/installer_common
/usr/lib64/passenger/6.0.1/resources/templates/installer_common/cannot_access_files_as_root.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/installer_common/gem_install_permission_problems.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/installer_common/low_amount_of_memory_warning.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/installer_common/run_installer_as_root.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/installer_common/world_inaccessible_directories.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx
/usr/lib64/passenger/6.0.1/resources/templates/nginx/ask_for_extra_configure_flags.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/cannot_write_to_dir.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/config_snippets.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/config_snippets_inserted.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/confirm_extra_configure_flags.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/deployment_example.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/nginx_module_sources_not_available.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/other_nginx_installations_exist.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/pcre_checksum_could_not_be_verified.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/pcre_could_not_be_downloaded.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/pcre_could_not_be_extracted.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/possible_solutions_for_compilation_and_installation_problems.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/possible_solutions_for_download_and_extraction_problems.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/query_download_and_install.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/nginx/welcome.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone
/usr/lib64/passenger/6.0.1/resources/templates/standalone/cannot_write_to_dir.txt.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/config.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/footer.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/global.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/http.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/mass_deployment_default_server.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/rails_asset_pipeline.erb
/usr/lib64/passenger/6.0.1/resources/templates/standalone/server.erb
/usr/lib64/passenger/6.0.1/resources/union_station_gateway.crt
/usr/lib64/passenger/6.0.1/resources/update_check_client_cert.p12
/usr/lib64/passenger/6.0.1/resources/update_check_client_cert.pem
/usr/lib64/passenger/6.0.1/resources/update_check_server_pubkey.pem
/usr/lib64/passenger/6.0.1/src
/usr/lib64/passenger/6.0.1/support-binaries
/usr/lib64/passenger/6.0.1/support-binaries/PassengerAgent


Generated by rpm2html 1.8.1

Fabrice Bellet, Wed Nov 9 22:19:05 2022