Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python2-antlr-2.7.7-lp152.10.2 RPM for x86_64

From OpenSuSE Leap 15.2 for x86_64

Name: python2-antlr Distribution: openSUSE Leap 15.2
Version: 2.7.7 Vendor: openSUSE
Release: lp152.10.2 Build date: Mon Mar 2 05:45:41 2020
Group: Development/Tools/Other Build host: lamb58
Size: 162569 Source RPM: antlr-2.7.7-lp152.10.2.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.antlr.org/
Summary: ANother Tool for Language Recognition (python runtime)
Python support for generating your Lexers, Parsers and TreeParsers in Python.
This feature extends the benefits of ANTLR's predicated-LL(k) parsing
technology to the Python language and platform.

ANTLR Python support was contributed (and is to be maintained) by Wolfgang
Haefelinger and Marq Kole.

Provides

Requires

License

GPL-2.0-or-later AND SUSE-Public-Domain AND MIT

Changelog

* Mon Jan 06 2020 Fridrich Strba <fstrba@suse.com>
  - Not only provide python-antlr, but also obsolete it
* Wed Jul 31 2019 Martin Liška <mliska@suse.cz>
  - Use FAT LTO objects in order to provide proper static library.
* Sun Nov 18 2018 Fridrich Strba <fstrba@suse.com>
  - Install as maven artifact using the pom file from maven central
* Thu Sep 13 2018 Tomáš Chvátal <tchvatal@suse.com>
  - Do not create compat symlink for python stuff as it was not working
    before anyway
  - Rename python package to python2-antlr (provide old symbol)
* Fri Jul 20 2018 tchvatal@suse.com
  - Do not use old compat macros for python directories
* Tue May 15 2018 fstrba@suse.com
  - Build with source and target 8 to prepare for a possible removal
    of 1.6 compatibility
* Fri Jan 12 2018 tchvatal@suse.com
  - Add condition about python2 module, the rewrite happened in antlr4
    for python3 support and it is completely different than the antlr2
    * The python module is not used by any package in TW bsc#1068226
* Thu Dec 07 2017 dimstar@opensuse.org
  - Fix build with RPM 4.14: a command that exits with error > 0
    aborts the build (and grep not finding a string is retval 1).
* Fri Nov 03 2017 mpluskal@suse.com
  - Explicitly require python2 [bsc#1068226, fate#323526]
* Fri Sep 29 2017 fstrba@suse.com
  - Require java-devel >= 1.6 to build, because of the source and
    target level
* Wed Sep 06 2017 fstrba@suse.com
  - fixes necessary to compile with Java 9
    * set javac source and target to 1.6
* Fri Jun 09 2017 tchvatal@suse.com
  - Drop the javadoc so we can be build with java bootstrapping reducing
    the cycle/failures
* Fri May 19 2017 tchvatal@suse.com
  - Reduce dependencies a bit
* Thu Dec 04 2014 p.drouand@gmail.com
  - Remove java-devel dependency; not needed anymore

Files

/usr/lib64/python2.7/site-packages/antlr
/usr/lib64/python2.7/site-packages/antlr/__init__.py
/usr/lib64/python2.7/site-packages/antlr/__init__.pyc
/usr/lib64/python2.7/site-packages/antlr/antlr.py
/usr/lib64/python2.7/site-packages/antlr/antlr.pyc
/usr/share/antlr-2.7.7


Generated by rpm2html 1.8.1

Fabrice Bellet, Mon May 25 23:37:55 2020