Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

ant-scripts-1.9.10-lp152.4.5 RPM for noarch

From OpenSuSE Leap 15.2 for noarch

Name: ant-scripts Distribution: openSUSE Leap 15.2
Version: 1.9.10 Vendor: openSUSE
Release: lp152.4.5 Build date: Sat Sep 21 01:49:09 2019
Group: Development/Tools/Building Build host: lamb20
Size: 13083 Source RPM: ant-1.9.10-lp152.4.5.src.rpm
Packager: https://bugs.opensuse.org
Url: http://ant.apache.org/
Summary: Additional scripts for ant
Apache Ant is a Java-based build tool.

This package contains additional perl and python scripts for Apache
Ant.

Provides

Requires

License

Apache-2.0

Changelog

* Thu Aug 16 2018 jsikes@suse.de
  - Add security patch to handle malformed zip file paths bsc#1100053:
    * apache-ant-unzip-path.patch
    * CVE-2018-10886
* Thu Feb 22 2018 tchvatal@suse.com
  - Add patch to run scripts with python3 if applicable bsc#1082202:
    * ant-python3.patch
* Thu Feb 22 2018 tchvatal@suse.com
  - Update to 1.9.10:
    * Various fixes for java10
    * Small fixes all around
  - Remove merged patch reproducible.patch
* Sat Oct 28 2017 jengelh@inai.de
  - Simply use find -delete over xargs.
  - Make description neutral.
* Tue Oct 24 2017 bwiedemann@suse.com
  - Add reproducible-build-date.patch to allow to have fixed build dates
    to make other packages build more reproducibly
* Wed Oct 04 2017 fstrba@suse.com
  - Remove dependency on java-1_5_0-gcj-compat-devel and build even
    the bootstrap package with java source and target 1.6
* Fri Sep 29 2017 fstrba@suse.com
  - Don't condition the maven defines on release version, but on
    _maven_repository being defined
* Thu Sep 14 2017 fstrba@suse.com
  - Allow bootstrapping with something else then
    java-1_5_0-gcj-compat, but still require
    java-1_5_0-gcj-compat-devel
  - Added patch:
    * apache-ant-bootstrap.patch
    - Add -sourcepath option to fix build breakages with Eclipse
      Compiler for Java(tm)
* Wed Sep 06 2017 fstrba@suse.com
  - Added patch:
    * apache-ant-1.9.9-sourcetarget.patch
      + Change java source and target versions to 1.6 to allow build
      with jdk9
  - For non-boostrap builds require java-devel >= 1.6
* Fri Jun 09 2017 tchvatal@suse.com
  - Do not generate poms on ant core packages to reduce deps and
    allow bootstrap
* Wed May 31 2017 tchvatal@suse.com
  - Fix bootstrap to avoid new cycle bsc#1041966
* Fri May 19 2017 tchvatal@suse.com
  - Disable javadoc completely it is on the web in much better form
  - Remove if0 conditions
  - Remove patch apache-ant-old-gcj-build.patch for sle11 and unused
  - Fix build with split javapackages-tools
* Mon May 08 2017 bwiedemann@suse.com
  - Version bump to 1.9.9:
    * Read WHATSNEW file for full changelist
* Mon May 08 2017 bwiedemann@suse.de
  - Add reproducible.patch to allow reproducible builds of ant itself
    and packages built with ant like jcodings
* Mon Feb 20 2017 tchvatal@suse.com
  - Revert the previous change as it broke the build of most java
    software stack
* Mon Feb 13 2017 guoyunhebrave@gmail.com
  - Add profile.d scripts to set ANT_HOME
* Fri Jan 15 2016 opensuse@dstoecker.de
  - junit4 test did not work (bnc#915686)
* Wed Jul 29 2015 tchvatal@suse.com
  - Add xalan-j2-serializer to ant-antlr requirements
* Tue Jul 28 2015 tchvatal@suse.com
  - Sync the changes files among the subpkgs
  - Version bump to 1.9.6:
    * Read WHATSNEW file for full changelist
* Sun Jun 21 2015 jengelh@inai.de
  - Do better quoting to get better error messages when it fails
* Wed Mar 18 2015 tchvatal@suse.com
  - Fix build with new javapackages-tools

Files

/usr/bin/antRun.pl
/usr/bin/complete-ant-cmd.pl
/usr/bin/runant.pl
/usr/bin/runant.py


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Jan 19 23:28:58 2020