Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

antlr-2.7.7-lp150.7.6 RPM for x86_64

From OpenSuSE Leap 15.0 for x86_64

Name: antlr Distribution: openSUSE Leap 15.0
Version: 2.7.7 Vendor: openSUSE
Release: lp150.7.6 Build date: Tue Apr 10 01:47:44 2018
Group: Development/Tools/Other Build host: lamb19
Size: 22322 Source RPM: antlr-2.7.7-lp150.7.6.src.rpm
Packager: https://bugs.opensuse.org
Url: http://www.antlr.org/
Summary: Another Tool for Language Recognition
ANTLR, Another Tool for Language Recognition, (formerly PCCTS) is a
language tool that provides a framework for constructing recognizers,
compilers, and translators from grammatical descriptions containing C++
or Java actions (you can use PCCTS 1.xx to generate C-based parsers).

Provides

Requires

License

GPL-2.0+ AND SUSE-Public-Domain AND MIT

Changelog

* Fri Jan 12 2018 tchvatal@suse.com
  - Add condition about python2 module, the rewrite happened in antlr4
    for python3 support and it is completely different than the antlr2
    * The python module is not used by any package in TW bsc#1068226
* Thu Dec 07 2017 dimstar@opensuse.org
  - Fix build with RPM 4.14: a command that exits with error > 0
    aborts the build (and grep not finding a string is retval 1).
* Fri Nov 03 2017 mpluskal@suse.com
  - Explicitly require python2 [bsc#1068226, fate#323526]
* Fri Sep 29 2017 fstrba@suse.com
  - Require java-devel >= 1.6 to build, because of the source and
    target level
* Wed Sep 06 2017 fstrba@suse.com
  - fixes necessary to compile with Java 9
    * set javac source and target to 1.6
* Fri Jun 09 2017 tchvatal@suse.com
  - Drop the javadoc so we can be build with java bootstrapping reducing
    the cycle/failures
* Fri May 19 2017 tchvatal@suse.com
  - Reduce dependencies a bit
* Thu Dec 04 2014 p.drouand@gmail.com
  - Remove java-devel dependency; not needed anymore
* Fri Jul 04 2014 tchvatal@suse.com
  - Cleanup with spec-cleaner and fix the sle11 build properly.
* Wed Apr 30 2014 darin@darins.net
  - Set buildarch on SLE_11 or the python subpackage is packaged
    as noarch when they need be arch specific.
    http://lists.opensuse.org/opensuse-packaging/2014-04/msg00055.html
* Tue Apr 29 2014 darin@darins.net
  - supporess bytecode version check on SLE
  - fix perms for SLES
* Mon Sep 09 2013 tchvatal@suse.com
  - Move from jpackage-utils to javapackage-tools
* Thu Jul 11 2013 dmueller@suse.com
  - drop antlr-cshap, entirely unused and removes mono dependency
* Wed Oct 31 2012 mvyskocil@suse.com
  - examples files are now 0644 to beeing able to fdupes them properly (bnc#784670)
* Thu Jul 21 2011 toddrme2178@gmail.com
  - Modify descriptions (fix for RPMLINT warnings)
  - Check for duplicate files (fix for RPMLINT warnings)
* Mon Aug 23 2010 mvyskocil@suse.cz
  - add missing java requires of antlr-java package
* Thu Aug 19 2010 mvyskocil@suse.cz
  - enabled the python (python-antlr) and csharp (antlr-csharp) support
  - moved jar files to new antlr-java package, which is required by main antlr
    one. This is to have jar files in noarch package
  - do not use default make install, but install files manually with a
    compatibility links to /usr/share/antlr-2.7.7
* Wed Aug 18 2010 tittiatcoke@opensuse.org
  - Ensure that the development files are build too. The package is now a build
    requirement for the KDESDK4 package.
  - Removed the structure to build just the native version.

Files

/usr/bin/antlr
/usr/bin/antlr-config
/usr/share/antlr-2.7.7
/usr/share/doc/packages/antlr
/usr/share/doc/packages/antlr/CHANGES.txt
/usr/share/doc/packages/antlr/LICENSE.txt
/usr/share/doc/packages/antlr/README.txt


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun May 10 04:23:57 2020