Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

loki_update-1.0.13_20040208-204.1.2 RPM for x86_64

From OpenSuSE 12.3 for x86_64

Name: loki_update Distribution: openSUSE 12.3
Version: 1.0.13_20040208 Vendor: openSUSE
Release: 204.1.2 Build date: Fri Feb 1 18:10:14 2013
Group: Amusements/Games/Other Build host: build23
Size: 560084 Source RPM: loki_setup-1.6.5_20070404-204.1.2.src.rpm
Summary: Updater program for games
An updater program for games that were installed using Loki Setup

    Sam Lantinga






* Thu Oct 25 2012
  - add explicit buildrequire on libbz2-devel
* Mon Jun 11 2012
  - define PROTOTYPES to fix build
* Wed Jun 06 2012
  - fix for new automake
* Thu May 03 2012
  - update ancient config.sub's
* Mon Apr 02 2012
  - build require xorg-x11-devel to fix build on factory.
* Wed Dec 21 2011
  - remove call to suse_update_config (very old work around)
* Fri Dec 02 2011
  - add automake as buildrequire to avoid implicit dependency
* Tue May 31 2011
  - remove ru locale (bnc#681500)
  - remove __DATE__ reference
* Tue Dec 28 2010
  - Softlink duplicates only. Hardlinking /usr/bin to /usr/share is
    not good practice, as the folders could remain on different
* Wed Sep 08 2010
  - define _LARGEFILE64_SOURCE to fix build
  - use normal %patch mechanism
  - refresh some patches that had fuzz
* Tue Sep 07 2010
  - Remove gpm from BuildRequires, it's not used at all.
* Fri Jan 15 2010
  - remove gtk1-compat patch, not needed.
* Thu Jan 07 2010
  - Only require gtk1-compat-devel on openSUSE 11.2 and earlier. It's
    generally not needed since loki_* has been ported to GTK+ 2.x,
    but to be on the safe side, we keep a
    loki_patch-gtk1-compat.diff patch (see below) that requires
  - Drop gtk1-compat-devel BuildRequires: it shouldn't be needed
    anymore since it has been ported to GTK+ 2.x.
  - Add loki_setup-xgettext-glade.diff: use xgettext directly instead
    of libglade-xgettext, that doesn't exist anymore.
  - Update loki_update-Makefile.diff:
    + use xml2-config and pkg-config instead of
    + add -DGTK_ENABLE_BROKEN to make the build work with really old
      GTK+ API
    + use xgettext directly instead of libglade-xgettext
  - Add loki_update-libglade2.patch: port the code to libglade2 API.
  - Update loki_patch-fixes.diff:
    + do not use gtk-config in since the xdelta
      cflags/libs will have the right value in openSUSE 11.3
    + do not add AM_PATH_GTK in for the same reason
    + use xml2-config instead of xml-config
  - Update loki_patch-xdelta.diff: do not change AM_PATH_GTK to
    AM_PATH_GLIB since it's not there anymore.
  - Add loki_patch-gtk1-compat.diff: this patch will be
    applied on openSUSE < 11.3, to get the same results as before.
  - Pass --with-libxml2 to configure of loki_setupdb.
* Fri Jun 19 2009
  - disable as-needed for this package as it fails to build with it
* Tue Apr 14 2009
  - update baselibs.conf to build cross packages for i586, x86_64, ppc
    and ppc64
  - fix exit code 3 handling of



Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 10 04:16:39 2015