Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

yast2-ruby-bindings-0.3.8-2.1.2 RPM for x86_64

From OpenSuSE 12.1 for x86_64

Name: yast2-ruby-bindings Distribution: openSUSE 12.1
Version: 0.3.8 Vendor: openSUSE
Release: 2.1.2 Build date: Sat Oct 29 22:08:52 2011
Group: System/YaST Build host: build22
Size: 169167 Source RPM: yast2-ruby-bindings-0.3.8-2.1.2.src.rpm
Packager: http://bugs.opensuse.org
Summary: Ruby bindings for the YaST platform
The bindings allow YaST modules to be written using the Ruby language
and also Ruby scripts can use YaST agents, APIs and modules.

Provides

Requires

License

GPL

Changelog

* Mon Oct 03 2011 mvidner@suse.cz
  - WIP: Ruby objects usable from YCP (FATE#312825).
      except those that get garbage collected :-/)
  - Run the tests at RPM build time.
  - Less log clutter when importing a Ruby namespace.
  - 0.3.8
* Tue Jul 26 2011 kkaempf@novell.com
  - Re-init the Ruby stack when calling a Ruby function. bnc#708059
  - 0.3.7
* Mon Jul 25 2011 kkaempf@novell.com
  - wrap rb_funcall in rb_protect to prevent segfaults if the
    calling function raises an exception (bnc#705425)
  - 0.3.6
* Tue Nov 03 2009 dmacvicar@novell.com
  - support for nested namespaces (Foo::Bar)
    (bnc #551881)
  - 0.3.5
* Mon Nov 02 2009 dmacvicar@suse.de
  - fix convertion of ruby hashes to ycp maps
    (bnc #551791)
  - 0.3.4
* Thu Apr 09 2009 kkaempf@suse.de
  - add and enable CTest
  - generate rdoc documentation
  - pass explicit rpath to linker so plugins are found
  - general code cleanup
  - 0.3.3
* Tue May 06 2008 aj@suse.de
  - Fix spec file for last change.
* Wed Apr 16 2008 dmacvicar@suse.de
  - find yast pugins without requiring LD_LIBRARY_PATH
    (bnc #353405)
  - require 'yast' is now require 'ycp'
  - misc. fixes
  - 0.3.2
* Thu Feb 21 2008 sh@suse.de
  - Added new UI packages to Requires/BuildRequires in .spec file
  - V 0.3.1
* Wed Feb 20 2008 coolo@suse.de
  - fix against latest yast2-core

Files

/usr/lib64/YaST2/plugin/libpy2lang_ruby.so
/usr/lib64/ruby/vendor_ruby/1.8/x86_64-linux/ycpx.so
/usr/lib64/ruby/vendor_ruby/1.8/ycp.rb


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Oct 10 12:35:59 2014