Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

loki_setup-64bit-1.6.5_20070404-197.1.2 RPM for i586

From OpenSuSE 12.1 for i586

Name: loki_setup-64bit Distribution: openSUSE 12.1
Version: 1.6.5_20070404 Vendor: openSUSE
Release: 197.1.2 Build date: Sat Oct 29 21:50:05 2011
Group: Development/Tools/Other Build host: build06
Size: 575152 Source RPM: loki_setup-1.6.5_20070404-197.1.2.src.rpm
Packager: http://bugs.opensuse.org
Url: http://icculus.org/loki_setup/
Summary: Installer Program Mainly for Games
loki_setup is an installer program mainly for games. It supports an
ncurses-based GUI for console and server installs. Users running the X
Window System have a GTK+ interface.



Authors:
--------
    Sam Lantinga
    Stéphane Peter
    Ryan C. Gordon

Provides

Requires

License

GPLv2+

Changelog

* Tue May 31 2011 lnussel@suse.de
  - remove ru locale (bnc#681500)
  - remove __DATE__ reference
* Tue Dec 28 2010 dimstar@opensuse.org
  - Softlink duplicates only. Hardlinking /usr/bin to /usr/share is
    not good practice, as the folders could remain on different
    partitions.
* Wed Sep 08 2010 lnussel@suse.de
  - define _LARGEFILE64_SOURCE to fix build
  - use normal %patch mechanism
  - refresh some patches that had fuzz
* Tue Sep 07 2010 aj@suse.de
  - Remove gpm from BuildRequires, it's not used at all.
* Fri Jan 15 2010 lnussel@suse.de
  - remove gtk1-compat patch, not needed.
* Thu Jan 07 2010 vuntz@opensuse.org
  - Only require gtk1-compat-devel on openSUSE 11.2 and earlier. It's
    generally not needed since loki_* has been ported to GTK+ 2.x,
    but to be on the safe side, we keep a
    loki_patch-gtk1-compat.diff patch (see below) that requires
    glib-config.
  - Drop gtk1-compat-devel BuildRequires: it shouldn't be needed
    anymore since it has been ported to GTK+ 2.x.
  - Add loki_setup-xgettext-glade.diff: use xgettext directly instead
    of libglade-xgettext, that doesn't exist anymore.
  - Update loki_update-Makefile.diff:
    + use xml2-config and pkg-config instead of
      {xml,gtk,libglade}-config
    + add -DGTK_ENABLE_BROKEN to make the build work with really old
      GTK+ API
    + use xgettext directly instead of libglade-xgettext
  - Add loki_update-libglade2.patch: port the code to libglade2 API.
  - Update loki_patch-fixes.diff:
    + do not use gtk-config in Makefile.in since the xdelta
      cflags/libs will have the right value in openSUSE 11.3
    + do not add AM_PATH_GTK in configure.in for the same reason
    + use xml2-config instead of xml-config
  - Update loki_patch-xdelta.diff: do not change AM_PATH_GTK to
    AM_PATH_GLIB since it's not there anymore.
  - Add loki_patch-gtk1-compat.diff: this patch will be
    applied on openSUSE < 11.3, to get the same results as before.
  - Pass --with-libxml2 to configure of loki_setupdb.
* Fri Jun 19 2009 coolo@novell.com
  - disable as-needed for this package as it fails to build with it
* Tue Apr 14 2009 lnussel@suse.de
  - update baselibs.conf to build cross packages for i586, x86_64, ppc
    and ppc64
  - fix exit code 3 handling of setup.sh
* Mon Jun 30 2008 lnussel@suse.de
  - add baselibs.conf so one can generate e.g a combined i386/x86_64
    installer on x86_64
* Mon Jun 30 2008 lnussel@suse.de
  - add baselibs.conf so one can generate e.g a combined i386/x86_64
    installer on x86_64

Files

/usr/share/loki-setup
/usr/share/loki-setup/image
/usr/share/loki-setup/image/setup.data
/usr/share/loki-setup/image/setup.data/bin
/usr/share/loki-setup/image/setup.data/bin/Linux
/usr/share/loki-setup/image/setup.data/bin/Linux/x86_64
/usr/share/loki-setup/image/setup.data/bin/Linux/x86_64/setup
/usr/share/loki-setup/image/setup.data/bin/Linux/x86_64/setup.gtk2
/usr/share/loki-setup/image/setup.data/bin/Linux/x86_64/uninstall


Generated by rpm2html 1.8.1

Fabrice Bellet, Sun Aug 10 13:52:28 2014