Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

python-antlr-2.7.7-80.4 RPM for i586

From OpenSuSE 11.4 for i586

Name: python-antlr Distribution: openSUSE 11.4
Version: 2.7.7 Vendor: openSUSE
Release: 80.4 Build date: Tue Feb 22 23:19:19 2011
Group: Development/Tools/Other Build host: build13
Size: 162568 Source RPM: antlr-2.7.7-80.4.src.rpm
Summary: ANother Tool for Language Recognition (python runtime)
Python support for generating your Lexers, Parsers and TreeParsers in Python.
This feature extends the benefits of ANTLR's predicated-LL(k) parsing
technology to the Python language and platform.

ANTLR Python support was contributed (and is to be maintained) by Wolfgang
Haefelinger and Marq Kole.




GPLv2+ ; Public Domain, Freeware ; MIT


* Mon Aug 23 2010
  - add missing java requires of antlr-java package
* Thu Aug 19 2010
  - enabled the python (python-antlr) and csharp (antlr-csharp) support
  - moved jar files to new antlr-java package, which is required by main antlr
    one. This is to have jar files in noarch package
  - do not use default make install, but install files manually with a
    compatibility links to /usr/share/antlr-2.7.7
* Wed Aug 18 2010
  - Ensure that the development files are build too. The package is now a build
    requirement for the KDESDK4 package.
  - Removed the structure to build just the native version.
* Mon Mar 03 2008
  - updated to 2.7.7
    * updated to make the doWorkForAll method static. Same
      behaviour, except no ClassCastExceptions when sibling.getFirstChild()
      happens to return an AST that doesn't extend BaseAST.  Oliver Wong contributed
      the patch.
    * updated to reflect bug fixes discovered
      in v3 counterpart.
* Wed Feb 20 2008
  - do not PreReq files to fix build env setup for other packages
  - remove SL-9.1 traces
* Fri May 04 2007
  - added unzip to BuildRequires
* Sat Oct 07 2006
  - added check that checks whether deleted files and are really not in place
* Thu Oct 05 2006
  - deleted
    from tar ball due to licensing issues (Bug #207621)
* Mon Sep 25 2006
  - fixes necessary to compile with Java 1.5.0
    - set source="1.4" and target="1.4" for ant "javac" tasks
    - set source="1.4" for ant "javadoc" tasks
* Wed Sep 20 2006
  - Provide: antlr-bootstrap
    Obsoletes: antlr-bootstrap



Generated by rpm2html 1.8.1

Fabrice Bellet, Tue Nov 10 04:30:25 2015