Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

apache-mod_perl-1.3.28_1.28-1mdk RPM for i586

From Mandriva 9.2 for i586 / Mandrake / RPMS

Name: apache-mod_perl Distribution: Mandrake Linux
Version: 1.3.28_1.28 Vendor: MandrakeSoft
Release: 1mdk Build date: Mon Sep 15 13:33:55 2003
Group: System/Servers Build host: ADVX.mandrakesoft.com
Size: 623260 Source RPM: apache-mod_perl-1.3.28_1.28-1mdk.src.rpm
Packager: Jean-Michel Dault <jmdault@mandrakesoft.com>
Url: http://perl.apache.org
Summary: Apache Web server with a built-in Perl interpreter
Apache is a powerful, full-featured, efficient and freely-available
Web server.

mod_perl incorporates a Perl interpreter into the Apache web
server, so that the Apache web server can directly execute Perl
code.  Mod_perl links the Perl runtime library into the Apache
web server and provides an object-oriented Perl interface for
Apache's C language API.  The end result is a quicker CGI script
turnaround process, since no external Perl interpreter has to
be started.

This package contains Apache with mod_perl linked statically. It also
contains a statically linked HTML::Embperl module, but you need the separate
HTML-Embperl package to activate it.

Provides

Requires

License

Apache License

Changelog

* Tue Sep 16 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.28_1.28-1mdk
  - rebuild for apache security release
* Mon Aug 04 2003 Pixel <pixel@mandrakesoft.com> 1.3.27_1.28-12mdk
  - new release
  - revive "make test" on mod_perl
  - drop mod_perl-1.27-URI.patch.bz2
* Mon Aug 04 2003 Pixel <pixel@mandrakesoft.com> 1.3.27_1.27-12mdk
  - rebuild for new perl
* Thu Jul 31 2003 Pixel <pixel@mandrakesoft.com> 1.3.27_1.27-11mdk
  - when requiring the perl-base used for building, include the epoch
  - fix build (regarding vendor_perl)
* Tue Jul 22 2003 David Baudens <baudens@mandrakesoft.com> 1.3.27_1.27-10mdk
  - Rebuild to fix bad signature
* Sun Jun 01 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 1.3.27_1.27-9mdk
  - fix requires
* Sun Jun 01 2003 Oden Eriksson <oden.eriksson@kvikkjokk.net> 1.3.27_1.27-8mdk
  - rebuilt to let rpm v4.2 know about some perl stuff
  - added S1
  - misc spec file fixes
* Wed Feb 19 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27-1.27-7mdk
  - fix requires (mod_perl-common does not require apache)
  - remove old macros and replace them by ADVX macros
* Thu Feb 13 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-6mdk
  - add AP13pre macro to make sure about the sanity of the conf files
* Wed Jan 08 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-5mdk
  - Clean spec file a bit, some files were installed but not packaged.
* Tue Jan 07 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-4mdk
  - Add Provides: ADVXpackage, all ADVX package will have this tag, 
    so we can easily do a rpm --whatprovides ADVXpackage to find out
    what ADVX packages a user has installed on his system. 
  - Likewise, add Provides: AP13package and AP20package in the same
    manner
* Thu Jan 02 2003 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-3mdk
  - rebuilt for new mm version
* Fri Nov 08 2002 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-2mdk
  - Rebuild for Cooker
* Mon Oct 28 2002 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.27_1.27-1mdk
  - New version
* Sat Sep 07 2002 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.26_1.27-7mdk
  - Don't use apache.apache for the documentation
  - Bzip patches
* Sat Sep 07 2002 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.26_1.27-6mdk
  - Fix file conflict, fix link to documentation and re-add test script.
* Wed Aug 07 2002 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.26_1.27-5mdk
  - rebuild with new perl
* Thu Jul 11 2002 Pixel <pixel@mandrakesoft.com> 1.3.26_1.27-4mdk
  - get rid of a few more "Requires: perl = 5.6.1"
* Wed Jul 10 2002 Pixel <pixel@mandrakesoft.com> 1.3.26_1.27-3mdk
  - have "Requires: perl = %{perl_version}" instead of hard-coding it
* Wed Jul 10 2002 Pixel <pixel@mandrakesoft.com> 1.3.26_1.27-2mdk
  - rebuild for perl 5.8.0
  - disable some test for HTML-Embperl :-(
    (will report to perl and Embperl projects)
* Fri Jun 28 2002 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.26_1.27-1mdk
  - apache 1.3.26.
  - mod_perl 1.27
  - regenerate Source80.
* Fri May 17 2002 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.24_1.26-2mdk
  - Rebuild
* Tue Apr 16 2002 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.24_1.26-1mdk
  - Apache 1.3.24.
* Sat Mar 02 2002 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.23_1.26-5mdk
  - Disable expat to prevent segfault with axkit
  - Put back make test
  - Fix broken link in doc
* Mon Feb 04 2002 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.23_1.26-4mdk
  - Rollback to Embperl 1.3.4.
  - Rebuild against latest apache.
  - Build mod_rewrite part against ndbm.h instead of db.h.
  - mod_perl test still not working (it doesn't find URI perl module).
* Sun Oct 28 2001 Stefan van der Eijk <stefan@eijk.nu> 1.3.22_1.26-3mdk
  - EXTRA_LIBS=-ldb-3.2 --> EXTRA_LIBS=-ldb-3.3
* Fri Oct 26 2001 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.22_1.26-2mdk
  - Provides the Obsoletes for compatibilty.
* Fri Oct 26 2001 Christian Belisle <cbelisle@mandrakesoft.com> 1.3.22_1.26-1mdk
  - mod_perl 1.26.
  - Embperl 2.0b3 (make test not working...).
  - Build against new apache.
  - Build against new db3.
  - make rpmlint happier.
* Thu Aug 30 2001 Philippe Libat <philippe@mandrakesoft.com> 1.3.20_1.25_01-3mdk
  - build against libgdbm2
* Fri Jul 13 2001 Philippe Libat <philippe@mandrakesoft.com> 1.3.20_1.25_01-2mdk
  - fix HTML-Embed version
* Wed Jul 11 2001 Philippe Libat <philippe@mandrakesoft.com> 1.3.20_1.25_01-1mdk
  - upgrade
  - new apache version
  - fix db3 lib
* Thu Jun 14 2001 Pixel <pixel@mandrakesoft.com> 1.3.19_1.25-4mdk
  - rebuild for perl 5.6.1
  - new HTML-Embed 1.3.3 (needed for perl 5.6.1)
* Sat Apr 14 2001 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.19_1.25-3mdk
  - fix requires
  - fix documentation links
* Tue Apr 10 2001 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.19_1.25-2mdk
  - fix httpd-perl segfault when installing apache-conf
  - BuildRequires perl-CGI now that the package has been split
* Mon Mar 26 2001 Jean-Michel Dault <jmdault@mandrakesoft.com> 1.3.19_1.25-1mdk
  - Completely remade spec file
  - Re-split mod_perl in its own package again
  - Get Apache source from package apache-source so we share the same code
    and it's easier to maintain
  - Get optflags from apxs so that apache and apache-mod_perl have the same
    flags and we can use the same modules
  - Get apache-mod_perl and apache share same modules so we can have a static
    apache+mod_perl and still have mod_dav, etc...
  - Put httpd-perl.conf in apache-conf package to enable better configuration
    for OEMs and ISPs

Files

/etc/httpd/conf/addon-modules/proxied_handlers.pl
/usr/sbin/httpd-perl
/usr/share/doc/apache-mod_perl-1.3.28_1.28
/usr/share/doc/apache-mod_perl-1.3.28_1.28/README.ADVX


Generated by rpm2html 1.8.1

Fabrice Bellet, Fri Nov 10 00:25:14 2017