Index index by Group index by Distribution index by Vendor index by creation date index by Name Mirrors Help Search

perl-devel-5.16.3-1.mga3 RPM for i586

From Mageia 3 for i586 / media / core / release

Name: perl-devel Distribution: Mageia
Version: 5.16.3 Vendor: Mageia.Org
Release: 1.mga3 Build date: Sun Mar 17 19:57:17 2013
Group: Development/Perl Build host: jonund.mageia.org
Size: 1709517 Source RPM: perl-5.16.3-1.mga3.src.rpm
Packager: guillomovitch <guillomovitch>
Url: http://www.perl.org/
Summary: The Perl programming language (devel)
This is the devel package for perl.

Provides

Requires

License

GPL+ or Artistic

Changelog

* Wed Mar 13 2013 jquelin <jquelin> 2:5.16.3-1.mga3
  + Revision: 402345
  - forgot to add the new @INC
  - update to 5.16.3
* Mon Feb 04 2013 jquelin <jquelin> 2:5.16.2-5.mga3
  + Revision: 394527
  - fix Locale-Maketext CVE-2012-6329 (mga#8815)
* Sun Jan 13 2013 umeabot <umeabot> 2:5.16.2-4.mga3
  + Revision: 362755
  - Mass Rebuild - https://wiki.mageia.org/en/Feature:Mageia3MassRebuild
  
    + jquelin <jquelin>
      - perl 5.16.2 shebang rebuild
* Tue Nov 06 2012 jquelin <jquelin> 2:5.16.2-2.mga3
  + Revision: 314831
  - get rid of legacy %ifarch
* Mon Nov 05 2012 jquelin <jquelin> 2:5.16.2-1.mga3
  + Revision: 314423
  - update to 5.16.2
  - patch inlined as configure option (-Dperllib) to prevent patch
    creeping
* Tue Oct 16 2012 fwang <fwang> 2:5.16.1-8.mga3
  + Revision: 307034
  - do not fail if it is not installed
  - use hanextra for zh_CN.GB18030 promoted in mga3
* Thu Sep 20 2012 tv <tv> 2:5.16.1-7.mga3
  + Revision: 296295
  - rebuild for missing x86_64 binaries
* Tue Sep 18 2012 jquelin <jquelin> 2:5.16.1-6.mga3
  + Revision: 295881
  - update list of provides
* Fri Aug 24 2012 tv <tv> 2:5.16.1-5.mga3
  + Revision: 283511
  - rebuild with fixed rpm-mageia-setup-build
* Fri Aug 24 2012 tv <tv> 2:5.16.1-4.mga3
  + Revision: 283498
  - Provides: perlapi-5.16.0
* Fri Aug 24 2012 pterjan <pterjan> 2:5.16.1-3.mga3
  + Revision: 283393
  - Provide /bin/perl
  - Clean rebuild
* Thu Aug 23 2012 tv <tv> 2:5.16.1-2.mga3
  + Revision: 283354
  - rebuild b/c find-provides insert perlapi provides depending on installed
    perl, not the one we currently build...
* Thu Aug 23 2012 jquelin <jquelin> 2:5.16.1-1.mga3
  + Revision: 283273
  - remove files no more shipped
  - update link patch to match perl 5.16.1
  - update to perl 5.16.1
* Thu Aug 16 2012 jquelin <jquelin> 2:5.16.0-11.mga3
  + Revision: 281481
  - provide perl(open) - mga#6907
* Fri Aug 03 2012 tv <tv> 2:5.16.0-10.mga3
  + Revision: 278316
  - rebuild with compressed debug info
* Thu Aug 02 2012 tv <tv> 2:5.16.0-9.mga3
  + Revision: 277891
  - rebuild with mini debug info
* Mon Jul 30 2012 tv <tv> 2:5.16.0-8.mga3
  + Revision: 276234
  - rebuild for db-5.3
  - drop 4 years old conflicts
  - perlapi provides is automatic now
* Fri Jul 27 2012 fwang <fwang> 2:5.16.0-7.mga3
  + Revision: 274717
  - use system default db libmajor
* Fri Jun 01 2012 tv <tv> 2:5.16.0-6.mga3
  + Revision: 252835
  - conflict with perl-IO-Compress
* Fri Jun 01 2012 tv <tv> 2:5.16.0-5.mga3
  + Revision: 252787
  - conflict with perl-Pod-Perldoc
* Thu May 31 2012 pterjan <pterjan> 2:5.16.0-4.mga3
  + Revision: 252545
  - Fix one more conflict
* Thu May 31 2012 pterjan <pterjan> 2:5.16.0-3.mga3
  + Revision: 252543
  - Make conflicts less stricts
* Thu May 31 2012 blino <blino> 2:5.16.0-2.mga3
  + Revision: 252542
  - update conflicts with perl-Archive-Tar
  
    + jquelin <jquelin>
      - update to perl 5.16
        to minimize differences to upstream, i did not remove any module.
        dual-lifed modules conflicting on a script will rename the script to
        version it (eg: /usr/bin/script-x.y.z)
* Fri Apr 20 2012 tv <tv> 2:5.14.2-7.mga2
  + Revision: 232117
  - move some files from perl to perl-base in order to debloat minimal install
    (saves 10.35% of mininmal install: 280->251Mo)
* Fri Mar 16 2012 anssi <anssi> 2:5.14.2-6.mga2
  + Revision: 223649
  - bump perl-base versioned conflict on drakxtools-backend, as it didn't
    contain the proper perlapi requires until recently as per bug #3731
    (fixes possible non-added kernels and skipped initramfs regeneration
    on mga1->mga2 upgrade)
* Mon Dec 05 2011 fwang <fwang> 2:5.14.2-5.mga2
  + Revision: 176901
  - rebuild for new gdbm
* Fri Nov 25 2011 fwang <fwang> 2:5.14.2-4.mga2
  + Revision: 171776
  - fix linkage
  
    + jquelin <jquelin>
      - see if new define is the bs problem
      - installing /usr/bin/perl within configure
* Fri Oct 14 2011 jquelin <jquelin> 2:5.14.2-3.mga2
  + Revision: 155117
  - perl 5.14.2 rebuild
* Fri Oct 14 2011 jquelin <jquelin> 2:5.14.2-2.mga2
  + Revision: 155116
  - rebuild
* Fri Oct 14 2011 jquelin <jquelin> 2:5.14.2-1.mga2
  + Revision: 155097
  - update to 5.14.2
  - script to find package owning scripts with wrong shebang
  
    + fwang <fwang>
      - promote ldflags also when building exts
* Sun Jun 19 2011 jquelin <jquelin> 2:5.14.1-1.mga2
  + Revision: 109798
  - update to perl 5.14.1
  
    + tv <tv>
      - make doc subpackage noarch
* Mon Jun 13 2011 jquelin <jquelin> 2:5.14.0-5.mga2
  + Revision: 105783
  - make sure perl-JSON-PP is picked by urpmi in the same transaction
* Mon Jun 13 2011 jquelin <jquelin> 2:5.14.0-4.mga2
  + Revision: 105756
  - adding some conflicts with modules known to be perl 5.14 incompatible
* Sun Jun 12 2011 jquelin <jquelin> 2:5.14.0-3.mga2
  + Revision: 104268
  - fixing conflict with perl-Digest-SHA
  - perl 5.14 rebuild
  - try to fix eumm cflags overriding
  - fixing last remaining errors
  - preparation to migrate to 5.14.0
  - prep works fine (patch updated or dropped if merged upstream)
  - build works fine
  - all test work but 1: number 7 in t/porting/regen.t
    i did not manage to get a shell access with iurt, so i didn't have the
    chance to investigate further. i(m giving it up currently. in worst
    case, i think that skipping this test is not that big a deal.
* Mon May 16 2011 jquelin <jquelin> 2:5.12.3-4.mga1
  + Revision: 99222
  - fix bug#1300 lc/uc bypass taint (cve 2011-1487)
* Thu Feb 17 2011 jquelin <jquelin> 2:5.12.3-3.mga1
  + Revision: 52901
  + rebuild (emptylog)
* Wed Feb 16 2011 jquelin <jquelin> 2:5.12.3-2.mga1
  + Revision: 52702
  - forgot to add previous arch @inc
* Wed Feb 16 2011 jquelin <jquelin> 2:5.12.3-1.mga1
  + Revision: 52620
  - update to 5.12.3
* Wed Feb 16 2011 jquelin <jquelin> 2:5.12.2-11.mga1
  + Revision: 52448
  - adding missing provides:
* Mon Jan 31 2011 jquelin <jquelin> 2:5.12.2-10.mga1
  + Revision: 45158
  - install man pages from core modules in section 3pm, to avoid conflict with standalone versions of the same modules
* Wed Jan 26 2011 jquelin <jquelin> 2:5.12.2-9.mga1
  + Revision: 40024
  - adding missing provides:
* Tue Jan 25 2011 jquelin <jquelin> 2:5.12.2-8.mga1
  + Revision: 38277
  - adding missing provides:
* Tue Jan 18 2011 blino <blino> 2:5.12.2-7.mga1
  + Revision: 23248
  - rebuild
  - revert incorrect import
* Mon Jan 10 2011 jquelin <jquelin> 2:5.12.2-5.mga1
  + Revision: 5260
  - imported package perl
  
    + blino <blino>
      - update distro name
      - use generic distribution macros
      - remove old conflicts
      - imported package perl
* Fri Nov 19 2010 Oden Eriksson <oeriksson@mandriva.com> 2:5.12.2-5mdv2011.0
  + Revision: 599067
  - P51: fix borkiness with Compress::Zlib
  - rediffed fuzzy patches
  
    + Jérôme Quelin <jquelin@mandriva.org>
      - remove path setting, which did not help
* Thu Sep 09 2010 Götz Waschk <waschk@mandriva.org> 2:5.12.2-4mdv2011.0
  + Revision: 577004
  - reenable checks
* Thu Sep 09 2010 Götz Waschk <waschk@mandriva.org> 2:5.12.2-3mdv2011.0
  + Revision: 577002
  - disable checks for bootstrapping
  
    + Jérôme Quelin <jquelin@mandriva.org>
      - not sure tests pick up the correct path
      - mdv#60956 - fix h2ph
* Thu Sep 09 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.2-2mdv2011.0
  + Revision: 576910
  - fix #60939 - provides perl-libnet again
* Tue Sep 07 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.2-1mdv2011.0
  + Revision: 576627
  - update to 5.12.2
* Fri Aug 06 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.1-3mdv2011.0
  + Revision: 566958
  - perl-suid should be obsoleted, not conflicted
* Tue Jul 27 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.1-2mdv2011.0
  + Revision: 561874
  - submitting directly to main/release
* Tue Jul 27 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.1-1mdv2011.0
  + Revision: 561860
  - update perlapi and @INC list
  - update to perl 5.12.1
  - 5.12 is now current
* Fri Jun 11 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.10.1-10mdv2010.1
  + Revision: 547928
  - 5.12 dvpt should be done in a branch
  - forgot to commit tarball
  - 5.12.0 final
* Wed Apr 07 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.0-0.RC4.1mdv2010.1
  + Revision: 532699
  - update to 5.12.0-rc4
* Wed Mar 31 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.0-0.RC1.1mdv2010.1
  + Revision: 530267
  - update to 5.12.0-rc1
* Fri Mar 26 2010 Jérôme Quelin <jquelin@mandriva.org> 2:5.12.0-0.RC0.1mdv2010.1
  + Revision: 527724
  - rebuild
  - *** /!\ WARNING /!\
  - SUID emulation has been removed in perl 5.12
      Configure is now run without -Dd_dosuid
      ==> perl-suid package doesn't exist anymore
      perl-base now has a "Conflicts: perl-suid" to ensure smooth upgrade
    *** Patches changes
  - patch 3: perl-5.10.1-RC1-norootcheck.patch
      merged upstream
      patch dropped
  - patch 6: perl-5.8.8-RC1-fix-LD_RUN_PATH-for-MakeMaker.patch
      module moved to cpan/ExtUtils-MakeMaker
      patch rediffed
      renamed to perl-5.12.0-RC0-fix-LD_RUN_PATH-for-MakeMaker.patch
  - patch 14: perl-5.12.0-RC0-install-files-using-chmod-644.patch
      module moved to dist/ExtUtils-Install
      renamed to perl-5.10.1-RC1-install-files-using-chmod-644.patch
  - patch 16: perl-5.8.5-RC1-perldoc-use-nroff-compatibility-option.patch
      module moved to dist/Pod-Perldoc
      renamed to perl-5.12.0-RC0-perldoc-use-nroff-compatibility-option.patch
  - patch 23: perl-5.10.1-patchlevel.patch
      update to match RC0
      renamed to perl-5.12.0-RC0-patchlevel.patch
  - patch 24: perl-5.8.4-no-test-fcgi.patch
      test for FastCGI, which the CPAN version has a dependency on, but is not in core
      from #p5p:
      17:08:16 @Nicholas> yes, and I forget why, but I think that it
          became easier not to include it, as it would only skip in core.
      17:24:35 @Bram> It would not always skip in core. I believe that was
          the problem... (If the system perl has CGI::Fast installed and if it is
          the same version as the 'new' perl and the same INC path then the test
          woul pick up the CGI::Fast from the system and attempt to run the test
          (during make test that is))
      ==> patch dropped
  - patch 29: perl-5.8.8-rpmdebug.patch
      module moved to cpan/ExtUtils-Manifest
      renamed to perl-5.12.0-RC0-rpmdebug.patch
  - patch 42: perl-5.9.5-allow-to-override-core-modules.patch
  - patch 43: perl-5.10.1-RC1-skip-tests-using-dev-log-for-iurt.patch
      module moved to cpan/Sys-Syslog
      renamed to perl-5.12.0-RC0-skip-tests-using-dev-log-for-iurt.patch

Files

/usr/bin/c2ph
/usr/bin/config_data
/usr/bin/corelist
/usr/bin/cpan
/usr/bin/cpan2dist
/usr/bin/cpanp
/usr/bin/cpanp-run-perl
/usr/bin/enc2xs
/usr/bin/h2ph
/usr/bin/h2xs
/usr/bin/instmodsh
/usr/bin/json_pp
/usr/bin/libnetcfg
/usr/bin/piconv
/usr/bin/pl2pm
/usr/bin/pod2usage
/usr/bin/podchecker
/usr/bin/podselect
/usr/bin/prove
/usr/bin/psed
/usr/bin/pstruct
/usr/bin/shasum
/usr/bin/xsubpp
/usr/lib/perl5/5.16.3/Encode/encode.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/EXTERN.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/INTERN.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/XSUB.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/av.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/cop.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/cv.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/dosish.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/embed.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/embedvar.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/fakesdio.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/fakethr.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/form.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/gv.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/handy.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/hv.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/intrpvar.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/iperlsys.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/keywords.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/malloc_ctl.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/mg.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/nostdio.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/op.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/opcode.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/opnames.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/overload.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/pad.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/parser.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/patchlevel.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perlapi.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perlio.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perliol.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perlsdio.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perlsfio.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perlvars.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/perly.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/pp.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/pp_proto.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/proto.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/reentr.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/regcharclass.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/regcomp.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/regexp.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/regnodes.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/scope.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/sv.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/thread.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/uconfig.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/unixish.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/utf8.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/utfebcdic.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/util.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/uudmap.h
/usr/lib/perl5/5.16.3/i386-linux-thread-multi/CORE/warnings.h


Generated by rpm2html 1.8.1

Fabrice Bellet, Sat Aug 10 07:41:14 2019